Package HostCMS Element Index

Element index for package HostCMS

Index of all elements
$ a b c d e f g h i j k l m n o p q r s t u v w x
top
$
$row['constants_name'] | in file Kernel.php, constant $row['constants_name']
top
a
$action_width | in file show_table.class.php, variable show_table::$action_width
$additional_attribute | in file show_table.class.php, variable table_fields::$additional_attribute
$additional_filed | in file show_table.class.php, variable table_fields::$additional_filed
$additional_filed_value | in file show_table.class.php, variable table_fields::$additional_filed_value
$align | in file show_table.class.php, variable table_fields::$align
$align_title | in file show_table.class.php, variable table_fields::$align_title
$array | in file show_table.class.php, variable table_fields::$array
$attribute | in file show_table.class.php, variable table_fields::$attribute
$a_count_property in file Structure.class.php, variable Structure::$a_count_property
Ассоциативный массив-Кэш количества свойств для разных сайтов
$a_count_property in file InformationSystems.class.php, variable InformationSystem::$a_count_property
Кэш количества свойств
AddAdminMenuItem in file AdminMenu.class.php, method AdminMenu::AddAdminMenuItem()
Метод добавляет элемент в меню раздела администрирования
AddBanner in file Advertisement.class.php, method Advertisement::AddBanner()
Метод добавления/редактирования баннера
AddEditConstants in file Constants.class.php, method Constants::AddEditConstants()
Метод добавления/редактирования данных о константе
AddEditInitialData in file Counter.class.php, method counter::AddEditInitialData()
Метод добавления/редактирования начальных данных для счетчика
AddEditMessage in file Forums.class.php, method Forums::AddEditMessage()
Метод добавления/редактирования сообщения темы
AddEditTheme in file Forums.class.php, method Forums::AddEditTheme()
Метод осуществляет добавление/редактирование темы
AddInclude in file Kernel.class.php, method kernel::AddInclude()
Метод подключает переданный файл или выводит сообщение об ошибке подключения
AddModule in file Kernel.class.php, method kernel::AddModule()
Метод подключения модуля
AddSiteUser in file Site_users.class.php, method SiteUsers::AddSiteUser()
Метод добавления нового пользователя в систему
ADD_COMMENT_DELAY | in file Kernel.php, constant ADD_COMMENT_DELAY
add_modules_version in file Kernel.class.php, method kernel::add_modules_version()
Метод добавления модуля в массив-список модулей
add_page in file Structure.class.php, method Structure::add_page()
Метод добавления и редактирования данных о страницах
Admin in file Admin.class.php, class Admin
Ядро, методы управления разделом администрирования HostCMS
AdminMenu in file AdminMenu.class.php, class AdminMenu
Ядро, класс для формирования меню в разделе администрирования
ADMIN_EMAIL_XSL | in file config.php, constant ADMIN_EMAIL_XSL
admin_init in file Admin.class.php, method Admin::admin_init()
Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта
admin_output.fns.php | procedural page admin_output.fns.php
admin_session_valid in file Admin.class.php, method Admin::admin_session_valid()
Метод проверки авторизации пользователя
Advertisement in file Advertisement.class.php, class Advertisement
Класс модуля "Реклама"
Advertisement.class.php | procedural page Advertisement.class.php
Advertisement.php | procedural page Advertisement.php
AlignTextSpace in file Counter.class.php, method counter::AlignTextSpace()
Метод выравнивания текста по центру с помощью пробелов
AdminMenu.class.php | procedural page AdminMenu.class.php
Admin.class.php | procedural page Admin.class.php
top
b
$BannerCache | in file Advertisement.class.php, variable Advertisement::$BannerCache
$button | in file show_table.class.php, variable show_table::$button
$button_name | in file show_table.class.php, variable show_table::$button_name
$button_value | in file show_table.class.php, variable show_table::$button_value
Backup in file Backup.class.php, class Backup
Класс модуля "Резервное копирование"
Backup.class.php | procedural page Backup.class.php
Backup.php | procedural page Backup.php
BBcode2HTML in file Forums.class.php, method Forums::BBcode2HTML()
Метод замены BBcode на HTML
BeginRecord in file Cache.class.php, method Cache::BeginRecord()
Метод перехватывает информацию, размещаемую в потоке и сохраняет ее в памяти
build in file Xsl.class.php, method xsl::build()
Метод обработки XML данных с помощью XSL шаблона
BuildCapture in file Captcha.class.php, method Captcha::BuildCapture()
Метод для построения изображения CAPTCHA и помещения его текста в сессию
build_counter in file Counter.class.php, method counter::build_counter()
Метод вывода счетчика
top
c
$cache_InformationSystem in file InformationSystems.class.php, variable InformationSystem::$cache_InformationSystem
Кэш данных о информационной системе пример $this->cache_InformationSystem[$id]
$cache_life_time in file Cache.class.php, variable Cache::$cache_life_time
Время жизни кэша, по умолчанию равно 60 секунд
$cache_structure_property in file Structure.class.php, variable Structure::$cache_structure_property
Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.
$checked | in file show_table.class.php, variable table_fields::$checked
$CommentMass in file InformationSystems.class.php, variable InformationSystem::$CommentMass
Кэш с данными о комментариях
$copy_show | in file show_table.class.php, variable show_table::$copy_show
$count_mark_after_separator | in file show_table.class.php, variable table_fields::$count_mark_after_separator
$count_row | in file Site.class.php, variable site::$count_row
$count_row | in file Mysql.class.php, variable MySQL::$count_row
$count_row | in file Modules.class.php, variable modules_admin::$count_row
$count_row in file Structure.class.php, variable Structure::$count_row
Количество выбранных элементов
$count_row | in file Templates.class.php, variable templates::$count_row
$count_row | in file Xsl.class.php, variable xsl::$count_row
Cache in file Cache.class.php, class Cache
Класс модуля "Кэширование"
Cache in file Cache.class.php, method Cache::Cache()
Конструктор
Cache.class.php | procedural page Cache.class.php
Cache.php | procedural page Cache.php
CACHE_INSTALL | in file Cache.php, constant CACHE_INSTALL
CACHE_LIMIT | in file Cache.php, constant CACHE_LIMIT
Captcha in file Captcha.class.php, class Captcha
Ядро, класс для работы с CAPTCHA
ChangeMySqlDate in file Date.class.php, method DateClass::ChangeMySqlDate()
Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд
ChangeNormalDate in file Date.class.php, method DateClass::ChangeNormalDate()
Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд
CheckBot in file Counter.class.php, method counter::CheckBot()
Метод проверки - является ли user agent ботом
CheckTypeGzip in file Compression.class.php, method compression::CheckTypeGzip()
Метод вовзращает тип сжатия gzip, в противном случае false
ClearAdvertisementList in file Advertisement.class.php, method Advertisement::ClearAdvertisementList()
Метод очищающий список показов, произошедших $count_days назад
ClearCache in file Cache.class.php, method Cache::ClearCache()
Метод удаления всех файлов из кэша
ClearStructure in file Structure.class.php, method Structure::ClearStructure()
Метод очистки параметров класса
CloseForum in file Forums.class.php, method Forums::CloseForum()
Метод, закрывающий/открывающий форум
CloseTheme in file Forums.class.php, method Forums::CloseTheme()
Метод, открыввающий/закрывающий тему для доступа
cms_error_handler in file Error.fns.php, function cms_error_handler()
Ядро, обработчики ошибок в HostCMS
code_ip in file Counter.class.php, method counter::code_ip()
Метод для преобразования IP в HEX
COMMENT_DALAY_ERROR_XSL | in file config.php, constant COMMENT_DALAY_ERROR_XSL
compression in file Compression.class.php, class compression
Класс модуля "Система сжатия (компрессия)"
Compression.class.php | procedural page Compression.class.php
Compression.php | procedural page Compression.php
COMPRESSION_INSTALL | in file Compression.php, constant COMPRESSION_INSTALL
ConfirmGetForm in file Forms.class.php, method Forms::ConfirmGetForm()
Метод, определяющий может ли пользователь отправлять форму
confirm_information_item in file InformationSystems.class.php, method InformationSystem::confirm_information_item()
Метод определения возможности пользователя добавлять информационный элемент
Constants in file Constants.class.php, class Constants
Класс модуля "Константы"
Constants.class.php | procedural page Constants.class.php
Constants.php | procedural page Constants.php
CopyDataTemplate in file Templates.class.php, method templates::CopyDataTemplate()
Метод копирования шаблона страниц
CopyDocuments in file Documents.class.php, method documents::CopyDocuments()
Метод копирования документа
CopyExtraProperty in file Site_users.class.php, method SiteUsers::CopyExtraProperty()
Метод копирования дополнительного параметра
CopyFascicle in file Maillist.class.php, method Maillist::CopyFascicle()
Метод копирования выпуска рассылки
CopyForms in file Forms.class.php, method Forms::CopyForms()
Метод копирования структуры формы и ее полей
CopyFormsField in file Forms.class.php, method Forms::CopyFormsField()
Метод копирования структуры поля формы
CopyInformationItem in file InformationSystems.class.php, method InformationSystem::CopyInformationItem()
Метод копирования элемента информационной системы
CopyListItem in file Lists.class.php, method lists::CopyListItem()
Метод копирования элементов списка
CopyTemplate in file Templates.class.php, method templates::CopyTemplate()
Метод копирования макета
CopyXsl in file Xsl.class.php, method xsl::CopyXsl()
Метод копирования XSL-шаблона
counter in file Counter.class.php, class counter
Класс модуля "Статистика посещаемости сайта"
COUNTER_BOT_COUNT | in file config.php, constant COUNTER_BOT_COUNT
config.php | procedural page config.php
Counter.class.php | procedural page Counter.class.php
Counter.php | procedural page Counter.php
COUNTER_INSTALL | in file Counter.php, constant COUNTER_INSTALL
CreateBackup in file Backup.class.php, method Backup::CreateBackup()
Метод создания резевной копии базы данных
CreateGroupsXmlTree in file InformationSystems.class.php, method InformationSystem::CreateGroupsXmlTree()
Метод формирования XML дерева для информационных групп
CreateRSS in file RssWrite.class.php, method RssWrite::CreateRSS()
Метод формирования XML-файла в стандарте RSS
current_alias in file Site.class.php, method site::current_alias()
Метод преобразования алиаса (домена) сайта в основной
current_version in file Documents.class.php, method documents::current_version()
Метод для переобозначения текущей версии документа
CURRENT_VERSION | in file Kernel.php, constant CURRENT_VERSION
config.php | procedural page config.php
config.php | procedural page config.php
Captcha.class.php | procedural page Captcha.class.php
config.php | procedural page config.php
top
d
$dec_point | in file show_table.class.php, variable table_fields::$dec_point
$delete_confirm | in file show_table.class.php, variable show_table::$delete_confirm
$delete_show | in file show_table.class.php, variable show_table::$delete_show
DateClass in file Date.class.php, class DateClass
Ядро, класс для работы с датами
DateSqlToUnix in file Date.class.php, method DateClass::DateSqlToUnix()
Метод преобразовывает дату в формате SQL в число секунд с начала эпохи
datetime_format in file Date.class.php, method DateClass::datetime_format()
Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT
datetime_format_sql in file Date.class.php, method DateClass::datetime_format_sql()
Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL
DateUnixToSQL in file Date.class.php, method DateClass::DateUnixToSQL()
Метод преобразовывает дату из числа секунд в формат SQL
date_format in file Date.class.php, method DateClass::date_format()
Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT
date_format_sql in file Date.class.php, method DateClass::date_format_sql()
Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат
db_connect in file Mysql.class.php, method MySQL::db_connect()
Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.
declension in file Kernel.class.php, method kernel::declension()
Метод получения существительного в форме, соответствующей числу
decode_ip in file Counter.class.php, method counter::decode_ip()
Метод для декодирования IP из HEX
DEFAULT_LNG | in file Kernel.php, constant DEFAULT_LNG
DelBannerGroup in file Advertisement.class.php, method Advertisement::DelBannerGroup()
Метод исключения баннера из группы
DelBannersGroup in file Advertisement.class.php, method Advertisement::DelBannersGroup()
Метод удаления группы баннеров
DelConstants in file Constants.class.php, method Constants::DelConstants()
Метод удаления константы
DeleteBanner in file Advertisement.class.php, method Advertisement::DeleteBanner()
Метод удаления баннера
DeleteExtraProperty in file Site_users.class.php, method SiteUsers::DeleteExtraProperty()
Метод удаления дополнительного параматра
DeleteForum in file Forums.class.php, method Forums::DeleteForum()
Метод удаления форума
DeleteSiteUser in file Site_users.class.php, method SiteUsers::DeleteSiteUser()
Метод удаления пользователя из системы
DeleteUserDeniedAccessBefore in file UserAccess.class.php, method UserAccessDenied::DeleteUserDeniedAccessBefore()
Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд
DeleteUsers in file Maillist.class.php, method Maillist::DeleteUsers()
Метод снятия подписки с подписчика
DeleteUsersGroup in file Maillist.class.php, method Maillist::DeleteUsersGroup()
Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке
delete_old_version in file Documents.class.php, method documents::delete_old_version()
Метод удаления записей обо всех не текущих версиях
delete_page in file Structure.class.php, method Structure::delete_page()
Метод удаления страницы
Delete_search_words in file Search.class.php, method Search::Delete_search_words()
Метод удаления из индекса страницы с указанным адресом
delete_status in file Documents.class.php, method documents::delete_status()
Метод удаления статуса документов
delete_version in file Documents.class.php, method documents::delete_version()
Метод удаления записей о версиях
DelFascicle in file Maillist.class.php, method Maillist::DelFascicle()
Метод удаления выпуска рассылки
DelFillForms in file Forms.class.php, method Forms::DelFillForms()
Удаление бланка заполненной формы
DelFillValues in file Forms.class.php, method Forms::DelFillValues()
Метод удаления значения одного из полей отправленной формы
DelForms in file Forms.class.php, method Forms::DelForms()
Метод удаления данных о форме
DelFormsFields in file Forms.class.php, method Forms::DelFormsFields()
Метод удаления поля формы
DelForumsGroup in file Forums.class.php, method Forums::DelForumsGroup()
Метод удаления группы форумов
DelGroupUser in file Site_users.class.php, method SiteUsers::DelGroupUser()
Метод удаления пользователя из группы
DelInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertys()
Метод удаления дополнительного свойства информационной группы
DelInformationGroupPropertysValue in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertysValue()
Метод удаления значений дополнительных свойств информационной группы
DelInformationSystem in file InformationSystems.class.php, method InformationSystem::DelInformationSystem()
Метод удаления информационной системы
DelIp in file ip.class.php, method ip::DelIp()
Метод удаления информации об IP-адресе
DELL_TIME | in file config.php, constant DELL_TIME
DelMaillist in file Maillist.class.php, method Maillist::DelMaillist()
Метод удаления рассылки
DelMessage in file Forums.class.php, method Forums::DelMessage()
Метод удаления сообщения темы
DelStatInfomationForSite in file Counter.class.php, method counter::DelStatInfomationForSite()
Метод удаления статистической информации для сайта
DelStructurePropertys in file Structure.class.php, method Structure::DelStructurePropertys()
Метод удаления дополнительного свойства
DelStructurePropertysValue in file Structure.class.php, method Structure::DelStructurePropertysValue()
Метод удаления значений дополнительных свойств из таблицы связи
DelTheme in file Forums.class.php, method Forums::DelTheme()
Метод удаления темы форума
DelUserGroup in file Site_users.class.php, method SiteUsers::DelUserGroup()
Метод удаления группы пользователей заданной идентификатором
del_alias in file Site.class.php, method site::del_alias()
Метод преобразования алиаса (домена) сайта в основной
del_comment in file InformationSystems.class.php, method InformationSystem::del_comment()
Метод удаления комментария к информационному элементу
del_data_templates in file Templates.class.php, method templates::del_data_templates()
Метод удаления шаблона страниц
del_dir in file FileManager.class.php, method FileManager::del_dir()
Метод удаления директории вместе с вложенными файлами и директориями
del_documents in file Documents.class.php, method documents::del_documents()
Метод удаления документов
del_documents_dir in file Documents.class.php, method documents::del_documents_dir()
Метод удаления разделов документов
del_file in file FileManager.class.php, method FileManager::del_file()
Метод удаления файла или директории
del_information_groups in file InformationSystems.class.php, method InformationSystem::del_information_groups()
Метод удаления информационных групп
del_information_items in file InformationSystems.class.php, method InformationSystem::del_information_items()
Метод удаления элемента информационной системы
del_information_propertys in file InformationSystems.class.php, method InformationSystem::del_information_propertys()
Метод удаления дополнительного свойства информационной системы
del_lists in file Lists.class.php, method lists::del_lists()
Метод удаления списка
del_lists_items in file Lists.class.php, method lists::del_lists_items()
Метод удаления элемента списка
del_module in file Modules.class.php, method modules_admin::del_module()
Метод удаления информации о модуле
del_poll in file Polls.class.php, method polls::del_poll()
Метод удаления опроса
del_poll_reply in file Polls.class.php, method polls::del_poll_reply()
Метод удаления варианта ответа
del_site in file Site.class.php, method site::del_site()
Метод удаления информации о сайте
del_templates in file Templates.class.php, method templates::del_templates()
Метод удаления макета
del_user in file UserAccess.class.php, method user_access::del_user()
Метод удаления пользователя
del_user_type in file UserAccess.class.php, method user_access::del_user_type()
Метод удаления типа пользователей
del_xsl in file Xsl.class.php, method xsl::del_xsl()
Метод удаления XSL-шаблона
del_xsl_dir in file Xsl.class.php, method xsl::del_xsl_dir()
Метод удаления XSL-раздела
Diagramm in file Graphic.class.php, method graphic::Diagramm()
Метод рисования круговой диаграммы
DIAGRAMM_LIMIT | in file Counter.php, constant DIAGRAMM_LIMIT
DIAGRAMM_WIDTH | in file Counter.php, constant DIAGRAMM_WIDTH
documents in file Documents.class.php, class documents
Класс модуля "Старницы и документы"
Documents.class.php | procedural page Documents.class.php
Documents.php | procedural page Documents.php
Download in file File.class.php, method File::Download()
Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла
do_html_footer_admin in file admin_output.fns.php, function do_html_footer_admin()
Функция выводит "подвал" для страниц раздела администрирования
do_html_header_admin in file admin_output.fns.php, function do_html_header_admin()
Функция выводит "шапку" для страниц раздела администрирования
do_show_table in file show_table.class.php, method show_table::do_show_table()
Метод отображает сформированную таблицу
Date.class.php | procedural page Date.class.php
top
e
$edit_id in file Structure.class.php, variable Structure::$edit_id
Идентификатор редактируемого узла структуры
$edit_show | in file show_table.class.php, variable show_table::$edit_show
$error | in file Modules.class.php, variable modules_admin::$error
$error | in file Templates.class.php, variable templates::$error
$error | in file Site.class.php, variable site::$error
$error in file Polls.class.php, variable polls::$error
Enter description here...
EDIT_TIME | in file config.php, constant EDIT_TIME
EndRecord in file Cache.class.php, method Cache::EndRecord()
Метод заканчивает запись из потока, выводит записанную информацию и сохраняет в кэше с именем $CacheName
EventsJournal in file EventsJournal.class.php, class EventsJournal
Ядро, класс журналирования событий
EventsJournalAdmin in file EventsJournal.class.php, class EventsJournalAdmin
Класс модуля "Журнал событий"
EventsJournal.class.php | procedural page EventsJournal.class.php
EventsJournal.php | procedural page EventsJournal.php
EventsMail in file EventsJournal.class.php, method EventsJournalAdmin::EventsMail()
Метод отправки письма с отчетом
ExecDump in file ExecSqlQuery.class.php, method ExecSqlQuery::ExecDump()
Метод выполнения SQL-запроса
ExecSqlQuery in file ExecSqlQuery.class.php, class ExecSqlQuery
Класс модуля "SQL-запросы"
ExecSqlQuery.class.php | procedural page ExecSqlQuery.class.php
ExecSqlQuery.php | procedural page ExecSqlQuery.php
ExternalXml in file ExternalXml.class.php, class ExternalXml
Ядро, класс формирует дерево XML по переданному массиву
E_STRICT | in file Kernel.php, constant E_STRICT
Error.fns.php | procedural page Error.fns.php
EventsJournal.class.php | procedural page EventsJournal.class.php
ExternalXml.class.php | procedural page ExternalXml.class.php
top
f
$field | in file show_table.class.php, variable table_fields::$field
$FieldForIndexArray | in file show_table.class.php, variable table_fields::$FieldForIndexArray
$field_action_show | in file show_table.class.php, variable show_table::$field_action_show
$field_copy | in file show_table.class.php, variable show_table::$field_copy
$field_delete | in file show_table.class.php, variable show_table::$field_delete
$field_description | in file show_table.class.php, variable table_fields::$field_description
$field_edit | in file show_table.class.php, variable show_table::$field_edit
$field_link | in file show_table.class.php, variable table_fields::$field_link
$field_name | in file show_table.class.php, variable table_fields::$field_name
$field_prefix | in file show_table.class.php, variable table_fields::$field_prefix
$field_type | in file show_table.class.php, variable table_fields::$field_type
$flag | in file ExternalXml.class.php, variable ExternalXml::$flag
$form_action | in file show_table.class.php, variable show_table::$form_action
File in file File.class.php, class File
Ядро, класс для работы с файлами
FileManager in file FileManager.class.php, class FileManager
Класс модуля "Файловый менеджер"
FileManager.class.php | procedural page FileManager.class.php
FileManager.php | procedural page FileManager.php
FillMasGroup in file InformationSystems.class.php, method InformationSystem::FillMasGroup()
Метод формирования массива групп самого верхнего уровня для данной информационной системы.
fill_xsl_dir in file Xsl.class.php, method xsl::fill_xsl_dir()
Метод формирования дерева разделов доски объявлений
FLUDE_PROTECTION | in file config.php, constant FLUDE_PROTECTION
Forms in file Forms.class.php, class Forms
Класс модуля "Формы"
Forms.class.php | procedural page Forms.class.php
Forms.php | procedural page Forms.php
Forums in file Forums.class.php, class Forums
Класс модуля "Форумы"
Forums.class.php | procedural page Forums.class.php
Forums.php | procedural page Forums.php
FORUMS_PARAM_INDEX | in file config.php, constant FORUMS_PARAM_INDEX
FORUMS_PATH | in file config.php, constant FORUMS_PATH
File.class.php | procedural page File.class.php
top
g
$GroupMass in file InformationSystems.class.php, variable InformationSystem::$GroupMass
Кэш с данными о группах
Graphic.class.php | procedural page Graphic.class.php
GenAddEditThemeXML in file Forums.class.php, method Forums::GenAddEditThemeXML()
Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
GenEditMessageXML in file Forums.class.php, method Forums::GenEditMessageXML()
Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
GenForumsXML in file Forums.class.php, method Forums::GenForumsXML()
Метод, формирующий XML для таблицы групп форумов (форумов) и выводящий его на экран в соответствии с указанным xsl шаблоном
GenGroupXmlTree in file InformationSystems.class.php, method InformationSystem::GenGroupXmlTree()
Метод формирования полного XML дерева информационных групп для информационной системы
GenMessageXML in file Forums.class.php, method Forums::GenMessageXML()
Метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном
GenSmilesXML in file Forums.class.php, method Forums::GenSmilesXML()
Метод возвращает XML для смайликов
GenThemesXML in file Forums.class.php, method Forums::GenThemesXML()
Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном
GenUserInfoXML in file Forums.class.php, method Forums::GenUserInfoXML()
Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном
GenXml in file ExternalXml.class.php, method ExternalXml::GenXml()
Метод генерации XML для переданного массива
GenXML4InfSys in file Structure.class.php, method Structure::GenXML4InfSys()
Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры
GenXml4StructureLevelMass in file Structure.class.php, method Structure::GenXml4StructureLevelMass()
Метод генерации части XML-а для записей указанного уровня
GetAccessItem in file InformationSystems.class.php, method InformationSystem::GetAccessItem()
Метод определения доступности информационного элемента
GetAlias in file Site.class.php, method site::GetAlias()
Метод получения данных об алиасе сайта
GetArrayCacheContent in file Cache.class.php, method Cache::GetArrayCacheContent()
Метод получает сохраненный в кэше массив
GetBotsInfo in file Counter.class.php, method counter::GetBotsInfo()
Метод получения данных о ботах и посещенных ими страницах
GetCacheContent in file Cache.class.php, method Cache::GetCacheContent()
Метод получения содержания кэша для заданного имени
GetCacheLifeTime in file Cache.class.php, method Cache::GetCacheLifeTime()
Метод возвращает время актуальности кэш-файла в секундах
GetCacheName in file Cache.class.php, method Cache::GetCacheName()
Метод возвращает имя кэш-файла для переданного имени
GetCaptchaId in file Captcha.class.php, method Captcha::GetCaptchaId()
Метод генерирует и возвращает уникальный индекс для CAPTCHA
GetCommentInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCommentInformationSystemItem()
Метод получения комментариев информационных элементов
GetConstants in file Constants.class.php, method Constants::GetConstants()
Метод получения данных о константах
GetCounterInform in file Counter.class.php, method counter::GetCounterInform()
Метод получения информации о данных счетчика за определенную дату
GetCountInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCountInformationSystemItem()
Метод получения количества элементов информационной системы
GetCountProperty4InformationSystem in file InformationSystems.class.php, method InformationSystem::GetCountProperty4InformationSystem()
Метод получения числа свойств информационной системы
GetCountProperty4Structure in file Structure.class.php, method Structure::GetCountProperty4Structure()
Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют
GetCountShowingBanner in file Advertisement.class.php, method Advertisement::GetCountShowingBanner()
Метод возвращает количество показов баннера
GetCountShowingBannerAtDay in file Advertisement.class.php, method Advertisement::GetCountShowingBannerAtDay()
Метод возвращает количество показов баннера за конкретный день
GetCurrentAlias in file Site.class.php, method site::GetCurrentAlias()
Метод определения основного алиаса сайта
GetCurrentSiteUser in file Site_users.class.php, method SiteUsers::GetCurrentSiteUser()
Метод определения идентификатора текущего пользователя сайта.
GetCurrentYear in file Kernel.class.php, method kernel::GetCurrentYear()
Метод получения значения текущего года
GetDBVersion in file Kernel.class.php, method kernel::GetDBVersion()
Метод определения версии MySQL
GetDefaultGroup in file Site_users.class.php, method SiteUsers::GetDefaultGroup()
Метод получения id группы используемой по умолчанию
GetDocumentVersion in file Documents.class.php, method documents::GetDocumentVersion()
Метод получения информации о текущей версии документа
GetExpansion in file InformationSystems.class.php, method InformationSystem::GetExpansion()
Метод получения расширения файла
GetExtension in file Kernel.class.php, method kernel::GetExtension()
Метод возвращает расширение файла
GetExternalInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetExternalInformationSystemItem()
Метод получения элементов информационной системы. Переименован с GetInformationSystemItem
GetExtraProperty in file Site_users.class.php, method SiteUsers::GetExtraProperty()
Метод получения значения характеристик дополнительного параметра
GetFileContent in file File.class.php, method File::GetFileContent()
Метод получения содержимого файла
GetForm in file Forms.class.php, method Forms::GetForm()
Метод обработки содержимого отправленной формы
GetFormFields in file Forms.class.php, method Forms::GetFormFields()
Метод получения данных о полях формы
GetForumAccess in file Forums.class.php, method Forums::GetForumAccess()
Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму
GetGDVersion in file Kernel.class.php, method kernel::GetGDVersion()
Метод определения версии GD библиотеки
GetGroupsInformationSystem in file InformationSystems.class.php, method InformationSystem::GetGroupsInformationSystem()
Метод формирования дерева групп информационной группы
GetIdInformationItem in file InformationSystems.class.php, method InformationSystem::GetIdInformationItem()
Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы
GetImageSize in file Image.class.php, method Image::GetImageSize()
Метод определяет высоту и ширину изображения
GetInformationFromPath in file InformationSystems.class.php, method InformationSystem::GetInformationFromPath()
Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI
GetInformationGroupName in file InformationSystems.class.php, method InformationSystem::GetInformationGroupName()
Метод получения имени информационной группы
GetInformationSystem in file InformationSystems.class.php, method InformationSystem::GetInformationSystem()
Метод получения данных об информационной системе
GetInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItem()
Метод для получения данных об информационном элементе
GetInformationSystemItems in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItems()
Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит
GetInitialData in file Counter.class.php, method counter::GetInitialData()
Метод получения начальных данных для счетчика
GetIpInfo in file ip.class.php, method ip::GetIpInfo()
Метод получения информации о запретах для переданного ip-адреса
GetIpInformation in file Counter.class.php, method counter::GetIpInformation()
Метод выборки информации для IP-адреса
GetLastModified in file Kernel.class.php, method kernel::GetLastModified()
Метод получения времени последнего изменения страницы
GetList in file Lists.class.php, method lists::GetList()
Метод выборки данных о списках
GetListExtraProperties in file Site_users.class.php, method SiteUsers::GetListExtraProperties()
Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором
GetListItem in file Lists.class.php, method lists::GetListItem()
Метод получения данные об элементе списка
GetListPrimaryProperties in file Site_users.class.php, method SiteUsers::GetListPrimaryProperties()
Метод получения списка значений обязательных для заполнения параметров пользователя определяемого идентификатором
GetMaillistXML in file Maillist.class.php, method Maillist::GetMaillistXML()
Метод генерирующий XML для состояния подписки конкретного пользователя сайта
getmicrotime in file Kernel.class.php, method kernel::getmicrotime()
Метод получения значения времени
GetNewUsersInform in file Counter.class.php, method counter::GetNewUsersInform()
Метод выборки информации о новых пользователях сайта
GetPageInfo in file Search.class.php, method Search::GetPageInfo()
Метод получения информации о проиндексированных страницах
GetPathGroup in file InformationSystems.class.php, method InformationSystem::GetPathGroup()
Метод формирования пути по информационным группам
GetPathItem in file InformationSystems.class.php, method InformationSystem::GetPathItem()
Метод формирования пути к данному информационному элементу
GetProperrtyMenuId in file Structure.class.php, method Structure::GetProperrtyMenuId()
Метод получения информации о текущем разделе меню
GetPropertyACountProperty in file Structure.class.php, method Structure::GetPropertyACountProperty()
Метод получения количества свойств для разных сайтов
GetPropertyCountRow in file InformationSystems.class.php, method InformationSystem::GetPropertyCountRow()
Метод получения числа записей в выборке инфосистем, групп или информационных элементов
GetPropertyCountRow in file Structure.class.php, method Structure::GetPropertyCountRow()
Метод получения количества выбранных элементов
GetPropertyEditId in file Structure.class.php, method Structure::GetPropertyEditId()
Метод полчения информации о редактиремом элементе структуры
GetPropertyError in file InformationSystems.class.php, method InformationSystem::GetPropertyError()
Метод возвращающий код ошибки, возникающей при работе с методами класса
GetPropertyLevel in file Structure.class.php, method Structure::GetPropertyLevel()
Метод получения информации о максимальном уровне
GetPropertyMasInformationGroups | in file InformationSystems.class.php, method InformationSystem::GetPropertyMasInformationGroups()
GetPropertyParentId in file Structure.class.php, method Structure::GetPropertyParentId()
Метод получения идентификатора родительского узла текущего элемента структуры
GetPropertyRecordOnPage in file InformationSystems.class.php, method InformationSystem::GetPropertyRecordOnPage()
Метод получения числа записей, выводимых на страницу
GetPropertyRss in file InformationSystems.class.php, method InformationSystem::GetPropertyRss()
Метод получения значения свойства RSS
GetPropertySectionPath in file InformationSystems.class.php, method InformationSystem::GetPropertySectionPath()
Метод получения значения свойтва, содержащего пути по группам
GetPropertySeparator in file Structure.class.php, method Structure::GetPropertySeparator()
Метод получения информации о разделителе
GetPropertysGroup in file InformationSystems.class.php, method InformationSystem::GetPropertysGroup()
Метод получения данных о дополнительных свойствах информационной группы
GetPropertysInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetPropertysInformationSystemItem()
Метод получения свойств информационных элементов
GetPropertyStructureMass in file Structure.class.php, method Structure::GetPropertyStructureMass()
Метод получения информации об элементах структуры
GetPropertyStructureParentMass in file Structure.class.php, method Structure::GetPropertyStructureParentMass()
Метод получения информации о родительских разделах элемента структуры
GetPropertyStructurePropertysList in file Structure.class.php, method Structure::GetPropertyStructurePropertysList()
Метод получения дополнительных свойств структуры
GetSearchSystemInform in file Counter.class.php, method counter::GetSearchSystemInform()
Метод выборки информации о поисковых системах
GetSecondaryStat in file Counter.class.php, method counter::GetSecondaryStat()
Метод получения статистической информации из таблицы сессий
GetSelect in file show_table.class.php, method show_table::GetSelect()
Метод формирования html содержимого тега select
GetSite in file Site.class.php, method site::GetSite()
Метод получения данных о сайте по его идентификатору
GetStatArray in file Counter.class.php, method counter::GetStatArray()
Метод получения статистической информации из основной таблицы
GetStatDataArray in file Counter.class.php, method counter::GetStatDataArray()
Метод получения статистических данных за переданный промежуток времени
GetStructure in file Structure.class.php, method Structure::GetStructure()
Метод выборки всех страниц структуры
GetStructureAccess in file Structure.class.php, method Structure::GetStructureAccess()
Метод получения информации о доступе к узлу элементов структуры
GetStructureForParent in file Structure.class.php, method Structure::GetStructureForParent()
Метод получения подразделов для раздела
GetStructureItem in file Structure.class.php, method Structure::GetStructureItem()
* Метод получения данных об элементе структуры
GetStructurePath in file Structure.class.php, method Structure::GetStructurePath()
Методж= определения полного пути к странице
GetStructureProperty in file Structure.class.php, method Structure::GetStructureProperty()
Метод возвращает заполненные св-ва узлов структуры
GetTemplate in file Templates.class.php, method templates::GetTemplate()
Метод получения информации о макете
GetTemplate in file Kernel.class.php, method kernel::GetTemplate()
Метод получения текущего шаблона
GetUseCJ in file Counter.class.php, method counter::GetUseCJ()
Метод получения данных о использовании кукисов и Java
GetUserGroups in file Site_users.class.php, method SiteUsers::GetUserGroups()
Метод определения идентификаторов всех групп, в которые входит пользователь
GetValueExtraProperty in file Site_users.class.php, method SiteUsers::GetValueExtraProperty()
Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра
GetXml4StructurePropertys in file Structure.class.php, method Structure::GetXml4StructurePropertys()
Метод получения XML для свойств структуры
GetXmlForInformatioItem in file InformationSystems.class.php, method InformationSystem::GetXmlForInformatioItem()
Метод формирования XML для отображения информационного элемента
GetXsl in file Xsl.class.php, method xsl::GetXsl()
Метод получения информаци об XSL-шаблоне по его имени
get_count_row in file Mysql.class.php, method MySQL::get_count_row()
Метод возвращает количество строк в последнем запросе
get_CSS in file Kernel.class.php, method kernel::get_CSS()
Метод получения CSS стиля для страницы
get_current_page in file Kernel.class.php, method kernel::get_current_page()
Метод получения идентификатора текущего узла структуры
get_current_page_path in file Kernel.class.php, method kernel::get_current_page_path()
Метод получения пути текущей страницы
get_description in file Kernel.class.php, method kernel::get_description()
Метод получения описания страницы
get_documents_dir in file Documents.class.php, method documents::get_documents_dir()
Метод формирования дерева разделов
get_file_perms in file File.class.php, method File::get_file_perms()
Метод получения строки прав доступа к файлу
get_information_groups_path in file InformationSystems.class.php, method InformationSystem::get_information_groups_path()
Метод формирования пути по дереву информационных групп.
get_keywords in file Kernel.class.php, method kernel::get_keywords()
Метод получения ключевых слов страницы
get_mas_information_groups_for_xml in file InformationSystems.class.php, method InformationSystem::get_mas_information_groups_for_xml()
Метод возвращает XML для информационных групп
get_page_id in file Kernel.class.php, method kernel::get_page_id()
Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя
get_path in file Documents.class.php, method documents::get_path()
Метод формирования строки ссылок с родительскими разделами
get_polls_name in file Polls.class.php, method polls::get_polls_name()
Метод получения названия опроса
get_section_path in file Xsl.class.php, method xsl::get_section_path()
Функция возвращает путь по дереву разделов
get_title in file Kernel.class.php, method kernel::get_title()
Метод получения заголовка страницы
GISTOGRAMM_LIMIT | in file Counter.php, constant GISTOGRAMM_LIMIT
graphic | in file Graphic.class.php, class graphic
graphic_diagramma in file Graphic.class.php, method graphic::graphic_diagramma()
Метод вывода круговой диаграммы
graphic_gistogramma in file Graphic.class.php, method graphic::graphic_gistogramma()
Метод вывода гистограммы
top
h
$html | in file show_table.class.php, variable show_table::$html
top
i
$image | in file show_table.class.php, variable table_fields::$image
$image | in file show_table.class.php, variable show_table::$image
$image_is_link | in file show_table.class.php, variable table_fields::$image_is_link
$image_link | in file show_table.class.php, variable table_fields::$image_link
$IndexForArray | in file show_table.class.php, variable table_fields::$IndexForArray
$ItemMass in file InformationSystems.class.php, variable InformationSystem::$ItemMass
Кэш с данными об элементах
Image in file Image.class.php, class Image
Ядро, класс для работы с графическими изображениями
imagebar in file Graphic.class.php, method graphic::imagebar()
Метод вывода гистограммы
implode_array in file Kernel.class.php, method kernel::implode_array()
Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно
IncCountMessage in file Forums.class.php, method Forums::IncCountMessage()
Метод наращивания счётчика количества сообщений для пользователя
IndexationForums in file Forums.class.php, method Forums::IndexationForums()
Метод индексации форумов
IndexationForumsMessages in file Forums.class.php, method Forums::IndexationForumsMessages()
Метод индексации сообщений тем форумов
IndexationStructure in file Structure.class.php, method Structure::IndexationStructure()
Метод индексации элементов структуры
InformationSystem in file InformationSystems.class.php, class InformationSystem
Класс модуля "Информационные системы"
InformationSystemGroupAccess in file InformationSystems.class.php, method InformationSystem::InformationSystemGroupAccess()
Метод определения доступности информационной группы для пользователей сайта
InformationSystemItemAccess in file InformationSystems.class.php, method InformationSystem::InformationSystemItemAccess()
Метод определения доступности информационного элемента для пользователя
InformationSystems.class.php | procedural page InformationSystems.class.php
InformationSystems.php | procedural page InformationSystems.php
InitConstants in file Kernel.class.php, method kernel::InitConstants()
Метод инициализации констант сайта в соответствии с константой CURRENT_SITE
InsertArrayIntoCache in file Cache.class.php, method Cache::InsertArrayIntoCache()
Метод сохраняет в кэше массив
InsertBanners in file Advertisement.class.php, method Advertisement::InsertBanners()
Метод добавления баннера в группу/редактирования приоритета показа баннера в группе
InsertBannersGroup in file Advertisement.class.php, method Advertisement::InsertBannersGroup()
Метод добавления/редактирования информации о группе баннеров
InsertExtraProperty in file Site_users.class.php, method SiteUsers::InsertExtraProperty()
Метод добавления/редактирования дополнительного параметра
InsertFascicle in file Maillist.class.php, method Maillist::InsertFascicle()
Метод добавления/редактирования выпуска рассылки
InsertForms in file Forms.class.php, method Forms::InsertForms()
Метод вставки/обновления информации о форме
InsertFormsFields in file Forms.class.php, method Forms::InsertFormsFields()
Метод вставки/обновления информации о поле формы
InsertFormsFill in file Forms.class.php, method Forms::InsertFormsFill()
Метод вставки/обновления информации о заполнении формы
InsertFormsFillValues in file Forms.class.php, method Forms::InsertFormsFillValues()
Метод вставки/обновления значений заполненной формы
InsertForum in file Forums.class.php, method Forums::InsertForum()
Метод добавления/редактирования форума
InsertForumsGroup in file Forums.class.php, method Forums::InsertForumsGroup()
Метод добавления/редактирования группы форумов
InsertInformationGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationGroups()
Метод вставки/обновления данных об информационной группе
InsertInformationItems in file InformationSystems.class.php, method InformationSystem::InsertInformationItems()
Метод вставки/обновления данных об информационном элементе
InsertInformationPropertys in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertys()
Метод вставки/обновления информации о свойстве информационной системы
InsertInformationPropertysGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroups()
Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы
InsertInformationPropertysGroupsValue in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroupsValue()
Метод вставки/обновления значения свойства информационной группы
InsertInformationPropertysItems in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysItems()
Метод вставки/обновления значения свойства информационной
InsertInfotmationSystem in file InformationSystems.class.php, method InformationSystem::InsertInfotmationSystem()
Метод вставки/обновления данных об информационной системе
InsertIntoCache in file Cache.class.php, method Cache::InsertIntoCache()
Метод размещает строковые данные в кэше
InsertIp in file ip.class.php, method ip::InsertIp()
Метод вставки/обновления информации об IP-адресе
InsertMaillist in file Maillist.class.php, method Maillist::InsertMaillist()
Метод добавления/редактирования информации о рассылке
InsertRecord in file Counter.class.php, method counter::InsertRecord()
Метод добавления записи в основную таблицу статистики
InsertSession in file Counter.class.php, method counter::InsertSession()
Метод для вставки записи о сессии
InsertStructurePropertys in file Structure.class.php, method Structure::InsertStructurePropertys()
Метод вставки и редактирования дополнительного свойства для структуры
InsertStructurePropertysValue in file Structure.class.php, method Structure::InsertStructurePropertysValue()
Метод вставки и редактирования значения дополнительного свойства в таблице связи
InsertUserDeniedAccess in file UserAccess.class.php, method UserAccessDenied::InsertUserDeniedAccess()
Метод записи в базу информации о неудачной попытке входа в BackOffice
InsertUserGroup in file Site_users.class.php, method SiteUsers::InsertUserGroup()
Метод вставки и обновления информации о группе пользователей
InsertUsers in file Maillist.class.php, method Maillist::InsertUsers()
Метод добавления/редактирования информации о подписчике
InsertUsers in file Site_users.class.php, method SiteUsers::InsertUsers()
Метод добавления пользователя в группу
InsertUsersGroup in file Forums.class.php, method Forums::InsertUsersGroup()
Метод добавления/редактирования группы пользователей для определения доступа к форуму
InsertUsersGroup in file Maillist.class.php, method Maillist::InsertUsersGroup()
Метод, открывающий доступ группе пользователей сайта к рассылке
insert_alias in file Site.class.php, method site::insert_alias()
Метод вставки/обновления информации об алиасе (домене) сайта
insert_comment in file InformationSystems.class.php, method InformationSystem::insert_comment()
Метод вставки/обновления комментария для элемента информационной системы
insert_comment_without_striptags in file InformationSystems.class.php, method InformationSystem::insert_comment_without_striptags()
Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах
insert_data_templates in file Templates.class.php, method templates::insert_data_templates()
Методы добавления (редактирования) шаблонов страниц
insert_documents in file Documents.class.php, method documents::insert_documents()
Метод вставки и обновления новых документов
insert_documents_dir in file Documents.class.php, method documents::insert_documents_dir()
Метод вставки и обновления разделов документов
insert_lists in file Lists.class.php, method lists::insert_lists()
Метод вставки/обновления данных о списке
insert_lists_items in file Lists.class.php, method lists::insert_lists_items()
Метод вставки/обновления данных об элементе списка
insert_module in file Modules.class.php, method modules_admin::insert_module()
Метод вставки/обновления информации о модуле
insert_poll in file Polls.class.php, method polls::insert_poll()
Метод осуществляет вставку и обновление опросов
insert_poll_reply in file Polls.class.php, method polls::insert_poll_reply()
Метод, осуществляет вставку и обновление вариантов ответов
insert_site in file Site.class.php, method site::insert_site()
Метод вставки/обновления информации о сайте
insert_status in file Documents.class.php, method documents::insert_status()
Метод добавления(редактирования) статусов документов
insert_template in file Templates.class.php, method templates::insert_template()
Метод добавления макета
insert_user in file UserAccess.class.php, method user_access::insert_user()
Метод вставки и обновления информации о пользователе
insert_user_type in file UserAccess.class.php, method user_access::insert_user_type()
Метод вставки и обновления информации о типе пользователей
insert_version in file Documents.class.php, method documents::insert_version()
Метод добавления/редактирования записей о версиях
insert_xsl in file Xsl.class.php, method xsl::insert_xsl()
Метод вставки/обновления XSL
insert_xsl_dir in file Xsl.class.php, method xsl::insert_xsl_dir()
Метод вставки и обновления XSL рубрик
ip in file ip.class.php, class ip
Класс модуля "IP-адреса"
ip.class.php | procedural page ip.class.php
ip.php | procedural page ip.php
IsSearchSystem in file Counter.class.php, method counter::IsSearchSystem()
Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:
IssetCacheContent in file Cache.class.php, method Cache::IssetCacheContent()
Метод возвращает наличие/отсутствие кэш-файла для переданного имени кэш-элемента
IssetGroup in file InformationSystems.class.php, method InformationSystem::IssetGroup()
Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе
IssetGroupItemInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetGroupItemInsertUpdate()
Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента
IssetItem in file InformationSystems.class.php, method InformationSystem::IssetItem()
Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы
IssetItemGroupInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetItemGroupInsertUpdate()
Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы
IssetModule in file Modules.class.php, method modules_admin::IssetModule()
Метод проверки наличия активного модуля
IssetPath in file Structure.class.php, method Structure::IssetPath()
Метод определения наличия пути
isset_id in file Counter.class.php, method counter::isset_id()
Метод проверки наличия id сайта
Image.class.php | procedural page Image.class.php
top
j
JPG_QUALITY | in file Kernel.php, constant JPG_QUALITY
top
k
$key_id | in file show_table.class.php, variable show_table::$key_id
kernel in file Kernel.class.php, class kernel
Класс ядра системы управления сайтом HostCMS
Kernel.class.php | procedural page Kernel.class.php
Kernel.php | procedural page Kernel.php
top
l
$level in file Structure.class.php, variable Structure::$level
Максимальный уровень структуры
link_len in file Url.class.php, method url::link_len()
Метод сокращения длины строки
lists in file Lists.class.php, class lists
Класс модуля "Списки"
LISTS_INSTALL | in file Lists.php, constant LISTS_INSTALL
Lists.class.php | procedural page Lists.class.php
Lists.php | procedural page Lists.php
LoadModules in file Kernel.class.php, method kernel::LoadModules()
Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS
LoadModulesLngFile in file Kernel.class.php, method kernel::LoadModulesLngFile()
Метод загрузки языкового файла для модуля
load_files in file FileManager.class.php, method FileManager::load_files()
Метод загрузки файлов
log_access in file EventsJournal.class.php, method EventsJournal::log_access()
Метод протоколирования получения доступа к системе управления
top
m
$mas | in file show_table.class.php, variable show_table::$mas
$MasGroup in file InformationSystems.class.php, variable InformationSystem::$MasGroup
Массив групп
$mas_documents_dir in file Documents.class.php, variable documents::$mas_documents_dir
Массив разделов документов
$mas_image | in file show_table.class.php, variable table_fields::$mas_image
$mas_xsl_dir | in file Xsl.class.php, variable xsl::$mas_xsl_dir
$menu_id in file Structure.class.php, variable Structure::$menu_id
Идентификатор раздела меню
Mysqldump.class.php | procedural page Mysqldump.class.php
Message.fns.php | procedural page Message.fns.php
Mysql.class.php | procedural page Mysql.class.php
Maillist in file Maillist.class.php, class Maillist
Класс модуля "Почтовые рассылки"
Maillist.class.php | procedural page Maillist.class.php
Maillist.php | procedural page Maillist.php
MailReport in file Counter.class.php, method counter::MailReport()
Метод отправки письма с отчетом администратору сайта
MAIL_EVENTS_STATUS | in file Kernel.php, constant MAIL_EVENTS_STATUS
MAX_HEIGHT_AVATAR | in file config.php, constant MAX_HEIGHT_AVATAR
MAX_SIZE_AVATAR | in file config.php, constant MAX_SIZE_AVATAR
MAX_WIDTH_AVATAR | in file config.php, constant MAX_WIDTH_AVATAR
Menu.class.php | procedural page Menu.class.php
Menu.php | procedural page Menu.php
modules_admin in file Modules.class.php, class modules_admin
Класс модуля "Управление модулями"
Modules.class.php | procedural page Modules.class.php
Modules.php | procedural page Modules.php
MySQL in file Mysql.class.php, class MySQL
Ядро, класс для работы с MySQL
MySQL in file Mysql.class.php, method MySQL::MySQL()
Конструктор.
top
n
$new_session in file Counter.class.php, variable counter::$new_session
Флаг добавления новой сессии при обновлении данных счетчика
NodeIsParent in file Structure.class.php, method Structure::NodeIsParent()
Метод определения принадлежности узла структуры вышестоящему родителю
NoticeTheme in file Forums.class.php, method Forums::NoticeTheme()
Метод делающий тему объявлением или наоборот
top
o
ON_PAGE | in file Kernel.php, constant ON_PAGE
ON_PAGE_MESSAGE | in file config.php, constant ON_PAGE_MESSAGE
ON_PAGE_THEME | in file config.php, constant ON_PAGE_THEME
OrderExtraProperty in file Site_users.class.php, method SiteUsers::OrderExtraProperty()
Метод обновления коэффициентов порядка сортировки
OrderForums in file Forums.class.php, method Forums::OrderForums()
Метод изменения порядка сортировки форумов в группе
OrderForumsGroup in file Forums.class.php, method Forums::OrderForumsGroup()
Метод изменения порядка сортировки групп форумов
OS_UNIX | in file tar.class.php, constant OS_UNIX
top
p
$parent_id in file Structure.class.php, variable Structure::$parent_id
Идентификатор родительского узла элемента структуры
$PropertyGroupMass in file InformationSystems.class.php, variable InformationSystem::$PropertyGroupMass
Кэш с данными о дополнительных свойствах информационных групп
$PropertyMass in file InformationSystems.class.php, variable InformationSystem::$PropertyMass
Кэш с данными о свойствах инфоррмационных элементов
Password.class.php | procedural page Password.class.php
PageCompressionBegin in file Compression.class.php, method compression::PageCompressionBegin()
Метод начала приема из стандартного потока содержимого для компрессии
PageCompressionEnd in file Compression.class.php, method compression::PageCompressionEnd()
Метод выводит сжатые данные, размещаемые в потоке
PathCorrection in file FileManager.class.php, method FileManager::PathCorrection()
Метод удаляет потенциально опасных символы из пути или имени файла
polls in file Polls.class.php, class polls
Класс модуля "Опросы"
Polls.class.php | procedural page Polls.class.php
Polls.php | procedural page Polls.php
POLLS_WIDTH | in file Kernel.php, constant POLLS_WIDTH
PrivateOfficeXML in file Site_users.class.php, method SiteUsers::PrivateOfficeXML()
Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону
top
q
$query | in file show_table.class.php, variable show_table::$query
query in file Mysql.class.php, method MySQL::query()
Метод выполнения SQL-запроса
quote_smart in file Security.fns.php, function quote_smart()
Экранирует потенциально опасные символы для MySQL запросов
top
r
$record_on_page in file Polls.class.php, variable polls::$record_on_page
Enter description here...
$record_on_page in file Lists.class.php, variable lists::$record_on_page
Количество выводимых элементов на страницу
$record_on_page | in file Modules.class.php, variable modules_admin::$record_on_page
$record_on_page in file Documents.class.php, variable documents::$record_on_page
Число записей, выводимых на странице в административной части
$record_on_page | in file Site.class.php, variable site::$record_on_page
$record_on_page in file RssWrite.class.php, variable RssWrite::$record_on_page
Количество в потоке
$record_on_page | in file Xsl.class.php, variable xsl::$record_on_page
$record_on_page in file ip.class.php, variable ip::$record_on_page
Число записей, отображаемых на странице
$record_on_page | in file Templates.class.php, variable templates::$record_on_page
$result | in file Mysql.class.php, variable MySQL::$result
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RssRead.class.php | procedural page RssRead.class.php
RssWrite.class.php | procedural page RssWrite.class.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
random_shuffle in file Kernel.class.php, method kernel::random_shuffle()
Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.
ReadRSS in file RssRead.class.php, method RssRead::ReadRSS()
Метод чтения данных из RSS потока
RegistrationXML in file Site_users.class.php, method SiteUsers::RegistrationXML()
Метод формирования XML для раздела регистрации и вывода его на экран согласно указанному xsl шаблону
RenewMaillist in file Maillist.class.php, method Maillist::RenewMaillist()
Метод обновления информации о подписке для конкретного подписчика
resizeToFile in file Image.class.php, method Image::resizeToFile()
Метод изменения размера изображения
RssRead in file RssRead.class.php, class RssRead
Ядро, класс для чтения RSS
RssWrite in file RssWrite.class.php, class RssWrite
Ядро, класс для генерации RSS
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
top
s
$section_path | in file Xsl.class.php, variable xsl::$section_path
$separator in file Structure.class.php, variable Structure::$separator
Разделитель для уровней
$size | in file show_table.class.php, variable table_fields::$size
$StructureMass in file Structure.class.php, variable Structure::$StructureMass
Массив с элементами структуры
$StructureParentMass in file Structure.class.php, variable Structure::$StructureParentMass
Массив родительских разделов
$structure_propertys_list in file Structure.class.php, variable Structure::$structure_propertys_list
Хранит результат запроса на выборку дополнительных свойств структуры
Security.fns.php | procedural page Security.fns.php
Search | in file Search.class.php, class Search
SearchWords in file Search.class.php, method Search::SearchWords()
Поиск списка слов в индексе
Search.class.php | procedural page Search.class.php
Search.php | procedural page Search.php
select in file Mysql.class.php, method MySQL::select()
Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()
SelectBannersGroup in file Advertisement.class.php, method Advertisement::SelectBannersGroup()
Метод получения информации о конкретной группе баннеров или обо всех баннерах
SelectFascicle in file Maillist.class.php, method Maillist::SelectFascicle()
Метод получения данных о выпуске рассылки
SelectForms in file Forms.class.php, method Forms::SelectForms()
Метод выбора данных о формах
SelectFormsFields in file Forms.class.php, method Forms::SelectFormsFields()
Метод выбора данных о поле формы
SelectForum in file Forums.class.php, method Forums::SelectForum()
Метод, возвращающий информацию о форуме
SelectForumsGroup in file Forums.class.php, method Forums::SelectForumsGroup()
Метод, возвращающий информацию о группе форумов
SelectInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::SelectInformationGroupPropertys()
Метод получения данных о свойствах группы информационной системы
SelectInformationGroups in file InformationSystems.class.php, method InformationSystem::SelectInformationGroups()
Метод получения информации об информационных группах конкретной информационной системы
SelectInformationSystem in file InformationSystems.class.php, method InformationSystem::SelectInformationSystem()
Метод получения информации об информационной системе
SelectIp in file ip.class.php, method ip::SelectIp()
Метод получения информации об IP-адресах
SelectListInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::SelectListInformationGroupPropertys()
Метод получения списка дополнительных свойств информационноq группы данной инфосистемы
SelectListsItems in file Lists.class.php, method lists::SelectListsItems()
Метод получения данных об элементах списка
SelectMaillist in file Maillist.class.php, method Maillist::SelectMaillist()
Метод получения данных о рассылке
SelectMessage in file Forums.class.php, method Forums::SelectMessage()
Метод возвращающий информацию о сообщении
SelectStructurePropertys in file Structure.class.php, method Structure::SelectStructurePropertys()
Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)
SelectTheme in file Forums.class.php, method Forums::SelectTheme()
Метод, возвращающий информацию о теме
SelectUser in file Maillist.class.php, method Maillist::SelectUser()
Метод получения информации о состоянии подписки подписчика на рассылку
SelectUserDeniedAccess in file UserAccess.class.php, method UserAccessDenied::SelectUserDeniedAccess()
Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса
SelectUserType in file Site_users.class.php, method SiteUsers::SelectUserType()
Метод возвращает параметры группы пользователя
select_alias in file Site.class.php, method site::select_alias()
Метод получения информации об алиасе (домене) сайта
select_comments in file InformationSystems.class.php, method InformationSystem::select_comments()
Метод получения комментариев к информационному элементу
select_data_templates in file Templates.class.php, method templates::select_data_templates()
Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)
select_documents in file Documents.class.php, method documents::select_documents()
Метод получения информации о документе или обо всех документах
select_documents_dir in file Documents.class.php, method documents::select_documents_dir()
Метод выбора раздела документов
select_information_items in file InformationSystems.class.php, method InformationSystem::select_information_items()
Метод получения данных об информационном элементе
select_information_propertys in file InformationSystems.class.php, method InformationSystem::select_information_propertys()
Метод получения данных о свойствах информационной системы
select_lists_items in file Lists.class.php, method lists::select_lists_items()
Метод получения данных об элементе списка
select_modules in file Modules.class.php, method modules_admin::select_modules()
Метод получения информации о модуле
select_poll in file Polls.class.php, method polls::select_poll()
Метод осуществляет выборку опросов
select_poll_reply in file Polls.class.php, method polls::select_poll_reply()
Метод выбора вариантов ответов
select_site in file Site.class.php, method site::select_site()
Метод получения данных о сайте
select_status in file Documents.class.php, method documents::select_status()
Метод получения информации о статусе документа
select_user in file UserAccess.class.php, method user_access::select_user()
Метод получения информации о пользователях пользователе
select_user_access in file UserAccess.class.php, method user_access::select_user_access()
Метод получения тнформации о типах доступа пользователей
select_user_type in file UserAccess.class.php, method user_access::select_user_type()
Метод выбора типа пользователей
select_version in file Documents.class.php, method documents::select_version()
Метод выборки информации о версиях
select_xsl in file Xsl.class.php, method xsl::select_xsl()
Метод получения данных о XSL-шаблонах
select_xsl_dir in file Xsl.class.php, method xsl::select_xsl_dir()
Метод получения информации о XSL-разделах
SendFascicle in file Maillist.class.php, method Maillist::SendFascicle()
Метод отправки выпуска всем подписчикам рассылки
SendNewPassword in file Site_users.class.php, method SiteUsers::SendNewPassword()
Метод отправки нового пароля на почтовый ящик пользователю
SendRegistInf in file Site_users.class.php, method SiteUsers::SendRegistInf()
Метод отправки пользователю регистрайионной информации
session_start in file Admin.class.php, method Admin::session_start()
Метод старта сессии для раздела администрирования
SetActionWidth in file show_table.class.php, method show_table::SetActionWidth()
Изменяет ширину поля Действие
SetButton in file show_table.class.php, method show_table::SetButton()
Изменяет флаг вывода кнопки
SetButtonName in file show_table.class.php, method show_table::SetButtonName()
Устанавливает наименование кнопки
SetButtonValue in file show_table.class.php, method show_table::SetButtonValue()
Изменяет value кнопки
SetCacheLifeTime in file Cache.class.php, method Cache::SetCacheLifeTime()
Метод устанавливает время актуальности кэш-файла для запрашиваемого имени
SetConfirmation in file Site_users.class.php, method SiteUsers::SetConfirmation()
Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)
SetConfirmationID in file Site_users.class.php, method SiteUsers::SetConfirmationID()
Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки
SetCopyShow in file show_table.class.php, method show_table::SetCopyShow()
Изменяет флаг показа кнопки для копирования
SetCurrentSite in file Admin.class.php, method Admin::SetCurrentSite()
Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта
SetDefaultGroup in file Site_users.class.php, method SiteUsers::SetDefaultGroup()
Метод установления группы с указанным идентификатором по умолчанию
SetDeleteConfirm in file show_table.class.php, method show_table::SetDeleteConfirm()
Изменяет сообщение, выводимое при удалении
SetDeleteShow in file show_table.class.php, method show_table::SetDeleteShow()
Изменяет флаг показа кнопки удалить
SetEditShow in file show_table.class.php, method show_table::SetEditShow()
Изменяет флаг показа кнопки редактировать
SetFieldActionShow in file show_table.class.php, method show_table::SetFieldActionShow()
Изменяет флаг вывода поля с действиями
SetFieldCopy in file show_table.class.php, method show_table::SetFieldCopy()
Изменяет поле для копирования
SetFieldDelete in file show_table.class.php, method show_table::SetFieldDelete()
Изменяет поле для удаления
SetFieldEdit in file show_table.class.php, method show_table::SetFieldEdit()
Изменяет поле для редактирования
SetFormAction in file show_table.class.php, method show_table::SetFormAction()
Изменяет action формы
SetHtml in file show_table.class.php, method show_table::SetHtml()
Устанавливает значение свойству html
SetImage in file show_table.class.php, method show_table::SetImage()
Изменяет значение свойства - путь к картинке
SetKeyId in file show_table.class.php, method show_table::SetKeyId()
Изменяет ключевое поле
SetLastModified in file Kernel.class.php, method kernel::SetLastModified()
Метод установления времени последнего изменения страницы
SetMas in file show_table.class.php, method show_table::SetMas()
Изменяет массив экземпляров класса table_fields
SetModerator in file Forums.class.php, method Forums::SetModerator()
Метод установления/снятия прав модератора текущего форума для группы пользователей
SetQuery in file show_table.class.php, method show_table::SetQuery()
Изменяет запрос для выборки данных
SetTableWidth in file show_table.class.php, method show_table::SetTableWidth()
Изменяет ширину таблицы
SetTemplate in file Kernel.class.php, method kernel::SetTemplate()
Метод установления текущего шаблона
SetValueExtraProperty in file Site_users.class.php, method SiteUsers::SetValueExtraProperty()
Метод установки значения дополнительного параметра пользователя
set_CSS in file Kernel.class.php, method kernel::set_CSS()
Метод изменения адреса файла CSS-стиля для страницы
set_current_page in file Kernel.class.php, method kernel::set_current_page()
Метод изменения адреса страницы
set_current_page_data_template in file Kernel.class.php, method kernel::set_current_page_data_template()
Метод изменения шаблона страницы
set_description in file Kernel.class.php, method kernel::set_description()
Метод изменения описания страницы
set_keywords in file Kernel.class.php, method kernel::set_keywords()
Метод изменения ключевых слов страницы
set_title in file Kernel.class.php, method kernel::set_title()
Метод изменения заголовока страницы
shop.class.php | procedural page shop.class.php
shop.php | procedural page shop.php
ShowAddComment in file InformationSystems.class.php, method InformationSystem::ShowAddComment()
Метод добавления комментария к элементу информационной системы
ShowBanner in file Advertisement.class.php, method Advertisement::ShowBanner()
Метод показа баннера
ShowBannerGroup in file Advertisement.class.php, method Advertisement::ShowBannerGroup()
Метод показа баннера из указанной группы в соответствии с приоритетом
ShowBannerIsTrue in file Advertisement.class.php, method Advertisement::ShowBannerIsTrue()
Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили
ShowCounterCode in file Counter.class.php, method counter::ShowCounterCode()
Метод, осуществляющий вывод кода счетчика
ShowDocument in file Documents.class.php, method documents::ShowDocument()
Метод вызывает показ текущей версии переданной страницы
ShowForm in file Forms.class.php, method Forms::ShowForm()
Метод отображения формы
ShowInformationSystem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystem()
Метод отображения групп и элементов информационной системы
ShowInformationSystemItem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemItem()
Метод отображения информацию об информационном элементе
ShowInformationSystemRss in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemRss()
Метод отображения RSS ленты
ShowPoll in file Polls.class.php, method polls::ShowPoll()
Метод отображения опроса
ShowPolls in file Polls.class.php, method polls::ShowPolls()
Метод отображения всех активных опросов
ShowStructure in file Structure.class.php, method Structure::ShowStructure()
Метод для отображения структуры в клиентской части сайта
show_CSS in file Kernel.class.php, method kernel::show_CSS()
Метод вывода CSS стиля для страницы
show_current_page in file Kernel.class.php, method kernel::show_current_page()
Метод вывода страницы
show_current_template in file Kernel.class.php, method kernel::show_current_template()
Метод вывода текущего шаблона
show_date in file Counter.class.php, method counter::show_date()
Метод для вывода формы с полями для дат (для вывода статистики)
show_description in file Kernel.class.php, method kernel::show_description()
Метод вывода описания страницы
show_error_message in file Message.fns.php, function show_error_message()
Ядро, функция отображения сообщения об ошибке
show_keywords in file Kernel.class.php, method kernel::show_keywords()
Метод вывода ключевых слов страницы
show_link in file Counter.class.php, method counter::show_link()
Метод для вывода ссылок на различные пункты статистики
show_link in file Documents.class.php, method documents::show_link()
Метод формирования строки ссылок на разделы и подразделы
show_message in file Message.fns.php, function show_message()
Ядро, функция отображения сообщения
show_table | in file show_table.class.php, class show_table
show_table.class.php | procedural page show_table.class.php
show_title in file Kernel.class.php, method kernel::show_title()
Метод вывода заголовка страницы
show_ws in file Wysiwyg.class.php, method wysiwyg::show_ws()
Метод отображает визуальный редактор
site in file Site.class.php, class site
Класс модуля "Сайты"
SiteUsers in file Site_users.class.php, class SiteUsers
Класс модуля "Пользователи сайта"
Site.class.php | procedural page Site.class.php
Site.php | procedural page Site.php
Site_users.class.php | procedural page Site_users.class.php
Site_users.php | procedural page Site_users.php
Smile2HTML in file Forums.class.php, method Forums::Smile2HTML()
Метод замены смайликов на HTML
SortStructureMass in file Structure.class.php, method Structure::SortStructureMass()
Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией
STAT_ON_PAGE | in file Counter.php, constant STAT_ON_PAGE
STAT_PERIOD_STORAGE | in file Counter.php, constant STAT_PERIOD_STORAGE
strips in file Security.fns.php, function strips()
Вызывает stripslashes для всех элементов массива
strips in file Kernel.class.php, method kernel::strips()
Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag
Structure | in file Structure.class.php, class Structure
structure in file Structure.class.php, method Structure::structure()
Конструктор
Structure.class.php | procedural page Structure.class.php
Structure.php | procedural page Structure.php
SUPERUSER_EMAIL | in file Kernel.php, constant SUPERUSER_EMAIL
Support in file Support.class.php, class Support
Класс модуля "Техническая поддержка"
SupportMail in file Support.class.php, method Support::SupportMail()
Метод отправки письма с просьбой о технической поддержке
Support.class.php | procedural page Support.class.php
Support.php | procedural page Support.php
symbol2ASCII in file Security.fns.php, function symbol2ASCII()
Возвращает текст с печатаемыми символами ASCII кода
top
t
$table_width | in file show_table.class.php, variable show_table::$table_width
$thousands_sep | in file show_table.class.php, variable table_fields::$thousands_sep
tar.class.php | procedural page tar.class.php
table_fields in file show_table.class.php, method table_fields::table_fields()
Метод, установления свойств класса
table_fields | in file show_table.class.php, class table_fields
templates in file Templates.class.php, class templates
Класс модуля "Шаблоны и макеты"
Templates.class.php | procedural page Templates.class.php
Templates.php | procedural page Templates.php
to_array in file Security.fns.php, function to_array()
Функция приведения аргумента к массиву
to_float in file Security.fns.php, function to_float()
Функция приведения аргумента к вещественному типу
to_int in file Security.fns.php, function to_int()
Функция приведения аргумента к целочисленному типу
to_str in file Security.fns.php, function to_str()
Функция приведения аргумента к строковому типу
top
u
Url.class.php | procedural page Url.class.php
UserAccess.class.php | procedural page UserAccess.class.php
Unregistration in file Site_users.class.php, method SiteUsers::Unregistration()
Метод дерегистрации пользователя определяемого по индексу(для клиентской части)
UpdateSiteUser in file Site_users.class.php, method SiteUsers::UpdateSiteUser()
Метод обновления анкетных данных пользователя
UpdateSubDir in file Structure.class.php, method Structure::UpdateSubDir()
Метод обновления идентификатора меню у подразделов определенного раздела
update_vote in file Polls.class.php, method polls::update_vote()
Метод обработки результата голосования
UPLOADDIR | in file Kernel.php, constant UPLOADDIR
url in file Url.class.php, class url
Ядро, класс для работы с адресной строкой
UserAccessDenied in file UserAccess.class.php, class UserAccessDenied
Ядро, класс проверки возможности доступа пользователей BackOffice
UserAccess.class.php | procedural page UserAccess.class.php
UserAccess.php | procedural page UserAccess.php
UserCanAddComment in file InformationSystems.class.php, method InformationSystem::UserCanAddComment()
Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY
user_access in file UserAccess.class.php, class user_access
Класс модуля "Пользователи раздела администрирования"
USER_NONE | in file Kernel.php, constant USER_NONE
top
v
ValidCaptcha in file Captcha.class.php, method Captcha::ValidCaptcha()
Метод проверки соответствия введенного пользователем текста хранимому в сессии
ValidUser in file Site_users.class.php, method SiteUsers::ValidUser()
Метод определения зарегистрирован ли пользователь
valid_email in file Security.fns.php, function valid_email()
Проверка правильности электронного адреса
VisibleTheme in file Forums.class.php, method Forums::VisibleTheme()
Метод, устанавливающий видимость/невидимость темы
vote in file Polls.class.php, method polls::vote()
Метод обработки и отображения результатов голосования
vote_result in file Polls.class.php, method polls::vote_result()
Метод вывода результатов голосования
top
w
Wysiwyg.class.php | procedural page Wysiwyg.class.php
win2uni in file Graphic.class.php, method graphic::win2uni()
Метод перекодировки из win в unicode
wysiwyg in file Wysiwyg.class.php, class wysiwyg
Ядро, класс визуального редактора
top
x
$xml | in file ExternalXml.class.php, variable ExternalXml::$xml
XMLparser.class.php | procedural page XMLparser.class.php
xsl in file Xsl.class.php, class xsl
Класс модуля "XSL-шаблоны"
Xsl.class.php | procedural page Xsl.class.php
Xsl.php | procedural page Xsl.php


Class Trees for Package HostCMS

Root class Admin
  • Admin
 Root class AdminMenu
  • AdminMenu
 Root class Advertisement
  • Advertisement
 Root class Backup
  • Backup
 Root class Cache
  • Cache
 Root class Captcha
  • Captcha
 Root class compression
  • compression
 Root class Constants
  • Constants
 Root class counter
  • counter
 Root class DateClass
  • DateClass
 Root class documents
  • documents
 Root class EventsJournal
  • EventsJournal
    • EventsJournalAdmin
 Root class ExecSqlQuery
  • ExecSqlQuery
 Root class ExternalXml
  • ExternalXml
 Root class File
  • File
 Root class FileManager
  • FileManager
 Root class Forms
  • Forms
 Root class Forums
  • Forums
 Root class graphic
  • graphic
 Root class Image
  • Image
 Root class InformationSystem
  • InformationSystem
 Root class ip
  • ip
 Root class kernel
  • kernel
 Root class lists
  • lists
 Root class Maillist
  • Maillist
 Root class modules_admin
  • modules_admin
 Root class MySQL
  • MySQL
 Root class polls
  • polls
 Root class RssRead
  • RssRead
 Root class RssWrite
  • RssWrite
 Root class Search
  • Search
 Root class show_table
  • show_table
 Root class site
  • site
 Root class SiteUsers
  • SiteUsers
 Root class Structure
  • Structure
 Root class Support
  • Support
 Root class table_fields
  • table_fields
 Root class templates
  • templates
 Root class url
  • url
 Root class UserAccessDenied
  • UserAccessDenied
 Root class user_access
  • user_access
 Root class wysiwyg
  • wysiwyg
 Root class xsl
  • xsl
Documentation generated on Sun, 01 Oct 2006 21:01:09 +0400 by phpDocumentor 1.3.0RC3


Docs for page Admin.class.php

File: /Kernel/Admin.class.php

Classes in this file:
Admin
ßäðî, ìåòîäû óïðàâëåíèÿ ðàçäåëîì àäìèíèñòðèðîâàíèÿ HostCMS

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:09 +0400 by phpDocumentor 1.3.0RC3


Docs for page AdminMenu.class.php

File: /Kernel/AdminMenu.class.php

Classes in this file:
AdminMenu
ßäðî, êëàññ äëÿ ôîðìèðîâàíèÿ ìåíþ â ðàçäåëå àäìèíèñòðèðîâàíèÿ

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:10 +0400 by phpDocumentor 1.3.0RC3


Docs for page admin_output.fns.php

File: /admin_output.fns.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

  • void do_html_footer_admin()
    Ôóíêöèÿ âûâîäèò "ïîäâàë" äëÿ ñòðàíèö ðàçäåëà àäìèíèñòðèðîâàíèÿ
  • void do_html_header_admin()
    Ôóíêöèÿ âûâîäèò "øàïêó" äëÿ ñòðàíèö ðàçäåëà àäìèíèñòðèðîâàíèÿ

Global Variable Detail

Constant Detail

Function Detail

  • void do_html_footer_admin() [line 244]

    Usage: do_html_footer_admin( )

    Îïèñàíèå

    Ôóíêöèÿ âûâîäèò "ïîäâàë" äëÿ ñòðàíèö ðàçäåëà àäìèíèñòðèðîâàíèÿ

    [ Top ]

  • void do_html_header_admin() [line 13]

    Usage: do_html_header_admin( string $title)

    Ïðèíèìàåìûå ïàðàìåòðû

    $title

    Îïèñàíèå

    Ôóíêöèÿ âûâîäèò "øàïêó" äëÿ ñòðàíèö ðàçäåëà àäìèíèñòðèðîâàíèÿ

    [ Top ]

Documentation generated on Sun, 01 Oct 2006 21:01:10 +0400 by phpDocumentor 1.3.0RC3


Docs for page Advertisement.class.php

File: /Advertisement/Advertisement.class.php

Classes in this file:
Advertisement
Êëàññ ìîäóëÿ "Ðåêëàìà"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:10 +0400 by phpDocumentor 1.3.0RC3


Docs for page Advertisement.php

File: /Advertisement/Advertisement.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:10 +0400 by phpDocumentor 1.3.0RC3


Docs for page Backup.class.php

File: /Backup/Backup.class.php

Classes in this file:
Backup
Êëàññ ìîäóëÿ "Ðåçåðâíîå êîïèðîâàíèå"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs for page Backup.php

File: /Backup/Backup.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs for page Cache.class.php

File: /Cache/Cache.class.php

Classes in this file:
Cache
Êëàññ ìîäóëÿ "Êýøèðîâàíèå"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs for page Cache.php

File: /Cache/Cache.php

Classes in this file:

Global Variable Summary

Constant Summary

  • CACHE_INSTALL = true
  • CACHE_LIMIT = 300

Function Summary

Global Variable Detail

Constant Detail

  • CACHE_INSTALL = true [line 8]

  • CACHE_LIMIT = 300 [line 19]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs for page Captcha.class.php

File: /Kernel/Captcha.class.php

Classes in this file:
Captcha
ßäðî, êëàññ äëÿ ðàáîòû ñ CAPTCHA

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs for page Compression.class.php

File: /Compression/Compression.class.php

Classes in this file:
compression
Êëàññ ìîäóëÿ "Ñèñòåìà ñæàòèÿ (êîìïðåññèÿ)"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs for page Compression.php

File: /Compression/Compression.php

Classes in this file:

Global Variable Summary

Constant Summary

  • COMPRESSION_INSTALL = 1

Function Summary

Global Variable Detail

Constant Detail

  • COMPRESSION_INSTALL = 1 [line 8]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page config.php

File: /Counter/config/config.php

Classes in this file:

Global Variable Summary

Constant Summary

  • COUNTER_BOT_COUNT = true

Function Summary

Global Variable Detail

Constant Detail

  • COUNTER_BOT_COUNT = true [line 4]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page config.php

File: /Forums/config/config.php

Classes in this file:

Global Variable Summary

Constant Summary

  • DELL_TIME = 1800
  • EDIT_TIME = 14400
  • FLUDE_PROTECTION = 1
  • FORUMS_PARAM_INDEX = count(explode("/",FORUMS_PATH))-3
  • FORUMS_PATH = '/forums/'
  • MAX_HEIGHT_AVATAR = 100
  • MAX_SIZE_AVATAR = 12000
  • MAX_WIDTH_AVATAR = 100
  • ON_PAGE_MESSAGE = 10
  • ON_PAGE_THEME = 10

Function Summary

Global Variable Detail

Constant Detail

  • DELL_TIME = 1800 [line 11]

  • EDIT_TIME = 14400 [line 10]

  • FLUDE_PROTECTION = 1 [line 6]

  • FORUMS_PARAM_INDEX = count(explode("/",FORUMS_PATH))-3 [line 3]

  • FORUMS_PATH = '/forums/' [line 2]

  • MAX_HEIGHT_AVATAR = 100 [line 9]

  • MAX_SIZE_AVATAR = 12000 [line 7]

  • MAX_WIDTH_AVATAR = 100 [line 8]

  • ON_PAGE_MESSAGE = 10 [line 5]

  • ON_PAGE_THEME = 10 [line 4]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page config.php

File: /Kernel/config/config.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page config.php

File: /InformationSystems/config/config.php

Classes in this file:

Global Variable Summary

Constant Summary

  • ADMIN_EMAIL_XSL = 'ÎòïðàâêàÏèñüìàÀäìèíèñòðàòîðóÄîáàâëåíèåÊîììåíòàðèÿ'
  • COMMENT_DALAY_ERROR_XSL = 'ÂûâîäÎøèáêèÄîáàâëåíèÿÊîììåíòàðèÿ'

Function Summary

Global Variable Detail

Constant Detail

  • ADMIN_EMAIL_XSL = 'ÎòïðàâêàÏèñüìàÀäìèíèñòðàòîðóÄîáàâëåíèåÊîììåíòàðèÿ' [line 4]

  • COMMENT_DALAY_ERROR_XSL = 'ÂûâîäÎøèáêèÄîáàâëåíèÿÊîììåíòàðèÿ' [line 7]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page Constants.class.php

File: /Constants/Constants.class.php

Classes in this file:
Constants
Êëàññ ìîäóëÿ "Êîíñòàíòû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page Constants.php

File: /Constants/Constants.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page Counter.class.php

File: /Counter/Counter.class.php

Classes in this file:
counter
Êëàññ ìîäóëÿ "Ñòàòèñòèêà ïîñåùàåìîñòè ñàéòà"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs for page Counter.php

File: /Counter/Counter.php

Classes in this file:

Global Variable Summary

Constant Summary

  • COUNTER_INSTALL = true
  • DIAGRAMM_LIMIT = 20
  • DIAGRAMM_WIDTH = 500
  • GISTOGRAMM_LIMIT = STAT_ON_PAGE
  • STAT_ON_PAGE = 50
  • STAT_PERIOD_STORAGE = 30

Function Summary

Global Variable Detail

Constant Detail

  • COUNTER_INSTALL = true [line 7]

  • DIAGRAMM_LIMIT = 20 [line 23]

  • DIAGRAMM_WIDTH = 500 [line 31]

  • GISTOGRAMM_LIMIT = STAT_ON_PAGE [line 27]

  • STAT_ON_PAGE = 50 [line 19]

  • STAT_PERIOD_STORAGE = 30 [line 15]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:13 +0400 by phpDocumentor 1.3.0RC3


Docs for page Date.class.php

File: /Kernel/Date.class.php

Classes in this file:
DateClass
ßäðî, êëàññ äëÿ ðàáîòû ñ äàòàìè

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:13 +0400 by phpDocumentor 1.3.0RC3


Docs for page Documents.class.php

File: /Documents/Documents.class.php

Classes in this file:
documents
Êëàññ ìîäóëÿ "Ñòàðíèöû è äîêóìåíòû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:13 +0400 by phpDocumentor 1.3.0RC3


Docs for page Documents.php

File: /Documents/Documents.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:14 +0400 by phpDocumentor 1.3.0RC3


Docs for page Error.fns.php

File: /Kernel/Error.fns.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

  • void cms_error_handler()
    ßäðî, îáðàáîò÷èêè îøèáîê â HostCMS

Global Variable Detail

Constant Detail

Function Detail

  • void cms_error_handler() [line 15]

    Usage: cms_error_handler( int $code, string $msg, string $file, int $line)

    Ïðèíèìàåìûå ïàðàìåòðû

    $code

    êîä îøèáêè - E_ERROR è ò.ä.

    $msg

    ñîîáùåíèå îá îøáèêå

    $file

    èìÿ ôàéëà, â êîòîðîì ïðîèçîøëà îøèáêà

    $line

    ñòðîêà, â êîòîðîì ïðîèçîøëà îøèáêà

    Îïèñàíèå

    ßäðî, îáðàáîò÷èêè îøèáîê â HostCMS

    [ Top ]

Documentation generated on Sun, 01 Oct 2006 21:01:14 +0400 by phpDocumentor 1.3.0RC3


Docs for page EventsJournal.class.php

File: /EventsJournal/EventsJournal.class.php

Classes in this file:
EventsJournalAdmin
Êëàññ ìîäóëÿ "Æóðíàë ñîáûòèé"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:14 +0400 by phpDocumentor 1.3.0RC3


Docs for page EventsJournal.class.php

File: /Kernel/EventsJournal.class.php

Classes in this file:
EventsJournal
ßäðî, êëàññ æóðíàëèðîâàíèÿ ñîáûòèé

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:14 +0400 by phpDocumentor 1.3.0RC3


Docs for page EventsJournal.php

File: /EventsJournal/EventsJournal.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:14 +0400 by phpDocumentor 1.3.0RC3


Docs for page ExecSqlQuery.class.php

File: /ExecSqlQuery/ExecSqlQuery.class.php

Classes in this file:
ExecSqlQuery
Êëàññ ìîäóëÿ "SQL-çàïðîñû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs for page ExecSqlQuery.php

File: /ExecSqlQuery/ExecSqlQuery.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs for page ExternalXml.class.php

File: /Kernel/ExternalXml.class.php

Classes in this file:
ExternalXml
ßäðî, êëàññ ôîðìèðóåò äåðåâî XML ïî ïåðåäàííîìó ìàññèâó

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs for page File.class.php

File: /Kernel/File.class.php

Classes in this file:
File
ßäðî, êëàññ äëÿ ðàáîòû ñ ôàéëàìè

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs for page FileManager.class.php

File: /FileManager/FileManager.class.php

Classes in this file:
FileManager
Êëàññ ìîäóëÿ "Ôàéëîâûé ìåíåäæåð"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs for page FileManager.php

File: /FileManager/FileManager.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs for page Forms.class.php

File: /Forms/Forms.class.php

Classes in this file:
Forms
Êëàññ ìîäóëÿ "Ôîðìû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs for page Forms.php

File: /Forms/Forms.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:16 +0400 by phpDocumentor 1.3.0RC3


Docs for page Forums.class.php

File: /Forums/Forums.class.php

Classes in this file:
Forums
Êëàññ ìîäóëÿ "Ôîðóìû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:16 +0400 by phpDocumentor 1.3.0RC3


Docs for page Forums.php

File: /Forums/Forums.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:17 +0400 by phpDocumentor 1.3.0RC3


Docs for page Graphic.class.php

File: /Counter/Graphic.class.php

Classes in this file:
graphic

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:17 +0400 by phpDocumentor 1.3.0RC3


Docs for page Image.class.php

File: /Kernel/Image.class.php

Classes in this file:
Image
ßäðî, êëàññ äëÿ ðàáîòû ñ ãðàôè÷åñêèìè èçîáðàæåíèÿìè

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:17 +0400 by phpDocumentor 1.3.0RC3


Docs for page InformationSystems.class.php

File: /InformationSystems/InformationSystems.class.php

Classes in this file:
InformationSystem
Êëàññ ìîäóëÿ "Èíôîðìàöèîííûå ñèñòåìû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:17 +0400 by phpDocumentor 1.3.0RC3


Docs for page InformationSystems.php

File: /InformationSystems/InformationSystems.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:19 +0400 by phpDocumentor 1.3.0RC3


Docs for page ip.class.php

File: /ip/ip.class.php

Classes in this file:
ip
Êëàññ ìîäóëÿ "IP-àäðåñà"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:19 +0400 by phpDocumentor 1.3.0RC3


Docs for page ip.php

File: /ip/ip.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:19 +0400 by phpDocumentor 1.3.0RC3


Docs for page Kernel.class.php

File: /Kernel/Kernel.class.php

Classes in this file:
kernel
Êëàññ ÿäðà ñèñòåìû óïðàâëåíèÿ ñàéòîì HostCMS

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:19 +0400 by phpDocumentor 1.3.0RC3


Docs for page Kernel.php

File: /Kernel/Kernel.php

Classes in this file:

Global Variable Summary

Constant Summary

  • $row['constants_name'] = $row['constants_value']
  • ADD_COMMENT_DELAY = 10
  • CURRENT_VERSION = '3.2.4'
  • DEFAULT_LNG = 'ru'
  • E_STRICT = 2048
  • JPG_QUALITY = 60
  • MAIL_EVENTS_STATUS = 2
  • ON_PAGE = 20
  • POLLS_WIDTH = 100
  • SUPERUSER_EMAIL = 'email@not.exists'
  • UPLOADDIR = 'upload/'
  • USER_NONE = '#####'

Function Summary

Global Variable Detail

Constant Detail

  • $row['constants_name'] = $row['constants_value'] [line 57]

  • ADD_COMMENT_DELAY = 10 [line 77]

  • CURRENT_VERSION = '3.2.4' [line 7]

  • DEFAULT_LNG = 'ru' [line 87]

  • E_STRICT = 2048 [line 113]

  • JPG_QUALITY = 60 [line 102]

  • MAIL_EVENTS_STATUS = 2 [line 82]

  • ON_PAGE = 20 [line 67]

  • POLLS_WIDTH = 100 [line 92]

  • SUPERUSER_EMAIL = 'email@not.exists' [line 72]

  • UPLOADDIR = 'upload/' [line 107]

  • USER_NONE = '#####' [line 97]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:20 +0400 by phpDocumentor 1.3.0RC3


Docs for page Lists.class.php

File: /Lists/Lists.class.php

Classes in this file:
lists
Êëàññ ìîäóëÿ "Ñïèñêè"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:20 +0400 by phpDocumentor 1.3.0RC3


Docs for page Lists.php

File: /Lists/Lists.php

Classes in this file:

Global Variable Summary

Constant Summary

  • LISTS_INSTALL = true

Function Summary

Global Variable Detail

Constant Detail

  • LISTS_INSTALL = true [line 17]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:20 +0400 by phpDocumentor 1.3.0RC3


Docs for page Maillist.class.php

File: /Maillist/Maillist.class.php

Classes in this file:
Maillist
Êëàññ ìîäóëÿ "Ïî÷òîâûå ðàññûëêè"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:20 +0400 by phpDocumentor 1.3.0RC3


Docs for page Maillist.php

File: /Maillist/Maillist.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:21 +0400 by phpDocumentor 1.3.0RC3


Docs for page Menu.class.php

File: /Menu/Menu.class.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:21 +0400 by phpDocumentor 1.3.0RC3


Docs for page Menu.php

File: /Menu/Menu.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:21 +0400 by phpDocumentor 1.3.0RC3


Docs for page Message.fns.php

File: /Kernel/Message.fns.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

  • void show_error_message()
    ßäðî, ôóíêöèÿ îòîáðàæåíèÿ ñîîáùåíèÿ îá îøèáêå
  • void show_message()
    ßäðî, ôóíêöèÿ îòîáðàæåíèÿ ñîîáùåíèÿ

Global Variable Detail

Constant Detail

Function Detail

  • void show_error_message() [line 26]

    Usage: show_error_message( string $text)

    Ïðèíèìàåìûå ïàðàìåòðû

    $text

    Îïèñàíèå

    ßäðî, ôóíêöèÿ îòîáðàæåíèÿ ñîîáùåíèÿ îá îøèáêå

    [ Top ]

  • void show_message() [line 11]

    Usage: show_message( string $text)

    Ïðèíèìàåìûå ïàðàìåòðû

    $text

    Îïèñàíèå

    ßäðî, ôóíêöèÿ îòîáðàæåíèÿ ñîîáùåíèÿ

    [ Top ]

Documentation generated on Sun, 01 Oct 2006 21:01:21 +0400 by phpDocumentor 1.3.0RC3


Docs for page Modules.class.php

File: /Modules/Modules.class.php

Classes in this file:
modules_admin
Êëàññ ìîäóëÿ "Óïðàâëåíèå ìîäóëÿìè"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:21 +0400 by phpDocumentor 1.3.0RC3


Docs for page Modules.php

File: /Modules/Modules.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:21 +0400 by phpDocumentor 1.3.0RC3


Docs for page Mysql.class.php

File: /Kernel/Mysql.class.php

Classes in this file:
MySQL
ßäðî, êëàññ äëÿ ðàáîòû ñ MySQL

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs for page Mysqldump.class.php

File: /Backup/Mysqldump.class.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs for page Password.class.php

File: /Kernel/Password.class.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs for page Polls.class.php

File: /Polls/Polls.class.php

Classes in this file:
polls
Êëàññ ìîäóëÿ "Îïðîñû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs for page Polls.php

File: /Polls/Polls.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs for page RssRead.class.php

File: /Kernel/RssRead.class.php

Classes in this file:
RssRead
ßäðî, êëàññ äëÿ ÷òåíèÿ RSS

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs for page RssWrite.class.php

File: /Kernel/RssWrite.class.php

Classes in this file:
RssWrite
ßäðî, êëàññ äëÿ ãåíåðàöèè RSS

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /ip/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Templates/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Xsl/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Menu/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /UserAccess/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Support/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Polls/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Search/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /shop/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Site/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Site_users/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Structure/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Modules/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:23 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Forums/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Cache/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /EventsJournal/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Advertisement/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Maillist/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Backup/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Constants/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /ExecSqlQuery/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Lists/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Forms/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /FileManager/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Documents/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /InformationSystems/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page ru.php

File: /Counter/lng/ru/ru.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:24 +0400 by phpDocumentor 1.3.0RC3


Docs for page Search.class.php

File: /Search/Search.class.php

Classes in this file:
Search

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs for page Search.php

File: /Search/Search.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs for page Security.fns.php

File: /Kernel/Security.fns.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

  • string quote_smart()
    Экранирует потенциально опасные символы для MySQL запросов
  • void strips()
    Вызывает stripslashes для всех элементов массива
  • string symbol2ASCII()
    Возвращает текст с печатаемыми символами ASCII кода
  • array to_array()
    Функция приведения аргумента к массиву
  • float to_float()
    Функция приведения аргумента к вещественному типу
  • int to_int()
    Функция приведения аргумента к целочисленному типу
  • string to_str()
    Функция приведения аргумента к строковому типу
  • boolean valid_email()
    Проверка правильности электронного адреса

Global Variable Detail

Constant Detail

Function Detail

  • string quote_smart() [line 32]

    Usage: quote_smart( string $value, [boolean $remove_xss = true])

    Принимаемые параметры

    $value

    значение

    $remove_xss

    удалять элементы XSS атак

    Описание

    Экранирует потенциально опасные символы для MySQL запросов

    [ Top ]

  • void strips() [line 12]

    Usage: strips( array &$var)

    Принимаемые параметры

    $var

    Описание

    Вызывает stripslashes для всех элементов массива

    [ Top ]

  • string symbol2ASCII() [line 173]

    Usage: symbol2ASCII( mixed $string, string $num)

    Принимаемые параметры

    $num

    Описание

    Возвращает текст с печатаемыми символами ASCII кода

    [ Top ]

  • array to_array() [line 256]

    Usage: to_array( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к массиву

    [ Top ]

  • float to_float() [line 237]

    Usage: to_float( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к вещественному типу

    [ Top ]

  • int to_int() [line 215]

    Usage: to_int( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к целочисленному типу

    [ Top ]

  • string to_str() [line 197]

    Usage: to_str( unknown_type &$var)

    Принимаемые параметры

    $var

    Описание

    Функция приведения аргумента к строковому типу

    [ Top ]

  • boolean valid_email() [line 121]

    Usage: valid_email( string $address)

    Принимаемые параметры

    $address

    e-mail адрес

    Возвращает

    true или false

    Описание

    Проверка правильности электронного адреса

    [ Top ]

Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs for page shop.class.php

File: /shop/shop.class.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs for page shop.php

File: /shop/shop.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs for page show_table.class.php

File: /show_table.class.php

Classes in this file:
table_fields
show_table

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs for page Site.class.php

File: /Site/Site.class.php

Classes in this file:
site
Êëàññ ìîäóëÿ "Ñàéòû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:26 +0400 by phpDocumentor 1.3.0RC3


Docs for page Site.php

File: /Site/Site.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:26 +0400 by phpDocumentor 1.3.0RC3


Docs for page Site_users.class.php

File: /Site_users/Site_users.class.php

Classes in this file:
SiteUsers
Êëàññ ìîäóëÿ "Ïîëüçîâàòåëè ñàéòà"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:26 +0400 by phpDocumentor 1.3.0RC3


Docs for page Site_users.php

File: /Site_users/Site_users.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:27 +0400 by phpDocumentor 1.3.0RC3


Docs for page Structure.class.php

File: /Structure/Structure.class.php

Classes in this file:
Structure

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:27 +0400 by phpDocumentor 1.3.0RC3


Docs for page Structure.php

File: /Structure/Structure.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:28 +0400 by phpDocumentor 1.3.0RC3


Docs for page Support.class.php

File: /Support/Support.class.php

Classes in this file:
Support
Êëàññ ìîäóëÿ "Òåõíè÷åñêàÿ ïîääåðæêà"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:28 +0400 by phpDocumentor 1.3.0RC3


Docs for page Support.php

File: /Support/Support.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:28 +0400 by phpDocumentor 1.3.0RC3


Docs for page tar.class.php

File: /Backup/tar/tar.class.php

Classes in this file:

Global Variable Summary

Constant Summary

  • OS_UNIX = false

Function Summary

Global Variable Detail

Constant Detail

  • OS_UNIX = false [line 10]

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:28 +0400 by phpDocumentor 1.3.0RC3


Docs for page Templates.class.php

File: /Templates/Templates.class.php

Classes in this file:
templates
Êëàññ ìîäóëÿ "Øàáëîíû è ìàêåòû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:28 +0400 by phpDocumentor 1.3.0RC3


Docs for page Templates.php

File: /Templates/Templates.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs for page Url.class.php

File: /Kernel/Url.class.php

Classes in this file:
url
ßäðî, êëàññ äëÿ ðàáîòû ñ àäðåñíîé ñòðîêîé

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs for page UserAccess.class.php

File: /UserAccess/UserAccess.class.php

Classes in this file:
user_access
Êëàññ ìîäóëÿ "Ïîëüçîâàòåëè ðàçäåëà àäìèíèñòðèðîâàíèÿ"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs for page UserAccess.class.php

File: /Kernel/UserAccess.class.php

Classes in this file:
UserAccessDenied
ßäðî, êëàññ ïðîâåðêè âîçìîæíîñòè äîñòóïà ïîëüçîâàòåëåé BackOffice

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs for page UserAccess.php

File: /UserAccess/UserAccess.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs for page Wysiwyg.class.php

File: /Kernel/Wysiwyg.class.php

Classes in this file:
wysiwyg
ßäðî, êëàññ âèçóàëüíîãî ðåäàêòîðà

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs for page XMLparser.class.php

File: /Kernel/XMLparser.class.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:30 +0400 by phpDocumentor 1.3.0RC3


Docs for page Xsl.class.php

File: /Xsl/Xsl.class.php

Classes in this file:
xsl
Êëàññ ìîäóëÿ "XSL-øàáëîíû"

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:30 +0400 by phpDocumentor 1.3.0RC3


Docs for page Xsl.php

File: /Xsl/Xsl.php

Classes in this file:

Global Variable Summary

Constant Summary

Function Summary

Global Variable Detail

Constant Detail

Function Detail

Documentation generated on Sun, 01 Oct 2006 21:01:30 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Admin

Class Admin

[line 10]

Размещен: /Kernel/Admin.class.php

Описание

Ядро, методы управления разделом администрирования HostCMS

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void admin_init()

    Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта

  • boolean admin_session_valid()

    Метод проверки авторизации пользователя

  • void session_start()

    Метод старта сессии для раздела администрирования

  • void SetCurrentSite()

    Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта

Унаследованные методы

Описания методов

    Admin::admin_init

admin_init(
 );

    Описание

    Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта

    [ Top ]

    Admin::admin_session_valid

admin_session_valid(
string
$modules_path );

    Принимаемые параметры

    $modules_path

    путь к модулю

    Возвращает

    true в случае  наличия у авторизированного пользователя прав доступа к данному модулю на текущем сайте или прерывает выполнение страницы, производя редирект на страницу авторизации в противном случае

    Описание

    Метод проверки авторизации пользователя

    [ Top ]

    Admin::session_start

session_start(
 );

    Описание

    Метод старта сессии для раздела администрирования

    [ Top ]

    Admin::SetCurrentSite

SetCurrentSite(
 );

    Описание

    Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:09 +0400 by phpDocumentor 1.3.0RC3


Docs For Class AdminMenu

Class AdminMenu

[line 11]

Размещен: /Kernel/AdminMenu.class.php

Описание

Ядро, класс для формирования меню в разделе администрирования

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void AddAdminMenuItem()

    Метод добавляет элемент в меню раздела администрирования

Унаследованные методы

Описания методов

    AdminMenu::AddAdminMenuItem

AddAdminMenuItem(
string
$order, string
$name, string
$link, string
$module_name );

    Принимаемые параметры

    $order

    порядок элемента в меню

    $name

    имя элемента

    $link

    ссылка

    $module_name

    имя модуля-владельца раздела меню

    Описание

    Метод добавляет элемент в меню раздела администрирования

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:10 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Advertisement

Class Advertisement

[line 11]

Размещен: /Advertisement/Advertisement.class.php

Описание

Класс модуля "Реклама"

Свойства класса

  • $BannerCache = array()

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean AddBanner()

    Метод добавления/редактирования баннера

  • boolean ClearAdvertisementList()

    Метод очищающий список показов, произошедших $count_days назад

  • boolean DelBannerGroup()

    Метод исключения баннера из группы

  • boolean DelBannersGroup()

    Метод удаления группы баннеров

  • boolean DeleteBanner()

    Метод удаления баннера

  • mixed:
     GetCountShowingBanner()

    Метод возвращает количество показов баннера

  • mixed:
     GetCountShowingBannerAtDay()

    Метод возвращает количество показов баннера за конкретный день

  • boolean InsertBanners()

    Метод добавления баннера в группу/редактирования приоритета показа баннера в группе

  • mixed InsertBannersGroup()

    Метод добавления/редактирования информации о группе баннеров

  • resource SelectBannersGroup()

    Метод получения информации о конкретной группе баннеров или обо всех баннерах

  • boolean ShowBanner()

    Метод показа баннера

  • boolean ShowBannerGroup()

    Метод показа баннера из указанной группы в соответствии с приоритетом

  • mixed:
     ShowBannerIsTrue()

    Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили

Унаследованные методы

Описания методов

    Advertisement::AddBanner

AddBanner(
int
$advertisement_id, string
$advertisement_name, string
$advertisement_comment, int
$advertisement_width, int
$advertisement_height, int
$advertisement_allcount, int
$advertisement_allcount_at_day, int
$advertisement_type, array
$advertisement_image_path, string
$advertisement_image_link, string
$advertisement_text, int
$structure_id );

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    $advertisement_name

    название баннера

    $advertisement_comment

    описание баннера

    $advertisement_width

    ширина баннера

    $advertisement_height

    высота баннера

    $advertisement_allcount

    сколько раз показать

    $advertisement_allcount_at_day

    сколько раз показывать в день

    $advertisement_type

    тип баннера

    $advertisement_image_path

    элемент массива $_FILES

    $advertisement_image_link

    ссылка с баннера

    $advertisement_text

    текст баннера

    $structure_id

    идентификатор элемента структуры

    Описание

    Метод добавления/редактирования баннера

    [ Top ]

    Advertisement::ClearAdvertisementList

ClearAdvertisementList(
[mixed
$count_days = 1], int
$count_days=1 );

    Принимаемые параметры

    $count_days=1

    количество дней хранения списка показов

    Описание

    Метод очищающий список показов, произошедших $count_days назад

    [ Top ]

    Advertisement::DelBannerGroup

DelBannerGroup(
int
$advertisement_group_id, int
$advertisement_id );

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $advertisement_id

    идентификатор баннера

    Описание

    Метод исключения баннера из группы

    [ Top ]

    Advertisement::DelBannersGroup

DelBannersGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы баннеров

    Описание

    Метод удаления группы баннеров

    [ Top ]

    Advertisement::DeleteBanner

DeleteBanner(
int
$advertisement_id );

    Принимаемые параметры

    $advertisement_id

    идентификатор баннера

    Описание

    Метод удаления баннера

    [ Top ]

    Advertisement::GetCountShowingBanner

GetCountShowingBanner(
int
$banner_id );

    Принимаемые параметры

    $banner_id

    идентификатор баннера

    Возвращает

    int количество показов, если операция была выполнена;
      boolean false если операция не была выполнена

    Описание

    Метод возвращает количество показов баннера

    [ Top ]

    Advertisement::GetCountShowingBannerAtDay

GetCountShowingBannerAtDay(
string
$date, int
$banner_id );

    Принимаемые параметры

    $date

    дата

    $banner_id

    идентификатор баннера

    Возвращает

    int количество показов, если операция была выполнена;
      boolean false если операция не была выполнена

    Описание

    Метод возвращает количество показов баннера за конкретный день

    [ Top ]

    Advertisement::InsertBanners

InsertBanners(
int
$advertisement_group_id, int
$banner_id, int
$banner_value );

    Принимаемые параметры

    $advertisement_group_id

    идентификатор группы баннеров

    $banner_id

    идентификатор баннера

    $banner_value

    значение приоретета показа

    Описание

    Метод добавления баннера в группу/редактирования приоритета показа баннера в группе

    [ Top ]

    Advertisement::InsertBannersGroup

InsertBannersGroup(
int
$advertisement_group_id, string
$advertisement_group_name, string
$advertisement_group_comment );

    Принимаемые параметры

    $advertisement_group_id

    идентификатор  группы баннеров

    $advertisement_group_name

    имя группы баннеров

    $advertisement_group_comment

    комментарий к группе баннеров

    Возвращает

    результат выполнения запроса:
    int идентификатор успешно добавленной/редактированной группы;
    boolean false если операция не была выполнена

    Описание

    Метод добавления/редактирования информации о группе баннеров

    [ Top ]

    Advertisement::SelectBannersGroup

SelectBannersGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы баннеров (-1 выбрать все)

    Возвращает

    результат выполнения запроса на выборку

    Описание

    Метод получения информации о конкретной группе баннеров или обо всех баннерах

    [ Top ]

    Advertisement::ShowBanner

ShowBanner(
int
$banner_id );

    Принимаемые параметры

    $banner_id

    идентификатор баннера

    Описание

    Метод показа баннера

    [ Top ]

    Advertisement::ShowBannerGroup

ShowBannerGroup(
int
$group_id );

    Принимаемые параметры

    $group_id

    идентификатор группы баннеров

    Описание

    Метод показа баннера из указанной группы в соответствии с приоритетом

    [ Top ]

    Advertisement::ShowBannerIsTrue

ShowBannerIsTrue(
int
$list_id );

    Принимаемые параметры

    $list_id

    идентификатор записи показа

    Возвращает

    string ссылка с баннера, если операция была выполнена;
      boolean false, если операция не была выполнена

    Описание

    Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили

    [ Top ]

Variable Detail

  • $BannerCache = array() [line 13]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:10 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Backup

Class Backup

[line 11]

Размещен: /Backup/Backup.class.php

Описание

Класс модуля "Резервное копирование"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void CreateBackup()

    Метод создания резевной копии базы данных

Унаследованные методы

Описания методов

    Backup::CreateBackup

CreateBackup(
string
$backup_name, string
$userName, string
$password, string
$host, string
$db_name );

    Принимаемые параметры

    $backup_name

    полный путь к файлу для резервной копии

    $userName

    имя пользователя БД

    $password

    пароль пользователя БД

    $host

    host БД

    $db_name

    имя базы данных

    Описание

    Метод создания резевной копии базы данных

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Cache

Class Cache

[line 11]

Размещен: /Cache/Cache.class.php

Описание

Класс модуля "Кэширование"

Свойства класса

  • $cache_life_time =  60

        Время жизни кэша, по умолчанию равно 60 секунд

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • Cache Cache()

    Конструктор

  • void BeginRecord()

    Метод перехватывает информацию, размещаемую в потоке и сохраняет ее в памяти

  • boolean ClearCache()

    Метод удаления всех файлов из кэша

  • void EndRecord()

    Метод заканчивает запись из потока, выводит записанную информацию и сохраняет в кэше с именем $CacheName

  • mixed GetArrayCacheContent()

    Метод получает сохраненный в кэше массив

  • mixed GetCacheContent()

    Метод получения содержания кэша для заданного имени

  • int GetCacheLifeTime()

    Метод возвращает время актуальности кэш-файла в секундах

  • string GetCacheName()

    Метод возвращает имя кэш-файла для переданного имени

  • boolean InsertArrayIntoCache()

    Метод сохраняет в кэше массив

  • boolean InsertIntoCache()

    Метод размещает строковые данные в кэше

  • boolean IssetCacheContent()

    Метод возвращает наличие/отсутствие кэш-файла для переданного имени кэш-элемента

  • void SetCacheLifeTime()

    Метод устанавливает время актуальности кэш-файла для запрашиваемого имени

Унаследованные методы

Описания методов

    Cache::Cache

Cache(
[boolean
$cache_life_time = false] );

    Принимаемые параметры

    $cache_life_time

    время жизни кэша

    Описание

    Конструктор

    [ Top ]

    Cache::BeginRecord

BeginRecord(
 );

    Описание

    Метод перехватывает информацию, размещаемую в потоке и сохраняет ее в памяти

    [ Top ]

    Cache::ClearCache

ClearCache(
 );

    Описание

    Метод удаления всех файлов из кэша

    [ Top ]

    Cache::EndRecord

EndRecord(
string
$CacheName );

    Принимаемые параметры

    $CacheName

    имя кэш-элемента

    Описание

    Метод заканчивает запись из потока, выводит записанную информацию и сохраняет в кэше с именем $CacheName

    [ Top ]

    Cache::GetArrayCacheContent

GetArrayCacheContent(
string
$name );

    Принимаемые параметры

    $name

    имя кэш-элемента

    Возвращает

    массив, сохраненный в кэше, в случае успешного выполнения или false в противном случае

    Описание

    Метод получает сохраненный в кэше массив

    [ Top ]

    Cache::GetCacheContent

GetCacheContent(
string
$name );

    Принимаемые параметры

    $name

    имя кэш-элемента

    Возвращает

    контент из кэша в случае успешного выполнения или false в противном случае

    Описание

    Метод получения содержания кэша для заданного имени

    [ Top ]

    Cache::GetCacheLifeTime

GetCacheLifeTime(
 );

    Возвращает

    время жизни кэша в секундах

    Описание

    Метод возвращает время актуальности кэш-файла в секундах

    [ Top ]

    Cache::GetCacheName

GetCacheName(
string
$name );

    Принимаемые параметры

    $name

    имя кэш-элемента

    Возвращает

    имя кэш-файла для переданного имени

    Описание

    Метод возвращает имя кэш-файла для переданного имени

    [ Top ]

    Cache::InsertArrayIntoCache

InsertArrayIntoCache(
string
$name, array
$content_array );

    Принимаемые параметры

    $name

    имя кэш-элемента

    $content_array

    массив для сохранения

    Возвращает

    true в случае успешного выполнения или false в противном случае

    Описание

    Метод сохраняет в кэше массив

    [ Top ]

    Cache::InsertIntoCache

InsertIntoCache(
string
$name, string
$content );

    Принимаемые параметры

    $name

    имя кэш-элемента

    $content

    содержание для помещения в кэш

    Возвращает

    true или false в зависимости от успеха опреации

    Описание

    Метод размещает строковые данные в кэше

    [ Top ]

    Cache::IssetCacheContent

IssetCacheContent(
string
$name );

    Принимаемые параметры

    $name

    имя кэш-элемента

    Возвращает

    true в случае наличия кэш-файла для переданного имени кэш-элемента или false в противном случае

    Описание

    Метод возвращает наличие/отсутствие кэш-файла для переданного имени кэш-элемента

    [ Top ]

    Cache::SetCacheLifeTime

SetCacheLifeTime(
int
$time );

    Принимаемые параметры

    $time

    время жизни кэша в секундах

    Описание

    Метод устанавливает время актуальности кэш-файла для запрашиваемого имени

    [ Top ]

Variable Detail

  • $cache_life_time =  60 [line 18]
    •

  • Data type: int
    •

    Описание

    Время жизни кэша, по умолчанию равно 60 секунд

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Captcha

Class Captcha

[line 11]

Размещен: /Kernel/Captcha.class.php

Описание

Ядро, класс для работы с CAPTCHA

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void BuildCapture()

    Метод для построения изображения CAPTCHA и помещения его текста в сессию

  • unknown GetCaptchaId()

    Метод генерирует и возвращает уникальный индекс для CAPTCHA

  • boolean ValidCaptcha()

    Метод проверки соответствия введенного пользователем текста хранимому в сессии

Унаследованные методы

Описания методов

    Captcha::BuildCapture

BuildCapture(
int
$id, [mixed
$param = array()], array
$param
 );

    Принимаемые параметры

    $id

    - уникальный номер CAPTCHA

    $param

    $param['alphabet'] Символы используемые в тексте
    $param['allowed_symbols'] Символы, исключающие ошибки распознавания (o=0, i=j, 1=l) используются для формирования строки
    $param['fontsdir'] Путь к шрифтам
    $param['length'] Количество символов
    $param['width'] Ширина базового изображения
    $param['height'] Высота базового изображения
    $param['dest_x'] Ширина реального изображения
    $param['dest_y'] Высота реального изображения
    $param['foreground_color'] Цвет текста в RGB задаётся массивом
    $param['background_color'] Цвет фона в RGB задаётся массивом

    Описание

    Метод для построения изображения CAPTCHA и помещения его текста в сессию

    [ Top ]

    Captcha::GetCaptchaId

GetCaptchaId(
 );

    Описание

    Метод генерирует и возвращает уникальный индекс для CAPTCHA

    [ Top ]

    Captcha::ValidCaptcha

ValidCaptcha(
int
$id, string
$text );

    Принимаемые параметры

    $id

    уникальный номер CAPTCHA

    $text

    текст, введённый пользователем

    Описание

    Метод проверки соответствия введенного пользователем текста хранимому в сессии

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs For Class compression

Class compression

[line 11]

Размещен: /Compression/Compression.class.php

Описание

Класс модуля "Система сжатия (компрессия)"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • string CheckTypeGzip()

    Метод вовзращает тип сжатия gzip, в противном случае false

  • boolean PageCompressionBegin()

    Метод начала приема из стандартного потока содержимого для компрессии

  • void PageCompressionEnd()

    Метод выводит сжатые данные, размещаемые в потоке

Унаследованные методы

Описания методов

    compression::CheckTypeGzip

CheckTypeGzip(
 );

    Возвращает

    возвращает строку или false

    Описание

    Метод вовзращает тип сжатия gzip, в противном случае false

    [ Top ]

    compression::PageCompressionBegin

PageCompressionBegin(
 );

    Описание

    Метод начала приема из стандартного потока содержимого для компрессии

    [ Top ]

    compression::PageCompressionEnd

PageCompressionEnd(
 );

    Описание

    Метод выводит сжатые данные, размещаемые в потоке

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:11 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Constants

Class Constants

[line 11]

Размещен: /Constants/Constants.class.php

Описание

Класс модуля "Константы"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • mixed AddEditConstants()

    Метод добавления/редактирования данных о константе

  • boolean DelConstants()

    Метод удаления константы

  • mixed GetConstants()

    Метод получения данных о константах

Унаследованные методы

Описания методов

    Constants::AddEditConstants

AddEditConstants(
int
$type, int
$constants_id, string
$constants_name, string
$constants_value, string
$constants_description, int
$constants_activity );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление данных о константе (0 - вставка, 1 - обновление)

    $constants_id

    идентификатор константы, если идет обновление

    $constants_name

    имя константы

    $constants_value

    значение константы

    $constants_description

    описание константы

    $constants_activity

    статус активности константы (0 - неактивна, 1 - активна)

    Возвращает

    идентификатор вставленной/обновленной записи в случае успешного выполнения, false - в противном случае

    Описание

    Метод добавления/редактирования данных о константе

    [ Top ]

    Constants::DelConstants

DelConstants(
int
$constants_id );

    Принимаемые параметры

    $constants_id

    идентификатор удаляемой константы

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления константы

    [ Top ]

    Constants::GetConstants

GetConstants(
mixed
$constants_id );

    Принимаемые параметры

    $constants_id

    идентификатор константы, данные о которой необходимо получить,  false - получаем данные о всех константах

    Возвращает

    resource в случае успешного выполнения, false в противном случае

    Описание

    Метод получения данных о константах

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs For Class counter

Class counter

[line 7]

Размещен: /Counter/Counter.class.php

Описание

Класс модуля "Статистика посещаемости сайта"

Свойства класса

  • $new_session =  false

        Флаг добавления новой сессии при обновлении данных счетчика

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean AddEditInitialData()

    Метод добавления/редактирования начальных данных для счетчика

  • string AlignTextSpace()

    Метод выравнивания текста по центру с помощью пробелов

  • mixed build_counter()

    Метод вывода счетчика

  • boolean CheckBot()

    Метод проверки - является ли user agent ботом

  • string code_ip()

    Метод для преобразования IP в HEX

  • string decode_ip()

    Метод для декодирования IP из HEX

  • void DelStatInfomationForSite()

    Метод удаления статистической информации для сайта

  • mixed GetBotsInfo()

    Метод получения данных о ботах и посещенных ими страницах

  • mixed GetCounterInform()

    Метод получения информации о данных счетчика за определенную дату

  • mixed GetInitialData()

    Метод получения начальных данных для счетчика

  • mixed GetIpInformation()

    Метод выборки информации для IP-адреса

  • mixed GetNewUsersInform()

    Метод выборки информации о новых пользователях сайта

  • mixed GetSearchSystemInform()

    Метод выборки информации о поисковых системах

  • array GetSecondaryStat()

    Метод получения статистической информации из таблицы сессий

  • array GetStatArray()

    Метод получения статистической информации из основной таблицы

  • array GetStatDataArray()

    Метод получения статистических данных за переданный промежуток времени

  • mixed GetUseCJ()

    Метод получения данных о использовании кукисов и Java

  • void InsertRecord()

    Метод добавления записи в основную таблицу статистики

  • int InsertSession()

    Метод для вставки записи о сессии

  • string IsSearchSystem()

    Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:

  • boolean isset_id()

    Метод проверки наличия id сайта

  • boolean MailReport()

    Метод отправки письма с отчетом администратору сайта

  • void ShowCounterCode()

    Метод, осуществляющий вывод кода счетчика

  • void show_date()

    Метод для вывода формы с полями для дат (для вывода статистики)

  • void show_link()

    Метод для вывода ссылок на различные пункты статистики

Унаследованные методы

Описания методов

    counter::AddEditInitialData

AddEditInitialData(
int
$type, int
$site_id, int
$sessions, int
$hosts, int
$hits, int
$new_users, int
$bots );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $site_id

    идентификатор сайта

    $sessions

    начальное значение сессий

    $hosts

    начальное значение хостов

    $hits

    начальное значение новых пользователей

    $new_users

    начальное значение ботов

    $bots

    начальное значение типа дейтсвия (0-вставка, 1-редактирование)

    Возвращает

    истину при удачной вставке/обновлении или ложь в случае ошибки

    Описание

    Метод добавления/редактирования начальных данных для счетчика

    [ Top ]

    counter::AlignTextSpace

AlignTextSpace(
int
$count_all, strlen
$text );

    Принимаемые параметры

    $count_all

    общее количество символов

    $text

    текст

    Возвращает

    строка с выровненным текстом

    Описание

    Метод выравнивания текста по центру с помощью пробелов

    [ Top ]

    counter::build_counter

build_counter(
int
$site_id, int
$js_version, int
$screen, int
$remote_addr, string
$current_page, string
$refer, int
$px, string
$user_agent, string
$cookie, string
$java, int
$counter, [int
$update_counter = 1] );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $js_version

    js версия пользователя

    $screen

    параметры экрана пользователя

    $remote_addr

    ip адрес пользователя

    $current_page

    посещенная страница

    $refer

    ссылающаяся страница

    $px

    глубина цвета пользователя

    $user_agent

    user agent пользователя

    $cookie

    флаг поддержки кукисов

    $java

    флаг поддержки java

    $counter

    номер счетчика для определения изображения

    $update_counter

    - флаг обновления данных счетчика (1-обновлять (по умолчанию), 0-просто построить счетчик)

    Возвращает

    ложь в случае ошибки, в случае успешного построения счетчика и вставки/обновления данных метод ничего не возвращает

    Описание

    Метод вывода счетчика

    [ Top ]

    counter::CheckBot

CheckBot(
string
$agent );

    Принимаемые параметры

    $agent

    user agent пользователя

    Возвращает

    истину, если это бот, ложь в противном случае

    Описание

    Метод проверки - является ли user agent ботом

    [ Top ]

    counter::code_ip

code_ip(
string
$ip );

    Принимаемые параметры

    $ip

    ip-адрес

    Возвращает

    ip-адрес, преобразованный в 16-ое значение для записи в базу

    Описание

    Метод для преобразования IP в HEX

    [ Top ]

    counter::decode_ip

decode_ip(
srting
$ip );

    Принимаемые параметры

    $ip

    ip-адрес в 16-ричном формате

    Возвращает

    ip-адрес в обычном формате для вывода

    Описание

    Метод для декодирования IP из HEX

    [ Top ]

    counter::DelStatInfomationForSite

DelStatInfomationForSite(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Описание

    Метод удаления статистической информации для сайта

    [ Top ]

    counter::GetBotsInfo

GetBotsInfo(
string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    информация о ботах в случае удачной выборки, ложь - при возникновении ошибки

    Описание

    Метод получения данных о ботах и посещенных ими страницах

    [ Top ]

    counter::GetCounterInform

GetCounterInform(
int
$site_id, [string
$date = ''], [string
$mark = "="] );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $date

    дата (не обязательный параметр, по умолчанию = '')

    $mark

    знак сравнения с датой (по умолчанию - "=")

    Возвращает

    массив с данными при успешной выборке, иначе - ложь

    Описание

    Метод получения информации о данных счетчика за определенную дату

    [ Top ]

    counter::GetInitialData

GetInitialData(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    информация о начальных данных, ложь - если запись не выбрана

    Описание

    Метод получения начальных данных для счетчика

    [ Top ]

    counter::GetIpInformation

GetIpInformation(
string
$ip_adr, string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $ip_adr

    ip адрес

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    массив с данными по ip адресу при успешной выборке, иначе - ложь

    Описание

    Метод выборки информации для IP-адреса

    [ Top ]

    counter::GetNewUsersInform

GetNewUsersInform(
string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    массив с данными о новых пользователях при успешной выборке, иначе - ложь

    Описание

    Метод выборки информации о новых пользователях сайта

    [ Top ]

    counter::GetSearchSystemInform

GetSearchSystemInform(
string
$date_from, string
$date_to, int
$site_id, [int
$limit = ''] );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничение количества выбираемых записей (не обязательный параметр)

    Возвращает

    массив с данными о поисковых системах при успешной выборке, ложь при возникновении ошибок

    Описание

    Метод выборки информации о поисковых системах

    [ Top ]

    counter::GetSecondaryStat

GetSecondaryStat(
int
$type, string
$date_from, string
$date_to, int
$site_id, [string
$limit = ''] );

    Принимаемые параметры

    $type

    вид информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничение количества страниц ($limit - не обязательный параметр)

    Возвращает

    информация с данными статистики

    Описание

    Метод получения статистической информации из таблицы сессий

    [ Top ]

    counter::GetStatArray

GetStatArray(
int
$type, string
$date_from, string
$date_to, int
$site_id, [string
$limit = ''] );

    Принимаемые параметры

    $type

    вид информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    $limit

    ограничения количества страниц

    Возвращает

    данные статистики

    Описание

    Метод получения статистической информации из основной таблицы

    [ Top ]

    counter::GetStatDataArray

GetStatDataArray(
string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор сайта

    Возвращает

    ассоциативный массив с данными

    Описание

    Метод получения статистических данных за переданный промежуток времени

    [ Top ]

    counter::GetUseCJ

GetUseCJ(
int
$type, string
$date_from, string
$date_to, int
$site_id );

    Принимаемые параметры

    $type

    тип отбираемой информации

    $date_from

    дата начала выборки данных

    $date_to

    дата окончания выборки данных

    $site_id

    идентификатор данных

    Возвращает

    ассоциативный массив с данными об использовании кукисов и Java при успешной выборке, иначе - ложь

    Описание

    Метод получения данных о использовании кукисов и Java

    [ Top ]

    counter::InsertRecord

InsertRecord(
int
$session_id, int
$site_id, string
$refer, string_type
$page, string
$cookie, string
$java, string
$search_system, string
$search_query, int_type
$user_number, int_type
$user_is_new, string
$ip_adr, string
$hostname );

    Принимаемые параметры

    $session_id

    идентификатор сессии

    $site_id

    идентификатор сайта

    $refer

    ссылающаяся страница

    $page

    страница

    $cookie

    флаг поддержки кукисов

    $java

    флаг поддержки java

    $search_system

    флаг поисковой системы

    $search_query

    поисковая фраза

    $user_number

    номер пользователя

    $user_is_new

    флаг новый пользователь или нет

    $ip_adr

    преобразованный ip

    $hostname

    имя хоста

    Описание

    Метод добавления записи в основную таблицу статистики

    [ Top ]

    counter::InsertSession

InsertSession(
int
$site_id, int
$color_depth, string
$display_name, string
$js_version, string
$ip_adr, string
$user_agent, int
$is_bot );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $color_depth

    глубина цвета

    $display_name

    параметры экрана

    $js_version

    версия js

    $ip_adr

    преобразованный ip

    $user_agent

    user agent

    $is_bot

    флаг - бот/не бот

    Возвращает

    идетнификатор вставленной записи, либо идентификатор уже имеющейся записи о текущей сессии

    Описание

    Метод для вставки записи о сессии

    [ Top ]

    counter::IsSearchSystem

IsSearchSystem(
string
$str );

    Принимаемые параметры

    $str

    адрес ссылающейся страницы

    Возвращает

    поисковый запрос

    Описание

    Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:

    Yandex
    Rambler
    Google
    Mail.Ru
    Aport
    MSN
    Altavista
    KM.Ru
    Yahoo.com
    Webalta
    Metabot
    Nigma

    [ Top ]

    counter::isset_id

isset_id(
int
$id );

    Принимаемые параметры

    $id

    идентификатор сайта

    Возвращает

    Истина при наличии сайта, ложь - если данного сайта не существует

    Описание

    Метод проверки наличия id сайта

    [ Top ]

    counter::MailReport

MailReport(
int
$site_id, string
$date );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $date

    дата отчета

    Возвращает

    ложь в случае ошибки, в случае успеной отправки метод не возвращет никаких значений

    Описание

    Метод отправки письма с отчетом администратору сайта

    [ Top ]

    counter::ShowCounterCode

ShowCounterCode(
number
$counter_type, string
$alias_name, array
$gCounterProperties, [string
$get_update_counter = ''] );

    Принимаемые параметры

    $counter_type

    тип выводимого счетчика (файл счетчика должен быть расположен в директории /counter/ и представлять собой изображение с именем {НОМЕР}.gif)

    $alias_name

    наименование домена сайта, например www.hostcms.ru

    $gCounterProperties

    глобальный массив, содержащий свойства счетчика

    $get_update_counter

    переменная с информацией о необходимости обновления счетчика, не обязательный параметр, по умолчанию равен пустоте

    Описание

    Метод, осуществляющий вывод кода счетчика

    Пример использования:

    1      <?
    2              $counter = new counter();
    3              $counter->ShowCounterCode(0,"www.hostcms.ru",$gCounterProperties,"&update_counter=0");
    4      ?>

    [ Top ]

    counter::show_date

show_date(
string
$part, [string
$action = 'counter.php'] );

    Принимаемые параметры

    $part

    раздел статистики (например, show_stat_user)

    $action

    action для формы

    Описание

    Метод для вывода формы с полями для дат (для вывода статистики)

    [ Top ]

    counter::show_link

show_link(
 );

    Описание

    Метод для вывода ссылок на различные пункты статистики

    [ Top ]

Variable Detail

  • $new_session =  false [line 13]
    •

  • Data type: boolean
    •

    Описание

    Флаг добавления новой сессии при обновлении данных счетчика

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:12 +0400 by phpDocumentor 1.3.0RC3


Docs For Class DateClass

Class DateClass

[line 11]

Размещен: /Kernel/Date.class.php

Описание

Ядро, класс для работы с датами

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • string ChangeMySqlDate()

    Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд

  • string ChangeNormalDate()

    Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд

  • mixe DateSqlToUnix()

    Метод преобразовывает дату в формате SQL в число секунд с начала эпохи

  • mixed datetime_format()

    Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT

  • mixed datetime_format_sql()

    Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL

  • string DateUnixToSQL()

    Метод преобразовывает дату из числа секунд в формат SQL

  • mixed date_format()

    Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT

  • mixed date_format_sql()

    Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат

Унаследованные методы

Описания методов

    DateClass::ChangeMySqlDate

ChangeMySqlDate(
int
$second, [string
$date = ''] );

    Принимаемые параметры

    $second

    число секунд

    $date

    принимаемая дата

    Возвращает

    измененная дата

    Описание

    Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд

    [ Top ]

    DateClass::ChangeNormalDate

ChangeNormalDate(
int
$second, [string
$date = ''] );

    Принимаемые параметры

    $second

    число секунд

    $date

    дата в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС

    Возвращает

    дата в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС

    Описание

    Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд

    [ Top ]

    DateClass::DateSqlToUnix

DateSqlToUnix(
string
$date, [string
$date_separator = '-'] );

    Принимаемые параметры

    $date

    дата в формате MySQL

    $date_separator

    разделитель даты (по умолчанию "-")

    Возвращает

    дата в формате числа секунд с начала эпохи в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразовывает дату в формате SQL в число секунд с начала эпохи

    [ Top ]

    DateClass::datetime_format

datetime_format(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT

    [ Top ]

    DateClass::datetime_format_sql

datetime_format_sql(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    дата в формате MySQL в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL

    [ Top ]

    DateClass::DateUnixToSQL

DateUnixToSQL(
string
$datetime );

    Принимаемые параметры

    $datetime

    число секунд с начала эпохи

    Возвращает

    дата в формате SQL

    Описание

    Метод преобразовывает дату из числа секунд в формат SQL

    [ Top ]

    DateClass::date_format

date_format(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    преобразованная дата в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT

    [ Top ]

    DateClass::date_format_sql

date_format_sql(
string
$date );

    Принимаемые параметры

    $date

    принимаемая дата

    Возвращает

    дата в формате MySQL в случае успешного выполнения, false в противном случае

    Описание

    Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:13 +0400 by phpDocumentor 1.3.0RC3


Docs For Class documents

Class documents

[line 11]

Размещен: /Documents/Documents.class.php

Описание

Класс модуля "Старницы и документы"

Свойства класса

  • $mas_documents_dir = array()

        Массив разделов документов

  • $record_on_page = ON_PAGE

        Число записей, выводимых на странице в административной части

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void CopyDocuments()

    Метод копирования документа

  • boolean current_version()

    Метод для переобозначения текущей версии документа

  • boolean delete_old_version()

    Метод удаления записей обо всех не текущих версиях

  • boolean delete_status()

    Метод удаления статуса документов

  • boolean delete_version()

    Метод удаления записей о версиях

  • boolean del_documents()

    Метод удаления документов

  • boolean del_documents_dir()

    Метод удаления разделов документов

  • mixed GetDocumentVersion()

    Метод получения информации о текущей версии документа

  • array get_documents_dir()

    Метод формирования дерева разделов

  • string get_path()

    Метод формирования строки ссылок с родительскими разделами

  • int insert_documents()

    Метод вставки и обновления новых документов

  • int insert_documents_dir()

    Метод вставки и обновления разделов документов

  • int insert_status()

    Метод добавления(редактирования) статусов документов

  • int insert_version()

    Метод добавления/редактирования записей о версиях

  • resource select_documents()

    Метод получения информации о документе или обо всех документах

  • resource select_documents_dir()

    Метод  выбора раздела документов

  • resource select_status()

    Метод получения информации о статусе документа

  • resource select_version()

    Метод выборки информации о версиях

  • void ShowDocument()

    Метод вызывает показ текущей версии переданной страницы

  • void show_link()

    Метод формирования строки ссылок на разделы и подразделы

Унаследованные методы

Описания методов

    documents::CopyDocuments

CopyDocuments(
int
$documents_id );

    Принимаемые параметры

    $documents_id

    идентификатор копируемого документа

    Описание

    Метод копирования документа

    [ Top ]

    documents::current_version

current_version(
int
$documents_id, int
$id );

    Принимаемые параметры

    $documents_id

    идентификатор документа

    $id

    идентификатор текущей версии

    Возвращает

    true при удачном обновлении данных, false в обратном случае

    Описание

    Метод для переобозначения текущей версии документа

    [ Top ]

    documents::delete_old_version

delete_old_version(
int
$documents_id );

    Принимаемые параметры

    $documents_id

    идентификатор документа

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления записей обо всех не текущих версиях

    [ Top ]

    documents::delete_status

delete_status(
int
$status_id );

    Принимаемые параметры

    $status_id

    идентификатор удаляемого статуса документов

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления статуса документов

    [ Top ]

    documents::delete_version

delete_version(
int
$version_id );

    Принимаемые параметры

    $version_id

    идентификатор удаляемой версии

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления записей о версиях

    [ Top ]

    documents::del_documents

del_documents(
int
$id );

    Принимаемые параметры

    $id

    идентификатор документа

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления документов

    [ Top ]

    documents::del_documents_dir

del_documents_dir(
int
$id );

    Принимаемые параметры

    $id

    идентификатор раздела

    Возвращает

    true при удачном удалении, false - в обратном случае

    Описание

    Метод удаления разделов документов

    [ Top ]

    documents::GetDocumentVersion

GetDocumentVersion(
int
$documents_id );

    Принимаемые параметры

    $documents_id

    идентификатор отображаемого документа

    Возвращает

    информарция о версии документа в случае успешного выполнения или false, если текущая версия не найдена

    Описание

    Метод получения информации о текущей версии документа

    [ Top ]

    documents::get_documents_dir

get_documents_dir(
int
$documents_dir_parent_id, int
$separator_dir, [int
$id_red = 0] );

    Принимаемые параметры

    $documents_dir_parent_id

    идентификатор родительского раздела, с которого начинается формирование

    $separator_dir

    отступ для подразделов

    $id_red

    идентификатор раздела, который необходимо пропустить (не включать в дерево вместе с подразделами)

    Возвращает

    ассоциативный массив с информацией о дереве разделов

    Описание

    Метод формирования дерева разделов

    [ Top ]

    documents::get_path

get_path(
int
$dir_id, string
$prefix, string
$sufix );

    Принимаемые параметры

    $dir_id

    идентификатор раздела

    $prefix

    префикс для формирования ссылки на раздел

    $sufix

    строку, дописываемую к ссылке

    Возвращает

    строка ссылок с родительскими разделами

    Описание

    Метод формирования строки ссылок с родительскими разделами

    [ Top ]

    documents::insert_documents

insert_documents(
int
$type, int
$documents_id, int
$documents_dir_id, int
$users_id, int
$documents_status_id, string
$documents_name, int
$version_id, int
$version_current, int
$version_comment, string
$documents_text, int
$templates_id );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $documents_id

    идентификатор документа

    $documents_dir_id

    идентификатор радздела

    $users_id

    идентификатор пользователя

    $documents_status_id

    идентификатор статуса документа

    $documents_name

    наименование документа

    $version_id

    идентификатор версии документа

    $version_current

    указатель на текущую версию

    $version_comment

    комментарий к версии документа

    $documents_text

    текст документа

    $templates_id

    идентификатор шаблона

    Возвращает

    идентификатор документа

    Описание

    Метод вставки и обновления новых документов

    [ Top ]

    documents::insert_documents_dir

insert_documents_dir(
int
$type, int
$documents_dir_id, int
$documents_dir_parent_id, string
$documents_dir_name );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $documents_dir_id

    идентификатор раздела

    $documents_dir_parent_id

    идентификатор родительского раздела

    $documents_dir_name

    наименование раздела

    Возвращает

    идентификатор отредактированного (вставленного) раздела

    Описание

    Метод вставки и обновления разделов документов

    [ Top ]

    documents::insert_status

insert_status(
int
$type, int
$status_id, string_type
$status_name, string
$status_description );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $status_id

    идентификатор статуса документа

    $status_name

    наименование статуса

    $status_description

    описание статуса

    Возвращает

    идентификатор нового или редатируемого статуса (в зависимости от типа действия)

    Описание

    Метод добавления(редактирования) статусов документов

    [ Top ]

    documents::insert_version

insert_version(
int
$type, int
$version_id, int
$documents_id, int
$version_current, string
$version_comment, string
$documents_text, int
$users_id, int
$templates_id );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $version_id

    идентификатор версии документа

    $documents_id

    идентификатор документа

    $version_current

    флаг текущей версии

    $version_comment

    комментарий к версии

    $documents_text

    текст документа

    $users_id

    идентификатор пользователя

    $templates_id

    идентификатор шаблона

    Возвращает

    идентификатор новой или редатируемой версии (в зависимости от типа действия)

    Описание

    Метод добавления/редактирования записей о версиях

    [ Top ]

    documents::select_documents

select_documents(
int
$id );

    Принимаемые параметры

    $id

    идентификатор документа (-1 - выбор всех документов)

    Возвращает

    реестр документов или данные о конкретном документе

    Описание

    Метод получения информации о документе или обо всех документах

    [ Top ]

    documents::select_documents_dir

select_documents_dir(
int
$id );

    Принимаемые параметры

    $id

    идентификатор раздела (-1 - выбор всех разделов)

    Возвращает

    список всех разделов или данные о конкретном разделе

    Описание

    Метод  выбора раздела документов

    [ Top ]

    documents::select_status

select_status(
int
$id );

    Принимаемые параметры

    $id

    идентификатор статуса (-1 - выбор всех статусов)

    Возвращает

    информация о статусе документа (обо всех статусах)

    Описание

    Метод получения информации о статусе документа

    [ Top ]

    documents::select_version

select_version(
int
$documents_id, int
$id, int
$current );

    Принимаемые параметры

    $documents_id

    идентификатор документа

    $id

    идентификатор версии

    $current

    указатель на текущую версию

    Возвращает

    информация о версиях документа

    Описание

    Метод выборки информации о версиях

    [ Top ]

    documents::ShowDocument

ShowDocument(
int
$document_id );

    Принимаемые параметры

    $document_id

    иднетификатор отображаемого документа

    Описание

    Метод вызывает показ текущей версии переданной страницы

    [ Top ]

    documents::show_link

show_link(
int
$documents_dir_id );

    Принимаемые параметры

    $documents_dir_id

    идентификатор раздела

    Описание

    Метод формирования строки ссылок на разделы и подразделы

    [ Top ]

Variable Detail

  • $mas_documents_dir = array() [line 34]
    •

  • Data type: array
    •

    Описание

    Массив разделов документов

  • $record_on_page = ON_PAGE [line 27]
    •

  • Data type: int
    •

    Описание

    Число записей, выводимых на странице в административной части

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:13 +0400 by phpDocumentor 1.3.0RC3


Docs For Class EventsJournalAdmin

Class EventsJournalAdmin

[line 11]
EventsJournal
   |
   --EventsJournalAdmin
Размещен: /EventsJournal/EventsJournal.class.php

Описание

Класс модуля "Журнал событий"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean EventsMail()
    Метод отправки письма с отчетом

Унаследованные методы

Унаследованные от класса EventsJournal

  • EventsJournal::log_access()
    Метод протоколирования получения доступа к системе управления

Описания методов

    EventsJournalAdmin::EventsMail

    EventsMail( string $date );

    Принимаемые параметры

    $date

    дата отчета

    Описание

    Метод отправки письма с отчетом

    [ Top ]

Variable Detail

Описание констант класса

Documentation generated on Sun, 01 Oct 2006 21:01:14 +0400 by phpDocumentor 1.3.0RC3


Docs For Class EventsJournal

Class EventsJournal

[line 11]

Classes extended from EventsJournal:

EventsJournalAdmin

Класс модуля "Журнал событий"

Размещен: /Kernel/EventsJournal.class.php

Описание

Ядро, класс журналирования событий

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean log_access()

    Метод протоколирования получения доступа к системе управления

Унаследованные методы

Описания методов

    EventsJournal::log_access

log_access(
string
$login, string_type
$message, [string
$status = 0], [mixed
$send_debug_email = true], string
$send_debug_emailотправлять );

    Принимаемые параметры

    $login

    логин пользователя

    $message

    текст сообщения для события

    $status

    статус события (значимость события), необязательный параметр.
    Статус имеет значения:
    0 – Нейтральное
    1 – Успешное
    2 – Низкий уровень критичности
    3 – Средний уровень критичности
    4 – Наивысший уровень критичности

    $send_debug_emailотправлять

    разработчику сообщение о произошедшем событии или нет (по умолчанию - отправлять), необязательный параметр, по умолчанию - true

    Описание

    Метод протоколирования получения доступа к системе управления

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:14 +0400 by phpDocumentor 1.3.0RC3


Docs For Class ExecSqlQuery

Class ExecSqlQuery

[line 11]

Ðàçìåùåí: /ExecSqlQuery/ExecSqlQuery.class.php

Îïèñàíèå

Êëàññ ìîäóëÿ "SQL-çàïðîñû"

Ñâîéñòâà êëàññà

Êîíñòàíòû êëàññà

Inherited Class Constant Summary

Óíàñëåäîâàííûå ñâîéñòâà êëàññà

Ìåòîäû

  • int ExecDump()

    Ìåòîä âûïîëíåíèÿ SQL-çàïðîñà

Óíàñëåäîâàííûå ìåòîäû

Îïèñàíèÿ ìåòîäîâ

    ExecSqlQuery::ExecDump

ExecDump(
string
$query );

    Ïðèíèìàåìûå ïàðàìåòðû

    $query

    SQL-çàïðîñ

    Âîçâðàùàåò

    êîëè÷åñòâî âûïîëíåííûõ çàïðîñîâ èëè false

    Îïèñàíèå

    Ìåòîä âûïîëíåíèÿ SQL-çàïðîñà

    [ Top ]

Variable Detail

Îïèñàíèå êîíñòàíò êëàññà

        Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs For Class ExternalXml

Class ExternalXml

[line 6]

Размещен: /Kernel/ExternalXml.class.php

Описание

Ядро, класс формирует дерево XML по переданному массиву

Свойства класса

  • $flag =  false

  • $xml =  ''

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • string GenXml()

    Метод генерации XML для переданного массива

Унаследованные методы

Описания методов

    ExternalXml::GenXml

GenXml(
array
$array );

    Принимаемые параметры

    $array

    массив с информацией о дереве

    Возвращает

    XML-код

    Описание

    Метод генерации XML для переданного массива

    [ Top ]

Variable Detail

  • $flag =  false [line 9]
    •

  • Data type: mixed
    •

  • $xml =  '' [line 8]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs For Class File

Class File

[line 11]

Размещен: /Kernel/File.class.php

Описание

Ядро, класс для работы с файлами

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean Download()

    Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла

  • string GetFileContent()

    Метод получения содержимого файла

  • string get_file_perms()

    Метод получения строки прав доступа к файлу

Унаследованные методы

Описания методов

    File::Download

Download(
string
$file, string
$filename );

    Принимаемые параметры

    $file

    абсолютный путь к файлу

    $filename

    имя файла

    Описание

    Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла

    [ Top ]

    File::GetFileContent

GetFileContent(
string
$filename );

    Принимаемые параметры

    $filename

    абсолютный путь к файлу

    Возвращает

    содержимое файла, если такой файл существует или false, если файл не существует или его невозможно прочитать

    Описание

    Метод получения содержимого файла

    [ Top ]

    File::get_file_perms

get_file_perms(
string
$filename, int
$type );

    Принимаемые параметры

    $filename

    имя файла

    $type

    тип строки (0 - "-rw-rw-rw-"; 1 - "0755")

    Возвращает

    строка прав доступа к файлу

    Описание

    Метод получения строки прав доступа к файлу

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs For Class FileManager

Class FileManager

[line 11]

Размещен: /FileManager/FileManager.class.php

Описание

Класс модуля "Файловый менеджер"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean del_dir()

    Метод удаления директории вместе с вложенными файлами и директориями

  • boolean del_file()

    Метод удаления файла или директории

  • boolean load_files()

    Метод загрузки файлов

  • string PathCorrection()

    Метод удаляет потенциально опасных символы из пути или имени файла

Унаследованные методы

Описания методов

    FileManager::del_dir

del_dir(
string
$dir );

    Принимаемые параметры

    $dir

    полный путь

    Возвращает

    true в случаее успешного выполнеия, false в противном случае

    Описание

    Метод удаления директории вместе с вложенными файлами и директориями

    [ Top ]

    FileManager::del_file

del_file(
string
$file_name );

    Принимаемые параметры

    $file_name

    полный путь

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления файла или директории

    [ Top ]

    FileManager::load_files

load_files(
array
$source, string
$file_name, string
$dir_file, [boolean
$rewrite = true] );

    Принимаемые параметры

    $source

    информация о файле $_FILES['file']

    $file_name

    имя файла

    $dir_file

    директория для размещения файла

    $rewrite

    разрешает замену уже существующего файла, по молчанию true

    Описание

    Метод загрузки файлов

    [ Top ]

    FileManager::PathCorrection

PathCorrection(
string
$path );

    Принимаемые параметры

    $path

    путь

    Возвращает

    путь без потенциально опасных символов

    Описание

    Метод удаляет потенциально опасных символы из пути или имени файла

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Forms

Class Forms

[line 11]

Размещен: /Forms/Forms.class.php

Описание

Класс модуля "Формы"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • int ConfirmGetForm()

    Метод, определяющий может ли пользователь отправлять форму

  • void CopyForms()

    Метод копирования структуры формы и ее полей

  • mixed CopyFormsField()

    Метод копирования структуры поля формы

  • boolean DelFillForms()

    Удаление бланка заполненной формы

  • boolean DelFillValues()

    Метод удаления значения одного из полей отправленной формы

  • boolean DelForms()

    Метод удаления данных о форме

  • boolean DelFormsFields()

    Метод удаления поля формы

  • boolean GetForm()

    Метод обработки содержимого отправленной формы

  • mixed GetFormFields()

    Метод получения данных о полях формы

  • mixed InsertForms()

    Метод вставки/обновления информации о форме

  • mixed InsertFormsFields()

    Метод вставки/обновления информации о поле формы

  • mixed InsertFormsFill()

    Метод вставки/обновления информации о заполнении формы

  • mixed InsertFormsFillValues()

    Метод вставки/обновления значений заполненной формы

  • mixed SelectForms()

    Метод выбора данных о формах

  • mixed SelectFormsFields()

    Метод выбора данных о поле формы

  • boolean ShowForm()

    Метод отображения формы

Унаследованные методы

Описания методов

    Forms::ConfirmGetForm

ConfirmGetForm(
int
$forms_id, string
$date, string
$forms_fill_ip );

    Принимаемые параметры

    $forms_id

    идентификатор отправляемой формы

    $date

    дата и время (в формате MySQL) отправки формы

    $forms_fill_ip

    ip-адрес компьютера отправителя формы

    Возвращает

    1 – пользователь может отправлять данные формы, 0 – пользователь не может отправлять данные формы

    Описание

    Метод, определяющий может ли пользователь отправлять форму

    [ Top ]

    Forms::CopyForms

CopyForms(
int
$forms_id );

    Принимаемые параметры

    $forms_id

    идентификатор формы, структуру которой необходимо скопировать

    Описание

    Метод копирования структуры формы и ее полей

    [ Top ]

    Forms::CopyFormsField

CopyFormsField(
int
$forms_field_id );

    Принимаемые параметры

    $forms_field_id

    идентификатор поля формы, копию которого необходимо сделать

    Возвращает

    идентификатор нового (скопированного) поля формы, false в противном случае

    Описание

    Метод копирования структуры поля формы

    [ Top ]

    Forms::DelFillForms

DelFillForms(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого бланка

    Возвращает

    true в случае успешного удаления, false в противном случае

    Описание

    Удаление бланка заполненной формы

    [ Top ]

    Forms::DelFillValues

DelFillValues(
int
$id );

    Принимаемые параметры

    $id

    идентификатор записи, содержащей значение поля отправленной формы

    Возвращает

    true в случае успешного удаления значения поля отправленной формы, false в противном случае

    Описание

    Метод удаления значения одного из полей отправленной формы

    [ Top ]

    Forms::DelForms

DelForms(
int
$id );

    Принимаемые параметры

    $id

    идентификатор формы, информацию о которой необходимо удалить

    Возвращает

    true в случае успешного удаления формы, false в противном случае

    Описание

    Метод удаления данных о форме

    [ Top ]

    Forms::DelFormsFields

DelFormsFields(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого поля формы

    Возвращает

    true в случае успешного удаления поля формы, false в противном случае

    Описание

    Метод удаления поля формы

    [ Top ]

    Forms::GetForm

GetForm(
int
$form_id, unknown_type
$xsl_forms, unknown_type
$xsl_email, [array
$param = array()], [array
$external_propertys = array()] );

    Принимаемые параметры

    $form_id

    идентификатор отправленной формы

    $xsl_forms

    XSL-шаблон, формирующий сообщение пользователю при отправке формы

    $xsl_email

    XSL-шаблон, формирующий текст письма куратору отправленной формы с данными, переданными в форме

    $param

    массив дополнительных параметров, имеет следующую структуру  $param['e-mail'] – e-mail отправителя письма  $param['subject'] - тема письма куратору формы  $param['type'] - тип письма (0- text/html, 1- text/plain).

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код

    Возвращает

    true в случае успешного отправления формы, false  в противном случае

    Описание

    Метод обработки содержимого отправленной формы

    [ Top ]

    Forms::GetFormFields

GetFormFields(
int
$form_id );

    Принимаемые параметры

    $form_id

    идентификатор формы

    Возвращает

    resorce в случае успешного выполнения, false в противном случае

    Описание

    Метод получения данных о полях формы

    [ Top ]

    Forms::InsertForms

InsertForms(
int
$type, int
$forms_id, string
$forms_name, string
$forms_description, string
$forms_email, int
$forms_button_type, string
$forms_button_name, string
$forms_button_value, string
$forms_button_text_value, [array
$param = array()] );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о форме( 0 – вставка, 1 обновление)

    $forms_id

    идентификатор обновляемой формы (при вставке равен 0)

    $forms_name

    имя формы

    $forms_description

    описание формы

    $forms_email

    e-mail куратора формы

    $forms_button_type

    тип кнопки для формы (0 – простая кнопка, 1кнопка типа button)

    $forms_button_name

    название кнопки (английское)

    $forms_button_value

    значение, передаваемое при нажатии кнопки

    $forms_button_text_value

    текст на кнопке

    $param

    массив дополнительных параметров  $param['forms_captcha_used'] параметр, определяющий использовать при отображении формы captcha (1 использовать, 0 не использовать)

    Возвращает

    идентификатор вставленной/обновленной формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления информации о форме

    [ Top ]

    Forms::InsertFormsFields

InsertFormsFields(
int
$type, int
$forms_fields_id, int
$forms_id, int
$lists_id, int
$forms_fields_type, string
$forms_fields_name, string
$forms_fields_text_name, string
$forms_fields_default_value, int
$forms_fields_order, int
$forms_fields_size, int
$forms_fields_rows, int
$forms_fields_cols, int
$forms_fields_checked, string
$forms_fields_comment, [int
$forms_fields_obligatory = 0] );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о поле формы (0 – вставка, 1 обновление)

    $forms_fields_id

    идентификатор обновляемого поля формы (при вставке равен 0)

    $forms_id

    идентификатор формы, к которой относится обновляемое/добавляемое поле

    $lists_id

    идентификатор списка, с которым связано поле (для полей типа «радиогруппа»,  «выпадающий список»)

    $forms_fields_type

    – тип поля формы (0 – текстовое поле, 1 – поле пароля, 2 – поле загрузки файла,    3 – радиокнопка, 4 – checkbox, 5 – большое текстовое поле, 6 – список, 7 – скрытое поле)

    $forms_fields_name

    английское название поля (тег “name”)

    $forms_fields_text_name

    поясняющий текст для поля формы

    $forms_fields_default_value

    значение по умолчанию

    $forms_fields_order

    порядоковый номер поля

    $forms_fields_size

    ширина поля формы (для текстового поля и поля пароля)

    $forms_fields_rows

    высота большого текстового поля

    $forms_fields_cols

    ширина большого текстового поля

    $forms_fields_checked

    параметр, определяющий отображать поле типа checkbox выбранным или нет (0 – не выбрано, 1 выбрано)

    $forms_fields_comment

    поясняющий комментарий к полю

    $forms_fields_obligatory

    параметр, определяющий является поле обязательным для заполнения (0 – необязательное (по умолчанию), 1 – обязательное)

    Возвращает

    идентификатор вставленной/обновленной записи с информацией о поле формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления информации о поле формы

    [ Top ]

    Forms::InsertFormsFill

InsertFormsFill(
int
$type, int
$forms_fill_id, int
$forms_id, int
$forms_fill_ip, string
$forms_fill_date );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации о заполнении формы

    $forms_fill_id

    идентификатор редактируемой записи с информацией о заполненной форме (при вставке равен 0)

    $forms_id

    идентификатор формы

    $forms_fill_ip

    ip-адрес компьютера пользователя, отправившего данные формы

    $forms_fill_date

    дата заполнения формы

    Возвращает

    идентификатор вставленной/обновленной записи с информацией о заполнении поле формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления информации о заполнении формы

    [ Top ]

    Forms::InsertFormsFillValues

InsertFormsFillValues(
int
$type, int
$forms_fill_values_id, int
$forms_fill_id, int
$forms_fields_id, string
$forms_fill_values_value );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление значений заполненной формы (0 - вставка, 1- обновление)

    $forms_fill_values_id

    идентификатор записи, хранящей данные одного из элементов формы

    $forms_fill_id

    идентификатор записи, хранящей данные о заполненной форме

    $forms_fields_id

    идентификатор элемента заполняемой формы

    $forms_fill_values_value

    значение элемента формы

    Возвращает

    идентификатор добавленной/отредактированной записи, хранящей данные о значении, переданном из формы в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки/обновления значений заполненной формы

    [ Top ]

    Forms::SelectForms

SelectForms(
int
$id );

    Принимаемые параметры

    $id

    идентификатор формы, данные о которой необходимо получить, если $id = -1, то получаем данные о всех формах

    Возвращает

    resource в случае успешного выполнения, false в потивном случае

    Описание

    Метод выбора данных о формах

    [ Top ]

    Forms::SelectFormsFields

SelectFormsFields(
int
$field_id );

    Принимаемые параметры

    $field_id

    идентификатор поля формы, данные о котором необходимо получить

    Возвращает

    resource в случае успешного выполнения, false в противном случае

    Описание

    Метод выбора данных о поле формы

    [ Top ]

    Forms::ShowForm

ShowForm(
int
$form_id, string
$xsl_name, [array
$external_propertys = array()], [array
$param = array()] );

    Принимаемые параметры

    $form_id

    идентификатор формы

    $xsl_name

    название XSL-шаблона

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код

    $param

    массив дополнительных параметров  $param['forms_fields_name'] название поля формы

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод отображения формы

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:15 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Forums

Class Forums

[line 11]

Размещен: /Forums/Forums.class.php

Описание

Класс модуля "Форумы"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • int:
     AddEditMessage()

    Метод добавления/редактирования сообщения темы

  • int:
     AddEditTheme()

    Метод осуществляет добавление/редактирование темы

  • string BBcode2HTML()

    Метод замены BBcode на HTML

  • boolean CloseForum()

    Метод, закрывающий/открывающий форум

  • boolean CloseTheme()

    Метод, открыввающий/закрывающий тему для доступа

  • boolean DeleteForum()

    Метод удаления форума

  • boolean DelForumsGroup()

    Метод удаления группы форумов

  • boolean DelMessage()

    Метод удаления сообщения темы

  • boolean DelTheme()

    Метод удаления темы форума

  • boolean GenAddEditThemeXML()

    Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

  • boolean GenEditMessageXML()

    Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

  • boolean GenForumsXML()

    Метод, формирующий XML для таблицы групп форумов (форумов) и выводящий его на экран в соответствии с указанным xsl шаблоном

  • boolean GenMessageXML()

    Метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном

  • string GenSmilesXML()

    Метод возвращает XML для смайликов

  • boolean GenThemesXML()

    Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном

  • boolean GenUserInfoXML()

    Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном

  • array GetForumAccess()

    Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму

  • boolean IncCountMessage()

    Метод наращивания счётчика количества сообщений для пользователя

  • array IndexationForums()

    Метод индексации форумов

  • array IndexationForumsMessages()

    Метод индексации сообщений тем форумов

  • boolean InsertForum()

    Метод добавления/редактирования форума

  • boolean InsertForumsGroup()

    Метод добавления/редактирования группы форумов

  • boolean InsertUsersGroup()

    Метод добавления/редактирования группы пользователей для определения доступа к форуму

  • boolean NoticeTheme()

    Метод делающий тему объявлением или наоборот

  • boolean OrderForums()

    Метод изменения порядка сортировки форумов в группе

  • boolean OrderForumsGroup()

    Метод изменения порядка сортировки групп форумов

  • mixed:
     SelectForum()

    Метод, возвращающий информацию о форуме

  • mixed:
     SelectForumsGroup()

    Метод, возвращающий информацию о группе форумов

  • mixed:
     SelectMessage()

    Метод возвращающий информацию о сообщении

  • mixed:
     SelectTheme()

    Метод, возвращающий информацию о теме

  • boolean SetModerator()

    Метод установления/снятия прав модератора текущего форума для группы пользователей

  • string Smile2HTML()

    Метод замены смайликов на HTML

  • boolean VisibleTheme()

    Метод, устанавливающий видимость/невидимость темы

Унаследованные методы

Описания методов

    Forums::AddEditMessage

AddEditMessage(
int
$forums_id, int
$forums_theme_id, string
$forums_theme_title, string
$forums_message_text, int
$site_users_id, int
$current_time, int
$forums_message_id, [array
$param = array()] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $forums_theme_title

    тема сообщения

    $forums_message_text

    текст сообщения

    $site_users_id

    идентификатор пользователя

    $current_time

    текущее время в Unix формате

    $forums_message_id

    идентификатор сообщения

    $param

    массив дополнительных параметров:
      $param['xslname'] string имя xsl шаблона письма куратору форума

    Возвращает

    -2 - неверное значение CAPTCHA,
      -1 - сработала защита от флуда,

    1. - ошибка выполнения запроса,
    2. - операция выполнена успешно

    Описание

    Метод добавления/редактирования сообщения темы

    [ Top ]

    Forums::AddEditTheme

AddEditTheme(
int
$forums_id, int
$theme_id, string
$theme_title, int
$theme_close, int
$theme_notice, int
$theme_visible, string
$first_message, int
$site_users_id, int
$current_time, [array
$param = array()] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $theme_title

    заголовок темы

    $theme_close

    флаг открытости (0 - закрыта, 1 - открыта)

    $theme_notice

    флаг объявления (1 - объявление)

    $theme_visible

    флаг видимости (0 - невидима, 1 - видима)

    $first_message

    текст первого сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_time

    текущее время в Unix формате

    $param

    массив дополнительных параметров:
      $param['xslname'] string имя xsl шаблона письма куратору форума

    Возвращает

    -2 - сработала защита от флуда,
      -1 - неверное значение CAPTCHA,

    1. - ошибка выполнения запроса,
    2. - операция выполнена успешно

    Описание

    Метод осуществляет добавление/редактирование темы

    [ Top ]

    Forums::BBcode2HTML

BBcode2HTML(
string
$text );

    Принимаемые параметры

    $text

    исходный текст

    Возвращает

    текст после замены

    Описание

    Метод замены BBcode на HTML

    [ Top ]

    Forums::CloseForum

CloseForum(
int
$forums_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    Описание

    Метод, закрывающий/открывающий форум

    [ Top ]

    Forums::CloseTheme

CloseTheme(
int
$forums_id, int
$forums_theme_id, int
$site_users_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод, открыввающий/закрывающий тему для доступа

    [ Top ]

    Forums::DeleteForum

DeleteForum(
int
$forums_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    Описание

    Метод удаления форума

    [ Top ]

    Forums::DelForumsGroup

DelForumsGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы форумов

    Описание

    Метод удаления группы форумов

    [ Top ]

    Forums::DelMessage

DelMessage(
int
$forums_id, int
$forums_theme_id, int
$forums_message_id, int
$site_users_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы форума

    $forums_message_id

    идентификатор сообщения темы

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод удаления сообщения темы

    [ Top ]

    Forums::DelTheme

DelTheme(
int
$forums_id, int
$forums_theme_id, int
$site_users_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод удаления темы форума

    [ Top ]

    Forums::GenAddEditThemeXML

GenAddEditThemeXML(
int
$forums_id, int
$theme_id, int
$site_users_id, int
$current_page, stringe
$xslname, [string
$error = ''], [array
$param = array()] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page

    индекс текущей страницы

    $xslname

    имя xsl шаблона

    $error

    текст сообщения об ошибке

    $param

    массив параметров темы:
      $param['theme_close'] int флаг закрытости темы;
      $param['theme_notice'] int флаг объявления;
      $param['theme_visible'] int флаг видимости;
      $param['theme_title'] string заголовок темы;
      $param['theme_message_text'] string текст первого сообщения

    Описание

    Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenEditMessageXML

GenEditMessageXML(
int
$forums_id, int
$forums_theme_id, int
$forums_message_id, int
$site_users_id, int
$current_page_theme, int
$current_page_message, string
$xslname, [mixed
$error = ''], [array
$param = array()], string
$error='' );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $forums_message_id

    идентификатор сообщения

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $xslname

    имя xsl шаблона

    $error=''

    текст сообщения об ошибке

    $param

    массив параметров сообщения:
      $param['message_theme'] string тема собщения;
      $param['message_текст'] string текст сообщения

    Описание

    Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenForumsXML

GenForumsXML(
int
$site_users_id, string
$xslname, [mixed
$error = ''], string
$error='' );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $xslname

    имя xsl шаблона

    $error=''

    текст ошибки доступа

    Описание

    Метод, формирующий XML для таблицы групп форумов (форумов) и выводящий его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenMessageXML

GenMessageXML(
int
$forums_id, int
$forums_theme_id, int
$site_users_id, int
$current_page_theme, int
$current_page_message, int
$items_on_page, string
$xslname, [string
$error = ''], [array
$param = array()] );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page_theme

    индекс текущей страницы тем

    $current_page_message

    индекс текущей страницы сообщений

    $items_on_page

    количество элементов на странице

    $xslname

    имя xsl шаблона

    $error

    текст сообщения об ошибке

    $param

    массив дополнительных параметров

    Описание

    Метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenSmilesXML

GenSmilesXML(
 );

    Возвращает

    XML

    Описание

    Метод возвращает XML для смайликов

    [ Top ]

    Forums::GenThemesXML

GenThemesXML(
int
$forums_id, int
$site_users_id, int
$current_page, int
$items_on_page, string
$xslname, [mixed
$error = ''], string
$error='' );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_id

    идентификатор пользователя сайта

    $current_page

    индекс текущей страницы

    $items_on_page

    количество записей на странице

    $xslname

    имя xsl шаблона

    $error=''

    текст сообщения об ошибке

    Описание

    Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GenUserInfoXML

GenUserInfoXML(
int
$forums_id, int
$theme_id, int
$site_users_id, string
$xslname, [mixed
$current_page_theme = 0], [mixed
$current_page_message = 0], [mixed
$error = ''], int
$current_page_theme=0, int
$current_page_message=0, string
$error='' );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    $xslname

    имя xsl шаблона

    $current_page_theme=0

    индекс текущей страницы тем

    $current_page_message=0

    индекс текущей страницы сообщений

    $error=''

    текст сообщения об ошибке

    Описание

    Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном

    [ Top ]

    Forums::GetForumAccess

GetForumAccess(
int
$forums_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    Возвращает

    массив идентификаторов групп пользователей сайта

    Описание

    Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму

    [ Top ]

    Forums::IncCountMessage

IncCountMessage(
int
$site_users_id );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод наращивания счётчика количества сообщений для пользователя

    [ Top ]

    Forums::IndexationForums

IndexationForums(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Принимаемые параметры

    $limit

    сколько записей проиндексировано

    $on_step

    сколько индексировать

    $parameters

    массив дополнительных параметров

    Возвращает

    массив данных для индексации:
      $result[$i][0] string название страницы;
      $result[$i][1] string адрес страницы;
      $result[$i][2] string текст страницы;
      $result[$i][3] float размер страницы;
      $result[$i][4] int идентификатор сайта (0 - для всех сайтов);
      $result[$i][5] array массив идентификаторов групп пользователей (0 - для всех)  $result[$i][6] string дата создания страницы

    Описание

    Метод индексации форумов

    [ Top ]

    Forums::IndexationForumsMessages

IndexationForumsMessages(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Принимаемые параметры

    $limit

    сколько записей проиндексировано

    $on_step

    сколько индексировать

    $parameters

    массив дополнительных параметров

    Возвращает

    массив данных для индексации:
      $result[$i][0] string название страницы;
      $result[$i][1] string адрес страницы;
      $result[$i][2] string текст страницы;
      $result[$i][3] float размер страницы;
      $result[$i][4] int идентификатор сайта (0 - для всех сайтов);
      $result[$i][5] array массив идентификаторов групп пользователей (0 - для всех)  $result[$i][6] string дата создания страницы

    Описание

    Метод индексации сообщений тем форумов

    [ Top ]

    Forums::InsertForum

InsertForum(
int
$forums_group_id, int
$forums_id, string
$forums_name, string
$forums_comment, [array
$param = array()] );

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $forums_id

    идентификатор форума

    $forums_name

    название форума

    $forums_comment

    описание форума

    $param

    массив дополнительных параметров:
      $param['forums_curator_email'] string E-mail куратора форума;
      $param['forums_postmoderation'] int использовать ли постмодерацию (0 - нет, 1 - да);
      $param['visible4all'] int отображать ли содержимое форума всем посетителям (0 - нет, 1 - да);
      $param['forums_captcha_used'] int использовать ли CAPTCHA (0 - нет, 1 - да)

    Описание

    Метод добавления/редактирования форума

    [ Top ]

    Forums::InsertForumsGroup

InsertForumsGroup(
int
$forums_group_id, string
$forums_group_name, string
$forums_group_comment );

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $forums_group_name

    название группы форумов

    $forums_group_comment

    коментарий к группе форумов

    Описание

    Метод добавления/редактирования группы форумов

    [ Top ]

    Forums::InsertUsersGroup

InsertUsersGroup(
int
$forums_id, int
$site_users_group_id, int
$moderator );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $site_users_group_id

    идентификатор группы пользователей

    $moderator

    является ли эта группа модераторами (0 - нет, 1 - да)

    Описание

    Метод добавления/редактирования группы пользователей для определения доступа к форуму

    [ Top ]

    Forums::NoticeTheme

NoticeTheme(
int
$forums_id, int
$forums_theme_id, int
$site_users_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    Описание

    Метод делающий тему объявлением или наоборот

    [ Top ]

    Forums::OrderForums

OrderForums(
int
$forums_group_id, array
$mas_orders );

    Принимаемые параметры

    $forums_group_id

    идентификатор группы форумов

    $mas_orders

    массив коэффициентов вида $mas_orders['order<идентификатор форума>']

    Описание

    Метод изменения порядка сортировки форумов в группе

    [ Top ]

    Forums::OrderForumsGroup

OrderForumsGroup(
array
$mas_orders );

    Принимаемые параметры

    $mas_orders

    массив коэффициентов вида $mas_orders['order<идентификатор группы форумов>']

    Описание

    Метод изменения порядка сортировки групп форумов

    [ Top ]

    Forums::SelectForum

SelectForum(
int
$id );

    Принимаемые параметры

    $id

    идентификатор форума (-1 выбрать все)

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Метод, возвращающий информацию о форуме

    [ Top ]

    Forums::SelectForumsGroup

SelectForumsGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы форумов (-1 выбрать все)

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Метод, возвращающий информацию о группе форумов

    [ Top ]

    Forums::SelectMessage

SelectMessage(
int
$id );

    Принимаемые параметры

    $id

    идентификатор сообщения

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Метод возвращающий информацию о сообщении

    [ Top ]

    Forums::SelectTheme

SelectTheme(
int
$id );

    Принимаемые параметры

    $id

    идентификатор темы

    Возвращает

    resource при успешном выполнении операции,
      boolean false в противном случае

    Описание

    Метод, возвращающий информацию о теме

    [ Top ]

    Forums::SetModerator

SetModerator(
int
$forums_users_group_list_id );

    Принимаемые параметры

    $forums_users_group_list_id

    идентификатор в таблице связи форумов и групп пользователей

    Описание

    Метод установления/снятия прав модератора текущего форума для группы пользователей

    [ Top ]

    Forums::Smile2HTML

Smile2HTML(
string
$text );

    Принимаемые параметры

    $text

    исходный текст

    Возвращает

    текст после замены

    Описание

    Метод замены смайликов на HTML

    [ Top ]

    Forums::VisibleTheme

VisibleTheme(
int
$forums_id, int
$forums_theme_id, int
$site_users_id );

    Принимаемые параметры

    $forums_id

    идентификатор форума

    $forums_theme_id

    идентификатор темы

    $site_users_id

    идентификатор пользователя сайта

    Описание

    Метод, устанавливающий видимость/невидимость темы

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:16 +0400 by phpDocumentor 1.3.0RC3


Docs For Class graphic

Class graphic

[line 2]

Размещен: /Counter/Graphic.class.php

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void Diagramm()

    Метод рисования круговой диаграммы

  • void graphic_diagramma()

    Метод вывода круговой диаграммы

  • boolean graphic_gistogramma()

    Метод вывода гистограммы

  • void imagebar()

    Метод вывода гистограммы

  • string win2uni()

    Метод перекодировки из win в unicode

Унаследованные методы

Описания методов

    graphic::Diagramm

Diagramm(
int
$im, array
$VALUES, array
$LEGEND, array
$COLORS, array
$SHADOWS );

    Принимаемые параметры

    $im

    идентификатор изображения

    $VALUES

    массив со значениями

    $LEGEND

    массив с подписями

    $COLORS

    массив цветов для диаграммы

    $SHADOWS

    массив цветов теней

    Описание

    Метод рисования круговой диаграммы

    [ Top ]

    graphic::graphic_diagramma

graphic_diagramma(
array
$VALUES, array
$LEGEND, int
$width );

    Принимаемые параметры

    $VALUES

    значения (массив со значениями)

    $LEGEND

    подписи (значения легенды, массив строк)

    $width

    - ширина изображения в пикселях

    Описание

    Метод вывода круговой диаграммы

    [ Top ]

    graphic::graphic_gistogramma

graphic_gistogramma(
int_type
$width, int
$height, array
$DATA, [array
$LEGEND = array('Хиты','Сессии','Хосты')] );

    Принимаемые параметры

    $width

    ширина гистограммы в пикселях

    $height

    высота гистограммы в пикселях

    $DATA

    массив со значенями для гистограммы

    $LEGEND

    массив подписей для легенды

    Возвращает

    истина при удачном выводе, ложь - в случае возникновения ошибки

    Описание

    Метод вывода гистограммы

    [ Top ]

    graphic::imagebar

imagebar(
int
$im, int
$x, int
$y, int
$w, int
$h, int
$dx, int
$dy, string
$c1, string
$c2, string
$c3 );

    Принимаемые параметры

    $im

    идентификатор изображения

    $x

    координата x верхнего левого угла куба

    $y

    координата y верхнего левого угла куба

    $w

    ширина куба

    $h

    высота куба

    $dx

    смещение задней грани куба по оси X

    $dy

    смещение задней грани куба по оси Y

    $c1

    цвет видимой граней куба

    $c2

    цвет видимой граней куба

    $c3

    цвет видимой граней куба

    Описание

    Метод вывода гистограммы

    [ Top ]

    graphic::win2uni

win2uni(
string
$winline );

    Принимаемые параметры

    $winline

    строка в win

    Возвращает

    перекодированная строка

    Описание

    Метод перекодировки из win в unicode

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:17 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Image

Class Image

[line 11]

Размещен: /Kernel/Image.class.php

Описание

Ядро, класс для работы с графическими изображениями

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • array GetImageSize()

    Метод определяет высоту и ширину изображения

  • boolean resizeToFile()

    Метод изменения размера изображения

Унаследованные методы

Описания методов

    Image::GetImageSize

GetImageSize(
string
$path );

    Принимаемые параметры

    $path

    полный путь к изображению

    Возвращает

    ассоциативный массив, содержащий высоту и ширину изображения
    array['width'] - ширина
    array['['height'] - высота  или false, если файл не существует

    Описание

    Метод определяет высоту и ширину изображения

    [ Top ]

    Image::resizeToFile

resizeToFile(
string
$sourcefile, int
$maxsize, string
$targetfile, int
$jpegqual );

    Принимаемые параметры

    $sourcefile

    путь к исходному файлу

    $maxsize

    максимальный размер в одном из измерений

    $targetfile

    путь для размещения преобразованного файла

    $jpegqual

    качество JPG

    Описание

    Метод изменения размера изображения

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:17 +0400 by phpDocumentor 1.3.0RC3


Docs For Class InformationSystem

Class InformationSystem

[line 20]

Размещен: /InformationSystems/InformationSystems.class.php

Описание

Класс модуля "Информационные системы"

Свойства класса

  • $a_count_property = array()

        Кэш количества свойств

  • $cache_InformationSystem = array()

        Кэш данных о информационной системе  пример $this->cache_InformationSystem[$id]

  • $CommentMass = array()

        Кэш с данными о комментариях

  • $GroupMass = array()

        Кэш с данными о группах

  • $ItemMass = array()

        Кэш с данными об элементах

  • $MasGroup = array()

        Массив групп

  • $PropertyGroupMass = array()

        Кэш с данными о дополнительных свойствах информационных групп

  • $PropertyMass = array()

        Кэш с данными о свойствах инфоррмационных элементов

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • int confirm_information_item()

    Метод определения возможности пользователя добавлять информационный элемент

  • void CopyInformationItem()

    Метод копирования элемента информационной системы

  • string CreateGroupsXmlTree()

    Метод формирования XML дерева для информационных групп

  • boolean DelInformationGroupPropertys()

    Метод удаления дополнительного свойства информационной группы

  • boolean DelInformationGroupPropertysValue()

    Метод удаления значений дополнительных свойств информационной группы

  • resource DelInformationSystem()

    Метод удаления информационной системы

  • boolean del_comment()

    Метод удаления комментария к информационному элементу

  • boolean del_information_groups()

    Метод удаления информационных групп

  • boolean del_information_items()

    Метод удаления элемента информационной системы

  • boolean del_information_propertys()

    Метод удаления дополнительного свойства информационной системы

  • void FillMasGroup()

    Метод формирования массива групп самого верхнего уровня для данной информационной системы.

  • string GenGroupXmlTree()

    Метод формирования  полного XML дерева информационных групп для информационной системы

  • boolean GetAccessItem()

    Метод определения доступности информационного элемента

  • mixed GetCommentInformationSystemItem()

    Метод получения комментариев информационных элементов

  • int GetCountInformationSystemItem()

    Метод получения количества элементов информационной системы

  • int GetCountProperty4InformationSystem()

    Метод получения числа свойств информационной системы

  • string GetExpansion()

    Метод получения расширения файла

  • $result GetExternalInformationSystemItem()

    Метод получения элементов информационной системы. Переименован с GetInformationSystemItem

  • array GetGroupsInformationSystem()

    Метод формирования дерева групп информационной группы

  • int GetIdInformationItem()

    Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы

  • mixed GetInformationFromPath()

    Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI

  • mixed GetInformationGroupName()

    Метод получения имени информационной группы

  • mixed GetInformationSystem()

    Метод получения данных об информационной системе

  • mixed GetInformationSystemItem()

    Метод для получения данных об информационном элементе

  • mixed GetInformationSystemItems()

    Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит

  • string GetPathGroup()

    Метод формирования пути по информационным группам

  • string GetPathItem()

    Метод формирования пути к данному информационному элементу

  • int GetPropertyCountRow()

    Метод получения числа записей в выборке инфосистем, групп или информационных элементов

  • $this->error GetPropertyError()

    Метод возвращающий код ошибки, возникающей при работе с методами класса

  • void GetPropertyMasInformationGroups()

  • int GetPropertyRecordOnPage()

    Метод получения числа записей, выводимых на страницу

  • string GetPropertyRss()

    Метод получения значения свойства RSS

  • string GetPropertySectionPath()

    Метод получения значения свойтва, содержащего пути по группам

  • array GetPropertysGroup()

    Метод получения данных о дополнительных свойствах информационной группы

  • mixed GetPropertysInformationSystemItem()

    Метод получения свойств информационных элементов

  • string GetXmlForInformatioItem()

    Метод формирования XML для отображения информационного элемента

  • void get_information_groups_path()

    Метод формирования пути по дереву информационных групп.

  • $this->mas_information_groups_for_xml get_mas_information_groups_for_xml()

    Метод возвращает XML для информационных групп

  • boolean InformationSystemGroupAccess()

    Метод определения доступности информационной группы для пользователей сайта

  • boolean InformationSystemItemAccess()

    Метод определения доступности информационного элемента для пользователя

  • int InsertInformationGroups()

    Метод вставки/обновления данных об информационной группе

  • int InsertInformationItems()

    Метод вставки/обновления данных об информационном элементе

  • int InsertInformationPropertys()

    Метод вставки/обновления информации о свойстве информационной системы

  • int InsertInformationPropertysGroups()

    Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы

  • int InsertInformationPropertysGroupsValue()

    Метод вставки/обновления значения свойства информационной группы

  • int InsertInformationPropertysItems()

    Метод вставки/обновления значения свойства информационной

  • int InsertInfotmationSystem()

    Метод вставки/обновления данных об информационной системе

  • int insert_comment()

    Метод вставки/обновления комментария для элемента информационной системы

  • int insert_comment_without_striptags()

    Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах

  • boolean IssetGroup()

    Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе

  • boolean IssetGroupItemInsertUpdate()

    Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента

  • boolean IssetItem()

    Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы

  • boolean IssetItemGroupInsertUpdate()

    Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы

  • resource SelectInformationGroupPropertys()

    Метод получения данных о свойствах группы информационной системы

  • resource SelectInformationGroups()

    Метод получения информации об информационных группах конкретной информационной системы

  • $result SelectInformationSystem()

    Метод получения информации об информационной системе

  • resource SelectListInformationGroupPropertys()

    Метод получения списка дополнительных свойств информационноq группы данной инфосистемы

  • resource select_comments()

    Метод получения комментариев к информационному элементу

  • resource select_information_items()

    Метод получения данных об информационном элементе

  • resource select_information_propertys()

    Метод получения данных о свойствах информационной системы

  • boollean ShowAddComment()

    Метод добавления комментария к элементу информационной системы

  • array ShowInformationSystem()

    Метод отображения групп и элементов информационной системы

  • boolean ShowInformationSystemItem()

    Метод отображения информацию об информационном элементе

  • void ShowInformationSystemRss()

    Метод отображения RSS ленты

  • boolean UserCanAddComment()

    Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY

Унаследованные методы

Описания методов

    InformationSystem::confirm_information_item

confirm_information_item(
string
$date, string
$information_item_ip );

    Принимаемые параметры

    $date

    дата и время (в Unix-формате) добавления информационного элемента

    $information_item_ip

    ip-адрес компьютера пользователя, добавляющего информационный элемент

    Возвращает

    0 – пользователь не может добавлять информационный элемент, 1- может добавлять информационный элемент

    Описание

    Метод определения возможности пользователя добавлять информационный элемент

    [ Top ]

    InformationSystem::CopyInformationItem

CopyInformationItem(
int
$information_item_id );

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента, который необходимо скопировать

    Описание

    Метод копирования элемента информационной системы

    [ Top ]

    InformationSystem::CreateGroupsXmlTree

CreateGroupsXmlTree(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$xmlData, int
$items_on_page, int
$items_begin );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор информационной группы, подгруппы которой будут включены для построения XML дерева

    $InformationSystem_id

    идентификатор информационной системы, для групп которой будет строиться XML дерево

    $xmlData

    XML с данными об информационной системе

    $items_on_page

    параметр, указывающий сколько элементов информационной системы будет отображаться на странице

    $items_begin

    параметр, указывающий с какого информационного элемента отображать элементы

    Возвращает

    XML дерево с данными об информационной системе и ее группах

    Описание

    Метод формирования XML дерева для информационных групп

    [ Top ]

    InformationSystem::DelInformationGroupPropertys

DelInformationGroupPropertys(
int
$property_id, [$group_id
$group_id = false] );

    Принимаемые параметры

    $property_id

    идентификатор дополнительного свойства информационной группы

    $group_id

    идентификатор группы

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления дополнительного свойства информационной группы

    [ Top ]

    InformationSystem::DelInformationGroupPropertysValue

DelInformationGroupPropertysValue(
int
$property_id, int
$group_id );

    Принимаемые параметры

    $property_id

    идентификатор значения дополнительного свойства информационной группы

    $group_id

    идентификатор информационной группы

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления значений дополнительных свойств информационной группы

    [ Top ]

    InformationSystem::DelInformationSystem

DelInformationSystem(
int
$id );

    Принимаемые параметры

    $id

    идентификатор информационной системы

    Описание

    Метод удаления информационной системы

    [ Top ]

    InformationSystem::del_comment

del_comment(
int
$id );

    Принимаемые параметры

    $id

    идентификатор комментария

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления комментария к информационному элементу

    [ Top ]

    InformationSystem::del_information_groups

del_information_groups(
int
$id, int
$InformationSystem_id );

    Принимаемые параметры

    $id

    идентификатор удаляемой информационной группы

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит информационная группа

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления информационных групп

    [ Top ]

    InformationSystem::del_information_items

del_information_items(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого информационного элемента

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления элемента информационной системы

    [ Top ]

    InformationSystem::del_information_propertys

del_information_propertys(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого свойства информационной системы

    Возвращает

    true - в случае успешного удаления, false - при возникновении ошибки

    Описание

    Метод удаления дополнительного свойства информационной системы

    [ Top ]

    InformationSystem::FillMasGroup

FillMasGroup(
[int
$InformationSystem_id = false] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы, для которой заполняем массив групп самого верхнего уровня

    Описание

    Метод формирования массива групп самого верхнего уровня для данной информационной системы.

    [ Top ]

    InformationSystem::GenGroupXmlTree

GenGroupXmlTree(
int
$information_system_id, [array
$property = array()] );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    $property

    массив дополнительных параметров  $property['groups_parent_id'] идентификатор группы, начиная с которой необходимо строить дерево

    Возвращает

    XML дерево групп информационной системы

    Описание

    Метод формирования  полного XML дерева информационных групп для информационной системы

    [ Top ]

    InformationSystem::GetAccessItem

GetAccessItem(
int
$user_id, int
$row_item, int
$parent );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $row_item

    идентификатор инфоэлемента

    $parent

    параметр, определяющий наследует ли информационный элемент тип доступа от родителя (1 - наследует, 0 - не наследует)

    Возвращает

    true - информационный элемент доступен пользователю, false - не доступен пользователя

    Описание

    Метод определения доступности информационного элемента

    [ Top ]

    InformationSystem::GetCommentInformationSystemItem

GetCommentInformationSystemItem(
int
$items_id );

    Принимаемые параметры

    $items_id

    идентификатор информационного элемента

    Возвращает

    массив со строками - комментариями, false в случае отсутствия комментариев к информационному элементу

    Описание

    Метод получения комментариев информационных элементов

    [ Top ]

    InformationSystem::GetCountInformationSystemItem

GetCountInformationSystemItem(
[mixed
$information_system_id = false], [mixed
$information_group_id = false] );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы, по умолчанию - false

    $information_group_id

    идентификатор группы информационной системы, по умолчанию - false

    Возвращает

    количество элементов информационной системы

    Описание

    Метод получения количества элементов информационной системы

    [ Top ]

    InformationSystem::GetCountProperty4InformationSystem

GetCountProperty4InformationSystem(
int
$information_system_id );

    Принимаемые параметры

    $information_system_id

    идентификатор информационной системы

    Возвращает

    число свойств информационной системы

    Описание

    Метод получения числа свойств информационной системы

    [ Top ]

    InformationSystem::GetExpansion

GetExpansion(
string
$fname );

    Принимаемые параметры

    $fname

    имя файла (путь к файлу)

    Возвращает

    расширение файла

    Описание

    Метод получения расширения файла

    [ Top ]

    InformationSystem::GetExternalInformationSystemItem

GetExternalInformationSystemItem(
[array
$select = array()] );

    Принимаемые параметры

    $select

    array('information_items_name'=>$result['items'][$i]['title'],    'information_blocks_id'=>$infsys_id)

    Описание

    Метод получения элементов информационной системы. Переименован с GetInformationSystemItem

    [ Top ]

    InformationSystem::GetGroupsInformationSystem

GetGroupsInformationSystem(
int
$information_groups_parent_id, int
$InformationSystem_id, [string
$separator = ''], [int
$information_grops_id = false] );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор группы, относительно которой строится дерево групп

    $InformationSystem_id

    идентификатор информационной системы, для которой строится дерево групп

    $separator

    символ, отделяющий группу нижнего уровня от родительской группы

    $information_grops_id

    идентификатор группы, которую вместе с ее подгруппами не нужно включать в дерево групп, если id = false, то включать в дерево групп все подгруппы.

    Возвращает

    двумерный массив, содержащий дерево подгрупп

    Описание

    Метод формирования дерева групп информационной группы

    [ Top ]

    InformationSystem::GetIdInformationItem

GetIdInformationItem(
string
$information_item_url, int
$information_group_id, [int
$information_system_id = 0] );

    Принимаемые параметры

    $information_item_url

    URL информационного элемента

    $information_group_id

    идентификатор информационной группы

    $information_system_id

    идентификатор информационной системы, к которой принадлежит информационный элемент, идентификатор которого надо определить

    Возвращает

    идентификатор информационного элемента

    Описание

    Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы

    [ Top ]

    InformationSystem::GetInformationFromPath

GetInformationFromPath(
int
$InformationSystem_id, [array
$param1 = ''] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит данный информационный элемент

    $param1

    массив, содержащий все элементы URL

    Возвращает

    ассоциативный массив, содержащий идентификатор информационной группы и идентификатор информационного элемента в случае успешного выполнения, false в противном случае

    Описание

    Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI

    [ Top ]

    InformationSystem::GetInformationGroupName

GetInformationGroupName(
int
$information_groups_id );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, имя которой необходимо получить

    Возвращает

    название группы информационной системы. Если группы с таким идентификатором нет, то возвращает false

    Описание

    Метод получения имени информационной группы

    [ Top ]

    InformationSystem::GetInformationSystem

GetInformationSystem(
int
$InformationSystem_id, [boolean
$use_cache = true] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы

    $use_cache

    параметр, определяющий использовать кэш или нет (по умолчанию истина)

    Возвращает

    ассоциативный массив с данными об информационной системе или false, если информационная система не найдена

    Описание

    Метод получения данных об информационной системе

    [ Top ]

    InformationSystem::GetInformationSystemItem

GetInformationSystemItem(
int
$items_id );

    Принимаемые параметры

    $items_id

    идентификатор информационного элемента

    Возвращает

    ассоциативный массив с данными об информационном элементе или ложь, если элемент не найден

    Описание

    Метод для получения данных об информационном элементе

    [ Top ]

    InformationSystem::GetInformationSystemItems

GetInformationSystemItems(
int
$information_item_id );

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента

    Возвращает

    ассоциативный массив с именами информационного элемента, информационной группы и системы, к которым он принадлежит, false - в том случае если данный элемент отсутствует

    Описание

    Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит

    [ Top ]

    InformationSystem::GetPathGroup

GetPathGroup(
int
$information_groups_id, string
$path );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, для которой надо сформировать путь

    $path

    параметр, используемый при формировании пути по группам

    Возвращает

    путь по группам от корневой до данной

    Описание

    Метод формирования пути по информационным группам

    [ Top ]

    InformationSystem::GetPathItem

GetPathItem(
int
$information_items_id, string
$path, [array
$row = ''] );

    Принимаемые параметры

    $information_items_id

    идентификатор информационного элемента

    $path

    параметр для хранения пути к данному информационному элементу

    $row

    ассоциативный массив, содержащий информацию об информационном элементе

    Возвращает

    путь к информационному элементу

    Описание

    Метод формирования пути к данному информационному элементу

    [ Top ]

    InformationSystem::GetPropertyCountRow

GetPropertyCountRow(
 );

    Описание

    Метод получения числа записей в выборке инфосистем, групп или информационных элементов

    [ Top ]

    InformationSystem::GetPropertyError

GetPropertyError(
 );

    Описание

    Метод возвращающий код ошибки, возникающей при работе с методами класса

    [ Top ]

    InformationSystem::GetPropertyMasInformationGroups

GetPropertyMasInformationGroups(
 );

    [ Top ]

    InformationSystem::GetPropertyRecordOnPage

GetPropertyRecordOnPage(
 );

    Возвращает

    - число записей на странице

    Описание

    Метод получения числа записей, выводимых на страницу

    [ Top ]

    InformationSystem::GetPropertyRss

GetPropertyRss(
 );

    Описание

    Метод получения значения свойства RSS

    [ Top ]

    InformationSystem::GetPropertySectionPath

GetPropertySectionPath(
 );

    Описание

    Метод получения значения свойтва, содержащего пути по группам

    [ Top ]

    InformationSystem::GetPropertysGroup

GetPropertysGroup(
int
$group_id, int
$information_system_id );

    Принимаемые параметры

    $group_id

    идентификатор группы

    $information_system_id

    идентификатор информационной системы

    Возвращает

    массив с информацией о дополнительных свойствах

    Описание

    Метод получения данных о дополнительных свойствах информационной группы

    [ Top ]

    InformationSystem::GetPropertysInformationSystemItem

GetPropertysInformationSystemItem(
int
$items_id, int
$information_system_id );

    Принимаемые параметры

    $items_id

    идентификатор информационного элемента

    $information_system_id

    идентификатор информацтонной системы

    Возвращает

    массив с данными о свойствах информационного элемента или false - в случае отсутствия дополнительных свойств у элементов данной информационной системы

    Описание

    Метод получения свойств информационных элементов

    [ Top ]

    InformationSystem::GetXmlForInformatioItem

GetXmlForInformatioItem(
int
$information_item_id, [array
$property = array('is_get_information_for_property' => false,
    'show_text'=>true)] );

    Принимаемые параметры

    $information_item_id

    идентификатор информационного элемента, который необходимо отобразить

    $property

    массив дополнительных параметров  $property['is_get_information_for_property'] параметр, исключающий рекурсию, возникающую при вызове свойства типа информационная система для элемента, имеющего также свойство типа информационная система (эффект зазеркаливания), по умолчанию false  $property['show_text'] параметр, указывающий включать в XML текст информационного элемента или нет, по умолчанию равен true. Если этот параметр не указан, то текст элемента включается в XML  Замечание: перед вызовом необходимо заполнить массив групп для конкретной информационной системы, например $InformationSystem->FillMasGroup($information_system_id);

    Возвращает

    метод, формирующий XML для отображения информационного элемента

    Описание

    Метод формирования XML для отображения информационного элемента

    [ Top ]

    InformationSystem::get_information_groups_path

get_information_groups_path(
int
$information_groups_id, int
$InformationSystem_id );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, для которой необходимо построить путь

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит группа.

    Описание

    Метод формирования пути по дереву информационных групп.

    [ Top ]

    InformationSystem::get_mas_information_groups_for_xml

get_mas_information_groups_for_xml(
 );

    Описание

    Метод возвращает XML для информационных групп

    [ Top ]

    InformationSystem::InformationSystemGroupAccess

InformationSystemGroupAccess(
int
$user_id, int
$information_group_id );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $information_group_id

    идентификатор информационной группы

    Возвращает

    true - пользователю разрешен доступ к информационной группе, false - пользователю запрещен доступ к информационной группе

    Описание

    Метод определения доступности информационной группы для пользователей сайта

    [ Top ]

    InformationSystem::InformationSystemItemAccess

InformationSystemItemAccess(
int
$user_id, int
$information_item_id );

    Принимаемые параметры

    $user_id

    идентификатор пользователя

    $information_item_id

    идентификатор информационного элемента

    Возвращает

    true - элемент доступен, false - элемент недоступен

    Описание

    Метод определения доступности информационного элемента для пользователя

    [ Top ]

    InformationSystem::InsertInformationGroups

InsertInformationGroups(
int
$type, int
$information_groups_id, int
$InformationSystem_id, int
$information_groups_parent_id, string
$information_groups_name, string
$information_groups_description, int
$information_groups_order, string
$information_groups_path, string
$information_groups_image, [int
$information_groups_allow_indexation = 1], [string
$information_groups_seo_title = ''], [string
$information_groups_seo_description = ''], [string
$information_groups_seo_keywords = ''], [int
$information_groups_access = -1] );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление данных об информационной группе (0 – вставка, 1 - обновление)

    $information_groups_id

    идентификатор обновляемой информационной группы (при вставке равен 0)

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит группа

    $information_groups_parent_id

    идентификатор родительской группы данной информационной группы

    $information_groups_name

    название информационной группы

    $information_groups_description

    описание информационной группы

    $information_groups_order

    порядковый номер группы в родительской группе

    $information_groups_path

    элемент URL информационной системы для данной группы

    $information_groups_image

    имя файла с изображением для информационной группы

    $information_groups_allow_indexation

    параметр, определяющий индексировать данную информационную группу или нет (1- индексировать, 0 - неиндексировать)

    $information_groups_seo_title

    параметр, используемый для задания заголовка страницы

    $information_groups_seo_description

    параметр, используемый для задания значения мета-тега description страницы

    $information_groups_seo_keywords

    параметр, используемый для задания значения мета-тега keywords страницы

    $information_groups_access

    параметр, определяющий тип доступа для данной информационной группы (0 - доступна всем, -1 - доступ как у родителя, 6 - доступно пользователю, 7 - недоступно всем, 8 - доступно модераторам)

    Возвращает

    идентификатор вставленной/обновленной информационной группы

    Описание

    Метод вставки/обновления данных об информационной группе

    [ Top ]

    InformationSystem::InsertInformationItems

InsertInformationItems(
int
$type, int
$information_items_id, int
$InformationSystem_id, int
$information_groups_id, string
$information_items_date, string
$information_items_name, string
$information_items_description, int
$information_items_status, string
$information_items_text, string
$information_items_image, int
$information_items_order, string
$information_items_ip, [string
$information_items_url = ''], [int
$information_items_allow_indexation = 1], [string
$information_items_seo_title = ''], [string
$information_items_seo_description = ''], [string
$information_items_seo_keywords = ''], [int
$information_items_access = -1], [array
$param = array()] );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление данных об информационном элементе (0 – вставка, 1 обновление)

    $information_items_id

    идентификатор обновляемого информационного элемента (при вставке равен 0)

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит элемент

    $information_groups_id

    идентификатор информационной группы, к которой принадлежит элемент

    $information_items_date

    дата добавления/обновления информационного элемента;

    $information_items_name

    название информационного элемента

    $information_items_description

    описание информационного элемента

    $information_items_status

    параметр, определяющий активность информационного элемента (0 – неактивен, 1 -активен)

    $information_items_text

    текст информационного элемента

    $information_items_image

    название файла изображения для информационного элемента

    $information_items_order

    порядковый номер информационного элемента

    $information_items_ip

    ip-адрес компьтера, с которого был добавлен инфорнмационный элемент

    $information_items_url

    название информационного элемента в URL

    $information_items_allow_indexation

    параметр, определяющий индексировать информационный элемент или нет (0 неиндексировать, 1- индексировать)

    $information_items_seo_title

    параметр, определяющий заголовок страницы при отображении информационного элемента

    $information_items_seo_description

    параметр, определяющий значение мета-тега description страницы, на которой отображается содержимое информационного элемента

    $information_items_seo_keywords

    параметр, определяющий значение мета-тега keywords страницы, на которой отображается содержимое информационного элемента

    $information_items_access

    параметр, определяющий тип доступа для данного информационного элемента (0 доступна всем, -1 доступ как у родителя, 6 доступно пользователю, 7 недоступно всем, 8 доступно модераторам)

    $param

    массив дополнительных параметров  $param['putoff_date'] дата начала публикации, по умолчанию текущее значение даты  $param['putend_date'] дата окончания публикации, по умолчанию отсутствует

    Возвращает

    идентификатор вставленного/обновленного  элемента информационной системы

    Описание

    Метод вставки/обновления данных об информационном элементе

    [ Top ]

    InformationSystem::InsertInformationPropertys

InsertInformationPropertys(
int
$type, int
$information_propertys_id, int
$InformationSystem_id, string
$information_propertys_name, int
$information_propertys_type, int
$information_propertys_order, string
$information_propertys_define_value, string
$information_propertys_xml_name, int
$information_propertys_lists_id, int
$information_propertys_information_systems_id );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление данных о свойстве информационной системы (0 вставка, 1 обновление)

    $information_propertys_id

    идентификатор обновляемого свойства (при вставке равен 0);

    $InformationSystem_id

    идентификатор информационной системы, к которой принадлежит свойство

    $information_propertys_name

    название свойства информационной системы

    $information_propertys_type

    код типа свойства информационной системы (0 число, 1 строка, 2 файл, 3 список, 4 большое текстовое поле, 5 информационная система, 6 визуальный редактор)

    $information_propertys_order

    порядковый номер свойства информационной системы

    $information_propertys_define_value

    значение свойства информационной системы по умолчанию

    $information_propertys_xml_name

    имя XML тэга для данного свойства информационной системы

    $information_propertys_lists_id

    идентификатор списка, который указывается в качестве свойства информационной системы

    $information_propertys_information_systems_id

    идентификатор информационной системы, которая указывается в качестве свойства данной информационной системы

    Возвращает

    идентификатор вставленного/обновленного свойства информационной системы

    Описание

    Метод вставки/обновления информации о свойстве информационной системы

    [ Top ]

    InformationSystem::InsertInformationPropertysGroups

InsertInformationPropertysGroups(
int
$type, int
$information_propertys_groups_id, int
$InformationSystem_id, string
$information_propertys_groups_name, int
$information_propertys_groups_type, int
$information_propertys_groups_order, string
$information_propertys_groups_default_value, string
$information_propertys_groups_xml_name, int
$information_propertys_groups_lists_id );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление информации о дополнительном свойстве информационной группы (0 - вставка, 1 - обновление)

    $information_propertys_groups_id

    идентификатор дополнительного свойства информационной группы (при вставке равен 0)

    $InformationSystem_id

    идентификатор информационной системы

    $information_propertys_groups_name

    название дополнительного свойства информационной группы

    $information_propertys_groups_type

    тип дополнительного свойства информационной группы (0 - число, 1 - строка, 2- файл, 3 - список, 4 - большое текстовое поле, 5 - информационная система, 6 - визуальный редактор)

    $information_propertys_groups_order

    порядковый номер информационной группы

    $information_propertys_groups_default_value

    значение дополнительного свойства информационной группы по умолчанию

    $information_propertys_groups_xml_name

    название xml-тега, соответсвующего данному дополнительному свойству информационной группы

    $information_propertys_groups_lists_id

    идентификатор списка, который указывается в качестве дополнительного свойства информационной группы

    Возвращает

    идентификатор вставленного/обновленного дополнительного свойства информационной системы для элемента информационной группы

    Описание

    Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы

    [ Top ]

    InformationSystem::InsertInformationPropertysGroupsValue

InsertInformationPropertysGroupsValue(
int
$type, int
$information_propertys_groups_value_id, int
$information_groups_id, int
$information_propertys_groups_id, string
$information_propertys_groups_value_value );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление значения дополнительного свойства информационной группы (0 - вставка, 1 - обновление)

    $information_propertys_groups_value_id

    идентификатор дополнительного свойства информационной группы (при вставке равен 0)

    $information_groups_id

    идентификатор информационной группы

    $information_propertys_groups_id

    идентификатор дополнительного свойства группы

    $information_propertys_groups_value_value

    значение дополнительного свойства информационной группы

    Возвращает

    идентификатор добавленнного/обновленного значения дополнительного свойства информационной группы

    Описание

    Метод вставки/обновления значения свойства информационной группы

    [ Top ]

    InformationSystem::InsertInformationPropertysItems

InsertInformationPropertysItems(
int
$type, int
$information_propertys_items_id, int
$information_propertys_id, int
$information_items_id, string
$information_propertys_items_value );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление значения свойства информационной системы (0 - вставка, 1 - обновление)

    $information_propertys_items_id

    идентификатор значения свойства информационной системы для конкретного элемента информационной системы (при вставке равен 0)

    $information_propertys_id

    идентификатор свойства информационной системы

    $information_items_id

    идентификатор элемента информационной системы

    $information_propertys_items_value

    значение элемента информационной системы

    Возвращает

    идентификатор вставленного/обновленного значения свойства информационной системы для элемента информационной системы

    Описание

    Метод вставки/обновления значения свойства информационной

    [ Top ]

    InformationSystem::InsertInfotmationSystem

InsertInfotmationSystem(
mixed
$param, array
$param
 );

    Принимаемые параметры

    $param

    $param['type'] элемент, определяющий будет производиться вставка или обновление данных об информационной системе (0 – вставка, 1 - обновление);  $param['id'] идентификатор обновляемой информационной системы (при вставке равен 0)  $param['site_id'] идентификатор сайта, к которому принадлежит информационная система  $param['name'] название информационной системы  $param['description']  описание информационной системы  $param['url'] адрес страницы из структуры сайта  $param['items_order_field'] поле сортировки элементов данной информационной системы  $param['items_order_type'] направление сортировки элементов информационной системы  $param['big_image_max_size'] максимальный размер «большого» варианта изображения при уменьшении загружаемого изображения элемента информационной системы  $param['small_image_max_size'] максимальный размер «маленького» варианта изображения при уменьшении загружаемого изображения элемента информационной системы  $param['template_id'] идентификатор применяемого макета

    Возвращает

    идентификатор вставленной/обновленной информационной системы

    Описание

    Метод вставки/обновления данных об информационной системе

    [ Top ]

    InformationSystem::insert_comment

insert_comment(
int
$type, int
$comment_id, int
$information_items_id, string
$comment_fio, string
$comment_email, string
$comment_text, int
$comment_status, string
$comment_subject, string
$comment_ip, string
$comment_date );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление комментария информационного элемента (0 - вставка, 1 - обновление)

    $comment_id

    идентификатор обновляемого комментария (при вставке равен 0)

    $information_items_id

    идентификатор информационного элемента

    $comment_fio

    ФИО автора комментария

    $comment_email

    e-mail автора комментария

    $comment_text

    текст комментария

    $comment_status

    статус активности комментария (0 – не отображать, 1- отображать)

    $comment_subject

    тема комментария

    $comment_ip

    ip-адрес отправителя комментария

    $comment_date

    дата отправки комментария

    Возвращает

    идентификатор вставленного/обновленного комментария для элемента информационной системы

    Описание

    Метод вставки/обновления комментария для элемента информационной системы

    [ Top ]

    InformationSystem::insert_comment_without_striptags

insert_comment_without_striptags(
int
$type, int
$comment_id, int
$information_items_id, string
$comment_fio, string
$comment_email, string
$comment_text, string
$comment_status, string
$comment_subject, string
$comment_ip, string
$comment_date );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление комментария информационного элемента (0 - вставка, 1 - обновление)

    $comment_id

    идентификатор обновляемого комментария (при вставке равен 0)

    $information_items_id

    идентитфикатор информационного элемента

    $comment_fio

    ФИО автора комментария

    $comment_email

    e-mail автора комментария

    $comment_text

    текст комментария

    $comment_status

    параметр, определяющий статус активности комментария (0 – не отображать, 1- отображать)

    $comment_subject

    тема комментария

    $comment_ip

    ip-адрес отправителя комментария

    $comment_date

    дата отправки комментария

    Возвращает

    идентификатор вставленного/обновленного комментария для элемента информационной системы

    Описание

    Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах

    [ Top ]

    InformationSystem::IssetGroup

IssetGroup(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$information_groups_path, [int
$edit_mode = 0], [int
$information_groups_id = 0] );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор родительской группы

    $InformationSystem_id

    идентификатор информационной системы, к которой относится данная группа

    $information_groups_path

    URL вставляемой/обновляемой группы

    $edit_mode

    параметр, указывающий производится вставка или обновление группы (0 –вставка, 1 – обновление)

    $information_groups_id

    идентификатор редактируемой информационной группы

    Возвращает

    true – в данной группе есть подгруппа, которая имеет такой же URL как и вставляемая/редактируемая подгруппа. В противном случае возвращает false

    Описание

    Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе

    [ Top ]

    InformationSystem::IssetGroupItemInsertUpdate

IssetGroupItemInsertUpdate(
int
$information_groups_id, int
$InformationSystem_id, string
$information_items_url );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, в которой осуществляется поиск

    $InformationSystem_id

    идентификатор информационной системы, к которой относится группа

    $information_items_url

    URL информационного элемента

    Возвращает

    true - в данной группе есть подгруппа, URL которой совпадает с URL информационного элемента, относящегося к данной группе. В противном случае возвращает false

    Описание

    Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента

    [ Top ]

    InformationSystem::IssetItem

IssetItem(
int
$information_groups_id, int
$InformationSystem_id, string
$information_items_url, [int
$information_items_id = 0], [int
$edit_mode = 0] );

    Принимаемые параметры

    $information_groups_id

    идентификатор информационной группы, среди элементов которой проводится проверка

    $InformationSystem_id

    идентификатор информационной системы, среди элементов которой проводится проверка;

    $information_items_url

    URL информационного элемента, для которого ищем совпадения среди URL других элементов данной информационной группы

    $information_items_id

    идентификатор редактируемого информационного элемента, при добавлении $id=0

    $edit_mode

    параметр, определяющий  режим вставки или добавления элемента (0 – вставка, 1- редактирование)

    Возвращает

    true – в информационной группе уже существует информационный элемент с таким же URL как и у данного элемента, false – в информационной группе не существует элементов с таким URL

    Описание

    Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы

    [ Top ]

    InformationSystem::IssetItemGroupInsertUpdate

IssetItemGroupInsertUpdate(
int
$information_groups_parent_id, int
$InformationSystem_id, string
$information_groups_path );

    Принимаемые параметры

    $information_groups_parent_id

    идентификатор родительской группы

    $InformationSystem_id

    идентификатор информационной системы

    $information_groups_path

    URL вставляемой/редактируемой группы

    Возвращает

    true – в данной группе есть информационный элемент, у которого URL совпадает с URL добавляемой/редактируемой группы. В противном случае возвращает false

    Описание

    Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы

    [ Top ]

    InformationSystem::SelectInformationGroupPropertys

SelectInformationGroupPropertys(
int
$id, int
$InformationSystem_id );

    Принимаемые параметры

    $id

    идентификатор свойства информационной группы

    $InformationSystem_id

    идентификатор информационной системы

    Описание

    Метод получения данных о свойствах группы информационной системы

    [ Top ]

    InformationSystem::SelectInformationGroups

SelectInformationGroups(
int
$id, [int
$information_system_id = false], [array
$param = array()] );

    Принимаемые параметры

    $id

    идентификатор выбираемой информационной группы, если $id = -1 – выбираются все группы данной информационной системы

    $information_system_id

    идентификатотр информационной системы

    $param

    массив дополнительных параметров  $param['OrderGroup'] = ASC/DESC порядок сортировки информацтонных групп  $param['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()  $param['NotInGroup'] идентификатор информационных групп, которые необходимо исключить из результатов  $param['groups_parent_id'] идентификатор родительской группы, необязательный параметр, по умолчанию false

    Описание

    Метод получения информации об информационных группах конкретной информационной системы

    [ Top ]

    InformationSystem::SelectInformationSystem

SelectInformationSystem(
int
$id );

    Принимаемые параметры

    $id

    идентифиеатор информационной системы

    Описание

    Метод получения информации об информационной системе

    [ Top ]

    InformationSystem::SelectListInformationGroupPropertys

SelectListInformationGroupPropertys(
int
$InformationSystem_id );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы

    Описание

    Метод получения списка дополнительных свойств информационноq группы данной инфосистемы

    [ Top ]

    InformationSystem::select_comments

select_comments(
int
$id, int
$information_items_id );

    Принимаемые параметры

    $id

    идентификатор комментария

    $information_items_id

    идентификатор информационного элемента

    Описание

    Метод получения комментариев к информационному элементу

    [ Top ]

    InformationSystem::select_information_items

select_information_items(
int
$id, [int
$information_groups_id = false], [int
$information_system_id = false] );

    Принимаемые параметры

    $id

    идентификатор выбираемого информационного элемента, если $id = false – выбираем все информационные элементы данной информационной системы

    $information_groups_id

    идентификатор информационной группы, элементы которой необходимо выбрать, если $id = false (по умолчанию), то выбираются все элементы данной информационной системы

    $information_system_id

    идентификатор информационной системы

    Описание

    Метод получения данных об информационном элементе

    [ Top ]

    InformationSystem::select_information_propertys

select_information_propertys(
int
$id, int
$InformationSystem_id );

    Принимаемые параметры

    $id

    идентификатор свойства информационной системы, если $id = -1, то выбираем все свойства информационной системы

    $InformationSystem_id

    идентификатор информационной системы

    Описание

    Метод получения данных о свойствах информационной системы

    [ Top ]

    InformationSystem::ShowAddComment

ShowAddComment(
string
$xslname, [array
$param = array(
    'confirm_comment'=>false,
    'status' => 0
    )] );

    Принимаемые параметры

    $xslname

    имя XSL шаблона для отображения информации о добавлении комментария

    $param

    массив дополнительных параметров  $param['confirm_comment'] определяет имеет ли пользователь право на добавления комментария (true - имеет право, false - не имеет право)  $param['status'] статус сообщения, добавленного пользователем (0 - недоступно посетителям, 1 - доступно посетителям сразу после публикации)

    Возвращает

    false в случае отсутствия данного информационного элемента

    Описание

    Метод добавления комментария к элементу информационной системы

    [ Top ]

    InformationSystem::ShowInformationSystem

ShowInformationSystem(
int
$InformationSystem_id, int
$information_groups_id, string
$xsl_name, int
$items_on_page, int
$items_begin, [array
$external_propertys = array()], [array
$property = array()] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы, группы и элементы которой отображаются

    $information_groups_id

    информационной группы, подгруппы и элементы которой необходимо показать

    $xsl_name

    имя XSL шаблона для отображения групп и элементов информационной системы

    $items_on_page

    число информационных элементов, отображаемых на странице

    $items_begin

    номер, начиная с которого выводить информационные элементы

    $external_propertys

    массив дополнительных свойств для включения в исходный XML код

    $property

    массив дополнительных параметров  $property['Order'] = ASC/DESC
    $property['OrderField'] поле сортировки, если случайная сортировка, то записать RAND()
    $property['NotIn'] идентификаторы элементов, которые необходимо исключить из результатов
    $property['OrderGroup'] направление сортировки (ASC - по возрастанию, DESC - по убыванию)
    $property['OrderGroupField'] поле сортировки, если случайная сортировка, то записать RAND()
    $property['NotInGroup'] идентификатор групп информационных элементов, которые необходимо исключить из результатов
    $property['cache'] разрешение кэширования, по умолчанию true
    $property['select'] массив ($element) с дополнительными параметрами для задания дополнительных условий отбора информационных элементов
    $element['type'] определяет, является ли поле основным свойством информационного элемента или дополнительным (0 - основное, 1 - дополнительное)
    $element['prefix'] префикс - строка, размещаемая перед условием
    $element['name'] имя поля для основного свойства, если свойство дополнительное, то не указывается
    $element['property_id'] идентификатор дополниетльного свойства
    $element['if'] строка, содержащая условный оператор
    $elemenr['value'] значение поля (или параметра)
    $element['sufix'] суффикс - строка, размещаемая после условия
    $property['show_group'] содержит массив групп системы для показа
    $property['show_information_item'] содержит массив отображаемых полей информационных элементов

    Пример использования:

    1      <?
    2      $InformationSystem = new InformationSystem();
    3      $external_propertys=array();
    4      $external_propertys[‘ПоказыватьСсылкиНаДругиеСтраницы’]=1;
    5      $property=array();
    6      # Заполняем первое условие
    7      $element['type']=0;
    8      $element['prefix'] = ' and (';
    9      $element['name'] = 'information_items_date';
    10     $element['if'] = '>';
    11     $elemenr['value'] = '2005-12-23 00:00:00';
    12     $element['sufix']='';
    13     $property['select'][]=$element;
    14     # Заполняем второе условие, в данном случае по значению дополнительного св-ва
    15     $element['type']=1;
    16     $element['prefix'] = 'and';
    17     $element['property_id'] = 17;
    18     $element['if'] = '>';
    19     $elemenr['value'] = '2005-12-23 00:00:00';
    20     $element['sufix']=')';
    21     $property['select'][]=$element;
    22     # Выводим элементы
    23     $InformationSystem-> ShowInformationSystem(1, 0, ‘СписокНовостей’, 10, 0, external_propertys, $property);
    24     ?>

    Пример сортировки по значению дополнительного поля:  <?  $InformationSystem = new InformationSystem();  $external_propertys=array();  $external_propertys[‘ПоказыватьСсылкиНаДругиеСтраницы’]=1;  $property=array();
    • Заполняем первое условие
     $element['type']=0;  $element['prefix'] = 'and (';  $element['name'] = 'information_items_date';  $element['if'] = '>';  $elemenr['value'] = '2005-12-23 00:00:00';  $element['sufix']='';  $property['select'][]=$element;  $element['type']=0;  $element['prefix'] = ' and '; // префикс  $element['name'] = 'information_propertys_table.information_propertys_id';  $element['if'] = '='; // Условие
    • Здесь указывается ID доп. св-ва, по которому производится сортировка
     $element['value'] = '38'; // ID дополнительного св-ва, по которому сортируем  $element['sufix']=')';  $property['select'][]=$element;
    • Указываем, что мы сортируем по значениям дополнительных полей
     $property['OrderField'] = 'information_propertys_table.information_propertys_id, information_propertys_items_value';
    • Выводим элементы
     $InformationSystem-> ShowInformationSystem(1, 0, ‘СписокНовостей’, 10, 0, $external_propertys, $property);  ?>

    Возвращает

    двумерный массив с данными о показанных записях информационной системы

    Описание

    Метод отображения групп и элементов информационной системы

    [ Top ]

    InformationSystem::ShowInformationSystemItem

ShowInformationSystemItem(
int
$information_item_id, string
$xsl_name, [array
$external_propertys = array()] );

    Принимаемые параметры

    $information_item_id

    идентификатор, отображаемого информационного элемента

    $xsl_name

    имя XSL-шаблона, применяемого для отображения информационного элемента

    $external_propertys

    массив дополнительных свойств, индексы массива - имена дополнительных XML-тэгов, элементы массива - значения этих тэгов

    Возвращает

    true

    Описание

    Метод отображения информацию об информационном элементе

    [ Top ]

    InformationSystem::ShowInformationSystemRss

ShowInformationSystemRss(
int
$InformationSystem_id, mixed
$information_groups_id, [int
$items_on_page = 10], [int
$items_begin = 0], [array
$property = array()] );

    Принимаемые параметры

    $InformationSystem_id

    идентификатор информационной системы

    $information_groups_id

    идентификатор информационной группы, если все группы – то false

    $items_on_page

    количество выводимых записей в ленте

    $items_begin

    параметр, определяющий с какой записи начинать вывод

    $property

    массив дополнительных параметров

    Описание

    Метод отображения RSS ленты

    [ Top ]

    InformationSystem::UserCanAddComment

UserCanAddComment(
string
$date, mixed
$ip, string
$comment_ip );

    Принимаемые параметры

    $date

    дата и время (в Unix-формате) добавления комментария

    $comment_ip

    ip-адрес компьютера пользователя, добавляющего комментарий

    Возвращает

    true - пользователь может отправлять комментарий, false - не может отправлять комментарий

    Описание

    Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY

    [ Top ]

Variable Detail

  • $a_count_property = array() [line 128]
    •

  • Data type: array
    •

    Описание

    Кэш количества свойств

  • $cache_InformationSystem = array() [line 136]
    •

  • Data type: array
    •

    Описание

    Кэш данных о информационной системе  пример $this->cache_InformationSystem[$id]

  • $CommentMass = array() [line 83]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о комментариях

  • $GroupMass = array() [line 69]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о группах

  • $ItemMass = array() [line 76]
    •

  • Data type: array
    •

    Описание

    Кэш с данными об элементах

  • $MasGroup = array() [line 121]
    •

  • Data type: array
    •

    Описание

    Массив групп

  • $PropertyGroupMass = array() [line 97]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о дополнительных свойствах информационных групп

  • $PropertyMass = array() [line 90]
    •

  • Data type: array
    •

    Описание

    Кэш с данными о свойствах инфоррмационных элементов

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:17 +0400 by phpDocumentor 1.3.0RC3


Docs For Class ip

Class ip

[line 11]

Размещен: /ip/ip.class.php

Описание

Класс модуля "IP-адреса"

Свойства класса

  • $record_on_page = ON_PAGE

        Число записей, отображаемых на странице

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • resource DelIp()

    Метод удаления информации об IP-адресе

  • mixed GetIpInfo()

    Метод получения информации о запретах для переданного ip-адреса

  • int InsertIp()

    Метод вставки/обновления информации об IP-адресе

  • resource SelectIp()

    Метод получения информации об IP-адресах

Унаследованные методы

Описания методов

    ip::DelIp

DelIp(
int
$id );

    Принимаемые параметры

    $id

    идентификатор IP-адреса

    Описание

    Метод удаления информации об IP-адресе

    [ Top ]

    ip::GetIpInfo

GetIpInfo(
string
$ip );

    Принимаемые параметры

    $ip

    IP-адрес

    Возвращает

    массив с информацией о запретах для IP-адреса, или false, если запретов нет

    Описание

    Метод получения информации о запретах для переданного ip-адреса

    [ Top ]

    ip::InsertIp

InsertIp(
int
$type, array
$fields );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление информации об IP-адресе (0-вставка, 1-обновление)

    $fields

    массив полей

    Возвращает

    идентификатор вставленной/обновленной записи с информацией об IP-адресе

    Описание

    Метод вставки/обновления информации об IP-адресе

    [ Top ]

    ip::SelectIp

SelectIp(
int
$id );

    Принимаемые параметры

    $id

    идентификатор IP-адреса, о котором необходимо получить информацию, если  $id=false - получаем информацию о всех  IP-адресах

    Описание

    Метод получения информации об IP-адресах

    [ Top ]

Variable Detail

  • $record_on_page = ON_PAGE [line 26]
    •

  • Data type: int
    •

    Описание

    Число записей, отображаемых на странице

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:19 +0400 by phpDocumentor 1.3.0RC3


Docs For Class kernel

Class kernel

[line 10]

Размещен: /Kernel/Kernel.class.php

Описание

Класс ядра системы управления сайтом HostCMS

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void AddInclude()

    Метод подключает переданный файл или выводит сообщение об ошибке подключения

  • void AddModule()

    Метод подключения модуля

  • void add_modules_version()

    Метод добавления модуля в массив-список модулей

  • string declension()

    Метод получения существительного в форме, соответствующей числу

  • int GetCurrentYear()

    Метод получения значения текущего года

  • string GetDBVersion()

    Метод определения версии MySQL

  • unknown GetExtension()

    Метод возвращает расширение файла

  • string GetGDVersion()

    Метод определения версии GD библиотеки

  • int GetLastModified()

    Метод получения  времени последнего изменения страницы

  • int getmicrotime()

    Метод получения значения времени

  • int GetTemplate()

    Метод получения текущего шаблона

  • string get_CSS()

    Метод получения CSS стиля для страницы

  • int get_current_page()

    Метод получения идентификатора текущего узла структуры

  • string get_current_page_path()

    Метод получения пути текущей страницы

  • string get_description()

    Метод получения описания страницы

  • string get_keywords()

    Метод получения ключевых слов страницы

  • int get_page_id()

    Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя

  • string get_title()

    Метод получения заголовка страницы

  • string implode_array()

    Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно

  • boolean InitConstants()

    Метод инициализации констант сайта в соответствии с константой CURRENT_SITE

  • void LoadModules()

    Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS

  • void LoadModulesLngFile()

    Метод загрузки языкового файла для модуля

  • array random_shuffle()

    Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.

  • void SetLastModified()

    Метод установления времени последнего изменения страницы

  • void SetTemplate()

    Метод установления текущего шаблона

  • void set_CSS()

    Метод изменения адреса файла CSS-стиля для страницы

  • void set_current_page()

    Метод изменения адреса страницы

  • void set_current_page_data_template()

    Метод изменения шаблона страницы

  • void set_description()

    Метод изменения описания страницы

  • void set_keywords()

    Метод изменения ключевых слов страницы

  • void set_title()

    Метод изменения заголовока страницы

  • void show_CSS()

    Метод вывода CSS стиля для страницы

  • void show_current_page()

    Метод вывода страницы

  • void show_current_template()

    Метод вывода текущего шаблона

  • void show_description()

    Метод вывода описания страницы

  • void show_keywords()

    Метод вывода ключевых слов страницы

  • void show_title()

    Метод вывода заголовка страницы

  • void strips()

    Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag

Унаследованные методы

Описания методов

    kernel::AddInclude

AddInclude(
string
$file );

    Принимаемые параметры

    $file

    имя файла

    Описание

    Метод подключает переданный файл или выводит сообщение об ошибке подключения

    [ Top ]

    kernel::AddModule

AddModule(
string
$modules_path );

    Принимаемые параметры

    $modules_path

    path-имя модуля, например Structure

    Описание

    Метод подключения модуля

    [ Top ]

    kernel::add_modules_version

add_modules_version(
string
$path, string
$version, [string
$date = ''] );

    Принимаемые параметры

    $path

    путь к модулю

    $version

    версия модуля

    $date

    дата

    Описание

    Метод добавления модуля в массив-список модулей

    [ Top ]

    kernel::declension

declension(
int
$num, int
$word_stem, int
$ends_of_word, [mixed
$prefix = ''], [mixed
$postfix = ''], int
$prefix='', int
$postfix='' );

    Принимаемые параметры

    $num

    число, с которым связано существительное

    $word_stem

    основа слова

    $ends_of_word

    массив окончаний слова

    $prefix=''

    префикс (возможно прилагательное)

    $postfix=''

    постфикс - конец фразы

    Возвращает

    сформированная строка

    Описание

    Метод получения существительного в форме, соответствующей числу

    version

    3.2

    [ Top ]

    kernel::GetCurrentYear

GetCurrentYear(
 );

    Возвращает

    текущий год

    Описание

    Метод получения значения текущего года

    [ Top ]

    kernel::GetDBVersion

GetDBVersion(
 );

    Возвращает

    версия MySQL

    Описание

    Метод определения версии MySQL

    [ Top ]

    kernel::GetExtension

GetExtension(
string
$filename );

    Принимаемые параметры

    $filename

    Описание

    Метод возвращает расширение файла

    [ Top ]

    kernel::GetGDVersion

GetGDVersion(
 );

    Возвращает

    версия GD библиотеки

    Описание

    Метод определения версии GD библиотеки

    [ Top ]

    kernel::GetLastModified

GetLastModified(
 );

    Описание

    Метод получения  времени последнего изменения страницы

    [ Top ]

    kernel::getmicrotime

getmicrotime(
 );

    Описание

    Метод получения значения времени

    [ Top ]

    kernel::GetTemplate

GetTemplate(
 );

    Описание

    Метод получения текущего шаблона

    [ Top ]

    kernel::get_CSS

get_CSS(
[boolean
$is_external = true] );

    Принимаемые параметры

    $is_external

    необязательный параметр $is_external - true - ссылка на CSS, false - возвращение содержания CSS стиля

    Возвращает

    CSS стиль для страницы

    Описание

    Метод получения CSS стиля для страницы

    [ Top ]

    kernel::get_current_page

get_current_page(
array
$param, [int
$site_id = CURRENT_SITE] );

    Принимаемые параметры

    $param

    имена разделов от родителя к ребенку, например services | guard_business_center,  например Array ( [0] => services [1] => guard_business_center)

    $site_id

    Возвращает

    идентификатор узла структуры

    Описание

    Метод получения идентификатора текущего узла структуры

    [ Top ]

    kernel::get_current_page_path

get_current_page_path(
 );

    Возвращает

    путь к текущей странице

    Описание

    Метод получения пути текущей страницы

    [ Top ]

    kernel::get_description

get_description(
 );

    Возвращает

    описание страницы

    Описание

    Метод получения описания страницы

    [ Top ]

    kernel::get_keywords

get_keywords(
 );

    Описание

    Метод получения ключевых слов страницы

    [ Top ]

    kernel::get_page_id

get_page_id(
string
$name, int
$parent_id, int
$site_id );

    Принимаемые параметры

    $name

    имя узла стурктуры

    $parent_id

    идентификатор родителя

    $site_id

    идентификатор сайта

    Возвращает

    идентификатор узла структуры или false

    Описание

    Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя

    [ Top ]

    kernel::get_title

get_title(
 );

    Возвращает

    значение заголовка страницы

    Описание

    Метод получения заголовка страницы

    [ Top ]

    kernel::implode_array

implode_array(
array
$array, [array
$separator = ''] );

    Принимаемые параметры

    $array

    массив

    $separator

    разделитель

    Возвращает

    строка

    Описание

    Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно

    [ Top ]

    kernel::InitConstants

InitConstants(
 );

    Возвращает

    true в случае успеха, false - данные о сайте отсутствуют

    Описание

    Метод инициализации констант сайта в соответствии с константой CURRENT_SITE

    [ Top ]

    kernel::LoadModules

LoadModules(
 );

    Описание

    Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS

    [ Top ]

    kernel::LoadModulesLngFile

LoadModulesLngFile(
string
$module_path_name, string
$modules_name );

    Принимаемые параметры

    $module_path_name

    имя в пути модуля, например Document

    $modules_name

    текстовое имя модуля, например "Документы"

    Описание

    Метод загрузки языкового файла для модуля

    [ Top ]

    kernel::random_shuffle

random_shuffle(
array
$array, [int
$hash = false] );

    Принимаемые параметры

    $array

    массив

    $hash

    некое числовое значение

    Возвращает

    перемешанный массив

    Описание

    Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.

    [ Top ]

    kernel::SetLastModified

SetLastModified(
int
$time );

    Принимаемые параметры

    $time

    Описание

    Метод установления времени последнего изменения страницы

    [ Top ]

    kernel::SetTemplate

SetTemplate(
int
$template_id );

    Принимаемые параметры

    $template_id

    Описание

    Метод установления текущего шаблона

    [ Top ]

    kernel::set_CSS

set_CSS(
string
$CSS );

    Принимаемые параметры

    $CSS

    Описание

    Метод изменения адреса файла CSS-стиля для страницы

    [ Top ]

    kernel::set_current_page

set_current_page(
string
$page );

    Принимаемые параметры

    $page

    адрес страницы

    Описание

    Метод изменения адреса страницы

    [ Top ]

    kernel::set_current_page_data_template

set_current_page_data_template(
string
$data_template );

    Принимаемые параметры

    $data_template

    Описание

    Метод изменения шаблона страницы

    [ Top ]

    kernel::set_description

set_description(
string
$description );

    Принимаемые параметры

    $description

    Описание

    Метод изменения описания страницы

    [ Top ]

    kernel::set_keywords

set_keywords(
string
$keywords );

    Принимаемые параметры

    $keywords

    Описание

    Метод изменения ключевых слов страницы

    [ Top ]

    kernel::set_title

set_title(
string
$title );

    Принимаемые параметры

    $title

    текст заголовка страницы

    Описание

    Метод изменения заголовока страницы

    [ Top ]

    kernel::show_CSS

show_CSS(
[boolean
$is_external = true] );

    Принимаемые параметры

    $is_external

    true - ссылка на CSS, false - вывод содержания CSS стиля

    Описание

    Метод вывода CSS стиля для страницы

    [ Top ]

    kernel::show_current_page

show_current_page(
 );

    Описание

    Метод вывода страницы

    [ Top ]

    kernel::show_current_template

show_current_template(
 );

    Описание

    Метод вывода текущего шаблона

    [ Top ]

    kernel::show_description

show_description(
 );

    Описание

    Метод вывода описания страницы

    [ Top ]

    kernel::show_keywords

show_keywords(
 );

    Описание

    Метод вывода ключевых слов страницы

    [ Top ]

    kernel::show_title

show_title(
 );

    Описание

    Метод вывода заголовка страницы

    [ Top ]

    kernel::strips

strips(
 );

    Описание

    Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:19 +0400 by phpDocumentor 1.3.0RC3


Docs For Class lists

Class lists

[line 11]

Размещен: /Lists/Lists.class.php

Описание

Класс модуля "Списки"

Свойства класса

  • $record_on_page = ON_PAGE

        Количество выводимых элементов на страницу

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • int CopyListItem()

    Метод копирования элементов списка

  • boolean del_lists()

    Метод удаления списка

  • boolean del_lists_items()

    Метод удаления элемента списка

  • resource GetList()

    Метод выборки данных о списках

  • mixed GetListItem()

    Метод получения данные об элементе списка

  • int insert_lists()

    Метод вставки/обновления данных о списке

  • int insert_lists_items()

    Метод вставки/обновления данных об элементе списка

  • resource SelectListsItems()

    Метод получения данных об элементах списка

  • resource select_lists_items()

    Метод получения данных об элементе списка

Унаследованные методы

Описания методов

    lists::CopyListItem

CopyListItem(
int
$list_item_id );

    Принимаемые параметры

    $list_item_id

    идентификатор копируемого элемента списка

    Возвращает

    идентификатор копии элемента списка

    Описание

    Метод копирования элементов списка

    [ Top ]

    lists::del_lists

del_lists(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого списка

    Возвращает

    true в случае успешного удаления списка, false в противном случае

    Описание

    Метод удаления списка

    [ Top ]

    lists::del_lists_items

del_lists_items(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого элемента списка

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления элемента списка

    [ Top ]

    lists::GetList

GetList(
mixed
$id );

    Принимаемые параметры

    $id

    идентификатор выбираемого списка, если идентификатор равен false, то производится выбор информации о всех списках

    Возвращает

    с данными о выбранных списках

    Описание

    Метод выборки данных о списках

    [ Top ]

    lists::GetListItem

GetListItem(
int
$id );

    Принимаемые параметры

    $id

    идентификатор элемента списка

    Возвращает

    ассоциативный массив с данными об элементе списка или false, если элемент не найден

    Описание

    Метод получения данные об элементе списка

    [ Top ]

    lists::insert_lists

insert_lists(
int
$type, $lists_id
$lists_id, string
$lists_name, string_type
$lists_description );

    Принимаемые параметры

    $type

    параметр, определяющий будет производиться вставка или обновление данных о списке (0 – вставка, 1 - обновление)

    $lists_name

    название списка

    $lists_description

    описание списка

    $lists_id

    идентификатор списка, для которого обновляется информация

    Возвращает

    идентификатор вставленного/обновленного списка

    Описание

    Метод вставки/обновления данных о списке

    [ Top ]

    lists::insert_lists_items

insert_lists_items(
int
$type, int
$lists_items_id, int
$lists_id, int
$lists_items_value );

    Принимаемые параметры

    $type

    параметр, определяющий будет производится вставка или обновление данных об элементе списка (0 – вставка, 1 - обновление)

    $lists_items_id

    идентификатор элемента списка, для которого обновляется информация

    $lists_id

    идетификатор списка, к которому относится вставляемый/обновляемый элемент

    $lists_items_value

    значение элемента списка

    Возвращает

    идентификатор вставленного/обновленного элемента списка

    Описание

    Метод вставки/обновления данных об элементе списка

    [ Top ]

    lists::SelectListsItems

SelectListsItems(
int
$list_id, [array
$property = array()] );

    Принимаемые параметры

    $list_id

    идентификатор списка

    $property

    дополнительные свойства
    $property['orderfield'] - поле сортировки, по умолчанию lists_items_order
    $property['ordertype'] - направление сортировки, по умолчанию

    Возвращает

    данных об элементах списка

    Описание

    Метод получения данных об элементах списка

    [ Top ]

    lists::select_lists_items

select_lists_items(
mixed
$id );

    Принимаемые параметры

    $id

    идентификатор выбираемого элемента. Если идетификатор = false или идентификатор = -1 - выбираются все элементы

    Возвращает

    данные об элементе списка

    Описание

    Метод получения данных об элементе списка

    [ Top ]

Variable Detail

  • $record_on_page = ON_PAGE [line 26]
    •

  • Data type: int
    •

    Описание

    Количество выводимых элементов на страницу

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:20 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Maillist

Class Maillist

[line 11]

Размещен: /Maillist/Maillist.class.php

Описание

Класс модуля "Почтовые рассылки"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean CopyFascicle()

    Метод копирования выпуска рассылки

  • unknown DeleteUsers()

    Метод снятия подписки с подписчика

  • boolean DeleteUsersGroup()

    Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке

  • boolean DelFascicle()

    Метод удаления выпуска рассылки

  • boolean DelMaillist()

    Метод удаления рассылки

  • выводит GetMaillistXML()

    Метод генерирующий XML для состояния подписки конкретного пользователя сайта

  • mixed InsertFascicle()

    Метод добавления/редактирования выпуска рассылки

  • boolean InsertMaillist()

    Метод добавления/редактирования информации о рассылке

  • boolean InsertUsers()

    Метод добавления/редактирования информации о подписчике

  • boolean InsertUsersGroup()

    Метод, открывающий доступ группе пользователей сайта к рассылке

  • boolean RenewMaillist()

    Метод обновления информации о подписке для конкретного подписчика

  • resource SelectFascicle()

    Метод получения данных о выпуске рассылки

  • resource SelectMaillist()

    Метод получения данных о рассылке

  • mixed SelectUser()

    Метод получения информации о состоянии подписки подписчика на рассылку

  • mixed SendFascicle()

    Метод отправки выпуска всем подписчикам рассылки

Унаследованные методы

Описания методов

    Maillist::CopyFascicle

CopyFascicle(
int
$fascicle_id );

    Принимаемые параметры

    $fascicle_id

    идентификатор выпуска рассылки

    Возвращает

    результат выполнения запроса на добавление

    Описание

    Метод копирования выпуска рассылки

    [ Top ]

    Maillist::DeleteUsers

DeleteUsers(
int
$user_id, int
$maillist_id );

    Принимаемые параметры

    $user_id

    идентификатор пользователя сайта

    $maillist_id

    идентификатор

    Описание

    Метод снятия подписки с подписчика

    [ Top ]

    Maillist::DeleteUsersGroup

DeleteUsersGroup(
int
$users_group_id, int
$maillist_id );

    Принимаемые параметры

    $users_group_id

    идентификатор группы пользователей

    $maillist_id

    идентификатор рассылки

    Возвращает

    результат выполнения запросов на удаление

    Описание

    Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке

    [ Top ]

    Maillist::DelFascicle

DelFascicle(
int
$id );

    Принимаемые параметры

    $id

    идентификатор выпуска рассылки

    Возвращает

    результат выполнения запроса на удаление

    Описание

    Метод удаления выпуска рассылки

    [ Top ]

    Maillist::DelMaillist

DelMaillist(
int
$id );

    Принимаемые параметры

    $id

    идентификатор рассылки

    Возвращает

    результат выполнения запросов на удаление

    Описание

    Метод удаления рассылки

    [ Top ]

    Maillist::GetMaillistXML

GetMaillistXML(
int
$site_user_id, string
$xslname );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя сайта

    $xslname

    имя XSL шаблона

    Возвращает

    на экран HTML код

    Описание

    Метод генерирующий XML для состояния подписки конкретного пользователя сайта

    [ Top ]

    Maillist::InsertFascicle

InsertFascicle(
int
$maillist_id, int
$maillist_fascicle_id, int
$maillist_htmltotext, string
$maillist_fascicle_theme, string
$maillist_fascicle_text, string
$maillist_fascicle_html );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $maillist_fascicle_id

    идентификатор выпуска рассылки

    $maillist_htmltotext

    строить ли текстовую версию на основе HTML

    $maillist_fascicle_theme

    тема выпуска

    $maillist_fascicle_text

    текстовая версия выпуска

    $maillist_fascicle_html

    HTML версия выпуска

    Возвращает

    результат выполнение запроса:
      int идентификатор добавленного выпуска;
      boolean результат выполнения запроса на обновление

    Описание

    Метод добавления/редактирования выпуска рассылки

    [ Top ]

    Maillist::InsertMaillist

InsertMaillist(
int
$maillist_id, string
$maillist_name, string
$maillist_description );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки (0 - добавляем, иначе - редактируем)

    $maillist_name

    нащвение рассылки

    $maillist_description

    описание рассылки

    Возвращает

    результат выполнения запроса

    Описание

    Метод добавления/редактирования информации о рассылке

    [ Top ]

    Maillist::InsertUsers

InsertUsers(
int
$maillist_id, int
$site_user_id, int
$value );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $site_user_id

    идентификатор пользователя сайта

    $value

    тип подписки (0 - текст, 1 - HTML)

    Возвращает

    результат выполнения запроса на добавление/редактирование

    Описание

    Метод добавления/редактирования информации о подписчике

    [ Top ]

    Maillist::InsertUsersGroup

InsertUsersGroup(
int
$maillist_id, int
$site_users_group_id );

    Принимаемые параметры

    $maillist_id

    идентификатор рассылки

    $site_users_group_id

    идентификатор группы пользователей

    Возвращает

    результат выполнения запроса на вставку

    Описание

    Метод, открывающий доступ группе пользователей сайта к рассылке

    [ Top ]

    Maillist::RenewMaillist

RenewMaillist(
int
$site_users_id, array
$array );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя сайта

    $array

    массив значений состояния подписки:
      $array['value'.$maillist_id] int тип подписки (0 - текст, 1 - HTML)

    Возвращает

    результат обновления состояния подписки

    Описание

    Метод обновления информации о подписке для конкретного подписчика

    [ Top ]

    Maillist::SelectFascicle

SelectFascicle(
int
$id );

    Принимаемые параметры

    $id

    идентификатор выпуска рассылки

    Возвращает

    результат выполнения запроса на выборку

    Описание

    Метод получения данных о выпуске рассылки

    [ Top ]

    Maillist::SelectMaillist

SelectMaillist(
int
$id );

    Принимаемые параметры

    $id

    идентификатор рассылки (-1 выбрать все рассылки)

    Возвращает

    результат выполнения запроса на выборку

    Описание

    Метод получения данных о рассылке

    [ Top ]

    Maillist::SelectUser

SelectUser(
int
$id, int
$maillist_id );

    Принимаемые параметры

    $id

    идентификатор пользователя сайта

    $maillist_id

    идентификатор рассылки

    Возвращает

    результат запроса на выборку:
      array массив данных о состоянии подписки  $result[0] Ф.И.О подписчика  $result[1] тип подписки (0 - текст, 1 - HTML)  boolean false если информация не найдена

    Описание

    Метод получения информации о состоянии подписки подписчика на рассылку

    [ Top ]

    Maillist::SendFascicle

SendFascicle(
int
$fascicle_id );

    Принимаемые параметры

    $fascicle_id

    идентификатор выпуска рассылки

    Возвращает

    результат отправки писем
      array результат успешной отправки:  $result[0] количество подписчиков;
      $result[1] количество успешных отправок  boolean false результат неудачной отправки

    Описание

    Метод отправки выпуска всем подписчикам рассылки

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:20 +0400 by phpDocumentor 1.3.0RC3


Docs For Class modules_admin

Class modules_admin

[line 11]

Размещен: /Modules/Modules.class.php

Описание

Класс модуля "Управление модулями"

Свойства класса

  • $count_row =

  • $error =

  • $record_on_page = ON_PAGE

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • resource del_module()

    Метод удаления информации о модуле

  • int insert_module()

    Метод вставки/обновления информации о модуле

  • boolean IssetModule()

    Метод проверки наличия активного модуля

  • resource select_modules()

    Метод получения информации о модуле

Унаследованные методы

Описания методов

    modules_admin::del_module

del_module(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого модуля

    Возвращает

    результат запроса на удаление модуля

    Описание

    Метод удаления информации о модуле

    [ Top ]

    modules_admin::insert_module

insert_module(
int
$type, int
$modules_id, string
$modules_name, string
$modules_description, string
$modules_status, string
$modules_path, int
$modules_order, int
$modules_privileged );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации о модуле (0 – вставка, 1 - обновление)

    $modules_id

    – идентификатор обновляемого модуля (при вставке равен 0)

    $modules_name

    - название модуля

    $modules_description

    – описание модуля

    $modules_status

    - флаг активности (доступности) модуля (1 – модуль активен (доступен), 0 – модуль неактивен)

    $modules_path

    – директория размещения модуля

    $modules_order

    – порядковый номер модуля в списке сортировки модулей

    $modules_privileged

    – флаг задающий привилегию модуля (0 – нет привилегии, 1 – есть привилегии)

    Возвращает

    идентификатор добавляемого/редактируемого модуля

    Описание

    Метод вставки/обновления информации о модуле

    [ Top ]

    modules_admin::IssetModule

IssetModule(
string
$module_path );

    Принимаемые параметры

    $module_path

    – название директории размещения модуля

    Возвращает

    true - модуль существует и активен, false – модуль не существует или он не активен.

    Описание

    Метод проверки наличия активного модуля

    [ Top ]

    modules_admin::select_modules

select_modules(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор модуля (если $id = -1 получаем информацию о всех модулях системы)

    Возвращает

    информация о модуле (модулях)

    Описание

    Метод получения информации о модуле

    [ Top ]

Variable Detail

  • $count_row =  [line 15]
    •

  • Data type: mixed
    •

  • $error =  [line 13]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [line 14]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:21 +0400 by phpDocumentor 1.3.0RC3


Docs For Class MySQL

Class MySQL

[line 19]

Размещен: /Kernel/Mysql.class.php

Описание

Ядро, класс для работы с MySQL

Свойства класса

  • $count_row =

  • $result =

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • MySQL MySQL()

    Конструктор.

  • boolean db_connect()

    Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.

  • int get_count_row()

    Метод возвращает количество строк в последнем запросе

  • resource query()

    Метод выполнения SQL-запроса

  • resource select()

    Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()

Унаследованные методы

Описания методов

    MySQL::MySQL

MySQL(
 );

    Описание

    Конструктор.

    [ Top ]

    MySQL::db_connect

db_connect(
 );

    Описание

    Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.

    [ Top ]

    MySQL::get_count_row

get_count_row(
 );

    Возвращает

    кличество строк, возвращенных последним запросом, выполненным методом select()

    Описание

    Метод возвращает количество строк в последнем запросе

    [ Top ]

    MySQL::query

query(
string
$query );

    Принимаемые параметры

    $query

    SQL-запрос

    Описание

    Метод выполнения SQL-запроса

    [ Top ]

    MySQL::select

select(
string
$query );

    Принимаемые параметры

    $query

    SQL-запрос

    Описание

    Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()

    [ Top ]

Variable Detail

  • $count_row =  [line 21]
    •

  • Data type: mixed
    •

  • $result =  [line 22]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs For Class polls

Class polls

[line 10]

Размещен: /Polls/Polls.class.php

Описание

Класс модуля "Опросы"

Свойства класса

  • $error =

        Enter description here...

  • $record_on_page = ON_PAGE

        Enter description here...

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean del_poll()

    Метод удаления опроса

  • boolean del_poll_reply()

    Метод удаления варианта ответа

  • string get_polls_name()

    Метод получения названия опроса

  • int insert_poll()

    Метод осуществляет вставку и обновление опросов

  • int insert_poll_reply()

    Метод, осуществляет вставку и обновление вариантов ответов

  • resource select_poll()

    Метод осуществляет выборку опросов

  • resource select_poll_reply()

    Метод выбора вариантов ответов

  • void ShowPoll()

    Метод отображения опроса

  • void ShowPolls()

    Метод отображения всех активных опросов

  • void update_vote()

    Метод обработки результата голосования

  • boolean vote()

    Метод обработки и отображения результатов голосования

  • void vote_result()

    Метод вывода результатов голосования

Унаследованные методы

Описания методов

    polls::del_poll

del_poll(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор удаляемого опроса

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод удаления опроса

    [ Top ]

    polls::del_poll_reply

del_poll_reply(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор удаляемого варианта ответа

    Возвращает

    true в случае успешного выполнения метода, false - в противном случае

    Описание

    Метод удаления варианта ответа

    [ Top ]

    polls::get_polls_name

get_polls_name(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор опроса

    Возвращает

    название опроса, если запрос с таким идентификатором существует, или слово «Опросы» в противном случае

    Описание

    Метод получения названия опроса

    [ Top ]

    polls::insert_poll

insert_poll(
int
$type, int
$poll_id, string
$poll_name, int
$poll_type, int
$poll_vote_public, int
$poll_visible, string
$poll_begin_date, string
$poll_end_date );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление опроса (0 – вставка, 1 - обновление)

    $poll_id

    – идентификатор обновляемого опроса (при вставке нового опроса равен 0)

    $poll_name

    – название (заголовок) опроса

    $poll_type

    – тип опроса (0 – можно выбрать только один вариант ответа, 1- можно выбрать несколько вариантов ответа)

    $poll_vote_public

    – параметр, определяющий показывать пользователю результаты голосования или нет (1 – показывать, 0 – не показывать)

    $poll_visible

    – параметр, определяющий отображать опрос или нет (1 – отображать, 0 – не отображать)

    $poll_begin_date

    – дата начала действия опроса

    $poll_end_date

    – дата окончания действия опроса

    Возвращает

    or boolean идентификатор вставленного или обновленного опроса в случае успешного выполнеия метода или false - в противном случае

    Описание

    Метод осуществляет вставку и обновление опросов

    [ Top ]

    polls::insert_poll_reply

insert_poll_reply(
int
$type, int
$poll_reply_id, string
$poll_id, string
$poll_reply_text, int
$poll_reply_number, int
$poll_reply_order );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление варианта ответа

    $poll_reply_id

    – идентификатор обновляемого варианта ответа (при вставке нового варианта ответа равен 0)

    $poll_id

    – идентификатор опроса, к которому относится обновляемый/добавляемый вариант ответа

    $poll_reply_text

    – текст варианта ответа

    $poll_reply_number

    – количество голосов, отданных за данный вариант ответа

    $poll_reply_order

    – порядковый номер варианта ответа

    Возвращает

    or boolean идентификатор вставленного или обновленного варианта ответа в случае успешного выполнеия метода или false - в противном случае

    Описание

    Метод, осуществляет вставку и обновление вариантов ответов

    [ Top ]

    polls::select_poll

select_poll(
[int
$id = false] );

    Принимаемые параметры

    $id

    or boolean $id – идентификатор выбираемого опроса (по умолчанию равен false – выбираем все опросы)

    Описание

    Метод осуществляет выборку опросов

    [ Top ]

    polls::select_poll_reply

select_poll_reply(
[int
$id = false] );

    Принимаемые параметры

    $id

    or boolean $id – идентификатор выбираемого варианта ответа (по умолчанию равен false – выбираем все варианты ответов)

    Описание

    Метод выбора вариантов ответов

    [ Top ]

    polls::ShowPoll

ShowPoll(
string
$xsl_name, [int
$id = false], [array
$external_propertys = array()] );

    Принимаемые параметры

    $xsl_name

    – имя XSL – шаблона для отображения опроса

    $external_propertys

    $id

    or boolean $id – идентификатор отображаемого опроса (по умолчанию равен false – опрос выбирается случайным образом)

    Описание

    Метод отображения опроса

    [ Top ]

    polls::ShowPolls

ShowPolls(
string
$xsl_name, int
$polls_on_page, int
$poll_begin, [array
$external_propertys = array()] );

    Принимаемые параметры

    $xsl_name

    – название XSL – шаблона для отображения опросов

    $polls_on_page

    – число опросов на страницу

    $poll_begin

    – число опросов на страницу

    $external_propertys

    – номер опроса, с которого начинать отображать опросы

    Описание

    Метод отображения всех активных опросов

    [ Top ]

    polls::update_vote

update_vote(
 );

    Описание

    Метод обработки результата голосования

    [ Top ]

    polls::vote

vote(
 );

    Возвращает

    true в том случае, если на вопрос еще не отвечали и false в противном случае

    Описание

    Метод обработки и отображения результатов голосования

    [ Top ]

    polls::vote_result

vote_result(
 );

    Описание

    Метод вывода результатов голосования

    [ Top ]

Variable Detail

  • $error =  [line 24]
    •

  • Data type: unknown_type
    •

    Описание

    Enter description here...

  • $record_on_page = ON_PAGE [line 17]
    •

  • Data type: unknown_type
    •

    Описание

    Enter description here...

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs For Class RssRead

Class RssRead

[line 7]

Размещен: /Kernel/RssRead.class.php

Описание

Ядро, класс для чтения RSS

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • array ReadRSS()

    Метод чтения данных из RSS потока

Унаследованные методы

Описания методов

    RssRead::ReadRSS

ReadRSS(
string
$url, [array
$param = array()] );

    Принимаемые параметры

    $url

    URL ресурса

    $param

    массив дополнительных параметров, необязательный параметр

    Возвращает

    ассоциативнй массив с инфомрацией о канале и элементах
    [chanel] => Array
     (
    [title] =>
    [link] =>
    [description] =>
    [image] => Array
    (
    [title] =>
    [link] =>
    [url] =>
    )
    )
    [items] => Array
    (
    [] => Array
    (
    [title] =>
    [link] =>
    [desc] =>
    [pubdate] =>
    )
    )

    Описание

    Метод чтения данных из RSS потока

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs For Class RssWrite

Class RssWrite

[line 19]

Размещен: /Kernel/RssWrite.class.php

Описание

Ядро, класс для генерации RSS

Свойства класса

  • $record_on_page = ON_PAGE

        Количество в потоке

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • string CreateRSS()

    Метод формирования XML-файла в стандарте RSS

Унаследованные методы

Описания методов

    RssWrite::CreateRSS

CreateRSS(
array
$rss_mas_header, array
$rss_mas_items );

    Принимаемые параметры

    $rss_mas_header

    массив, содержащий данные заголовка канала
    $rss_mas_items - массив, содержащий данные новостных заголовков
    $rss_mas_header['title'] - Заголовок канала
    $rss_mas_header['link'] - Ссылка на сайт
    $rss_mas_header['description'] - Краткое описание RSS-потока
    $rss_mas_header['image'] - Картинка для представления канала (необязательный элемент)
    $rss_mas_header['image']['url'] - Ссылка на файл изображения
    $rss_mas_header['image']['title'] -заменяющий текст для изображения
    $rss_mas_header['image']['link'] - Ссылка для перехода при щелчке по изображению

    $rss_mas_items

    массив, соддержащий данные о элементах канала
    $rss_mas_items[]['title'] - Название новости
    $rss_mas_items[]['link'] - Ссылка на страничку, содержащую соответствующую новость
    $rss_mas_items[]['description'] - Краткое описание новости
    $rss_mas_items[]['pubDate'] - Дата публикации новости, ПРИНИМАЕТСЯ В ФОРМАТЕ SQL

    Возвращает

    сгенерированный XML в формате RSS 2.0

    Описание

    Метод формирования XML-файла в стандарте RSS

    [ Top ]

Variable Detail

  • $record_on_page = ON_PAGE [line 50]
    •

  • Data type: int
    •

    Описание

    Количество в потоке

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:22 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Search

Class Search

[line 7]

Размещен: /Search/Search.class.php

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean Delete_search_words()

    Метод удаления из индекса страницы с указанным адресом

  • array GetPageInfo()

    Метод получения информации о проиндексированных страницах

  • mixed SearchWords()

    Поиск списка слов в индексе

Унаследованные методы

Описания методов

    Search::Delete_search_words

Delete_search_words(
string
$page_address );

    Принимаемые параметры

    $page_address

    адрес удаляемой из индекса страницы

    Возвращает

    результат выполнения запроса

    Описание

    Метод удаления из индекса страницы с указанным адресом

    [ Top ]

    Search::GetPageInfo

GetPageInfo(
[mixed
$page_id = -1], int
$page_id=-1 );

    Принимаемые параметры

    $page_id=-1

    идентификатор страницы
      (если равен -1, то возвращает информацию обо всех проиндексированных страницах)

    Возвращает

    массив строк результата запроса

    Описание

    Метод получения информации о проиндексированных страницах

    [ Top ]

    Search::SearchWords

SearchWords(
string
$terms, [array
$param = array('len'=>200)] );

    Принимаемые параметры

    $terms

    поисковой запрос

    $param

    массив дополнительных параметров:
      $param['site_user_id'] int идентификатор пользователя сайта для определения прав доступа;
      $param['current_page'] int номер текущей страницы результатов поиска;
      $param['items_on_page'] int количество записей на странице;
      $param['len']=200 int максимальная длина поискового запроса;
      $param['site_id'] int идентификатор сайта, по которому производится поиск.  Если необходим поиск по текущему сайту, а не по всем сайтам, поддерживаемых системой,  укажите дополнительный параметр в следующей редакции: array('site_id'=>CURRENT_SITE ...)

    Возвращает

    результат поиска:
      array массив страниц:
      $result[$i][0] string название страницы;
      $result[$i][1] string адрес страницы;
      $result[$i][2] string дата индексации;
      $result[$i][3] float размер страницы;
      boolean false если ничего не найдено

    Описание

    Поиск списка слов в индексе

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs For Class show_table

Class show_table

[line 200]

Размещен: /show_table.class.php

Свойства класса

  • $action_width = 70

  • $button = false

  • $button_name = ''

  • $button_value = 'Добавить/изменить'

  • $copy_show = false

  • $delete_confirm = 'Вы уверены, что хотите удалить?'

  • $delete_show = true

  • $edit_show = true

  • $field_action_show = true

  • $field_copy = ''

  • $field_delete = ''

  • $field_edit = ''

  • $form_action = ''

  • $html = ''

  • $image = ''

  • $key_id =

  • $mas =

  • $query =

  • $table_width = '100%'

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void do_show_table()

    Метод отображает сформированную таблицу

  • string GetSelect()

    Метод формирования html содержимого тега select

  • void SetActionWidth()

    Изменяет ширину поля Действие

  • void SetButton()

    Изменяет флаг вывода кнопки

  • void SetButtonName()

    Устанавливает наименование кнопки

  • void SetButtonValue()

    Изменяет value кнопки

  • void SetCopyShow()

    Изменяет флаг показа кнопки для копирования

  • void SetDeleteConfirm()

    Изменяет сообщение, выводимое при удалении

  • void SetDeleteShow()

    Изменяет флаг показа кнопки удалить

  • void SetEditShow()

    Изменяет флаг показа кнопки редактировать

  • void SetFieldActionShow()

    Изменяет флаг вывода поля с действиями

  • void SetFieldCopy()

    Изменяет поле для копирования

  • void SetFieldDelete()

    Изменяет поле для удаления

  • void SetFieldEdit()

    Изменяет поле для редактирования

  • void SetFormAction()

    Изменяет action формы

  • void SetHtml()

    Устанавливает значение свойству html

  • void SetImage()

    Изменяет значение свойства - путь к картинке

  • void SetKeyId()

    Изменяет ключевое поле

  • void SetMas()

    Изменяет массив экземпляров класса table_fields

  • void SetQuery()

    Изменяет запрос для выборки данных

  • void SetTableWidth()

    Изменяет ширину таблицы

Унаследованные методы

Описания методов

    show_table::do_show_table

do_show_table(
 );

    Описание

    Метод отображает сформированную таблицу

    [ Top ]

    show_table::GetSelect

GetSelect(
array
$mas, string
$index_selected );

    Принимаемые параметры

    $mas

    - массив, элементами которого заполняется тег select

    $index_selected

    - индекс элемента, выводимого по умолчанию

    Возвращает

    html-содержимого тега select

    Описание

    Метод формирования html содержимого тега select

    [ Top ]

    show_table::SetActionWidth

SetActionWidth(
string
$action_width );

    Принимаемые параметры

    $action_width

    - ширина поля Действие

    Описание

    Изменяет ширину поля Действие

    [ Top ]

    show_table::SetButton

SetButton(
unknown_type
$button );

    Принимаемые параметры

    $button

    Описание

    Изменяет флаг вывода кнопки

    [ Top ]

    show_table::SetButtonName

SetButtonName(
string
$button_name );

    Принимаемые параметры

    $button_name

    Описание

    Устанавливает наименование кнопки

    [ Top ]

    show_table::SetButtonValue

SetButtonValue(
unknown_type
$button_value );

    Принимаемые параметры

    $button_value

    Описание

    Изменяет value кнопки

    [ Top ]

    show_table::SetCopyShow

SetCopyShow(
boolean
$copy_show );

    Принимаемые параметры

    $copy_show

    - значение флага показа кнопки копирования

    Описание

    Изменяет флаг показа кнопки для копирования

    [ Top ]

    show_table::SetDeleteConfirm

SetDeleteConfirm(
string
$delete_confirm );

    Принимаемые параметры

    $delete_confirm

    - сообщение выводимое при удалении строки

    Описание

    Изменяет сообщение, выводимое при удалении

    [ Top ]

    show_table::SetDeleteShow

SetDeleteShow(
boolean
$delete_show );

    Принимаемые параметры

    $delete_show

    - значение флага показа кнопки удаления

    Описание

    Изменяет флаг показа кнопки удалить

    [ Top ]

    show_table::SetEditShow

SetEditShow(
boolean
$edit_show );

    Принимаемые параметры

    $edit_show

    - значение флага показа кнопки редактирования

    Описание

    Изменяет флаг показа кнопки редактировать

    [ Top ]

    show_table::SetFieldActionShow

SetFieldActionShow(
boolean
$field_action_show );

    Принимаемые параметры

    $field_action_show

    - значение флага вывода поля с действиями

    Описание

    Изменяет флаг вывода поля с действиями

    [ Top ]

    show_table::SetFieldCopy

SetFieldCopy(
int
$field_copy );

    Принимаемые параметры

    $field_copy

    - идентификатор поля для копирования

    Описание

    Изменяет поле для копирования

    [ Top ]

    show_table::SetFieldDelete

SetFieldDelete(
int
$field_delete );

    Принимаемые параметры

    $field_delete

    - идентификатор поля для удаления

    Описание

    Изменяет поле для удаления

    [ Top ]

    show_table::SetFieldEdit

SetFieldEdit(
unknown_type
$field_edit );

    Принимаемые параметры

    $field_edit

    Описание

    Изменяет поле для редактирования

    [ Top ]

    show_table::SetFormAction

SetFormAction(
unknown_type
$form_action );

    Принимаемые параметры

    $form_action

    Описание

    Изменяет action формы

    [ Top ]

    show_table::SetHtml

SetHtml(
string
$html );

    Принимаемые параметры

    $html

    - значение свойства $html

    Описание

    Устанавливает значение свойству html

    [ Top ]

    show_table::SetImage

SetImage(
string
$image );

    Принимаемые параметры

    $image

    - путь к изображению, выводимому вместо значения поля

    Описание

    Изменяет значение свойства - путь к картинке

    [ Top ]

    show_table::SetKeyId

SetKeyId(
int
$key_id );

    Принимаемые параметры

    $key_id

    Описание

    Изменяет ключевое поле

    [ Top ]

    show_table::SetMas

SetMas(
string
$mas );

    Принимаемые параметры

    $mas

    Описание

    Изменяет массив экземпляров класса table_fields

    [ Top ]

    show_table::SetQuery

SetQuery(
string
$query );

    Принимаемые параметры

    $query

    Описание

    Изменяет запрос для выборки данных

    [ Top ]

    show_table::SetTableWidth

SetTableWidth(
string
$table_width );

    Принимаемые параметры

    $table_width

    - ширина таблицы

    Описание

    Изменяет ширину таблицы

    [ Top ]

Variable Detail

  • $action_width = 70 [line 218]
    •

  • Data type: mixed
    •

  • $button = false [line 205]
    •

  • Data type: mixed
    •

  • $button_name = '' [line 206]
    •

  • Data type: mixed
    •

  • $button_value = 'Добавить/изменить' [line 207]
    •

  • Data type: mixed
    •

  • $copy_show = false [line 215]
    •

  • Data type: mixed
    •

  • $delete_confirm = 'Вы уверены, что хотите удалить?' [line 220]
    •

  • Data type: mixed
    •

  • $delete_show = true [line 214]
    •

  • Data type: mixed
    •

  • $edit_show = true [line 213]
    •

  • Data type: mixed
    •

  • $field_action_show = true [line 212]
    •

  • Data type: mixed
    •

  • $field_copy = '' [line 211]
    •

  • Data type: mixed
    •

  • $field_delete = '' [line 210]
    •

  • Data type: mixed
    •

  • $field_edit = '' [line 209]
    •

  • Data type: mixed
    •

  • $form_action = '' [line 208]
    •

  • Data type: mixed
    •

  • $html = '' [line 216]
    •

  • Data type: mixed
    •

  • $image = '' [line 219]
    •

  • Data type: mixed
    •

  • $key_id =  [line 204]
    •

  • Data type: mixed
    •

  • $mas =  [line 203]
    •

  • Data type: mixed
    •

  • $query =  [line 202]
    •

  • Data type: mixed
    •

  • $table_width = '100%' [line 217]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:25 +0400 by phpDocumentor 1.3.0RC3


Docs For Class table_fields

Class table_fields

[line 7]

Размещен: /show_table.class.php

Свойства класса

  • $additional_attribute = ''

  • $additional_filed = ''

  • $additional_filed_value = ''

  • $align = 'align=left'

  • $align_title = 'align=center'

  • $array = ''

  • $attribute = ''

  • $checked = '1'

  • $count_mark_after_separator = 2

  • $dec_point = '.'

  • $field =

  • $FieldForIndexArray = ''

  • $field_description =

  • $field_link = ''

  • $field_name =

  • $field_prefix = ''

  • $field_type = 0

  • $image = ''

  • $image_is_link = false

  • $image_link = ''

  • $IndexForArray = ''

  • $mas_image =

  • $size = 5

  • $thousands_sep = ' '

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • table_fields table_fields()

    Метод, установления свойств класса

Унаследованные методы

Описания методов

    table_fields::table_fields

table_fields(
[mixed
$mas = array()], array
$mas
 );

    Принимаемые параметры

    $mas

    $mas['field_description'] - название столбца таблицы  $mas['field_name'] - наименования поля  $mas['field_type'] - тип столбца  $mas['field_prefix'] - префикс имени  $mas['field_link'] - ссылка  $mas['checked'] - свойства, определяющее является ли элемент элемент checkbox в столбце выделенным  $mas['align'] - выравнивание для поля  $mas['align_title'] - выравнивание для заголовка  $mas['size'] - длина поля ввода  $mas['attribute'] - свойство, содержащее  значения атрибутов столбца таблицы  $mas['mas_image'] - массив картинок для значений поля  $mas['field'] - наименование поля при выводе картинки вместо значения поля  $mas['image_is_link'] - параметр, указывающий является изображение, выводимое вместо значения поля ссылкой;  $mas['image_link'] - текст, дописываемый для картинки-ссылки  $mas['FieldForIndexArray'] -  имя поля, служащего индексом для ассоциативного массива  $mas['array'] - параметр, используемый для вывода массива  $mas['additional_filed'] - параметр - дополнительное поле, определяющий выводим мы дополнительные атрибуты или нет  $mas['additional_filed_value'] - значение параметра $mas['additional_filed'], при котором мы выводим дополнительные атрибуты  $mas['additional_attribute'] - ширина и другие атрибуты ячейки, применение которых зависит от дополнительного поля  $mas['image'] - путь к файлу картинки  $mas['count_mark_after_separator'] - количество знаков после запятой для форматирования строки  $mas['dec_point'] - разделитель, используемый в качестве десятичной точки  $mas['thousands_sep'] - разделитель для групп (по умолчанию пробел)

    Описание

    Метод, установления свойств класса

    [ Top ]

Variable Detail

  • $additional_attribute = '' [line 39]
    •

  • Data type: mixed
    •

  • $additional_filed = '' [line 37]
    •

  • Data type: mixed
    •

  • $additional_filed_value = '' [line 38]
    •

  • Data type: mixed
    •

  • $align = 'align=left' [line 26]
    •

  • Data type: mixed
    •

  • $align_title = 'align=center' [line 27]
    •

  • Data type: mixed
    •

  • $array = '' [line 36]
    •

  • Data type: mixed
    •

  • $attribute = '' [line 29]
    •

  • Data type: mixed
    •

  • $checked = '1' [line 25]
    •

  • Data type: mixed
    •

  • $count_mark_after_separator = 2 [line 42]
    •

  • Data type: mixed
    •

  • $dec_point = '.' [line 43]
    •

  • Data type: mixed
    •

  • $field =  [line 31]
    •

  • Data type: mixed
    •

  • $FieldForIndexArray = '' [line 34]
    •

  • Data type: mixed
    •

  • $field_description =  [line 9]
    •

  • Data type: mixed
    •

  • $field_link = '' [line 24]
    •

  • Data type: mixed
    •

  • $field_name =  [line 10]
    •

  • Data type: mixed
    •

  • $field_prefix = '' [line 23]
    •

  • Data type: mixed
    •

  • $field_type = 0 [line 11]
    •

  • Data type: mixed
    •

  • $image = '' [line 40]
    •

  • Data type: mixed
    •

  • $image_is_link = false [line 32]
    •

  • Data type: mixed
    •

  • $image_link = '' [line 33]
    •

  • Data type: mixed
    •

  • $IndexForArray = '' [line 35]
    •

  • Data type: mixed
    •

  • $mas_image =  [line 30]
    •

  • Data type: mixed
    •

  • $size = 5 [line 28]
    •

  • Data type: mixed
    •

  • $thousands_sep = ' ' [line 44]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:26 +0400 by phpDocumentor 1.3.0RC3


Docs For Class site

Class site

[line 11]

Размещен: /Site/Site.class.php

Описание

Класс модуля "Сайты"

Свойства класса

  • $count_row =

  • $error =

  • $record_on_page = ON_PAGE

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • true current_alias()

    Метод преобразования алиаса (домена) сайта в основной

  • true del_alias()

    Метод преобразования алиаса (домена) сайта в основной

  • resource del_site()

    Метод удаления информации о сайте

  • mixed GetAlias()

    Метод получения данных об алиасе сайта

  • string GetCurrentAlias()

    Метод определения основного алиаса сайта

  • array GetSite()

    Метод получения данных о сайте по его  идентификатору

  • int insert_alias()

    Метод вставки/обновления информации об алиасе (домене) сайта

  • int insert_site()

    Метод вставки/обновления информации о сайте

  • resource select_alias()

    Метод получения информации об алиасе (домене) сайта

  • resource select_site()

    Метод получения данных о сайте

Унаследованные методы

Описания методов

    site::current_alias

current_alias(
unknown_type
$site_id, unknown_type
$id );

    Принимаемые параметры

    $site_id

    – идентификатор сайта

    $id

    – идентификатор алиаса сайта, который необходимо сделать основным

    Описание

    Метод преобразования алиаса (домена) сайта в основной

    [ Top ]

    site::del_alias

del_alias(
int
$id );

    Принимаемые параметры

    $id

    – – идентификатор алиаса сайта, который необходимо сделать основным

    Описание

    Метод преобразования алиаса (домена) сайта в основной

    [ Top ]

    site::del_site

del_site(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор удаляемого сайта

    Описание

    Метод удаления информации о сайте

    [ Top ]

    site::GetAlias

GetAlias(
string
$alias_name );

    Принимаемые параметры

    $alias_name

    Возвращает

    array данные об алиасе, false - если алиас не найден

    Описание

    Метод получения данных об алиасе сайта

    [ Top ]

    site::GetCurrentAlias

GetCurrentAlias(
unknown_type
$site_id );

    Принимаемые параметры

    $site_id

    – идентификатор сайта

    Возвращает

    имя основного алиаса сайта или false – в случае если основной алиас не найден

    Описание

    Метод определения основного алиаса сайта

    [ Top ]

    site::GetSite

GetSite(
[int
$site_id = CURRENT_SITE] );

    Принимаемые параметры

    $site_id

    – идентификатор сайта (по умолчанию равен идентификатору текущего сайта)

    Возвращает

    ассоциативный массив с информацией о сайте, если такой сайт существует или false – в противном случае

    Описание

    Метод получения данных о сайте по его  идентификатору

    [ Top ]

    site::insert_alias

insert_alias(
int
$type, int
$alias_id, int
$site_id, string
$alias_name, int
$alias_current );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации об алиасе сайта (0 – вставка, 1 - обновление)

    $alias_id

    – идентификатор обновляемого алиаса сайта (при вставке алиаса равен 0)

    $site_id

    – идентификатор сайта, для которого добавляется/обновляется алиас

    $alias_name

    – название алиаса сайта

    $alias_current

    – параметр, указывающий является ли алиас сайта основным (1 – основной, 0 - неосновной)

    Возвращает

    идентификатор добавляемого/обновляемого алиаса сайта

    Описание

    Метод вставки/обновления информации об алиасе (домене) сайта

    [ Top ]

    site::insert_site

insert_site(
int
$type, int
$site_id, string
$site_name, int
$site_is_active, string
$site_coding, int
$site_order, string
$site_locale, int
$site_max_size_load_image, int
$site_max_size_load_image_big, string
$site_admin_email, string
$site_backup_dir, string
$site_chmod, string
$site_date_format, string
$site_date_time_format, string
$site_error, int
$site_error404, int
$site_access_denied, string
$site_robots );

    Принимаемые параметры

    $type

    – параметр, определяющий производится вставка или обновление информации о сайте (0 – вставка, 1 - обновление)

    $site_id

    – идентификатор сайта, информация о котором обновляется

    $site_name

    – название добавляемого/обновляемого сайта

    $site_is_active

    – параметр, определяющий  активность (доступность) сайта (1 – активен,    0 - неактивен)

    $site_coding

    – кодировка, используемая сайтом

    $site_order

    – порядок сортировки сайта в административной части

    $site_locale

    – используемая локаль

    $site_max_size_load_image

    – максимальный размер малых изображений загружаемых на сайт

    $site_max_size_load_image_big

    – максимальный размер больших картинок загружаемых на сайт

    $site_admin_email

    – электронный адрес администратора сайта

    $site_backup_dir

    – адрес директории для резервных копий

    $site_chmod

    – права доступа к файлам

    $site_date_format

    – формат даты

    $site_date_time_format

    – формат даты-времени

    $site_error

    – режим вывода ошибок

    $site_error404

    – страница, отображаемая при возникновении 404 ошибки (страница не найдена),  если страница не указана, производится редирект на главную страницу

    $site_access_denied

    – страница, отображаемая при попытке доступа пользователя, не имеющего права доступа

    $site_robots

    – содержимое файла robots.txt для данного сайта

    Возвращает

    идентификатор добавленного или обновленного сайта

    Описание

    Метод вставки/обновления информации о сайте

    [ Top ]

    site::select_alias

select_alias(
int
$id );

    Принимаемые параметры

    $id

    – идентификатор алиаса, о котором необходимо получить информацию

    Возвращает

    данные об алиасе сайта

    Описание

    Метод получения информации об алиасе (домене) сайта

    [ Top ]

    site::select_site

select_site(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор сайта

    Описание

    Метод получения данных о сайте

    [ Top ]

Variable Detail

  • $count_row =  [line 15]
    •

  • Data type: mixed
    •

  • $error =  [line 13]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [line 14]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:26 +0400 by phpDocumentor 1.3.0RC3


Docs For Class SiteUsers

Class SiteUsers

[line 11]

Размещен: /Site_users/Site_users.class.php

Описание

Класс модуля "Пользователи сайта"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • int AddSiteUser()

    Метод добавления нового пользователя в систему

  • boolean CopyExtraProperty()

    Метод копирования дополнительного параметра

  • boolean DeleteExtraProperty()

    Метод удаления дополнительного параматра

  • boolean DeleteSiteUser()

    Метод удаления пользователя из системы

  • boolean DelGroupUser()

    Метод удаления пользователя из группы

  • boolean DelUserGroup()

    Метод удаления группы пользователей заданной идентификатором

  • int GetCurrentSiteUser()

    Метод определения идентификатора текущего пользователя сайта.

  • mixed:
     GetDefaultGroup()

    Метод получения id группы используемой по умолчанию

  • array GetExtraProperty()

    Метод получения значения характеристик дополнительного параметра

  • array GetListExtraProperties()

    Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором

  • mixed:
     GetListPrimaryProperties()

    Метод получения списка значений обязательных для заполнения параметров пользователя определяемого идентификатором

  • array GetUserGroups()

    Метод определения идентификаторов всех групп, в которые входит пользователь

  • mixed:
     GetValueExtraProperty()

    Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра

  • int InsertExtraProperty()

    Метод добавления/редактирования дополнительного параметра

  • boolean InsertUserGroup()

    Метод вставки и обновления информации о группе пользователей

  • boolean InsertUsers()

    Метод добавления пользователя в группу

  • boolean OrderExtraProperty()

    Метод обновления коэффициентов порядка сортировки

  • void PrivateOfficeXML()

    Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону

  • void RegistrationXML()

    Метод формирования XML для раздела регистрации и вывода его на экран согласно указанному xsl шаблону

  • resource SelectUserType()

    Метод возвращает параметры группы пользователя

  • boolean SendNewPassword()

    Метод отправки нового пароля на почтовый ящик пользователю

  • boolean SendRegistInf()

    Метод отправки пользователю регистрайионной информации

  • boolean SetConfirmation()

    Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)

  • int SetConfirmationID()

    Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки

  • boolean SetDefaultGroup()

    Метод установления группы с указанным идентификатором по умолчанию

  • boolean SetValueExtraProperty()

    Метод установки значения дополнительного параметра пользователя

  • boolean Unregistration()

    Метод дерегистрации пользователя определяемого по индексу(для клиентской части)

  • mixed:
     UpdateSiteUser()

    Метод обновления анкетных данных пользователя

  •  ValidUser()

    Метод определения зарегистрирован ли пользователь

Унаследованные методы

Описания методов

    SiteUsers::AddSiteUser

AddSiteUser(
int
$selected_group, string
$site_user_login, string
$site_user_password, string
$site_user_email, string
$site_user_fio, array
$list, [array
$param = array()] );

    Принимаемые параметры

    $selected_group

    идентификатор группы, в которую бутет автоматически добавлен пользователь

    $site_user_login

    логин

    $site_user_password

    пароль

    $site_user_email

    e-mail

    $site_user_fio

    ФИО пользователя

    $list

    список дополнительных параметров
      $list[$i][0] int идентификатор;
      $list[$i][1] string имя;
      $list[$i][2] string название;
      $list[$i][3] string тип;
      $list[$i][4] int размер значения;
      $list[$i][5] int количество строк;
      $list[$i][6] int количество столбцов;
      $list[$i][7] int выбран(1) или нет(0);
      $list[$i][8] mixed значение по умолчанию;
      $list[$i][9] int порядок сортировки;
      $list[$i][10] string коментарий;
      $list[$i][11] int идентификатор списка;
      $list[$i][12] mixed значение

    $param

    массив необязательных параметров
    $param['allow_access'] - авторизировать пользователя сразу после регистрации

    Возвращает

    идентификатор пользователя, 0,-1,-2,-3 - в случае возникновения раличного рода ошибок
      (0 - ошибка выполнения запроса, -1 - некорректный e-mail, -2 - дублирующийся e-mail, -3 - дублирующийся логин)

    Описание

    Метод добавления нового пользователя в систему

    [ Top ]

    SiteUsers::CopyExtraProperty

CopyExtraProperty(
int
$extraproperty_id );

    Принимаемые параметры

    $extraproperty_id

    идентификатор копируемого дополнительного параметра

    Описание

    Метод копирования дополнительного параметра

    [ Top ]

    SiteUsers::DeleteExtraProperty

DeleteExtraProperty(
int
$extraproperty_id );

    Принимаемые параметры

    $extraproperty_id

    идентификатор дополнительного параметра

    Описание

    Метод удаления дополнительного параматра

    [ Top ]

    SiteUsers::DeleteSiteUser

DeleteSiteUser(
int
$site_users_id );

    Принимаемые параметры

    $site_users_id

    - идентификатор удаляемого пользователя

    Описание

    Метод удаления пользователя из системы

    [ Top ]

    SiteUsers::DelGroupUser

DelGroupUser(
int
$site_users_id, [mixed
$site_users_group_id = -1], int
$site_users_group_id=-1 );

    Принимаемые параметры

    $site_users_id

    идентификатор группы

    $site_users_group_id=-1

    идентификатор пользователя сайта(-1 исключаем пользователя из всех групп)

    Описание

    Метод удаления пользователя из группы

    [ Top ]

    SiteUsers::DelUserGroup

DelUserGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы пользователей

    Описание

    Метод удаления группы пользователей заданной идентификатором

    [ Top ]

    SiteUsers::GetCurrentSiteUser

GetCurrentSiteUser(
 );

    Возвращает

    идентификатор текущего пользователя сайта (пользователь не задан - 0)

    Описание

    Метод определения идентификатора текущего пользователя сайта.

    [ Top ]

    SiteUsers::GetDefaultGroup

GetDefaultGroup(
 );

    Возвращает

    int идентификатор группы используемой по умолчанию,
      boolean false если запись не найдена

    Описание

    Метод получения id группы используемой по умолчанию

    [ Top ]

    SiteUsers::GetExtraProperty

GetExtraProperty(
string
$name_extra_property );

    Принимаемые параметры

    $name_extra_property

    имя дополнительного параметра

    Возвращает

    массив характеристик дополнительных параметров:
      $result[$i][0] int идентификатор;
      $result[$i][1] string имя;
      $result[$i][2] string название;
      $result[$i][3] string тип;
      $result[$i][4] int размер значения;
      $result[$i][5] int количество строк;
      $result[$i][6] int количество столбцов;
      $result[$i][7] int выбран(1) или нет(0);
      $result[$i][8] mixed значение по умолчанию;
      $result[$i][9] int порядок сортировки;
      $result[$i][10] string коментарий;
      $result[$i][11] int идентификатор списка

    Описание

    Метод получения значения характеристик дополнительного параметра

    [ Top ]

    SiteUsers::GetListExtraProperties

GetListExtraProperties(
int
$site_user_id );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    Возвращает

    массив характеристик дополнительных параметров:
      $result[$i][0] int идентификатор;
      $result[$i][1] string имя;
      $result[$i][2] string название;
      $result[$i][3] string тип;
      $result[$i][4] int размер значения;
      $result[$i][5] int количество строк;
      $result[$i][6] int количество столбцов;
      $result[$i][7] int выбран(1) или нет(0);
      $result[$i][8] mixed значение по умолчанию;
      $result[$i][9] int порядок сортировки;
      $result[$i][10] string коментарий;
      $result[$i][11] int идентификатор списка;
      $result[$i][12] mixed значение

    Описание

    Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором

    [ Top ]

    SiteUsers::GetListPrimaryProperties

GetListPrimaryProperties(
int
$site_user_id );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    Возвращает

    array массив:
      $result[0] string логин;
      $result[1] string e-mail;
      $result[2] string Ф.И.О;
      boolean false если не выбрано ни одной записи

    Описание

    Метод получения списка значений обязательных для заполнения параметров пользователя определяемого идентификатором

    [ Top ]

    SiteUsers::GetUserGroups

GetUserGroups(
int
$id );

    Принимаемые параметры

    $id

    идентификатор пользователя

    Возвращает

    ассоциативный массив, индексы которого - идентификаторы групп, а значения единицы

    Описание

    Метод определения идентификаторов всех групп, в которые входит пользователь

    [ Top ]

    SiteUsers::GetValueExtraProperty

GetValueExtraProperty(
int
$site_users_id, string
$name_extra_property );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $name_extra_property

    наименование дополнительного параметра

    Возвращает

    string значение дополнительного параметра,
      string '' если параметр не задан,
      boolean false если операция не выполнена

    Описание

    Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра

    [ Top ]

    SiteUsers::InsertExtraProperty

InsertExtraProperty(
int
$property_id, string
$property_name, string
$property_type, string
$property_title, int
$property_size, int
$property_rows, int
$property_cols, int
$property_checked, string
$property_default_value, int
$property_order, string
$property_comment, int
$lists_id );

    Принимаемые параметры

    $property_id

    идентификатор дополнительного параметра

    $property_name

    имя

    $property_type

    тип

    $property_title

    название

    $property_size

    размер

    $property_rows

    кол-во строк (для большого текстового поля)

    $property_cols

    ширина (для большого текстового поля)

    $property_checked

    значение свойства 'selected' тэга элемента формы

    $property_default_value

    значение по умолчанию

    $property_order

    порядок сортировки

    $property_comment

    комментарий

    $lists_id

    id списка

    Возвращает

    результат выполнения:
      -1 - если неверно задано имя параметра или оно дублируется,

    1. - произошла ошибка выполнения запроса,
    2. - функция выполнена успешно

    Описание

    Метод добавления/редактирования дополнительного параметра

    [ Top ]

    SiteUsers::InsertUserGroup

InsertUserGroup(
int
$site_users_group_id, string
$site_users_group_name, string
$site_users_group_comment );

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы (если 0, то добавление, в противном случае - редактирование)

    $site_users_group_name

    имя группы

    $site_users_group_comment

    коментарий к группе

    Описание

    Метод вставки и обновления информации о группе пользователей

    [ Top ]

    SiteUsers::InsertUsers

InsertUsers(
int
$site_users_group_id, int
$site_user_id );

    Принимаемые параметры

    $site_users_group_id

    идентификатор группы

    $site_user_id

    идентификатор пользователя сайта

    Описание

    Метод добавления пользователя в группу

    [ Top ]

    SiteUsers::OrderExtraProperty

OrderExtraProperty(
array
$mas_orders );

    Принимаемые параметры

    $mas_orders

    массив коэффициентов
      $mas_orders['order<идентификатор параметра>']

    Описание

    Метод обновления коэффициентов порядка сортировки

    [ Top ]

    SiteUsers::PrivateOfficeXML

PrivateOfficeXML(
string
$title, string
$links, string
$xslname );

    Принимаемые параметры

    $title

    заголовок

    $links

    массив с информацией о ссылке:
      $link[$i][0] string текст ссылки,
      $link[$i][1] string адрес ссылки

    $xslname

    наименование xsl шаблона

    Описание

    Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону

    [ Top ]

    SiteUsers::RegistrationXML

RegistrationXML(
string
$title, string
$login, string
$e_mail, string
$fio, array
$extra_properties, string
$xslname, [array
$param = array()] );

    Принимаемые параметры

    $title

    заголовок страницы

    $login

    логин пользователя

    $e_mail

    e-mail пользователя

    $fio

    ФИО пользователя

    $extra_properties

    массив со значениями дополнительных полей:
      $extra_properties[$i][0] int идентификатор;
      $extra_properties[$i][1] string имя;
      $extra_properties[$i][2] string название;
      $extra_properties[$i][3] string тип;
      $extra_properties[$i][4] int размер значения;
      $extra_properties[$i][5] int количество строк;
      $extra_properties[$i][6] int количество столбцов;
      $extra_properties[$i][7] int выбран(1) или нет(0);
      $extra_properties[$i][8] mixed значение по умолчанию;
      $extra_properties[$i][9] int порядок сортировки;
      $extra_properties[$i][10] string коментарий;
      $extra_properties[$i][11] int идентификатор списка;
      $extra_properties[$i][12] mixed значение

    $xslname

    наименование xsl-шаблона

    $param

    массив дополнительных параметров

    Описание

    Метод формирования XML для раздела регистрации и вывода его на экран согласно указанному xsl шаблону

    [ Top ]

    SiteUsers::SelectUserType

SelectUserType(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы пользователей (-1 выбрать все)

    Возвращает

    результат запроса на выборку по идентификатору

    Описание

    Метод возвращает параметры группы пользователя

    [ Top ]

    SiteUsers::SendNewPassword

SendNewPassword(
string
$login, string
$email, [mixed
$xslname = ''], string
$xslname='' );

    Принимаемые параметры

    $login

    логин пользователя

    $email

    e-mail пользователя

    $xslname=''

    xsl-шаблон для письма

    Описание

    Метод отправки нового пароля на почтовый ящик пользователю

    [ Top ]

    SiteUsers::SendRegistInf

SendRegistInf(
array
$param );

    Принимаемые параметры

    $param

    массив параметров, содержит следующие элементы:
      $param['site_user_id'] int идентификатор пользователя,
      $param['xslname'] string шаблон письма пользователю,
      $param['site_user_password'] string пароль пользователя,
      $param['location'] string указатель на страницу перехода после подтверждения регистрации.

    Описание

    Метод отправки пользователю регистрайионной информации

    [ Top ]

    SiteUsers::SetConfirmation

SetConfirmation(
string
$site_user_index );

    Принимаемые параметры

    $site_user_index

    индекс пользователя сайта

    Описание

    Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)

    [ Top ]

    SiteUsers::SetConfirmationID

SetConfirmationID(
int
$site_user_id );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    Возвращает

    значение подтверждения, или -1, если операция не выполнена

    Описание

    Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки

    [ Top ]

    SiteUsers::SetDefaultGroup

SetDefaultGroup(
int
$id );

    Принимаемые параметры

    $id

    идентификатор группы по умолчанию

    Описание

    Метод установления группы с указанным идентификатором по умолчанию

    [ Top ]

    SiteUsers::SetValueExtraProperty

SetValueExtraProperty(
int
$site_users_id, mixed
$extra_property_value, array
$param );

    Принимаемые параметры

    $site_users_id

    идентификатор пользователя

    $extra_property_value

    значение дополнительнго параметра

    $param

    массив дополнительных параметров, позволяющий задать дополнительное свойство как идентификатором, так и именем

    Описание

    Метод установки значения дополнительного параметра пользователя

    [ Top ]

    SiteUsers::Unregistration

Unregistration(
string
$site_user_index );

    Принимаемые параметры

    $site_user_index

    индекс пользователя

    Описание

    Метод дерегистрации пользователя определяемого по индексу(для клиентской части)

    [ Top ]

    SiteUsers::UpdateSiteUser

UpdateSiteUser(
int
$site_user_id, string
$site_user_login, string
$site_user_password, string
$site_user_email, string
$site_user_fio, array
$list );

    Принимаемые параметры

    $site_user_id

    идентификатор пользователя

    $site_user_login

    логин

    $site_user_password

    пароль

    $site_user_email

    e-mail

    $site_user_fio

    ФИО пользователя

    $list

    список дополнительных параметров
      $list[$i][0] int идентификатор;
      $list[$i][1] string имя;
      $list[$i][2] string название;
      $list[$i][3] string тип;
      $list[$i][4] int размер значения;
      $list[$i][5] int количество строк;
      $list[$i][6] int количество столбцов;
      $list[$i][7] int выбран(1) или нет(0);
      $list[$i][8] mixed значение по умолчанию;
      $list[$i][9] int порядок сортировки;
      $list[$i][10] string коментарий;
      $list[$i][11] int идентификатор списка;
      $list[$i][12] mixed значение

    Возвращает

    boolean true при успешном обновлении,
      int 0,-1,-2,-3 - в случае возникновения раличного рода ошибок
      (0 - ошибка выполнения запроса, -1 - некорректный e-mail, -2 - дублирующийся e-mail, -3 - дублирующийся логин)

    Описание

    Метод обновления анкетных данных пользователя

    [ Top ]

    SiteUsers::ValidUser

ValidUser(
string
$login, string
$password );

    Принимаемые параметры

    $login

    логин пользователя

    $password

    пароль пользователя

    Возвращает

    int идентификатор пользователя, если пользователь зарегистрирован,

    1. - пользователь не зарегистрирован,
     -1 - если пользователь зарегистрирован, но не подтвердил свою регистрацию

    Описание

    Метод определения зарегистрирован ли пользователь

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:26 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Structure

Class Structure

[line 9]

Размещен: /Structure/Structure.class.php

Свойства класса

  • $a_count_property =

        Ассоциативный массив-Кэш количества свойств для разных сайтов

  • $cache_structure_property =

        Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.

  • $count_row =

        Количество выбранных элементов

  • $edit_id =

        Идентификатор редактируемого узла структуры

  • $level =

        Максимальный уровень структуры

  • $menu_id =

        Идентификатор раздела меню

  • $parent_id =

        Идентификатор родительского узла элемента структуры

  • $separator = ''

        Разделитель для уровней

  • $StructureMass = array()

        Массив с элементами структуры

  • $StructureParentMass = array()

        Массив родительских разделов

  • $structure_propertys_list =

        Хранит результат запроса на выборку дополнительных свойств структуры

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • mixed add_page()

    Метод добавления и редактирования данных о страницах

  • void ClearStructure()

    Метод очистки параметров класса

  • boolean delete_page()

    Метод удаления страницы

  • истина DelStructurePropertys()

    Метод удаления дополнительного свойства

  • void DelStructurePropertysValue()

    Метод удаления значений дополнительных свойств из таблицы связи

  • string GenXML4InfSys()

    Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры

  • string GenXml4StructureLevelMass()

    Метод генерации части XML-а для записей указанного уровня

  • mixed GetCountProperty4Structure()

    Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют

  • int GetProperrtyMenuId()

    Метод получения информации о текущем разделе меню

  • array GetPropertyACountProperty()

    Метод получения количества свойств для разных сайтов

  • int GetPropertyCountRow()

    Метод получения количества выбранных элементов

  • int GetPropertyEditId()

    Метод полчения информации о редактиремом элементе структуры

  • int GetPropertyLevel()

    Метод получения информации о максимальном уровне

  • int GetPropertyParentId()

    Метод получения идентификатора родительского узла текущего элемента структуры

  • string GetPropertySeparator()

    Метод получения информации о разделителе

  • array GetPropertyStructureMass()

    Метод получения информации об элементах структуры

  • array GetPropertyStructureParentMass()

    Метод получения информации о родительских разделах элемента структуры

  • resource GetPropertyStructurePropertysList()

    Метод получения дополнительных свойств структуры

  • array GetStructure()

    Метод выборки всех страниц структуры

  • int GetStructureAccess()

    Метод получения информации о доступе к узлу элементов структуры

  • boolean GetStructureForParent()

    Метод получения подразделов для раздела

  • mixed GetStructureItem()

    *  Метод получения данных об элементе структуры

  • mixed GetStructurePath()

    Методж= определения полного пути к странице

  • array GetStructureProperty()

    Метод возвращает заполненные св-ва узлов структуры

  • string GetXml4StructurePropertys()

    Метод получения XML для свойств структуры

  • array IndexationStructure()

    Метод индексации элементов структуры

  • int InsertStructurePropertys()

    Метод  вставки и редактирования дополнительного свойства для структуры

  • int InsertStructurePropertysValue()

    Метод вставки и редактирования значения дополнительного свойства в таблице связи

  • mixed IssetPath()

    Метод определения наличия пути

  • boolean NodeIsParent()

    Метод определения принадлежности узла структуры вышестоящему родителю

  • resource SelectStructurePropertys()

    Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)

  • boolean ShowStructure()

    Метод для отображения структуры в клиентской части сайта

  • array SortStructureMass()

    Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией

  • void structure()

    Конструктор

  • void UpdateSubDir()

    Метод обновления идентификатора меню у подразделов определенного раздела

Унаследованные методы

Описания методов

    Structure::add_page

add_page(
int
$type, int
$structure_id, int
$menu_id, int
$templates_id, int
$data_templates_id, int
$site_id, int
$documents_id, int
$structure_parent_id, int
$structure_show, string
$structure_menu_name, string
$structure_title, string
$structure_description, string
$structure_keywords, string
$structure_external_link, int
$structure_order, string
$structure_path_name, int
$structure_type, string
$module, string
$module_config, int
$structure_access, int
$structure_activity, [int
$structure_allow_indexation = 1] );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_id

    идентификатор элемента структуры

    $menu_id

    идентификатор раздела меню

    $templates_id

    идентификатор макета

    $data_templates_id

    идентификатор шаблона страниц

    $site_id

    идентификатор сайта

    $documents_id

    идентификатор документа

    $structure_parent_id

    идентификатор родительского раздела

    $structure_show

    флаг вывода элемента структуры

    $structure_menu_name

    наименование раздела в меню

    $structure_title

    заголовок для раздела

    $structure_description

    описание раздела

    $structure_keywords

    ключевые фразы

    $structure_external_link

    внешняя ссылка для раздела

    $structure_order

    порядок сортировки

    $structure_path_name

    название раздела

    $structure_type

    тип раздела

    $module

    значение для динамической страницы

    $module_config

    конфиг для динамической страницы

    $structure_access

    доступ к разделу

    $structure_activity

    флаг активности раздела

    $structure_allow_indexation

    флаг индексирования раздела

    Возвращает

    идентификатор отредактированного раздела при успешной операции, ложь - при возникновении ошибки

    Описание

    Метод добавления и редактирования данных о страницах

    [ Top ]

    Structure::ClearStructure

ClearStructure(
 );

    Описание

    Метод очистки параметров класса

    [ Top ]

    Structure::delete_page

delete_page(
int
$id );

    Принимаемые параметры

    $id

    идентификатор страницы

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления страницы

    [ Top ]

    Structure::DelStructurePropertys

DelStructurePropertys(
int
$structure_propertys_id );

    Принимаемые параметры

    $structure_propertys_id

    идентификатор удаляемого дополнительного свойства

    Возвращает

    при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления дополнительного свойства

    [ Top ]

    Structure::DelStructurePropertysValue

DelStructurePropertysValue(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идентификатор раздела структуры

    Описание

    Метод удаления значений дополнительных свойств из таблицы связи

    [ Top ]

    Structure::GenXML4InfSys

GenXML4InfSys(
int
$inf_sys_id, int
$menu_id, int
$level, int
$inf_group_id, string
$full_path, [array
$param = array()] );

    Принимаемые параметры

    $inf_sys_id

    идентификатор информационной системы

    $menu_id

    идентификатор меню

    $level

    текущий уровень вложенности

    $inf_group_id

    идентификатор группы элементов информационной системы

    $full_path

    полный путь к текущей группе элементов информационной системы

    $param

    ассоциативный массив включающий следующие параметры:  $param['show_groups'] - отображать ли группы элементов инфосистемы  $param['show_items'] - отображать ли элементы инфосистемы  $param['hidden_groups'] - массив групп, скрытых для показа в текущем меню

    Возвращает

    XML для отображения элементов и групп элементов инфосистем при отображении структуры

    Описание

    Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры

    [ Top ]

    Structure::GenXml4StructureLevelMass

GenXml4StructureLevelMass(
int
$parent_id, array
$access, int
$level, [array
$param = array()] );

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $access

    массив с правами доступа

    $level

    уровень

    $param

    ассоциативный массив включающий следующие параметры:
      $param['show_groups'] - отображать ли группы элементов инфосистемы
      $param['show_items'] - отображать ли элементы инфосистемы
      $param['hidden_groups'] - массив групп, скрытых для показа в текущем меню

    Возвращает

    часть XML-а для записей указанного уровня

    Описание

    Метод генерации части XML-а для записей указанного уровня

    [ Top ]

    Structure::GetCountProperty4Structure

GetCountProperty4Structure(
int
$site_id );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    Возвращает

    число свойств раздела сайта или false, если свойства отсутствуют

    Описание

    Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют

    [ Top ]

    Structure::GetProperrtyMenuId

GetProperrtyMenuId(
 );

    Возвращает

    идентификатор текущего раздела

    Описание

    Метод получения информации о текущем разделе меню

    [ Top ]

    Structure::GetPropertyACountProperty

GetPropertyACountProperty(
 );

    Возвращает

    ассоциативный массив-Кэш количества свойств для разных сайтов

    Описание

    Метод получения количества свойств для разных сайтов

    [ Top ]

    Structure::GetPropertyCountRow

GetPropertyCountRow(
 );

    Возвращает

    количество выбранных элементов

    Описание

    Метод получения количества выбранных элементов

    [ Top ]

    Structure::GetPropertyEditId

GetPropertyEditId(
 );

    Возвращает

    идентификатор редактируемого элемента

    Описание

    Метод полчения информации о редактиремом элементе структуры

    [ Top ]

    Structure::GetPropertyLevel

GetPropertyLevel(
 );

    Возвращает

    значение максимального уровня

    Описание

    Метод получения информации о максимальном уровне

    [ Top ]

    Structure::GetPropertyParentId

GetPropertyParentId(
 );

    Возвращает

    идентификатор родительского узла элемента структуры

    Описание

    Метод получения идентификатора родительского узла текущего элемента структуры

    [ Top ]

    Structure::GetPropertySeparator

GetPropertySeparator(
 );

    Возвращает

    разделитель для уровней

    Описание

    Метод получения информации о разделителе

    [ Top ]

    Structure::GetPropertyStructureMass

GetPropertyStructureMass(
 );

    Возвращает

    массив с элементами структуры

    Описание

    Метод получения информации об элементах структуры

    [ Top ]

    Structure::GetPropertyStructureParentMass

GetPropertyStructureParentMass(
 );

    Возвращает

    информация о родительских разделах

    Описание

    Метод получения информации о родительских разделах элемента структуры

    [ Top ]

    Structure::GetPropertyStructurePropertysList

GetPropertyStructurePropertysList(
 );

    Возвращает

    результат запроса на выборку дополнительных свойств структуры

    Описание

    Метод получения дополнительных свойств структуры

    [ Top ]

    Structure::GetStructure

GetStructure(
string
$separator, int
$site_id, int
$menu_id, int
$level, int
$parent_id, [int
$edit_id = false] );

    Принимаемые параметры

    $separator

    разделитель для уровней

    $menu_id

    идентификатор раздела меню (если не задан - все разделы меню)

    $level

    максимальный уровень

    $parent_id

    идентификатор родительского узла

    $edit_id

    идентификатор редактируемой записи (необязательный параметр), для того, чтобы убрать редактируемую запись из списка возможных род. разделов

    $site_id

    or boolean $site_id идентификатор сайта, если равен 0 или false - то сайт игнорируется

    Возвращает

    информиация обо всех страницах структуры

    Описание

    Метод выборки всех страниц структуры

    [ Top ]

    Structure::GetStructureAccess

GetStructureAccess(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идентификатор страницы структуры

    Возвращает

    structure_access для заданого узла, либо -1 если узел (или один из родительских узлов) не найден.

    Описание

    Метод получения информации о доступе к узлу элементов структуры

    [ Top ]

    Structure::GetStructureForParent

GetStructureForParent(
int
$parent_id, string
$separator, int
$current_level );

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $separator

    разделитель для уровней

    $current_level

    текущий уровень

    Возвращает

    формирует массив с информацией о подразделах, а в случае ошибки возвращает ложь

    Описание

    Метод получения подразделов для раздела

    [ Top ]

    Structure::GetStructureItem

GetStructureItem(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идетификатор структуры

    Возвращает

    ассоциативный массив с данными об узле структуры или false, если узел не найден

    Описание

    *  Метод получения данных об элементе структуры

    [ Top ]

    Structure::GetStructurePath

GetStructurePath(
int
$structure_id, int
$type, [mixed
$path = ''] );

    Принимаемые параметры

    $structure_id

    идентификатор раздела, для него определяется полный пути снизу вверх

    $type

    тип результата (строка-0 или масссив-1)

    $path

    переменная, в которую возвращается результат (строка, либо массив)

    Возвращает

    полный путь к странице (в виде строки или массива)

    Описание

    Методж= определения полного пути к странице

    [ Top ]

    Structure::GetStructureProperty

GetStructureProperty(
array
$propertylist );

    Принимаемые параметры

    $propertylist

    массив ID узлов структуры

    Возвращает

    массив свойств элемента

    Описание

    Метод возвращает заполненные св-ва узлов структуры

    (также метод заполняет значение кэша $this->cache_structure_property)

    [ Top ]

    Structure::GetXml4StructurePropertys

GetXml4StructurePropertys(
int
$structure_id );

    Принимаемые параметры

    $structure_id

    идентификатор раздела структуры

    Возвращает

    XML для свойств структуры

    Описание

    Метод получения XML для свойств структуры

    [ Top ]

    Structure::IndexationStructure

IndexationStructure(
int
$limit, int
$on_step, [array
$parameters = array()] );

    Принимаемые параметры

    $limit

    ограничение (по сколько элементов индексировать)

    $on_step

    шаг для индексации

    $parameters

    массив дополнительных параметров

    Возвращает

    массив с данными о  проиндексированных элементах

    Описание

    Метод индексации элементов структуры

    [ Top ]

    Structure::InsertStructurePropertys

InsertStructurePropertys(
int
$type, int
$structure_propertys_id, int_type
$site_id, string
$structure_propertys_name, int
$structure_propertys_type, int
$structure_propertys_order, string
$structure_propertys_define_value, string
$structure_propertys_xml_name, int
$structure_propertys_lists_id, int
$structure_propertys_information_systems_id );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_propertys_id

    идентификатор дополнительного свойства

    $site_id

    идентификатор сайта

    $structure_propertys_name

    наименование дополнительного свойства

    $structure_propertys_type

    тип дополнительного свойства

    $structure_propertys_order

    порядок сортировки

    $structure_propertys_define_value

    значение по умолчанию для дополнительного свойства

    $structure_propertys_xml_name

    имя xml тега для дополнительного свойства

    $structure_propertys_lists_id

    идентификатор списка (если тип свойства - список)

    $structure_propertys_information_systems_id

    идентификатор информационной системы (для типа информационная система)

    Возвращает

    идентификатор отредактированного (вставленного) дополнительного свойства

    Описание

    Метод  вставки и редактирования дополнительного свойства для структуры

    [ Top ]

    Structure::InsertStructurePropertysValue

InsertStructurePropertysValue(
int
$type, int
$structure_propertys_values_id, int
$structure_id, int
$structure_propertys_id, string
$structure_propertys_values_value );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $structure_propertys_values_id

    идентификатор значения дополнительного свойства

    $structure_id

    идентификатор раздела структуры

    $structure_propertys_id

    идентификатор дополнительного свойства

    $structure_propertys_values_value

    значение дополнительного свойства

    Возвращает

    идентификатор отредактированной (добавленной) записи

    Описание

    Метод вставки и редактирования значения дополнительного свойства в таблице связи

    [ Top ]

    Structure::IssetPath

IssetPath(
array
$path_array, int
$menu_id );

    Принимаемые параметры

    $path_array

    массив с элементами пути, ID меню

    $menu_id

    идентификатор раздела меню

    Возвращает

    идентификатор родительского раздела - при наличии у данного меню страницы с аналогичным путем, false при ее отсутствии

    Описание

    Метод определения наличия пути

    [ Top ]

    Structure::NodeIsParent

NodeIsParent(
int
$children_node_id, int
$parent_node_id );

    Принимаемые параметры

    $children_node_id

    идентификатор дочернего узла

    $parent_node_id

    идетификатор узла - возможного родителя

    Возвращает

    истина, если узел принадлежит родителю, иначе ложь

    Описание

    Метод определения принадлежности узла структуры вышестоящему родителю

    [ Top ]

    Structure::SelectStructurePropertys

SelectStructurePropertys(
int
$site_id, [int
$structure_propertys_id = false] );

    Принимаемые параметры

    $site_id

    идентификатор сайта

    $structure_propertys_id

    идентификатор дополнительного свойства

    Возвращает

    результат выборки информации о дополнительном свойстве (обо всех дополнительных свойствах)

    Описание

    Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)

    [ Top ]

    Structure::ShowStructure

ShowStructure(
int
$menu_id, string
$xsl, [array
$param = array()], [array
$external_propertys = array()] );

    Принимаемые параметры

    $menu_id

    ID меню для отображения

    $xsl

    имя XSL шаблона для отображения

    $param

    содержит дополнительные параметры
      $param['parent_id'] - ID родительского узла
      $param['cache'] - разрешение кэширования, по умолчанию true
      $param['show_groups'] - отображать ли группы элементов инфосистемы, по умолчанию false
      $param['show_items'] - отображать ли элементы инфосистемы, по умолчанию false
      $param['hidden_groups'] - массив групп, скрытых для показа в текущем меню
      $param['site_id'] - ID сайта, для которого отображается структура, по умолчанию равен текущему сайту

    $external_propertys

    многомерный массив дополнительных свойств для включения в исходный XML код

    Возвращает

    истину при успешном отображении меню

    Описание

    Метод для отображения структуры в клиентской части сайта

    [ Top ]

    Structure::SortStructureMass

SortStructureMass(
int
$parent_id, [array
$mass = array()] );

    Принимаемые параметры

    $parent_id

    идентификатор родительского раздела

    $mass

    массив с элементами структуры

    Возвращает

    отсортированный массив

    Описание

    Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией

    [ Top ]

    Structure::structure

structure(
 );

    Описание

    Конструктор

    [ Top ]

    Structure::UpdateSubDir

UpdateSubDir(
int
$id, int
$menu_id );

    Принимаемые параметры

    $id

    идентификатор раздела структуры

    $menu_id

    идентификатор раздела меню

    Описание

    Метод обновления идентификатора меню у подразделов определенного раздела

    [ Top ]

Variable Detail

  • $a_count_property =  [line 72]
    •

  • Data type: array
    •

    Описание

    Ассоциативный массив-Кэш количества свойств для разных сайтов

  • $cache_structure_property =  [line 56]
    •

  • Data type: array
    •

    Описание

    Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.

  • $count_row =  [line 30]
    •

  • Data type: int
    •

    Описание

    Количество выбранных элементов

  • $edit_id =  [line 61]
    •

  • Data type: int
    •

    Описание

    Идентификатор редактируемого узла структуры

  • $level =  [line 20]
    •

  • Data type: int
    •

    Описание

    Максимальный уровень структуры

  • $menu_id =  [line 35]
    •

  • Data type: int
    •

    Описание

    Идентификатор раздела меню

  • $parent_id =  [line 15]
    •

  • Data type: int
    •

    Описание

    Идентификатор родительского узла элемента структуры

  • $separator = '' [line 25]
    •

  • Data type: string
    •

    Описание

    Разделитель для уровней

  • $StructureMass = array() [line 50]
    •

  • Data type: array
    •

    Описание

    Массив с элементами структуры

  • $StructureParentMass = array() [line 45]
    •

  • Data type: array
    •

    Описание

    Массив родительских разделов

  • $structure_propertys_list =  [line 67]
    •

  • Data type: resource
    •

    Описание

    Хранит результат запроса на выборку дополнительных свойств структуры

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:27 +0400 by phpDocumentor 1.3.0RC3


Docs For Class Support

Class Support

[line 11]

Размещен: /Support/Support.class.php

Описание

Класс модуля "Техническая поддержка"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean SupportMail()

    Метод отправки письма с просьбой о технической поддержке

Унаследованные методы

Описания методов

    Support::SupportMail

SupportMail(
string
$name, string
$mail, string
$phone, string
$number, string
$text, string
$sections, string
$priority, string
$subject );

    Принимаемые параметры

    $name

    ФИО пользователя

    $mail

    e-mail пользователя

    $phone

    телефон пользователя

    $number

    номер договора

    $text

    текст сообщения

    $sections

    отдел, в который необходимо направить письмо

    $priority

    приоритет сообщения

    $subject

    тема сообщения

    Возвращает

    истина при удачной отправке письма, ложь - в обратном случае

    Описание

    Метод отправки письма с просьбой о технической поддержке

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:28 +0400 by phpDocumentor 1.3.0RC3


Docs For Class templates

Class templates

[line 11]

Размещен: /Templates/Templates.class.php

Описание

Класс модуля "Шаблоны и макеты"

Свойства класса

  • $count_row =

  • $error =

  • $record_on_page = ON_PAGE

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • int CopyDataTemplate()

    Метод копирования шаблона страниц

  • int CopyTemplate()

    Метод копирования макета

  • boolean del_data_templates()

    Метод удаления шаблона страниц

  • boolean del_templates()

    Метод удаления макета

  • mixed GetTemplate()

    Метод получения информации о макете

  • mixed insert_data_templates()

    Методы добавления (редактирования) шаблонов страниц

  • int insert_template()

    Метод добавления макета

  • resource select_data_templates()

    Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)

Унаследованные методы

Описания методов

    templates::CopyDataTemplate

CopyDataTemplate(
int
$data_template_id );

    Принимаемые параметры

    $data_template_id

    идентификатор копируемого шаблона страниц

    Возвращает

    идентификатор нового добавленного шаблона страниц

    Описание

    Метод копирования шаблона страниц

    [ Top ]

    templates::CopyTemplate

CopyTemplate(
int
$template_id );

    Принимаемые параметры

    $template_id

    идентификатор копируемого макета

    Возвращает

    идентификатор нового добавленного макета

    Описание

    Метод копирования макета

    [ Top ]

    templates::del_data_templates

del_data_templates(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого шаблона

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления шаблона страниц

    [ Top ]

    templates::del_templates

del_templates(
int
$id );

    Принимаемые параметры

    $id

    идентификатор удаляемого макета

    Возвращает

    истина при удачном удалении, ложь - в обратном случае

    Описание

    Метод удаления макета

    [ Top ]

    templates::GetTemplate

GetTemplate(
int
$templates_id );

    Принимаемые параметры

    $templates_id

    идентификатор макета

    Возвращает

    ассоциативный массив с информацией о макете в случае удачной выборки, ложь - если макет не выбран

    Описание

    Метод получения информации о макете

    [ Top ]

    templates::insert_data_templates

insert_data_templates(
int
$type, int
$data_templates_id, string
$data_templates_value, string
$data_templates_name, string
$data_templates_description, int
$data_templates_order );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $data_templates_id

    идентификатор шаблона страниц

    $data_templates_value

    шаблон

    $data_templates_name

    наименование шаблона страниц

    $data_templates_description

    описание шаблона страниц

    $data_templates_order

    порядок сортировки

    Возвращает

    идентификатор добавленного (отредактированного) шаблона в случае успешной операции, ложь - при возникновении ошибки

    Описание

    Методы добавления (редактирования) шаблонов страниц

    [ Top ]

    templates::insert_template

insert_template(
int
$type, int
$templates_id, string
$templates_name, int
$templates_order, string
$templates_main, string
$templates_css );

    Принимаемые параметры

    $type

    тип действия 0 - вставка, 1 - обновление

    $templates_id

    идентификатор макета

    $templates_name

    наименование макета

    $templates_order

    порядок сортировки

    $templates_main

    значение макета

    $templates_css

    таблица стилей для макета

    Возвращает

    идентификатор нового или редатируемого макета (в зависимости от типа действия)

    Описание

    Метод добавления макета

    [ Top ]

    templates::select_data_templates

select_data_templates(
int
$id );

    Принимаемые параметры

    $id

    идентификатор шаблона

    Возвращает

    информация о шаблоне (обо всех щаблонах)

    Описание

    Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)

    [ Top ]

Variable Detail

  • $count_row =  [line 14]
    •

  • Data type: mixed
    •

  • $error =  [line 13]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [line 15]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:28 +0400 by phpDocumentor 1.3.0RC3


Docs For Class url

Class url

[line 11]

Размещен: /Kernel/Url.class.php

Описание

Ядро, класс для работы с адресной строкой

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • string link_len()

    Метод сокращения длины строки

Унаследованные методы

Описания методов

    url::link_len

link_len(
string
$str, int
$max_lenght );

    Принимаемые параметры

    $str

    строка

    $max_lenght

    максимальная длина

    Возвращает

    сокращенная строка

    Описание

    Метод сокращения длины строки

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs For Class user_access

Class user_access

[line 11]

Размещен: /UserAccess/UserAccess.class.php

Описание

Класс модуля "Пользователи раздела администрирования"

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • boolean del_user()

    Метод удаления пользователя

  • boolean del_user_type()

    Метод удаления типа пользователей

  • mixed insert_user()

    Метод вставки и обновления информации о пользователе

  • mixed insert_user_type()

    Метод вставки и обновления информации о типе пользователей

  • mixed select_user()

    Метод получения информации о пользователях пользователе

  • mixed select_user_access()

    Метод получения тнформации о типах доступа пользователей

  • mixed select_user_type()

    Метод выбора типа пользователей

Унаследованные методы

Описания методов

    user_access::del_user

del_user(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор удаляемого пользователя

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления пользователя

    [ Top ]

    user_access::del_user_type

del_user_type(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор типа пользователей

    Возвращает

    true в случае успешного выполнения, false в противном случае

    Описание

    Метод удаления типа пользователей

    [ Top ]

    user_access::insert_user

insert_user(
int
$type, int
$users_id, int
$users_type_id, string
$users_name, string
$users_password, [int
$users_superuser = 0] );

    Принимаемые параметры

    $type

    - параметр, определяющий производится вставка или обновление информации о пользователе

    $users_id

    - идентификатор пользователя, для которого обновляется информация (при вставке равен 0)

    $users_type_id

    - идентификатор типа пользователей, к которому относится пользователь, для которого добавляется/обновляется информация

    $users_name

    - имя пользователя

    $users_password

    - пароль пользователя

    $users_superuser

    - параметр,  определяющий, является пользователь сурерюзером или нет (0 - обычный пользователь, 1 - суперюзер)

    Возвращает

    идентификатор добавленной/обновленной информации о пользователе в случае успешного выполнения метода, 0 или false в противном случае (false - при вставке/обновлении пользователя с именем уже имеющимся в базе данных, 0 - в случае ошибки выполнения запроса)

    Описание

    Метод вставки и обновления информации о пользователе

    [ Top ]

    user_access::insert_user_type

insert_user_type(
int
$type, int
$users_type_id, int
$site_id, string
$users_type_name, string
$users_type_comment );

    Принимаемые параметры

    $type

    - параметр, определяющий производится вставка или обновление информации о типе пользователей

    $users_type_id

    - идентификатор типа пользователей, для которого обновляется информация (при вставке равен 0)

    $site_id

    - идентификатор сайта, к которому принадлежит тип пользователей

    $users_type_name

    - название типа пользователей

    $users_type_comment

    - описпние типа пользователей

    Возвращает

    идентификатор добавленной/обновленной информации о типе пользователей в случае успешного выполнения или false в противном случае

    Описание

    Метод вставки и обновления информации о типе пользователей

    [ Top ]

    user_access::select_user

select_user(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор пользователя

    Возвращает

    ассоциативный массив с информацией о пользователе в случае успешного выполнения, false в противном случае

    Описание

    Метод получения информации о пользователях пользователе

    [ Top ]

    user_access::select_user_access

select_user_access(
mixed
$id );

    Принимаемые параметры

    $id

    - идентификатор типа доступа пользователей, если $id равен false получаем информацию о всех типах доступа пользователей

    Возвращает

    result в случае успешного выполнения метода, false в противном случае

    Описание

    Метод получения тнформации о типах доступа пользователей

    [ Top ]

    user_access::select_user_type

select_user_type(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор типа пользователей

    Возвращает

    result в случае успешного выполнения, false в противном случае

    Описание

    Метод выбора типа пользователей

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs For Class UserAccessDenied

Class UserAccessDenied

[line 11]

Размещен: /Kernel/UserAccess.class.php

Описание

Ядро, класс проверки возможности доступа пользователей BackOffice

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • resource DeleteUserDeniedAccessBefore()

    Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд

  • resource InsertUserDeniedAccess()

    Метод записи в базу информации о неудачной попытке входа в BackOffice

  • resource SelectUserDeniedAccess()

    Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса

Унаследованные методы

Описания методов

    UserAccessDenied::DeleteUserDeniedAccessBefore

DeleteUserDeniedAccessBefore(
string
$current_date, [int
$delta_time = 86400] );

    Принимаемые параметры

    $current_date

    текущая дата

    $delta_time

    число секунд, по умолчанию сутки, от текущего момента времени

    Описание

    Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд

    [ Top ]

    UserAccessDenied::InsertUserDeniedAccess

InsertUserDeniedAccess(
string
$user_ip, string
$current_date );

    Принимаемые параметры

    $user_ip

    IP-адрес пользователя

    $current_date

    текущая дата

    Описание

    Метод записи в базу информации о неудачной попытке входа в BackOffice

    [ Top ]

    UserAccessDenied::SelectUserDeniedAccess

SelectUserDeniedAccess(
string
$user_ip, string
$current_date );

    Принимаемые параметры

    $user_ip

    IP-адрес пользователя

    $current_date

    текущая дата

    Описание

    Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs For Class wysiwyg

Class wysiwyg

[line 11]

Размещен: /Kernel/Wysiwyg.class.php

Описание

Ядро, класс визуального редактора

Свойства класса

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • void show_ws()

    Метод отображает визуальный редактор

Унаследованные методы

Описания методов

    wysiwyg::show_ws

show_ws(
string
$main_text, [int
$templates_id = 0], [string
$ws_name = 'textarea'] );

    Принимаемые параметры

    $main_text

    - соедржит текст, включаемый в редактор

    $templates_id

    - идентификатор шаблона

    $ws_name

    Описание

    Метод отображает визуальный редактор

    [ Top ]

Variable Detail

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:29 +0400 by phpDocumentor 1.3.0RC3


Docs For Class xsl

Class xsl

[line 11]

Размещен: /Xsl/Xsl.class.php

Описание

Класс модуля "XSL-шаблоны"

Свойства класса

  • $count_row =

  • $mas_xsl_dir = array()

  • $record_on_page = ON_PAGE

  • $section_path = ''

Константы класса

Inherited Class Constant Summary

Унаследованные свойства класса

Методы

  • string build()

    Метод обработки XML данных с помощью XSL шаблона

  • unknown CopyXsl()

    Метод копирования XSL-шаблона

  • boolean del_xsl()

    Метод удаления XSL-шаблона

  • boolean del_xsl_dir()

    Метод удаления XSL-раздела

  • array fill_xsl_dir()

    Метод формирования дерева разделов доски объявлений

  • mixed GetXsl()

    Метод получения информаци об XSL-шаблоне по его имени

  • void get_section_path()

    Функция возвращает путь по дереву разделов

  • boolean insert_xsl()

    Метод вставки/обновления XSL

  • mixed insert_xsl_dir()

    Метод вставки и обновления XSL рубрик

  • mixed select_xsl()

    Метод получения данных о XSL-шаблонах

  • mixed select_xsl_dir()

    Метод получения информации о XSL-разделах

Унаследованные методы

Описания методов

    xsl::build

build(
string
$xmlData, string
$template_name );

    Принимаемые параметры

    $xmlData

    - XML данные

    $template_name

    • название XSL шаблона для обработки XML данных

    Возвращает

    результат обработки XML данных XSL шаблоном

    Описание

    Метод обработки XML данных с помощью XSL шаблона

    [ Top ]

    xsl::CopyXsl

CopyXsl(
int
$xsl_id );

    Принимаемые параметры

    $xsl_id

    Описание

    Метод копирования XSL-шаблона

    [ Top ]

    xsl::del_xsl

del_xsl(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор XSL-шаблона

    Возвращает

    true в случае успешного выполнения метода, false в противном случае

    Описание

    Метод удаления XSL-шаблона

    [ Top ]

    xsl::del_xsl_dir

del_xsl_dir(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор XSL-заздела

    Возвращает

    true в случае успешного выполнения метода, false в противном случае

    Описание

    Метод удаления XSL-раздела

    [ Top ]

    xsl::fill_xsl_dir

fill_xsl_dir(
int
$xsl_dir_parent_id, string
$separator );

    Принимаемые параметры

    $xsl_dir_parent_id

    - идентификатор родительского раздела

    $separator

    - символ (строка)-разделитель

    Возвращает

    массив с данными о дереве XSL-разделов

    Описание

    Метод формирования дерева разделов доски объявлений

    [ Top ]

    xsl::GetXsl

GetXsl(
string
$template_name );

    Принимаемые параметры

    $template_name

    - имя XSL-шаблона

    Возвращает

    ассоциативный массив с информацией об XSL-шаблоне в случае успешного выполнения, false в противном случае

    Описание

    Метод получения информаци об XSL-шаблоне по его имени

    [ Top ]

    xsl::get_section_path

get_section_path(
int
$xsl_dir_id );

    Принимаемые параметры

    $xsl_dir_id

    Описание

    Функция возвращает путь по дереву разделов

    [ Top ]

    xsl::insert_xsl

insert_xsl(
int
$type, int
$xsl_id, int
$xsl_dir_id, string
$xsl_name, string
$xsl_value, string
$xsl_comment );

    Принимаемые параметры

    $type

    параметр, определяющий производится вставка или обновление XSL

    $xsl_id

    идентификатор обновляемого XSL шаблона (при вставке нового XSL шаблона равен 0)

    $xsl_dir_id

    идентификатор раздела, к которому относится данный XSL шаблон

    $xsl_name

    имя XSL шаблона

    $xsl_value

    текст XSL шаблона

    $xsl_comment

    комментарий к XSL шаблону

    Возвращает

    true при успешном добавлении/обновлении XSL шаблона, false – в противном случае

    Описание

    Метод вставки/обновления XSL

    [ Top ]

    xsl::insert_xsl_dir

insert_xsl_dir(
int
$type, int
$xsl_dir_id, int
$xsl_dir_parent_id, string
$xsl_dir_name );

    Принимаемые параметры

    $type

    - параметр, определяющий производится

    $xsl_dir_id

    - идентификатор обновляемой рубрики (при вставке равен 0)

    $xsl_dir_parent_id

    - идентификатор родительской рубрики

    $xsl_dir_name

    - название рубрики

    Возвращает

    идентификатор вставленной/обновленной рубрики в случае успешного выполнения, false в противном случае

    Описание

    Метод вставки и обновления XSL рубрик

    [ Top ]

    xsl::select_xsl

select_xsl(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор XSL-шаблона, если необходимо получить информацию о конкретном XSL-шаблоне, -1 - получить информацию о всех XSL-шаблонах

    Возвращает

    result в случае успешного выполнения метода, false в противном случае

    Описание

    Метод получения данных о XSL-шаблонах

    [ Top ]

    xsl::select_xsl_dir

select_xsl_dir(
int
$id );

    Принимаемые параметры

    $id

    - идентификатор XSL-раздела, если необходимо получить информацию о конкретном разделе, -1 - получить информацию о всех XSL-разделах

    Возвращает

    resorce в случае успешного выполнения метода, false в противном случае

    Описание

    Метод получения информации о XSL-разделах

    [ Top ]

Variable Detail

  • $count_row =  [line 13]
    •

  • Data type: mixed
    •

  • $mas_xsl_dir = array() [line 15]
    •

  • Data type: mixed
    •

  • $record_on_page = ON_PAGE [line 14]
    •

  • Data type: mixed
    •

  • $section_path = '' [line 16]
    •

  • Data type: mixed
    •

Описание констант класса

        Documentation generated on Sun, 01 Oct 2006 21:01:30 +0400 by phpDocumentor 1.3.0RC3


Element Index

Index of All Elements

Indexes by package:
HostCMS

$ a b c d e f g h i j k l m n o p q r s t u v w x
top
$
$row['constants_name'] | in file Kernel.php, constant $row['constants_name']
top
a
$action_width | in file show_table.class.php, variable show_table::$action_width
$additional_attribute | in file show_table.class.php, variable table_fields::$additional_attribute
$additional_filed | in file show_table.class.php, variable table_fields::$additional_filed
$additional_filed_value | in file show_table.class.php, variable table_fields::$additional_filed_value
$align | in file show_table.class.php, variable table_fields::$align
$align_title | in file show_table.class.php, variable table_fields::$align_title
$array | in file show_table.class.php, variable table_fields::$array
$attribute | in file show_table.class.php, variable table_fields::$attribute
$a_count_property in file Structure.class.php, variable Structure::$a_count_property
Ассоциативный массив-Кэш количества свойств для разных сайтов
$a_count_property in file InformationSystems.class.php, variable InformationSystem::$a_count_property
Кэш количества свойств
AddAdminMenuItem in file AdminMenu.class.php, method AdminMenu::AddAdminMenuItem()
Метод добавляет элемент в меню раздела администрирования
AddBanner in file Advertisement.class.php, method Advertisement::AddBanner()
Метод добавления/редактирования баннера
AddEditConstants in file Constants.class.php, method Constants::AddEditConstants()
Метод добавления/редактирования данных о константе
AddEditInitialData in file Counter.class.php, method counter::AddEditInitialData()
Метод добавления/редактирования начальных данных для счетчика
AddEditMessage in file Forums.class.php, method Forums::AddEditMessage()
Метод добавления/редактирования сообщения темы
AddEditTheme in file Forums.class.php, method Forums::AddEditTheme()
Метод осуществляет добавление/редактирование темы
AddInclude in file Kernel.class.php, method kernel::AddInclude()
Метод подключает переданный файл или выводит сообщение об ошибке подключения
AddModule in file Kernel.class.php, method kernel::AddModule()
Метод подключения модуля
AddSiteUser in file Site_users.class.php, method SiteUsers::AddSiteUser()
Метод добавления нового пользователя в систему
ADD_COMMENT_DELAY | in file Kernel.php, constant ADD_COMMENT_DELAY
add_modules_version in file Kernel.class.php, method kernel::add_modules_version()
Метод добавления модуля в массив-список модулей
add_page in file Structure.class.php, method Structure::add_page()
Метод добавления и редактирования данных о страницах
Admin in file Admin.class.php, class Admin
Ядро, методы управления разделом администрирования HostCMS
AdminMenu in file AdminMenu.class.php, class AdminMenu
Ядро, класс для формирования меню в разделе администрирования
ADMIN_EMAIL_XSL | in file config.php, constant ADMIN_EMAIL_XSL
admin_init in file Admin.class.php, method Admin::admin_init()
Метод вносит в сессию текущий CURRENT_SITE, инициализирует константы для данного сайта
admin_output.fns.php | procedural page admin_output.fns.php
admin_session_valid in file Admin.class.php, method Admin::admin_session_valid()
Метод проверки авторизации пользователя
Advertisement in file Advertisement.class.php, class Advertisement
Класс модуля "Реклама"
Advertisement.class.php | procedural page Advertisement.class.php
Advertisement.php | procedural page Advertisement.php
AlignTextSpace in file Counter.class.php, method counter::AlignTextSpace()
Метод выравнивания текста по центру с помощью пробелов
AdminMenu.class.php | procedural page AdminMenu.class.php
Admin.class.php | procedural page Admin.class.php
top
b
$BannerCache | in file Advertisement.class.php, variable Advertisement::$BannerCache
$button | in file show_table.class.php, variable show_table::$button
$button_name | in file show_table.class.php, variable show_table::$button_name
$button_value | in file show_table.class.php, variable show_table::$button_value
Backup in file Backup.class.php, class Backup
Класс модуля "Резервное копирование"
Backup.class.php | procedural page Backup.class.php
Backup.php | procedural page Backup.php
BBcode2HTML in file Forums.class.php, method Forums::BBcode2HTML()
Метод замены BBcode на HTML
BeginRecord in file Cache.class.php, method Cache::BeginRecord()
Метод перехватывает информацию, размещаемую в потоке и сохраняет ее в памяти
build in file Xsl.class.php, method xsl::build()
Метод обработки XML данных с помощью XSL шаблона
BuildCapture in file Captcha.class.php, method Captcha::BuildCapture()
Метод для построения изображения CAPTCHA и помещения его текста в сессию
build_counter in file Counter.class.php, method counter::build_counter()
Метод вывода счетчика
top
c
$cache_InformationSystem in file InformationSystems.class.php, variable InformationSystem::$cache_InformationSystem
Кэш данных о информационной системе пример $this->cache_InformationSystem[$id]
$cache_life_time in file Cache.class.php, variable Cache::$cache_life_time
Время жизни кэша, по умолчанию равно 60 секунд
$cache_structure_property in file Structure.class.php, variable Structure::$cache_structure_property
Двумерный массив для хранения св-в структуры. Первый элемент - ID структуры.
$checked | in file show_table.class.php, variable table_fields::$checked
$CommentMass in file InformationSystems.class.php, variable InformationSystem::$CommentMass
Кэш с данными о комментариях
$copy_show | in file show_table.class.php, variable show_table::$copy_show
$count_mark_after_separator | in file show_table.class.php, variable table_fields::$count_mark_after_separator
$count_row | in file Site.class.php, variable site::$count_row
$count_row | in file Mysql.class.php, variable MySQL::$count_row
$count_row | in file Modules.class.php, variable modules_admin::$count_row
$count_row in file Structure.class.php, variable Structure::$count_row
Количество выбранных элементов
$count_row | in file Templates.class.php, variable templates::$count_row
$count_row | in file Xsl.class.php, variable xsl::$count_row
Cache in file Cache.class.php, class Cache
Класс модуля "Кэширование"
Cache in file Cache.class.php, method Cache::Cache()
Конструктор
Cache.class.php | procedural page Cache.class.php
Cache.php | procedural page Cache.php
CACHE_INSTALL | in file Cache.php, constant CACHE_INSTALL
CACHE_LIMIT | in file Cache.php, constant CACHE_LIMIT
Captcha in file Captcha.class.php, class Captcha
Ядро, класс для работы с CAPTCHA
ChangeMySqlDate in file Date.class.php, method DateClass::ChangeMySqlDate()
Метод получения значения даты в формате MySQL путем изменения переданной на заданное число секунд
ChangeNormalDate in file Date.class.php, method DateClass::ChangeNormalDate()
Метод получения значения даты в формате ДД.ММ.ГГГГ ЧЧ:ММ:СС путем изменения переданной на заданное число секунд
CheckBot in file Counter.class.php, method counter::CheckBot()
Метод проверки - является ли user agent ботом
CheckTypeGzip in file Compression.class.php, method compression::CheckTypeGzip()
Метод вовзращает тип сжатия gzip, в противном случае false
ClearAdvertisementList in file Advertisement.class.php, method Advertisement::ClearAdvertisementList()
Метод очищающий список показов, произошедших $count_days назад
ClearCache in file Cache.class.php, method Cache::ClearCache()
Метод удаления всех файлов из кэша
ClearStructure in file Structure.class.php, method Structure::ClearStructure()
Метод очистки параметров класса
CloseForum in file Forums.class.php, method Forums::CloseForum()
Метод, закрывающий/открывающий форум
CloseTheme in file Forums.class.php, method Forums::CloseTheme()
Метод, открыввающий/закрывающий тему для доступа
cms_error_handler in file Error.fns.php, function cms_error_handler()
Ядро, обработчики ошибок в HostCMS
code_ip in file Counter.class.php, method counter::code_ip()
Метод для преобразования IP в HEX
COMMENT_DALAY_ERROR_XSL | in file config.php, constant COMMENT_DALAY_ERROR_XSL
compression in file Compression.class.php, class compression
Класс модуля "Система сжатия (компрессия)"
Compression.class.php | procedural page Compression.class.php
Compression.php | procedural page Compression.php
COMPRESSION_INSTALL | in file Compression.php, constant COMPRESSION_INSTALL
ConfirmGetForm in file Forms.class.php, method Forms::ConfirmGetForm()
Метод, определяющий может ли пользователь отправлять форму
confirm_information_item in file InformationSystems.class.php, method InformationSystem::confirm_information_item()
Метод определения возможности пользователя добавлять информационный элемент
Constants in file Constants.class.php, class Constants
Класс модуля "Константы"
Constants.class.php | procedural page Constants.class.php
Constants.php | procedural page Constants.php
CopyDataTemplate in file Templates.class.php, method templates::CopyDataTemplate()
Метод копирования шаблона страниц
CopyDocuments in file Documents.class.php, method documents::CopyDocuments()
Метод копирования документа
CopyExtraProperty in file Site_users.class.php, method SiteUsers::CopyExtraProperty()
Метод копирования дополнительного параметра
CopyFascicle in file Maillist.class.php, method Maillist::CopyFascicle()
Метод копирования выпуска рассылки
CopyForms in file Forms.class.php, method Forms::CopyForms()
Метод копирования структуры формы и ее полей
CopyFormsField in file Forms.class.php, method Forms::CopyFormsField()
Метод копирования структуры поля формы
CopyInformationItem in file InformationSystems.class.php, method InformationSystem::CopyInformationItem()
Метод копирования элемента информационной системы
CopyListItem in file Lists.class.php, method lists::CopyListItem()
Метод копирования элементов списка
CopyTemplate in file Templates.class.php, method templates::CopyTemplate()
Метод копирования макета
CopyXsl in file Xsl.class.php, method xsl::CopyXsl()
Метод копирования XSL-шаблона
counter in file Counter.class.php, class counter
Класс модуля "Статистика посещаемости сайта"
COUNTER_BOT_COUNT | in file config.php, constant COUNTER_BOT_COUNT
config.php | procedural page config.php
Counter.class.php | procedural page Counter.class.php
Counter.php | procedural page Counter.php
COUNTER_INSTALL | in file Counter.php, constant COUNTER_INSTALL
CreateBackup in file Backup.class.php, method Backup::CreateBackup()
Метод создания резевной копии базы данных
CreateGroupsXmlTree in file InformationSystems.class.php, method InformationSystem::CreateGroupsXmlTree()
Метод формирования XML дерева для информационных групп
CreateRSS in file RssWrite.class.php, method RssWrite::CreateRSS()
Метод формирования XML-файла в стандарте RSS
current_alias in file Site.class.php, method site::current_alias()
Метод преобразования алиаса (домена) сайта в основной
current_version in file Documents.class.php, method documents::current_version()
Метод для переобозначения текущей версии документа
CURRENT_VERSION | in file Kernel.php, constant CURRENT_VERSION
config.php | procedural page config.php
config.php | procedural page config.php
Captcha.class.php | procedural page Captcha.class.php
config.php | procedural page config.php
top
d
$dec_point | in file show_table.class.php, variable table_fields::$dec_point
$delete_confirm | in file show_table.class.php, variable show_table::$delete_confirm
$delete_show | in file show_table.class.php, variable show_table::$delete_show
DateClass in file Date.class.php, class DateClass
Ядро, класс для работы с датами
DateSqlToUnix in file Date.class.php, method DateClass::DateSqlToUnix()
Метод преобразовывает дату в формате SQL в число секунд с начала эпохи
datetime_format in file Date.class.php, method DateClass::datetime_format()
Метод преобразует формат выводы даты-времени из SQL-формата в формат, указанный в константе DATE_TIME_FORMAT
datetime_format_sql in file Date.class.php, method DateClass::datetime_format_sql()
Метод преобразования даты и времени из формата ДД.ММ.ГГ ЧЧ:ММ:СС в формат MySQL
DateUnixToSQL in file Date.class.php, method DateClass::DateUnixToSQL()
Метод преобразовывает дату из числа секунд в формат SQL
date_format in file Date.class.php, method DateClass::date_format()
Метод преобразует формат выводы даты из sql-формата в формат, указанный в константе DATE_FORMAT
date_format_sql in file Date.class.php, method DateClass::date_format_sql()
Метод преобразования даты из формата ДД.ММ.ГГГГ в SQL формат
db_connect in file Mysql.class.php, method MySQL::db_connect()
Метод соединения с БД. В случае невозможности соединения с БД или выбора БД - прерывает работу программы.
declension in file Kernel.class.php, method kernel::declension()
Метод получения существительного в форме, соответствующей числу
decode_ip in file Counter.class.php, method counter::decode_ip()
Метод для декодирования IP из HEX
DEFAULT_LNG | in file Kernel.php, constant DEFAULT_LNG
DelBannerGroup in file Advertisement.class.php, method Advertisement::DelBannerGroup()
Метод исключения баннера из группы
DelBannersGroup in file Advertisement.class.php, method Advertisement::DelBannersGroup()
Метод удаления группы баннеров
DelConstants in file Constants.class.php, method Constants::DelConstants()
Метод удаления константы
DeleteBanner in file Advertisement.class.php, method Advertisement::DeleteBanner()
Метод удаления баннера
DeleteExtraProperty in file Site_users.class.php, method SiteUsers::DeleteExtraProperty()
Метод удаления дополнительного параматра
DeleteForum in file Forums.class.php, method Forums::DeleteForum()
Метод удаления форума
DeleteSiteUser in file Site_users.class.php, method SiteUsers::DeleteSiteUser()
Метод удаления пользователя из системы
DeleteUserDeniedAccessBefore in file UserAccess.class.php, method UserAccessDenied::DeleteUserDeniedAccessBefore()
Метод удаления неудачных попыток входа в BackOffice за период ранее заданного числа секунд
DeleteUsers in file Maillist.class.php, method Maillist::DeleteUsers()
Метод снятия подписки с подписчика
DeleteUsersGroup in file Maillist.class.php, method Maillist::DeleteUsersGroup()
Метод, позволяющий закрыть группе пользователей сайта доступ к рассылке
delete_old_version in file Documents.class.php, method documents::delete_old_version()
Метод удаления записей обо всех не текущих версиях
delete_page in file Structure.class.php, method Structure::delete_page()
Метод удаления страницы
Delete_search_words in file Search.class.php, method Search::Delete_search_words()
Метод удаления из индекса страницы с указанным адресом
delete_status in file Documents.class.php, method documents::delete_status()
Метод удаления статуса документов
delete_version in file Documents.class.php, method documents::delete_version()
Метод удаления записей о версиях
DelFascicle in file Maillist.class.php, method Maillist::DelFascicle()
Метод удаления выпуска рассылки
DelFillForms in file Forms.class.php, method Forms::DelFillForms()
Удаление бланка заполненной формы
DelFillValues in file Forms.class.php, method Forms::DelFillValues()
Метод удаления значения одного из полей отправленной формы
DelForms in file Forms.class.php, method Forms::DelForms()
Метод удаления данных о форме
DelFormsFields in file Forms.class.php, method Forms::DelFormsFields()
Метод удаления поля формы
DelForumsGroup in file Forums.class.php, method Forums::DelForumsGroup()
Метод удаления группы форумов
DelGroupUser in file Site_users.class.php, method SiteUsers::DelGroupUser()
Метод удаления пользователя из группы
DelInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertys()
Метод удаления дополнительного свойства информационной группы
DelInformationGroupPropertysValue in file InformationSystems.class.php, method InformationSystem::DelInformationGroupPropertysValue()
Метод удаления значений дополнительных свойств информационной группы
DelInformationSystem in file InformationSystems.class.php, method InformationSystem::DelInformationSystem()
Метод удаления информационной системы
DelIp in file ip.class.php, method ip::DelIp()
Метод удаления информации об IP-адресе
DELL_TIME | in file config.php, constant DELL_TIME
DelMaillist in file Maillist.class.php, method Maillist::DelMaillist()
Метод удаления рассылки
DelMessage in file Forums.class.php, method Forums::DelMessage()
Метод удаления сообщения темы
DelStatInfomationForSite in file Counter.class.php, method counter::DelStatInfomationForSite()
Метод удаления статистической информации для сайта
DelStructurePropertys in file Structure.class.php, method Structure::DelStructurePropertys()
Метод удаления дополнительного свойства
DelStructurePropertysValue in file Structure.class.php, method Structure::DelStructurePropertysValue()
Метод удаления значений дополнительных свойств из таблицы связи
DelTheme in file Forums.class.php, method Forums::DelTheme()
Метод удаления темы форума
DelUserGroup in file Site_users.class.php, method SiteUsers::DelUserGroup()
Метод удаления группы пользователей заданной идентификатором
del_alias in file Site.class.php, method site::del_alias()
Метод преобразования алиаса (домена) сайта в основной
del_comment in file InformationSystems.class.php, method InformationSystem::del_comment()
Метод удаления комментария к информационному элементу
del_data_templates in file Templates.class.php, method templates::del_data_templates()
Метод удаления шаблона страниц
del_dir in file FileManager.class.php, method FileManager::del_dir()
Метод удаления директории вместе с вложенными файлами и директориями
del_documents in file Documents.class.php, method documents::del_documents()
Метод удаления документов
del_documents_dir in file Documents.class.php, method documents::del_documents_dir()
Метод удаления разделов документов
del_file in file FileManager.class.php, method FileManager::del_file()
Метод удаления файла или директории
del_information_groups in file InformationSystems.class.php, method InformationSystem::del_information_groups()
Метод удаления информационных групп
del_information_items in file InformationSystems.class.php, method InformationSystem::del_information_items()
Метод удаления элемента информационной системы
del_information_propertys in file InformationSystems.class.php, method InformationSystem::del_information_propertys()
Метод удаления дополнительного свойства информационной системы
del_lists in file Lists.class.php, method lists::del_lists()
Метод удаления списка
del_lists_items in file Lists.class.php, method lists::del_lists_items()
Метод удаления элемента списка
del_module in file Modules.class.php, method modules_admin::del_module()
Метод удаления информации о модуле
del_poll in file Polls.class.php, method polls::del_poll()
Метод удаления опроса
del_poll_reply in file Polls.class.php, method polls::del_poll_reply()
Метод удаления варианта ответа
del_site in file Site.class.php, method site::del_site()
Метод удаления информации о сайте
del_templates in file Templates.class.php, method templates::del_templates()
Метод удаления макета
del_user in file UserAccess.class.php, method user_access::del_user()
Метод удаления пользователя
del_user_type in file UserAccess.class.php, method user_access::del_user_type()
Метод удаления типа пользователей
del_xsl in file Xsl.class.php, method xsl::del_xsl()
Метод удаления XSL-шаблона
del_xsl_dir in file Xsl.class.php, method xsl::del_xsl_dir()
Метод удаления XSL-раздела
Diagramm in file Graphic.class.php, method graphic::Diagramm()
Метод рисования круговой диаграммы
DIAGRAMM_LIMIT | in file Counter.php, constant DIAGRAMM_LIMIT
DIAGRAMM_WIDTH | in file Counter.php, constant DIAGRAMM_WIDTH
documents in file Documents.class.php, class documents
Класс модуля "Старницы и документы"
Documents.class.php | procedural page Documents.class.php
Documents.php | procedural page Documents.php
Download in file File.class.php, method File::Download()
Метод возвращает содержимое файла в поток вместе с заголовком в соответствии с типом файла
do_html_footer_admin in file admin_output.fns.php, function do_html_footer_admin()
Функция выводит "подвал" для страниц раздела администрирования
do_html_header_admin in file admin_output.fns.php, function do_html_header_admin()
Функция выводит "шапку" для страниц раздела администрирования
do_show_table in file show_table.class.php, method show_table::do_show_table()
Метод отображает сформированную таблицу
Date.class.php | procedural page Date.class.php
top
e
$edit_id in file Structure.class.php, variable Structure::$edit_id
Идентификатор редактируемого узла структуры
$edit_show | in file show_table.class.php, variable show_table::$edit_show
$error | in file Modules.class.php, variable modules_admin::$error
$error | in file Templates.class.php, variable templates::$error
$error | in file Site.class.php, variable site::$error
$error in file Polls.class.php, variable polls::$error
Enter description here...
EDIT_TIME | in file config.php, constant EDIT_TIME
EndRecord in file Cache.class.php, method Cache::EndRecord()
Метод заканчивает запись из потока, выводит записанную информацию и сохраняет в кэше с именем $CacheName
EventsJournal in file EventsJournal.class.php, class EventsJournal
Ядро, класс журналирования событий
EventsJournalAdmin in file EventsJournal.class.php, class EventsJournalAdmin
Класс модуля "Журнал событий"
EventsJournal.class.php | procedural page EventsJournal.class.php
EventsJournal.php | procedural page EventsJournal.php
EventsMail in file EventsJournal.class.php, method EventsJournalAdmin::EventsMail()
Метод отправки письма с отчетом
ExecDump in file ExecSqlQuery.class.php, method ExecSqlQuery::ExecDump()
Метод выполнения SQL-запроса
ExecSqlQuery in file ExecSqlQuery.class.php, class ExecSqlQuery
Класс модуля "SQL-запросы"
ExecSqlQuery.class.php | procedural page ExecSqlQuery.class.php
ExecSqlQuery.php | procedural page ExecSqlQuery.php
ExternalXml in file ExternalXml.class.php, class ExternalXml
Ядро, класс формирует дерево XML по переданному массиву
E_STRICT | in file Kernel.php, constant E_STRICT
Error.fns.php | procedural page Error.fns.php
EventsJournal.class.php | procedural page EventsJournal.class.php
ExternalXml.class.php | procedural page ExternalXml.class.php
top
f
$field | in file show_table.class.php, variable table_fields::$field
$FieldForIndexArray | in file show_table.class.php, variable table_fields::$FieldForIndexArray
$field_action_show | in file show_table.class.php, variable show_table::$field_action_show
$field_copy | in file show_table.class.php, variable show_table::$field_copy
$field_delete | in file show_table.class.php, variable show_table::$field_delete
$field_description | in file show_table.class.php, variable table_fields::$field_description
$field_edit | in file show_table.class.php, variable show_table::$field_edit
$field_link | in file show_table.class.php, variable table_fields::$field_link
$field_name | in file show_table.class.php, variable table_fields::$field_name
$field_prefix | in file show_table.class.php, variable table_fields::$field_prefix
$field_type | in file show_table.class.php, variable table_fields::$field_type
$flag | in file ExternalXml.class.php, variable ExternalXml::$flag
$form_action | in file show_table.class.php, variable show_table::$form_action
File in file File.class.php, class File
Ядро, класс для работы с файлами
FileManager in file FileManager.class.php, class FileManager
Класс модуля "Файловый менеджер"
FileManager.class.php | procedural page FileManager.class.php
FileManager.php | procedural page FileManager.php
FillMasGroup in file InformationSystems.class.php, method InformationSystem::FillMasGroup()
Метод формирования массива групп самого верхнего уровня для данной информационной системы.
fill_xsl_dir in file Xsl.class.php, method xsl::fill_xsl_dir()
Метод формирования дерева разделов доски объявлений
FLUDE_PROTECTION | in file config.php, constant FLUDE_PROTECTION
Forms in file Forms.class.php, class Forms
Класс модуля "Формы"
Forms.class.php | procedural page Forms.class.php
Forms.php | procedural page Forms.php
Forums in file Forums.class.php, class Forums
Класс модуля "Форумы"
Forums.class.php | procedural page Forums.class.php
Forums.php | procedural page Forums.php
FORUMS_PARAM_INDEX | in file config.php, constant FORUMS_PARAM_INDEX
FORUMS_PATH | in file config.php, constant FORUMS_PATH
File.class.php | procedural page File.class.php
top
g
$GroupMass in file InformationSystems.class.php, variable InformationSystem::$GroupMass
Кэш с данными о группах
Graphic.class.php | procedural page Graphic.class.php
GenAddEditThemeXML in file Forums.class.php, method Forums::GenAddEditThemeXML()
Метод формирования XML для формы добавления/редактирования темы и вывод его на экран в соответствии с указанным xsl шаблоном
GenEditMessageXML in file Forums.class.php, method Forums::GenEditMessageXML()
Метод формирования XML для формы редактирования сообщения и вывод его на экран в соответствии с указанным xsl шаблоном
GenForumsXML in file Forums.class.php, method Forums::GenForumsXML()
Метод, формирующий XML для таблицы групп форумов (форумов) и выводящий его на экран в соответствии с указанным xsl шаблоном
GenGroupXmlTree in file InformationSystems.class.php, method InformationSystem::GenGroupXmlTree()
Метод формирования полного XML дерева информационных групп для информационной системы
GenMessageXML in file Forums.class.php, method Forums::GenMessageXML()
Метод, формирующий XML для таблицы сообщений темы и выводящий его на экран в соответствии с указанным xsl шаблоном
GenSmilesXML in file Forums.class.php, method Forums::GenSmilesXML()
Метод возвращает XML для смайликов
GenThemesXML in file Forums.class.php, method Forums::GenThemesXML()
Метод, формирующий XML для таблицы тем форума и выводящий его на экран в соответствии с указанным xsl шаблоном
GenUserInfoXML in file Forums.class.php, method Forums::GenUserInfoXML()
Метод формирования XML для пользователя форума и вывод информации на экран в соответствии с указанным xsl шаблоном
GenXml in file ExternalXml.class.php, method ExternalXml::GenXml()
Метод генерации XML для переданного массива
GenXML4InfSys in file Structure.class.php, method Structure::GenXML4InfSys()
Метод генерации XML для отображения элементов и групп элементов инфосистем при отображении структуры
GenXml4StructureLevelMass in file Structure.class.php, method Structure::GenXml4StructureLevelMass()
Метод генерации части XML-а для записей указанного уровня
GetAccessItem in file InformationSystems.class.php, method InformationSystem::GetAccessItem()
Метод определения доступности информационного элемента
GetAlias in file Site.class.php, method site::GetAlias()
Метод получения данных об алиасе сайта
GetArrayCacheContent in file Cache.class.php, method Cache::GetArrayCacheContent()
Метод получает сохраненный в кэше массив
GetBotsInfo in file Counter.class.php, method counter::GetBotsInfo()
Метод получения данных о ботах и посещенных ими страницах
GetCacheContent in file Cache.class.php, method Cache::GetCacheContent()
Метод получения содержания кэша для заданного имени
GetCacheLifeTime in file Cache.class.php, method Cache::GetCacheLifeTime()
Метод возвращает время актуальности кэш-файла в секундах
GetCacheName in file Cache.class.php, method Cache::GetCacheName()
Метод возвращает имя кэш-файла для переданного имени
GetCaptchaId in file Captcha.class.php, method Captcha::GetCaptchaId()
Метод генерирует и возвращает уникальный индекс для CAPTCHA
GetCommentInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCommentInformationSystemItem()
Метод получения комментариев информационных элементов
GetConstants in file Constants.class.php, method Constants::GetConstants()
Метод получения данных о константах
GetCounterInform in file Counter.class.php, method counter::GetCounterInform()
Метод получения информации о данных счетчика за определенную дату
GetCountInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetCountInformationSystemItem()
Метод получения количества элементов информационной системы
GetCountProperty4InformationSystem in file InformationSystems.class.php, method InformationSystem::GetCountProperty4InformationSystem()
Метод получения числа свойств информационной системы
GetCountProperty4Structure in file Structure.class.php, method Structure::GetCountProperty4Structure()
Метод, возвращающий число свойств раздела сайта или false, если свойства отсутствуют
GetCountShowingBanner in file Advertisement.class.php, method Advertisement::GetCountShowingBanner()
Метод возвращает количество показов баннера
GetCountShowingBannerAtDay in file Advertisement.class.php, method Advertisement::GetCountShowingBannerAtDay()
Метод возвращает количество показов баннера за конкретный день
GetCurrentAlias in file Site.class.php, method site::GetCurrentAlias()
Метод определения основного алиаса сайта
GetCurrentSiteUser in file Site_users.class.php, method SiteUsers::GetCurrentSiteUser()
Метод определения идентификатора текущего пользователя сайта.
GetCurrentYear in file Kernel.class.php, method kernel::GetCurrentYear()
Метод получения значения текущего года
GetDBVersion in file Kernel.class.php, method kernel::GetDBVersion()
Метод определения версии MySQL
GetDefaultGroup in file Site_users.class.php, method SiteUsers::GetDefaultGroup()
Метод получения id группы используемой по умолчанию
GetDocumentVersion in file Documents.class.php, method documents::GetDocumentVersion()
Метод получения информации о текущей версии документа
GetExpansion in file InformationSystems.class.php, method InformationSystem::GetExpansion()
Метод получения расширения файла
GetExtension in file Kernel.class.php, method kernel::GetExtension()
Метод возвращает расширение файла
GetExternalInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetExternalInformationSystemItem()
Метод получения элементов информационной системы. Переименован с GetInformationSystemItem
GetExtraProperty in file Site_users.class.php, method SiteUsers::GetExtraProperty()
Метод получения значения характеристик дополнительного параметра
GetFileContent in file File.class.php, method File::GetFileContent()
Метод получения содержимого файла
GetForm in file Forms.class.php, method Forms::GetForm()
Метод обработки содержимого отправленной формы
GetFormFields in file Forms.class.php, method Forms::GetFormFields()
Метод получения данных о полях формы
GetForumAccess in file Forums.class.php, method Forums::GetForumAccess()
Метод, возвращающий список групп пользователей имеющих права доступа к указанному форуму
GetGDVersion in file Kernel.class.php, method kernel::GetGDVersion()
Метод определения версии GD библиотеки
GetGroupsInformationSystem in file InformationSystems.class.php, method InformationSystem::GetGroupsInformationSystem()
Метод формирования дерева групп информационной группы
GetIdInformationItem in file InformationSystems.class.php, method InformationSystem::GetIdInformationItem()
Метод определения идентификатора информационного элемента по URL элемента и идентификатору информационной группы
GetImageSize in file Image.class.php, method Image::GetImageSize()
Метод определяет высоту и ширину изображения
GetInformationFromPath in file InformationSystems.class.php, method InformationSystem::GetInformationFromPath()
Метод определения идентификатора информационной группы и идентификатора информационного элемента по значению URI
GetInformationGroupName in file InformationSystems.class.php, method InformationSystem::GetInformationGroupName()
Метод получения имени информационной группы
GetInformationSystem in file InformationSystems.class.php, method InformationSystem::GetInformationSystem()
Метод получения данных об информационной системе
GetInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItem()
Метод для получения данных об информационном элементе
GetInformationSystemItems in file InformationSystems.class.php, method InformationSystem::GetInformationSystemItems()
Метод получения информации об имени информационного элемента, информационной группы и системы, к которым он принадлежит
GetInitialData in file Counter.class.php, method counter::GetInitialData()
Метод получения начальных данных для счетчика
GetIpInfo in file ip.class.php, method ip::GetIpInfo()
Метод получения информации о запретах для переданного ip-адреса
GetIpInformation in file Counter.class.php, method counter::GetIpInformation()
Метод выборки информации для IP-адреса
GetLastModified in file Kernel.class.php, method kernel::GetLastModified()
Метод получения времени последнего изменения страницы
GetList in file Lists.class.php, method lists::GetList()
Метод выборки данных о списках
GetListExtraProperties in file Site_users.class.php, method SiteUsers::GetListExtraProperties()
Метод возвращает список дополнительных параметров для пользователя с указанным идентификатором
GetListItem in file Lists.class.php, method lists::GetListItem()
Метод получения данные об элементе списка
GetListPrimaryProperties in file Site_users.class.php, method SiteUsers::GetListPrimaryProperties()
Метод получения списка значений обязательных для заполнения параметров пользователя определяемого идентификатором
GetMaillistXML in file Maillist.class.php, method Maillist::GetMaillistXML()
Метод генерирующий XML для состояния подписки конкретного пользователя сайта
getmicrotime in file Kernel.class.php, method kernel::getmicrotime()
Метод получения значения времени
GetNewUsersInform in file Counter.class.php, method counter::GetNewUsersInform()
Метод выборки информации о новых пользователях сайта
GetPageInfo in file Search.class.php, method Search::GetPageInfo()
Метод получения информации о проиндексированных страницах
GetPathGroup in file InformationSystems.class.php, method InformationSystem::GetPathGroup()
Метод формирования пути по информационным группам
GetPathItem in file InformationSystems.class.php, method InformationSystem::GetPathItem()
Метод формирования пути к данному информационному элементу
GetProperrtyMenuId in file Structure.class.php, method Structure::GetProperrtyMenuId()
Метод получения информации о текущем разделе меню
GetPropertyACountProperty in file Structure.class.php, method Structure::GetPropertyACountProperty()
Метод получения количества свойств для разных сайтов
GetPropertyCountRow in file InformationSystems.class.php, method InformationSystem::GetPropertyCountRow()
Метод получения числа записей в выборке инфосистем, групп или информационных элементов
GetPropertyCountRow in file Structure.class.php, method Structure::GetPropertyCountRow()
Метод получения количества выбранных элементов
GetPropertyEditId in file Structure.class.php, method Structure::GetPropertyEditId()
Метод полчения информации о редактиремом элементе структуры
GetPropertyError in file InformationSystems.class.php, method InformationSystem::GetPropertyError()
Метод возвращающий код ошибки, возникающей при работе с методами класса
GetPropertyLevel in file Structure.class.php, method Structure::GetPropertyLevel()
Метод получения информации о максимальном уровне
GetPropertyMasInformationGroups | in file InformationSystems.class.php, method InformationSystem::GetPropertyMasInformationGroups()
GetPropertyParentId in file Structure.class.php, method Structure::GetPropertyParentId()
Метод получения идентификатора родительского узла текущего элемента структуры
GetPropertyRecordOnPage in file InformationSystems.class.php, method InformationSystem::GetPropertyRecordOnPage()
Метод получения числа записей, выводимых на страницу
GetPropertyRss in file InformationSystems.class.php, method InformationSystem::GetPropertyRss()
Метод получения значения свойства RSS
GetPropertySectionPath in file InformationSystems.class.php, method InformationSystem::GetPropertySectionPath()
Метод получения значения свойтва, содержащего пути по группам
GetPropertySeparator in file Structure.class.php, method Structure::GetPropertySeparator()
Метод получения информации о разделителе
GetPropertysGroup in file InformationSystems.class.php, method InformationSystem::GetPropertysGroup()
Метод получения данных о дополнительных свойствах информационной группы
GetPropertysInformationSystemItem in file InformationSystems.class.php, method InformationSystem::GetPropertysInformationSystemItem()
Метод получения свойств информационных элементов
GetPropertyStructureMass in file Structure.class.php, method Structure::GetPropertyStructureMass()
Метод получения информации об элементах структуры
GetPropertyStructureParentMass in file Structure.class.php, method Structure::GetPropertyStructureParentMass()
Метод получения информации о родительских разделах элемента структуры
GetPropertyStructurePropertysList in file Structure.class.php, method Structure::GetPropertyStructurePropertysList()
Метод получения дополнительных свойств структуры
GetSearchSystemInform in file Counter.class.php, method counter::GetSearchSystemInform()
Метод выборки информации о поисковых системах
GetSecondaryStat in file Counter.class.php, method counter::GetSecondaryStat()
Метод получения статистической информации из таблицы сессий
GetSelect in file show_table.class.php, method show_table::GetSelect()
Метод формирования html содержимого тега select
GetSite in file Site.class.php, method site::GetSite()
Метод получения данных о сайте по его идентификатору
GetStatArray in file Counter.class.php, method counter::GetStatArray()
Метод получения статистической информации из основной таблицы
GetStatDataArray in file Counter.class.php, method counter::GetStatDataArray()
Метод получения статистических данных за переданный промежуток времени
GetStructure in file Structure.class.php, method Structure::GetStructure()
Метод выборки всех страниц структуры
GetStructureAccess in file Structure.class.php, method Structure::GetStructureAccess()
Метод получения информации о доступе к узлу элементов структуры
GetStructureForParent in file Structure.class.php, method Structure::GetStructureForParent()
Метод получения подразделов для раздела
GetStructureItem in file Structure.class.php, method Structure::GetStructureItem()
* Метод получения данных об элементе структуры
GetStructurePath in file Structure.class.php, method Structure::GetStructurePath()
Методж= определения полного пути к странице
GetStructureProperty in file Structure.class.php, method Structure::GetStructureProperty()
Метод возвращает заполненные св-ва узлов структуры
GetTemplate in file Templates.class.php, method templates::GetTemplate()
Метод получения информации о макете
GetTemplate in file Kernel.class.php, method kernel::GetTemplate()
Метод получения текущего шаблона
GetUseCJ in file Counter.class.php, method counter::GetUseCJ()
Метод получения данных о использовании кукисов и Java
GetUserGroups in file Site_users.class.php, method SiteUsers::GetUserGroups()
Метод определения идентификаторов всех групп, в которые входит пользователь
GetValueExtraProperty in file Site_users.class.php, method SiteUsers::GetValueExtraProperty()
Метод получения значения дополнительного параметра пользователя по идентификатору пользователя и имени параметра
GetXml4StructurePropertys in file Structure.class.php, method Structure::GetXml4StructurePropertys()
Метод получения XML для свойств структуры
GetXmlForInformatioItem in file InformationSystems.class.php, method InformationSystem::GetXmlForInformatioItem()
Метод формирования XML для отображения информационного элемента
GetXsl in file Xsl.class.php, method xsl::GetXsl()
Метод получения информаци об XSL-шаблоне по его имени
get_count_row in file Mysql.class.php, method MySQL::get_count_row()
Метод возвращает количество строк в последнем запросе
get_CSS in file Kernel.class.php, method kernel::get_CSS()
Метод получения CSS стиля для страницы
get_current_page in file Kernel.class.php, method kernel::get_current_page()
Метод получения идентификатора текущего узла структуры
get_current_page_path in file Kernel.class.php, method kernel::get_current_page_path()
Метод получения пути текущей страницы
get_description in file Kernel.class.php, method kernel::get_description()
Метод получения описания страницы
get_documents_dir in file Documents.class.php, method documents::get_documents_dir()
Метод формирования дерева разделов
get_file_perms in file File.class.php, method File::get_file_perms()
Метод получения строки прав доступа к файлу
get_information_groups_path in file InformationSystems.class.php, method InformationSystem::get_information_groups_path()
Метод формирования пути по дереву информационных групп.
get_keywords in file Kernel.class.php, method kernel::get_keywords()
Метод получения ключевых слов страницы
get_mas_information_groups_for_xml in file InformationSystems.class.php, method InformationSystem::get_mas_information_groups_for_xml()
Метод возвращает XML для информационных групп
get_page_id in file Kernel.class.php, method kernel::get_page_id()
Метод определения идентификатора страницы по имени узла стурктуры и идентификатору родителя
get_path in file Documents.class.php, method documents::get_path()
Метод формирования строки ссылок с родительскими разделами
get_polls_name in file Polls.class.php, method polls::get_polls_name()
Метод получения названия опроса
get_section_path in file Xsl.class.php, method xsl::get_section_path()
Функция возвращает путь по дереву разделов
get_title in file Kernel.class.php, method kernel::get_title()
Метод получения заголовка страницы
GISTOGRAMM_LIMIT | in file Counter.php, constant GISTOGRAMM_LIMIT
graphic | in file Graphic.class.php, class graphic
graphic_diagramma in file Graphic.class.php, method graphic::graphic_diagramma()
Метод вывода круговой диаграммы
graphic_gistogramma in file Graphic.class.php, method graphic::graphic_gistogramma()
Метод вывода гистограммы
top
h
$html | in file show_table.class.php, variable show_table::$html
top
i
$image | in file show_table.class.php, variable table_fields::$image
$image | in file show_table.class.php, variable show_table::$image
$image_is_link | in file show_table.class.php, variable table_fields::$image_is_link
$image_link | in file show_table.class.php, variable table_fields::$image_link
$IndexForArray | in file show_table.class.php, variable table_fields::$IndexForArray
$ItemMass in file InformationSystems.class.php, variable InformationSystem::$ItemMass
Кэш с данными об элементах
Image in file Image.class.php, class Image
Ядро, класс для работы с графическими изображениями
imagebar in file Graphic.class.php, method graphic::imagebar()
Метод вывода гистограммы
implode_array in file Kernel.class.php, method kernel::implode_array()
Метод конкатенации элементов многомерного массива. Вызывает себя рекурсивно
IncCountMessage in file Forums.class.php, method Forums::IncCountMessage()
Метод наращивания счётчика количества сообщений для пользователя
IndexationForums in file Forums.class.php, method Forums::IndexationForums()
Метод индексации форумов
IndexationForumsMessages in file Forums.class.php, method Forums::IndexationForumsMessages()
Метод индексации сообщений тем форумов
IndexationStructure in file Structure.class.php, method Structure::IndexationStructure()
Метод индексации элементов структуры
InformationSystem in file InformationSystems.class.php, class InformationSystem
Класс модуля "Информационные системы"
InformationSystemGroupAccess in file InformationSystems.class.php, method InformationSystem::InformationSystemGroupAccess()
Метод определения доступности информационной группы для пользователей сайта
InformationSystemItemAccess in file InformationSystems.class.php, method InformationSystem::InformationSystemItemAccess()
Метод определения доступности информационного элемента для пользователя
InformationSystems.class.php | procedural page InformationSystems.class.php
InformationSystems.php | procedural page InformationSystems.php
InitConstants in file Kernel.class.php, method kernel::InitConstants()
Метод инициализации констант сайта в соответствии с константой CURRENT_SITE
InsertArrayIntoCache in file Cache.class.php, method Cache::InsertArrayIntoCache()
Метод сохраняет в кэше массив
InsertBanners in file Advertisement.class.php, method Advertisement::InsertBanners()
Метод добавления баннера в группу/редактирования приоритета показа баннера в группе
InsertBannersGroup in file Advertisement.class.php, method Advertisement::InsertBannersGroup()
Метод добавления/редактирования информации о группе баннеров
InsertExtraProperty in file Site_users.class.php, method SiteUsers::InsertExtraProperty()
Метод добавления/редактирования дополнительного параметра
InsertFascicle in file Maillist.class.php, method Maillist::InsertFascicle()
Метод добавления/редактирования выпуска рассылки
InsertForms in file Forms.class.php, method Forms::InsertForms()
Метод вставки/обновления информации о форме
InsertFormsFields in file Forms.class.php, method Forms::InsertFormsFields()
Метод вставки/обновления информации о поле формы
InsertFormsFill in file Forms.class.php, method Forms::InsertFormsFill()
Метод вставки/обновления информации о заполнении формы
InsertFormsFillValues in file Forms.class.php, method Forms::InsertFormsFillValues()
Метод вставки/обновления значений заполненной формы
InsertForum in file Forums.class.php, method Forums::InsertForum()
Метод добавления/редактирования форума
InsertForumsGroup in file Forums.class.php, method Forums::InsertForumsGroup()
Метод добавления/редактирования группы форумов
InsertInformationGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationGroups()
Метод вставки/обновления данных об информационной группе
InsertInformationItems in file InformationSystems.class.php, method InformationSystem::InsertInformationItems()
Метод вставки/обновления данных об информационном элементе
InsertInformationPropertys in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertys()
Метод вставки/обновления информации о свойстве информационной системы
InsertInformationPropertysGroups in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroups()
Метод вставки/редактирования информации о дополнительных свойствах групп инфосистемы
InsertInformationPropertysGroupsValue in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysGroupsValue()
Метод вставки/обновления значения свойства информационной группы
InsertInformationPropertysItems in file InformationSystems.class.php, method InformationSystem::InsertInformationPropertysItems()
Метод вставки/обновления значения свойства информационной
InsertInfotmationSystem in file InformationSystems.class.php, method InformationSystem::InsertInfotmationSystem()
Метод вставки/обновления данных об информационной системе
InsertIntoCache in file Cache.class.php, method Cache::InsertIntoCache()
Метод размещает строковые данные в кэше
InsertIp in file ip.class.php, method ip::InsertIp()
Метод вставки/обновления информации об IP-адресе
InsertMaillist in file Maillist.class.php, method Maillist::InsertMaillist()
Метод добавления/редактирования информации о рассылке
InsertRecord in file Counter.class.php, method counter::InsertRecord()
Метод добавления записи в основную таблицу статистики
InsertSession in file Counter.class.php, method counter::InsertSession()
Метод для вставки записи о сессии
InsertStructurePropertys in file Structure.class.php, method Structure::InsertStructurePropertys()
Метод вставки и редактирования дополнительного свойства для структуры
InsertStructurePropertysValue in file Structure.class.php, method Structure::InsertStructurePropertysValue()
Метод вставки и редактирования значения дополнительного свойства в таблице связи
InsertUserDeniedAccess in file UserAccess.class.php, method UserAccessDenied::InsertUserDeniedAccess()
Метод записи в базу информации о неудачной попытке входа в BackOffice
InsertUserGroup in file Site_users.class.php, method SiteUsers::InsertUserGroup()
Метод вставки и обновления информации о группе пользователей
InsertUsers in file Maillist.class.php, method Maillist::InsertUsers()
Метод добавления/редактирования информации о подписчике
InsertUsers in file Site_users.class.php, method SiteUsers::InsertUsers()
Метод добавления пользователя в группу
InsertUsersGroup in file Forums.class.php, method Forums::InsertUsersGroup()
Метод добавления/редактирования группы пользователей для определения доступа к форуму
InsertUsersGroup in file Maillist.class.php, method Maillist::InsertUsersGroup()
Метод, открывающий доступ группе пользователей сайта к рассылке
insert_alias in file Site.class.php, method site::insert_alias()
Метод вставки/обновления информации об алиасе (домене) сайта
insert_comment in file InformationSystems.class.php, method InformationSystem::insert_comment()
Метод вставки/обновления комментария для элемента информационной системы
insert_comment_without_striptags in file InformationSystems.class.php, method InformationSystem::insert_comment_without_striptags()
Метод вставки/обновления комментария без удаления тэгов в передаваемых параметрах
insert_data_templates in file Templates.class.php, method templates::insert_data_templates()
Методы добавления (редактирования) шаблонов страниц
insert_documents in file Documents.class.php, method documents::insert_documents()
Метод вставки и обновления новых документов
insert_documents_dir in file Documents.class.php, method documents::insert_documents_dir()
Метод вставки и обновления разделов документов
insert_lists in file Lists.class.php, method lists::insert_lists()
Метод вставки/обновления данных о списке
insert_lists_items in file Lists.class.php, method lists::insert_lists_items()
Метод вставки/обновления данных об элементе списка
insert_module in file Modules.class.php, method modules_admin::insert_module()
Метод вставки/обновления информации о модуле
insert_poll in file Polls.class.php, method polls::insert_poll()
Метод осуществляет вставку и обновление опросов
insert_poll_reply in file Polls.class.php, method polls::insert_poll_reply()
Метод, осуществляет вставку и обновление вариантов ответов
insert_site in file Site.class.php, method site::insert_site()
Метод вставки/обновления информации о сайте
insert_status in file Documents.class.php, method documents::insert_status()
Метод добавления(редактирования) статусов документов
insert_template in file Templates.class.php, method templates::insert_template()
Метод добавления макета
insert_user in file UserAccess.class.php, method user_access::insert_user()
Метод вставки и обновления информации о пользователе
insert_user_type in file UserAccess.class.php, method user_access::insert_user_type()
Метод вставки и обновления информации о типе пользователей
insert_version in file Documents.class.php, method documents::insert_version()
Метод добавления/редактирования записей о версиях
insert_xsl in file Xsl.class.php, method xsl::insert_xsl()
Метод вставки/обновления XSL
insert_xsl_dir in file Xsl.class.php, method xsl::insert_xsl_dir()
Метод вставки и обновления XSL рубрик
ip in file ip.class.php, class ip
Класс модуля "IP-адреса"
ip.class.php | procedural page ip.class.php
ip.php | procedural page ip.php
IsSearchSystem in file Counter.class.php, method counter::IsSearchSystem()
Метод для определения запроса из поисковой системы. Метод работает с поисковыми системами:
IssetCacheContent in file Cache.class.php, method Cache::IssetCacheContent()
Метод возвращает наличие/отсутствие кэш-файла для переданного имени кэш-элемента
IssetGroup in file InformationSystems.class.php, method InformationSystem::IssetGroup()
Метод проверки наличия среди подгрупп данной группы подгруппы с таким же URL как и во вставляемой/редактируемой группе
IssetGroupItemInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetGroupItemInsertUpdate()
Метод проверки наличия подгруппы с URL, совпадающим с URL информационного элемента относящегося к данной группе, среди подгрупп данной группы. Используется при вставке/обновлении информационного элемента
IssetItem in file InformationSystems.class.php, method InformationSystem::IssetItem()
Метод провери наличия элемента с конкретным URL среди информационных элементов данной группы
IssetItemGroupInsertUpdate in file InformationSystems.class.php, method InformationSystem::IssetItemGroupInsertUpdate()
Метод проверки наличия среди информационных элементов данной группы такой, у которого URL совпадает с URL добавляемой/редактируемой информационной группы
IssetModule in file Modules.class.php, method modules_admin::IssetModule()
Метод проверки наличия активного модуля
IssetPath in file Structure.class.php, method Structure::IssetPath()
Метод определения наличия пути
isset_id in file Counter.class.php, method counter::isset_id()
Метод проверки наличия id сайта
Image.class.php | procedural page Image.class.php
top
j
JPG_QUALITY | in file Kernel.php, constant JPG_QUALITY
top
k
$key_id | in file show_table.class.php, variable show_table::$key_id
kernel in file Kernel.class.php, class kernel
Класс ядра системы управления сайтом HostCMS
Kernel.class.php | procedural page Kernel.class.php
Kernel.php | procedural page Kernel.php
top
l
$level in file Structure.class.php, variable Structure::$level
Максимальный уровень структуры
link_len in file Url.class.php, method url::link_len()
Метод сокращения длины строки
lists in file Lists.class.php, class lists
Класс модуля "Списки"
LISTS_INSTALL | in file Lists.php, constant LISTS_INSTALL
Lists.class.php | procedural page Lists.class.php
Lists.php | procedural page Lists.php
LoadModules in file Kernel.class.php, method kernel::LoadModules()
Метод загрузка модулей системы управления, вызывается при формировании любой страницы, генерируемой HostCMS
LoadModulesLngFile in file Kernel.class.php, method kernel::LoadModulesLngFile()
Метод загрузки языкового файла для модуля
load_files in file FileManager.class.php, method FileManager::load_files()
Метод загрузки файлов
log_access in file EventsJournal.class.php, method EventsJournal::log_access()
Метод протоколирования получения доступа к системе управления
top
m
$mas | in file show_table.class.php, variable show_table::$mas
$MasGroup in file InformationSystems.class.php, variable InformationSystem::$MasGroup
Массив групп
$mas_documents_dir in file Documents.class.php, variable documents::$mas_documents_dir
Массив разделов документов
$mas_image | in file show_table.class.php, variable table_fields::$mas_image
$mas_xsl_dir | in file Xsl.class.php, variable xsl::$mas_xsl_dir
$menu_id in file Structure.class.php, variable Structure::$menu_id
Идентификатор раздела меню
Mysqldump.class.php | procedural page Mysqldump.class.php
Message.fns.php | procedural page Message.fns.php
Mysql.class.php | procedural page Mysql.class.php
Maillist in file Maillist.class.php, class Maillist
Класс модуля "Почтовые рассылки"
Maillist.class.php | procedural page Maillist.class.php
Maillist.php | procedural page Maillist.php
MailReport in file Counter.class.php, method counter::MailReport()
Метод отправки письма с отчетом администратору сайта
MAIL_EVENTS_STATUS | in file Kernel.php, constant MAIL_EVENTS_STATUS
MAX_HEIGHT_AVATAR | in file config.php, constant MAX_HEIGHT_AVATAR
MAX_SIZE_AVATAR | in file config.php, constant MAX_SIZE_AVATAR
MAX_WIDTH_AVATAR | in file config.php, constant MAX_WIDTH_AVATAR
Menu.class.php | procedural page Menu.class.php
Menu.php | procedural page Menu.php
modules_admin in file Modules.class.php, class modules_admin
Класс модуля "Управление модулями"
Modules.class.php | procedural page Modules.class.php
Modules.php | procedural page Modules.php
MySQL in file Mysql.class.php, class MySQL
Ядро, класс для работы с MySQL
MySQL in file Mysql.class.php, method MySQL::MySQL()
Конструктор.
top
n
$new_session in file Counter.class.php, variable counter::$new_session
Флаг добавления новой сессии при обновлении данных счетчика
NodeIsParent in file Structure.class.php, method Structure::NodeIsParent()
Метод определения принадлежности узла структуры вышестоящему родителю
NoticeTheme in file Forums.class.php, method Forums::NoticeTheme()
Метод делающий тему объявлением или наоборот
top
o
ON_PAGE | in file Kernel.php, constant ON_PAGE
ON_PAGE_MESSAGE | in file config.php, constant ON_PAGE_MESSAGE
ON_PAGE_THEME | in file config.php, constant ON_PAGE_THEME
OrderExtraProperty in file Site_users.class.php, method SiteUsers::OrderExtraProperty()
Метод обновления коэффициентов порядка сортировки
OrderForums in file Forums.class.php, method Forums::OrderForums()
Метод изменения порядка сортировки форумов в группе
OrderForumsGroup in file Forums.class.php, method Forums::OrderForumsGroup()
Метод изменения порядка сортировки групп форумов
OS_UNIX | in file tar.class.php, constant OS_UNIX
top
p
$parent_id in file Structure.class.php, variable Structure::$parent_id
Идентификатор родительского узла элемента структуры
$PropertyGroupMass in file InformationSystems.class.php, variable InformationSystem::$PropertyGroupMass
Кэш с данными о дополнительных свойствах информационных групп
$PropertyMass in file InformationSystems.class.php, variable InformationSystem::$PropertyMass
Кэш с данными о свойствах инфоррмационных элементов
Password.class.php | procedural page Password.class.php
PageCompressionBegin in file Compression.class.php, method compression::PageCompressionBegin()
Метод начала приема из стандартного потока содержимого для компрессии
PageCompressionEnd in file Compression.class.php, method compression::PageCompressionEnd()
Метод выводит сжатые данные, размещаемые в потоке
PathCorrection in file FileManager.class.php, method FileManager::PathCorrection()
Метод удаляет потенциально опасных символы из пути или имени файла
polls in file Polls.class.php, class polls
Класс модуля "Опросы"
Polls.class.php | procedural page Polls.class.php
Polls.php | procedural page Polls.php
POLLS_WIDTH | in file Kernel.php, constant POLLS_WIDTH
PrivateOfficeXML in file Site_users.class.php, method SiteUsers::PrivateOfficeXML()
Метод формирования XML для кабинета пользователя и отображение его на экране согласно xsl шаблону
top
q
$query | in file show_table.class.php, variable show_table::$query
query in file Mysql.class.php, method MySQL::query()
Метод выполнения SQL-запроса
quote_smart in file Security.fns.php, function quote_smart()
Экранирует потенциально опасные символы для MySQL запросов
top
r
$record_on_page in file Polls.class.php, variable polls::$record_on_page
Enter description here...
$record_on_page in file Lists.class.php, variable lists::$record_on_page
Количество выводимых элементов на страницу
$record_on_page | in file Modules.class.php, variable modules_admin::$record_on_page
$record_on_page in file Documents.class.php, variable documents::$record_on_page
Число записей, выводимых на странице в административной части
$record_on_page | in file Site.class.php, variable site::$record_on_page
$record_on_page in file RssWrite.class.php, variable RssWrite::$record_on_page
Количество в потоке
$record_on_page | in file Xsl.class.php, variable xsl::$record_on_page
$record_on_page in file ip.class.php, variable ip::$record_on_page
Число записей, отображаемых на странице
$record_on_page | in file Templates.class.php, variable templates::$record_on_page
$result | in file Mysql.class.php, variable MySQL::$result
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
RssRead.class.php | procedural page RssRead.class.php
RssWrite.class.php | procedural page RssWrite.class.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
random_shuffle in file Kernel.class.php, method kernel::random_shuffle()
Метод перемешивания элементов массива. Если передан hash - сортировка будет осуществлена в соответствии с этим значением.
ReadRSS in file RssRead.class.php, method RssRead::ReadRSS()
Метод чтения данных из RSS потока
RegistrationXML in file Site_users.class.php, method SiteUsers::RegistrationXML()
Метод формирования XML для раздела регистрации и вывода его на экран согласно указанному xsl шаблону
RenewMaillist in file Maillist.class.php, method Maillist::RenewMaillist()
Метод обновления информации о подписке для конкретного подписчика
resizeToFile in file Image.class.php, method Image::resizeToFile()
Метод изменения размера изображения
RssRead in file RssRead.class.php, class RssRead
Ядро, класс для чтения RSS
RssWrite in file RssWrite.class.php, class RssWrite
Ядро, класс для генерации RSS
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
ru.php | procedural page ru.php
top
s
$section_path | in file Xsl.class.php, variable xsl::$section_path
$separator in file Structure.class.php, variable Structure::$separator
Разделитель для уровней
$size | in file show_table.class.php, variable table_fields::$size
$StructureMass in file Structure.class.php, variable Structure::$StructureMass
Массив с элементами структуры
$StructureParentMass in file Structure.class.php, variable Structure::$StructureParentMass
Массив родительских разделов
$structure_propertys_list in file Structure.class.php, variable Structure::$structure_propertys_list
Хранит результат запроса на выборку дополнительных свойств структуры
Security.fns.php | procedural page Security.fns.php
Search | in file Search.class.php, class Search
SearchWords in file Search.class.php, method Search::SearchWords()
Поиск списка слов в индексе
Search.class.php | procedural page Search.class.php
Search.php | procedural page Search.php
select in file Mysql.class.php, method MySQL::select()
Метод выбор данных из БД. Количество элементов, выбранных методом, можно получить с помощью метода get_count_row()
SelectBannersGroup in file Advertisement.class.php, method Advertisement::SelectBannersGroup()
Метод получения информации о конкретной группе баннеров или обо всех баннерах
SelectFascicle in file Maillist.class.php, method Maillist::SelectFascicle()
Метод получения данных о выпуске рассылки
SelectForms in file Forms.class.php, method Forms::SelectForms()
Метод выбора данных о формах
SelectFormsFields in file Forms.class.php, method Forms::SelectFormsFields()
Метод выбора данных о поле формы
SelectForum in file Forums.class.php, method Forums::SelectForum()
Метод, возвращающий информацию о форуме
SelectForumsGroup in file Forums.class.php, method Forums::SelectForumsGroup()
Метод, возвращающий информацию о группе форумов
SelectInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::SelectInformationGroupPropertys()
Метод получения данных о свойствах группы информационной системы
SelectInformationGroups in file InformationSystems.class.php, method InformationSystem::SelectInformationGroups()
Метод получения информации об информационных группах конкретной информационной системы
SelectInformationSystem in file InformationSystems.class.php, method InformationSystem::SelectInformationSystem()
Метод получения информации об информационной системе
SelectIp in file ip.class.php, method ip::SelectIp()
Метод получения информации об IP-адресах
SelectListInformationGroupPropertys in file InformationSystems.class.php, method InformationSystem::SelectListInformationGroupPropertys()
Метод получения списка дополнительных свойств информационноq группы данной инфосистемы
SelectListsItems in file Lists.class.php, method lists::SelectListsItems()
Метод получения данных об элементах списка
SelectMaillist in file Maillist.class.php, method Maillist::SelectMaillist()
Метод получения данных о рассылке
SelectMessage in file Forums.class.php, method Forums::SelectMessage()
Метод возвращающий информацию о сообщении
SelectStructurePropertys in file Structure.class.php, method Structure::SelectStructurePropertys()
Метод выбора дополнительного свойства структуры определенного сайта (false - выбор всех)
SelectTheme in file Forums.class.php, method Forums::SelectTheme()
Метод, возвращающий информацию о теме
SelectUser in file Maillist.class.php, method Maillist::SelectUser()
Метод получения информации о состоянии подписки подписчика на рассылку
SelectUserDeniedAccess in file UserAccess.class.php, method UserAccessDenied::SelectUserDeniedAccess()
Метод получения списка неудачных доступов к BackOffice для конкретного ip-адреса
SelectUserType in file Site_users.class.php, method SiteUsers::SelectUserType()
Метод возвращает параметры группы пользователя
select_alias in file Site.class.php, method site::select_alias()
Метод получения информации об алиасе (домене) сайта
select_comments in file InformationSystems.class.php, method InformationSystem::select_comments()
Метод получения комментариев к информационному элементу
select_data_templates in file Templates.class.php, method templates::select_data_templates()
Метод выбора информации о шаблоне страниц или обо всех шаблонах (при $id=-1)
select_documents in file Documents.class.php, method documents::select_documents()
Метод получения информации о документе или обо всех документах
select_documents_dir in file Documents.class.php, method documents::select_documents_dir()
Метод выбора раздела документов
select_information_items in file InformationSystems.class.php, method InformationSystem::select_information_items()
Метод получения данных об информационном элементе
select_information_propertys in file InformationSystems.class.php, method InformationSystem::select_information_propertys()
Метод получения данных о свойствах информационной системы
select_lists_items in file Lists.class.php, method lists::select_lists_items()
Метод получения данных об элементе списка
select_modules in file Modules.class.php, method modules_admin::select_modules()
Метод получения информации о модуле
select_poll in file Polls.class.php, method polls::select_poll()
Метод осуществляет выборку опросов
select_poll_reply in file Polls.class.php, method polls::select_poll_reply()
Метод выбора вариантов ответов
select_site in file Site.class.php, method site::select_site()
Метод получения данных о сайте
select_status in file Documents.class.php, method documents::select_status()
Метод получения информации о статусе документа
select_user in file UserAccess.class.php, method user_access::select_user()
Метод получения информации о пользователях пользователе
select_user_access in file UserAccess.class.php, method user_access::select_user_access()
Метод получения тнформации о типах доступа пользователей
select_user_type in file UserAccess.class.php, method user_access::select_user_type()
Метод выбора типа пользователей
select_version in file Documents.class.php, method documents::select_version()
Метод выборки информации о версиях
select_xsl in file Xsl.class.php, method xsl::select_xsl()
Метод получения данных о XSL-шаблонах
select_xsl_dir in file Xsl.class.php, method xsl::select_xsl_dir()
Метод получения информации о XSL-разделах
SendFascicle in file Maillist.class.php, method Maillist::SendFascicle()
Метод отправки выпуска всем подписчикам рассылки
SendNewPassword in file Site_users.class.php, method SiteUsers::SendNewPassword()
Метод отправки нового пароля на почтовый ящик пользователю
SendRegistInf in file Site_users.class.php, method SiteUsers::SendRegistInf()
Метод отправки пользователю регистрайионной информации
session_start in file Admin.class.php, method Admin::session_start()
Метод старта сессии для раздела администрирования
SetActionWidth in file show_table.class.php, method show_table::SetActionWidth()
Изменяет ширину поля Действие
SetButton in file show_table.class.php, method show_table::SetButton()
Изменяет флаг вывода кнопки
SetButtonName in file show_table.class.php, method show_table::SetButtonName()
Устанавливает наименование кнопки
SetButtonValue in file show_table.class.php, method show_table::SetButtonValue()
Изменяет value кнопки
SetCacheLifeTime in file Cache.class.php, method Cache::SetCacheLifeTime()
Метод устанавливает время актуальности кэш-файла для запрашиваемого имени
SetConfirmation in file Site_users.class.php, method SiteUsers::SetConfirmation()
Метод установки подтверждения регистрации пользователя определяемого по индексу(для клиентской части)
SetConfirmationID in file Site_users.class.php, method SiteUsers::SetConfirmationID()
Метод установки/снятия подтверждения регистрации пользователя определяемого по идентификатору для админки
SetCopyShow in file show_table.class.php, method show_table::SetCopyShow()
Изменяет флаг показа кнопки для копирования
SetCurrentSite in file Admin.class.php, method Admin::SetCurrentSite()
Метод устанавливает текущий сайт, обрабатывает изменение текущего сайта
SetDefaultGroup in file Site_users.class.php, method SiteUsers::SetDefaultGroup()
Метод установления группы с указанным идентификатором по умолчанию
SetDeleteConfirm in file show_table.class.php, method show_table::SetDeleteConfirm()
Изменяет сообщение, выводимое при удалении
SetDeleteShow in file show_table.class.php, method show_table::SetDeleteShow()
Изменяет флаг показа кнопки удалить
SetEditShow in file show_table.class.php, method show_table::SetEditShow()
Изменяет флаг показа кнопки редактировать
SetFieldActionShow in file show_table.class.php, method show_table::SetFieldActionShow()
Изменяет флаг вывода поля с действиями
SetFieldCopy in file show_table.class.php, method show_table::SetFieldCopy()
Изменяет поле для копирования
SetFieldDelete in file show_table.class.php, method show_table::SetFieldDelete()
Изменяет поле для удаления
SetFieldEdit in file show_table.class.php, method show_table::SetFieldEdit()
Изменяет поле для редактирования
SetFormAction in file show_table.class.php, method show_table::SetFormAction()
Изменяет action формы
SetHtml in file show_table.class.php, method show_table::SetHtml()
Устанавливает значение свойству html
SetImage in file show_table.class.php, method show_table::SetImage()
Изменяет значение свойства - путь к картинке
SetKeyId in file show_table.class.php, method show_table::SetKeyId()
Изменяет ключевое поле
SetLastModified in file Kernel.class.php, method kernel::SetLastModified()
Метод установления времени последнего изменения страницы
SetMas in file show_table.class.php, method show_table::SetMas()
Изменяет массив экземпляров класса table_fields
SetModerator in file Forums.class.php, method Forums::SetModerator()
Метод установления/снятия прав модератора текущего форума для группы пользователей
SetQuery in file show_table.class.php, method show_table::SetQuery()
Изменяет запрос для выборки данных
SetTableWidth in file show_table.class.php, method show_table::SetTableWidth()
Изменяет ширину таблицы
SetTemplate in file Kernel.class.php, method kernel::SetTemplate()
Метод установления текущего шаблона
SetValueExtraProperty in file Site_users.class.php, method SiteUsers::SetValueExtraProperty()
Метод установки значения дополнительного параметра пользователя
set_CSS in file Kernel.class.php, method kernel::set_CSS()
Метод изменения адреса файла CSS-стиля для страницы
set_current_page in file Kernel.class.php, method kernel::set_current_page()
Метод изменения адреса страницы
set_current_page_data_template in file Kernel.class.php, method kernel::set_current_page_data_template()
Метод изменения шаблона страницы
set_description in file Kernel.class.php, method kernel::set_description()
Метод изменения описания страницы
set_keywords in file Kernel.class.php, method kernel::set_keywords()
Метод изменения ключевых слов страницы
set_title in file Kernel.class.php, method kernel::set_title()
Метод изменения заголовока страницы
shop.class.php | procedural page shop.class.php
shop.php | procedural page shop.php
ShowAddComment in file InformationSystems.class.php, method InformationSystem::ShowAddComment()
Метод добавления комментария к элементу информационной системы
ShowBanner in file Advertisement.class.php, method Advertisement::ShowBanner()
Метод показа баннера
ShowBannerGroup in file Advertisement.class.php, method Advertisement::ShowBannerGroup()
Метод показа баннера из указанной группы в соответствии с приоритетом
ShowBannerIsTrue in file Advertisement.class.php, method Advertisement::ShowBannerIsTrue()
Метод, реализующий переход по ссылке баннера и наращивающий счётчик, если с этого показа мы ещё не переходили
ShowCounterCode in file Counter.class.php, method counter::ShowCounterCode()
Метод, осуществляющий вывод кода счетчика
ShowDocument in file Documents.class.php, method documents::ShowDocument()
Метод вызывает показ текущей версии переданной страницы
ShowForm in file Forms.class.php, method Forms::ShowForm()
Метод отображения формы
ShowInformationSystem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystem()
Метод отображения групп и элементов информационной системы
ShowInformationSystemItem in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemItem()
Метод отображения информацию об информационном элементе
ShowInformationSystemRss in file InformationSystems.class.php, method InformationSystem::ShowInformationSystemRss()
Метод отображения RSS ленты
ShowPoll in file Polls.class.php, method polls::ShowPoll()
Метод отображения опроса
ShowPolls in file Polls.class.php, method polls::ShowPolls()
Метод отображения всех активных опросов
ShowStructure in file Structure.class.php, method Structure::ShowStructure()
Метод для отображения структуры в клиентской части сайта
show_CSS in file Kernel.class.php, method kernel::show_CSS()
Метод вывода CSS стиля для страницы
show_current_page in file Kernel.class.php, method kernel::show_current_page()
Метод вывода страницы
show_current_template in file Kernel.class.php, method kernel::show_current_template()
Метод вывода текущего шаблона
show_date in file Counter.class.php, method counter::show_date()
Метод для вывода формы с полями для дат (для вывода статистики)
show_description in file Kernel.class.php, method kernel::show_description()
Метод вывода описания страницы
show_error_message in file Message.fns.php, function show_error_message()
Ядро, функция отображения сообщения об ошибке
show_keywords in file Kernel.class.php, method kernel::show_keywords()
Метод вывода ключевых слов страницы
show_link in file Counter.class.php, method counter::show_link()
Метод для вывода ссылок на различные пункты статистики
show_link in file Documents.class.php, method documents::show_link()
Метод формирования строки ссылок на разделы и подразделы
show_message in file Message.fns.php, function show_message()
Ядро, функция отображения сообщения
show_table | in file show_table.class.php, class show_table
show_table.class.php | procedural page show_table.class.php
show_title in file Kernel.class.php, method kernel::show_title()
Метод вывода заголовка страницы
show_ws in file Wysiwyg.class.php, method wysiwyg::show_ws()
Метод отображает визуальный редактор
site in file Site.class.php, class site
Класс модуля "Сайты"
SiteUsers in file Site_users.class.php, class SiteUsers
Класс модуля "Пользователи сайта"
Site.class.php | procedural page Site.class.php
Site.php | procedural page Site.php
Site_users.class.php | procedural page Site_users.class.php
Site_users.php | procedural page Site_users.php
Smile2HTML in file Forums.class.php, method Forums::Smile2HTML()
Метод замены смайликов на HTML
SortStructureMass in file Structure.class.php, method Structure::SortStructureMass()
Метод сортирует массив StructureMass, возвращает отсортированный массив в соответствии с иерархией
STAT_ON_PAGE | in file Counter.php, constant STAT_ON_PAGE
STAT_PERIOD_STORAGE | in file Counter.php, constant STAT_PERIOD_STORAGE
strips in file Security.fns.php, function strips()
Вызывает stripslashes для всех элементов массива
strips in file Kernel.class.php, method kernel::strips()
Метод удаляет добавленные слэши в суперглобальных массивах при magic_quotes_gpc = on и невозможности отключить через директивы php_flag
Structure | in file Structure.class.php, class Structure
structure in file Structure.class.php, method Structure::structure()
Конструктор
Structure.class.php | procedural page Structure.class.php
Structure.php | procedural page Structure.php
SUPERUSER_EMAIL | in file Kernel.php, constant SUPERUSER_EMAIL
Support in file Support.class.php, class Support
Класс модуля "Техническая поддержка"
SupportMail in file Support.class.php, method Support::SupportMail()
Метод отправки письма с просьбой о технической поддержке
Support.class.php | procedural page Support.class.php
Support.php | procedural page Support.php
symbol2ASCII in file Security.fns.php, function symbol2ASCII()
Возвращает текст с печатаемыми символами ASCII кода
top
t
$table_width | in file show_table.class.php, variable show_table::$table_width
$thousands_sep | in file show_table.class.php, variable table_fields::$thousands_sep
tar.class.php | procedural page tar.class.php
table_fields in file show_table.class.php, method table_fields::table_fields()
Метод, установления свойств класса
table_fields | in file show_table.class.php, class table_fields
templates in file Templates.class.php, class templates
Класс модуля "Шаблоны и макеты"
Templates.class.php | procedural page Templates.class.php
Templates.php | procedural page Templates.php
to_array in file Security.fns.php, function to_array()
Функция приведения аргумента к массиву
to_float in file Security.fns.php, function to_float()
Функция приведения аргумента к вещественному типу
to_int in file Security.fns.php, function to_int()
Функция приведения аргумента к целочисленному типу
to_str in file Security.fns.php, function to_str()
Функция приведения аргумента к строковому типу
top
u
Url.class.php | procedural page Url.class.php
UserAccess.class.php | procedural page UserAccess.class.php
Unregistration in file Site_users.class.php, method SiteUsers::Unregistration()
Метод дерегистрации пользователя определяемого по индексу(для клиентской части)
UpdateSiteUser in file Site_users.class.php, method SiteUsers::UpdateSiteUser()
Метод обновления анкетных данных пользователя
UpdateSubDir in file Structure.class.php, method Structure::UpdateSubDir()
Метод обновления идентификатора меню у подразделов определенного раздела
update_vote in file Polls.class.php, method polls::update_vote()
Метод обработки результата голосования
UPLOADDIR | in file Kernel.php, constant UPLOADDIR
url in file Url.class.php, class url
Ядро, класс для работы с адресной строкой
UserAccessDenied in file UserAccess.class.php, class UserAccessDenied
Ядро, класс проверки возможности доступа пользователей BackOffice
UserAccess.class.php | procedural page UserAccess.class.php
UserAccess.php | procedural page UserAccess.php
UserCanAddComment in file InformationSystems.class.php, method InformationSystem::UserCanAddComment()
Метод определения возможности пользователя добавлять комментарий на оснвании его предыдущих комментариев и разницы во времени. Время между комментариями задается с помощью ADD_COMMENT_DELAY
user_access in file UserAccess.class.php, class user_access
Класс модуля "Пользователи раздела администрирования"
USER_NONE | in file Kernel.php, constant USER_NONE
top
v
ValidCaptcha in file Captcha.class.php, method Captcha::ValidCaptcha()
Метод проверки соответствия введенного пользователем текста хранимому в сессии
ValidUser in file Site_users.class.php, method SiteUsers::ValidUser()
Метод определения зарегистрирован ли пользователь
valid_email in file Security.fns.php, function valid_email()
Проверка правильности электронного адреса
VisibleTheme in file Forums.class.php, method Forums::VisibleTheme()
Метод, устанавливающий видимость/невидимость темы
vote in file Polls.class.php, method polls::vote()
Метод обработки и отображения результатов голосования
vote_result in file Polls.class.php, method polls::vote_result()
Метод вывода результатов голосования
top
w
Wysiwyg.class.php | procedural page Wysiwyg.class.php
win2uni in file Graphic.class.php, method graphic::win2uni()
Метод перекодировки из win в unicode
wysiwyg in file Wysiwyg.class.php, class wysiwyg
Ядро, класс визуального редактора
top
x
$xml | in file ExternalXml.class.php, variable ExternalXml::$xml
XMLparser.class.php | procedural page XMLparser.class.php
xsl in file Xsl.class.php, class xsl
Класс модуля "XSL-шаблоны"
Xsl.class.php | procedural page Xsl.class.php
Xsl.php | procedural page Xsl.php


HostCMS v. 3.2.4

Welcome to HostCMS!

This documentation was generated by phpDocumentor v1.3.0RC3


phpDocumentor Parser Errors and Warnings

 Post-parsing
AdminMenu.class.php
admin_output.fns.php
Advertisement.class.php
Advertisement.php
Backup.class.php
Backup.php
Cache.class.php
Cache.php
Captcha.class.php
Compression.class.php
Compression.php
config.php
Constants.class.php
Constants.php
Counter.class.php
Counter.php
Date.class.php
Documents.class.php
Documents.php
Error.fns.php
EventsJournal.class.php
EventsJournal.php
ExecSqlQuery.class.php
ExecSqlQuery.php
ExternalXml.class.php
File.class.php
FileManager.class.php
FileManager.php
Forms.class.php
Forms.php
Forums.class.php
Forums.php
Graphic.class.php
Image.class.php
InformationSystems.class.php
InformationSystems.php
ip.class.php
ip.php
Kernel.class.php
Kernel.php
Lists.class.php
Lists.php
Maillist.class.php
Maillist.php
Menu.class.php
Menu.php
Message.fns.php
Modules.class.php
Modules.php
Mysql.class.php
Mysqldump.class.php
Password.class.php
Polls.class.php
Polls.php
RssRead.class.php
RssWrite.class.php
ru.php
Search.class.php
Search.php
Security.fns.php
shop.class.php
shop.php
show_table.class.php
Site.class.php
Site.php
Site_users.class.php
Site_users.php
Structure.class.php
Structure.php
Support.class.php
Support.php
tar.class.php
Templates.class.php
Templates.php
Url.class.php
UserAccess.class.php
UserAccess.php
Wysiwyg.class.php
XMLparser.class.php
Xsl.class.php
Xsl.php

Post-parsing

Warnings:

Warning - duplicate define element "FORUMS_PATH" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "FORUMS_PARAM_INDEX" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "ON_PAGE_THEME" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "ON_PAGE_MESSAGE" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "LoadKeys" in file H:\Internet\home\anfang.ru\htdocs\modules\Kernel\UserAccess.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "ClearSite" in file H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Url.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "SiteCreate" in file H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Kernel.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "Square" in file H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Kernel.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "send_error_letter" in file H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Message.fns.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "mod" in file H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Mysql.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "FLUDE_PROTECTION" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate function element "EqKeys" in file H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Kernel.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "MAX_SIZE_AVATAR" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "MAX_HEIGHT_AVATAR" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "EDIT_TIME" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning - duplicate define element "MAX_WIDTH_AVATAR" in file H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.

Admin.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class Admin
Warning on line 321 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Admin.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

AdminMenu.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class AdminMenu
Warning on line 33 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\AdminMenu.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

admin_output.fns.php

Warnings:

Warning on line 284 - File "H:\Internet\home\anfang.ru\htdocs\modules\admin_output.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Advertisement.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Advertisement
Warning on line 590 - File "H:\Internet\home\anfang.ru\htdocs\modules\Advertisement\Advertisement.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Advertisement.php

Warnings:

Warning on line 27 - File "H:\Internet\home\anfang.ru\htdocs\modules\Advertisement\Advertisement.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Backup.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Backup
Warning on line 30 - File "H:\Internet\home\anfang.ru\htdocs\modules\Backup\Backup.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Backup.php

Warnings:

Warning on line 31 - File "H:\Internet\home\anfang.ru\htdocs\modules\Backup\Backup.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Cache.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Cache
Warning on line 301 - File "H:\Internet\home\anfang.ru\htdocs\modules\Cache\Cache.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Cache.php

Warnings:

Warning on line 34 - File "H:\Internet\home\anfang.ru\htdocs\modules\Cache\Cache.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Captcha.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Captcha
Warning on line 368 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Captcha.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Compression.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class compression
Warning on line 105 - File "H:\Internet\home\anfang.ru\htdocs\modules\Compression\Compression.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Compression.php

Warnings:

Warning on line 15 - File "H:\Internet\home\anfang.ru\htdocs\modules\Compression\Compression.php" has no page-level DocBlock, use @package in the first DocBlock to create one

config.php

Warnings:

Warning on line 5 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 7 - File "H:\Internet\home\anfang.ru\htdocs\modules\InformationSystems\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 43 - File "H:\Internet\home\anfang.ru\htdocs\modules\Forums\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 158 - File "H:\Internet\home\anfang.ru\htdocs\modules\Counter\config\config.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Constants.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Constants
Warning on line 136 - File "H:\Internet\home\anfang.ru\htdocs\modules\Constants\Constants.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Constants.php

Warnings:

Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\Constants\Constants.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Counter.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class counter
Warning on line 33 - Unknown tag "@return " used
Warning on line 1791 - File "H:\Internet\home\anfang.ru\htdocs\modules\Counter\Counter.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Counter.php

Warnings:

Warning on line 54 - File "H:\Internet\home\anfang.ru\htdocs\modules\Counter\Counter.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Date.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class DateClass
Warning on line 339 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Date.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Documents.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class documents
Warning on line 854 - File "H:\Internet\home\anfang.ru\htdocs\modules\Documents\Documents.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Documents.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\Documents\Documents.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Error.fns.php

Warnings:

Warning on line 134 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Error.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

EventsJournal.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class EventsJournal
Warning on line 11 - no @package tag was used in a DocBlock for class EventsJournalAdmin
Warning on line 147 - File "H:\Internet\home\anfang.ru\htdocs\modules\EventsJournal\EventsJournal.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 231 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\EventsJournal.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

EventsJournal.php

Warnings:

Warning on line 36 - File "H:\Internet\home\anfang.ru\htdocs\modules\EventsJournal\EventsJournal.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ExecSqlQuery.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class ExecSqlQuery
Warning on line 78 - File "H:\Internet\home\anfang.ru\htdocs\modules\ExecSqlQuery\ExecSqlQuery.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ExecSqlQuery.php

Warnings:

Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\ExecSqlQuery\ExecSqlQuery.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ExternalXml.class.php

Warnings:

Warning on line 6 - no @package tag was used in a DocBlock for class ExternalXml
Warning on line 54 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\ExternalXml.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

File.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class File
Warning on line 243 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\File.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

FileManager.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class FileManager
Warning on line 145 - File "H:\Internet\home\anfang.ru\htdocs\modules\FileManager\FileManager.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

FileManager.php

Warnings:

Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\FileManager\FileManager.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Forms.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Forms
Warning on line 1142 - File "H:\Internet\home\anfang.ru\htdocs\modules\Forms\Forms.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Forms.php

Warnings:

Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\Forms\Forms.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Forums.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Forums
Warning on line 2567 - File "H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Forums.php

Warnings:

Warning on line 100 - File "H:\Internet\home\anfang.ru\htdocs\modules\Forums\Forums.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Graphic.class.php

Warnings:

Warning on line 2 - no @package tag was used in a DocBlock for class graphic
Warning on line 575 - File "H:\Internet\home\anfang.ru\htdocs\modules\Counter\Graphic.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Image.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Image
Warning on line 123 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Image.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

InformationSystems.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class information_blocks
Warning on line 20 - no @package tag was used in a DocBlock for class InformationSystem
Warning on line 5188 - File "H:\Internet\home\anfang.ru\htdocs\modules\InformationSystems\InformationSystems.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

InformationSystems.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\InformationSystems\InformationSystems.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ip.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class ip
Warning on line 248 - File "H:\Internet\home\anfang.ru\htdocs\modules\ip\ip.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ip.php

Warnings:

Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\ip\ip.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Kernel.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class kernel
Warning on line 1064 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Kernel.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Kernel.php

Warnings:

Warning on line 325 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Kernel.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Lists.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class lists
Warning on line 340 - File "H:\Internet\home\anfang.ru\htdocs\modules\Lists\Lists.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Lists.php

Warnings:

Warning on line 30 - File "H:\Internet\home\anfang.ru\htdocs\modules\Lists\Lists.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Maillist.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Maillist
Warning on line 488 - File "H:\Internet\home\anfang.ru\htdocs\modules\Maillist\Maillist.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Maillist.php

Warnings:

Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\Maillist\Maillist.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Menu.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class menu
Warning on line 124 - File "H:\Internet\home\anfang.ru\htdocs\modules\Menu\Menu.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Menu.php

Warnings:

Warning on line 30 - File "H:\Internet\home\anfang.ru\htdocs\modules\Menu\Menu.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Message.fns.php

Warnings:

Warning on line 190 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Message.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Modules.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class modules_admin
Warning on line 158 - File "H:\Internet\home\anfang.ru\htdocs\modules\Modules\Modules.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Modules.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\Modules\Modules.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Mysql.class.php

Warnings:

Warning on line 19 - no @package tag was used in a DocBlock for class MySQL
Warning on line 286 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Mysql.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Mysqldump.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class mysqldump
Warning on line 187 - File "H:\Internet\home\anfang.ru\htdocs\modules\Backup\Mysqldump.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Password.class.php

Warnings:

Warning on line 12 - no @package tag was used in a DocBlock for class Password
Warning on line 64 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Password.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Polls.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class polls
Warning on line 611 - File "H:\Internet\home\anfang.ru\htdocs\modules\Polls\Polls.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Polls.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\Polls\Polls.php" has no page-level DocBlock, use @package in the first DocBlock to create one

RssRead.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class RssRead
Warning on line 230 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\RssRead.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

RssWrite.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class rss
Warning on line 19 - no @package tag was used in a DocBlock for class RssWrite
Warning on line 285 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\RssWrite.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

ru.php

Warnings:

Warning on line 8 - File "H:\Internet\home\anfang.ru\htdocs\modules\Search\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 13 - File "H:\Internet\home\anfang.ru\htdocs\modules\Cache\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 16 - File "H:\Internet\home\anfang.ru\htdocs\modules\ExecSqlQuery\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 20 - File "H:\Internet\home\anfang.ru\htdocs\modules\Backup\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 23 - File "H:\Internet\home\anfang.ru\htdocs\modules\Menu\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 24 - File "H:\Internet\home\anfang.ru\htdocs\modules\ip\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 25 - File "H:\Internet\home\anfang.ru\htdocs\modules\Constants\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\EventsJournal\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 35 - File "H:\Internet\home\anfang.ru\htdocs\modules\FileManager\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 36 - File "H:\Internet\home\anfang.ru\htdocs\modules\Support\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 37 - File "H:\Internet\home\anfang.ru\htdocs\modules\Lists\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 38 - File "H:\Internet\home\anfang.ru\htdocs\modules\Xsl\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 42 - File "H:\Internet\home\anfang.ru\htdocs\modules\Templates\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 44 - File "H:\Internet\home\anfang.ru\htdocs\modules\UserAccess\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 54 - File "H:\Internet\home\anfang.ru\htdocs\modules\Polls\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 67 - File "H:\Internet\home\anfang.ru\htdocs\modules\Forums\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 68 - File "H:\Internet\home\anfang.ru\htdocs\modules\Site\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 71 - File "H:\Internet\home\anfang.ru\htdocs\modules\Modules\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 73 - File "H:\Internet\home\anfang.ru\htdocs\modules\Maillist\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 77 - File "H:\Internet\home\anfang.ru\htdocs\modules\Documents\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 85 - File "H:\Internet\home\anfang.ru\htdocs\modules\Advertisement\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 89 - File "H:\Internet\home\anfang.ru\htdocs\modules\Forms\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 90 - File "H:\Internet\home\anfang.ru\htdocs\modules\Site_users\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 90 - File "H:\Internet\home\anfang.ru\htdocs\modules\Structure\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 175 - File "H:\Internet\home\anfang.ru\htdocs\modules\InformationSystems\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 200 - File "H:\Internet\home\anfang.ru\htdocs\modules\Counter\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 524 - File "H:\Internet\home\anfang.ru\htdocs\modules\shop\lng\ru\ru.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Search.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class Search
Warning on line 900 - File "H:\Internet\home\anfang.ru\htdocs\modules\Search\Search.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Errors:

Error on line 31 - DocBlock has multiple @access tags, illegal. ignoring additional tag "@access private"

Search.php

Warnings:

Warning on line 28 - File "H:\Internet\home\anfang.ru\htdocs\modules\Search\Search.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Security.fns.php

Warnings:

Warning on line 259 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Security.fns.php" has no page-level DocBlock, use @package in the first DocBlock to create one

shop.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class shop
Warning on line 4971 - File "H:\Internet\home\anfang.ru\htdocs\modules\shop\shop.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

shop.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\shop\shop.php" has no page-level DocBlock, use @package in the first DocBlock to create one

show_table.class.php

Warnings:

Warning on line 7 - no @package tag was used in a DocBlock for class table_fields
Warning on line 200 - no @package tag was used in a DocBlock for class show_table
Warning on line 606 - File "H:\Internet\home\anfang.ru\htdocs\modules\show_table.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class site
Warning on line 452 - File "H:\Internet\home\anfang.ru\htdocs\modules\Site\Site.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\Site\Site.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site_users.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class SiteUsers
Warning on line 1464 - File "H:\Internet\home\anfang.ru\htdocs\modules\Site_users\Site_users.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Site_users.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\Site_users\Site_users.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Structure.class.php

Warnings:

Warning on line 9 - no @package tag was used in a DocBlock for class Structure
Warning on line 1886 - File "H:\Internet\home\anfang.ru\htdocs\modules\Structure\Structure.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Structure.php

Warnings:

Warning on line 30 - File "H:\Internet\home\anfang.ru\htdocs\modules\Structure\Structure.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Support.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class Support
Warning on line 102 - File "H:\Internet\home\anfang.ru\htdocs\modules\Support\Support.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Support.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\Support\Support.php" has no page-level DocBlock, use @package in the first DocBlock to create one

tar.class.php

Warnings:

Warning on line 13 - duplicate define element "OS_WINDOWS" in file H:\Internet\home\anfang.ru\htdocs\modules\Backup\tar\tar.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning on line 14 - duplicate define element "OS_UNIX" in file H:\Internet\home\anfang.ru\htdocs\modules\Backup\tar\tar.class.php will be ignored. Use an @ignore tag on the original if you want this case to be documented.
Warning on line 25 - no @package tag was used in a DocBlock for class Archive_Tar
Warning on line 1700 - File "H:\Internet\home\anfang.ru\htdocs\modules\Backup\tar\tar.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Templates.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class templates
Warning on line 437 - File "H:\Internet\home\anfang.ru\htdocs\modules\Templates\Templates.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Templates.php

Warnings:

Warning on line 33 - File "H:\Internet\home\anfang.ru\htdocs\modules\Templates\Templates.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Url.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class url
Warning on line 65 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Url.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

UserAccess.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class UserAccessDenied
Warning on line 11 - no @package tag was used in a DocBlock for class user_access
Warning on line 126 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\UserAccess.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Warning on line 303 - File "H:\Internet\home\anfang.ru\htdocs\modules\UserAccess\UserAccess.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

UserAccess.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\UserAccess\UserAccess.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Wysiwyg.class.php

Warnings:

Warning on line 10 - no @package tag was used in a DocBlock for class wysiwyg
Warning on line 187 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\Wysiwyg.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

XMLparser.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class XMLparser
Warning on line 120 - File "H:\Internet\home\anfang.ru\htdocs\modules\Kernel\XMLparser.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Xsl.class.php

Warnings:

Warning on line 11 - no @package tag was used in a DocBlock for class xsl
Warning on line 568 - File "H:\Internet\home\anfang.ru\htdocs\modules\Xsl\Xsl.class.php" has no page-level DocBlock, use @package in the first DocBlock to create one

Xsl.php

Warnings:

Warning on line 29 - File "H:\Internet\home\anfang.ru\htdocs\modules\Xsl\Xsl.php" has no page-level DocBlock, use @package in the first DocBlock to create one
Documentation generated on Sun, 01 Oct 2006 21:01:30 +0400 by phpDocumentor 1.3.0RC3


Documentation generated on Sun, 01 Oct 2006 21:01:09 +0400 by phpDocumentor 1.3.0RC3